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Setup and installation

Installing the software
Activate the software

To submit a feature request or bug report about After Effects, choose Help > Send Feedback.

. To the to
Installing the software 0
Before installing Adobe After Effects software, review complete system requirements and recommendations in the Read Me file. The Read Me file
is on the installation disc, as well as being included in the Release Notes document available through the After Effects support section of the
Adobe website.

For assistance with installation issues, see the Creative Suite Help and Support section on the Adobe website.

In addition to the full version of Adobe After Effects, you can also install additional copies on additional computers to use as After Effects render
engines to assist with network rendering. You install render engines in the same manner as the full version of the application. You run the render
engine using the Adobe After Effects Render Engine shortcut in the Adobe After Effects CS5 or After Effects CS5.5 folder.

Limitations of the trial version for Adobe After Effects CS5.5 and later

The trial version of After Effects CS5.5 and later includes all of the codecs that are included with the full version of After Effects CS5.5 and later.
This means that you can import and export to all of the supported file formats using the trial version. The free trial version of Adobe After Effects
CS5.5 and later software does not include some features that depend upon software licensed from parties other than Adobe. For example, Cycore
(CC) effects, mocha-AE, mocha Shape, FreeForm, and Color Finesse are available only with the full version of Adobe After Effects software.
(Keylight is included, however.) If your installation of After Effects is missing some third-party components, contact your system administrator to
ensure that all licensed components have been installed correctly. For more information about limitations of the trial version for After Effects
CS5.5, see the Adobe website.

Limitations of the trial version for Adobe After Effects CS5

The free trial version of Adobe After Effects CS5 software does not include some features that depend upon software licensed from parties other
than Adobe. For example, mocha for After Effects, some effect plug-ins, and some codecs for encoding and decoding MPEG formats are available
only with the full version of Adobe After Effects software. If your installation of After Effects is missing some third-party components, contact your
system administrator to ensure that all licensed components have been installed correctly. For more information about limitations of the trial
version for After Effects CS5, see the Adobe website.

After Effects CS5 and later is a 64-bit application

After Effects CS5 and later is a 64-bit application, so it can only run on 64-bit operating systems. If you are installing Adobe Creative Suite
Production Premium or Master Collection edition on a computer with a 32-bit operating system, then you can install After Effects CS4 and
Premiere Pro CS4 using an intaller that is included with the suite. To activate the CS4 versions of these applications, you must use a separate
serial number. For assistance, contact Adobe Customer Service.

For more information about installing and activating the 32-bit applications, see the Adobe website.

Activate the software To the top

Activation is a simple, anonymous process. After installation, your Adobe software attempts to contact Adobe to complete the license activation
process. No personal data is transmitted.

A single-user retail license activation supports two computers. For example, you can install the software on a desktop computer at work and on a
laptop computer at home.

For more information on product licensing and activation, see the Read Me file or go to the Adobe website.

Note: Before transferring an activation to a different computer, deactivate the software by choosing Help > Deactivate.
More Help topics

B Adobe Product Improvement Program
B Activation and registration
Help and support

E Services, downloads, and extras
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Workflows

General workflow in After Effects
Basic workflow tutorial: Create a simple movie

General workflow in After Effects To thetop

Overview of general workflow in After Effects

Whether you use Adobe After Effects to animate a simple title, create complex motion graphics, or composite realistic visual effects, you generally
follow the same basic workflow, though you may repeat or skip some steps. For example, you may repeat the cycle of modifying layer properties,
animating, and previewing until everything looks right. You may skip the step of importing footage if you intend to create graphical elements entirely
in After Effects.

1. Import and organize footage

After you create a project, import your footage into the project in the Project panel. After Effects automatically interprets many common media
formats, but you can also specify how you want After Effects to interpret attributes such as frame rate and pixel aspect ratio. You can view each
item in a Footage panel and set its start and end times to fit your composition. For more information, see Importing and interpreting footage items.

2. Create, arrange, and composite layers in a composition

Create one or more compositions. Any footage item can be the source for one or more layers in a composition. You can arrange the layers
spatially in the Composition panel or arrange them in time using the Timeline panel. You can stack layers in two dimensions or arrange them in
three dimensions. You can use masks, blending modes, and keying tools to composite (combine), the images of multiple layers. You can even use
shape layers, text layers, and paint tools to create your own visual elements. For more information, see Composition basics, Creating layers,
Transparency, opacity, and compositing, Overview of shape layers, paths, and vector graphics, and Creating and editing text layers.

3. Modify and animate layer properties

You can modify any property of a layer, such as size, position, and opacity. You can make any combination of layer properties change over time,
using keyframes and expressions. Use motion tracking to stabilize motion or to animate one layer so that it follows the motion in another layer. For
more information, see Animation basics, Expression basics, and Tracking and stabilizing motion (CS5).

4. Add effects and modify effect properties

You can add any combination of effects to alter the appearance or sound of a layer, and even generate visual elements from scratch. You can
apply any of the hundreds of effects, animation presets, and layer styles. You can even create and save your own animation presets. You can
animate effect properties, too, which are simply layer properties within an effect property group. For more information, see Effects and animation
presets overview.

5. Preview

Previewing compositions on your computer monitor or an external video monitor is fast and convenient, even for complex projects, especially if you
use OpenGL technology to accelerate previews. You can change the speed and quality of previews by specifying their resolution and frame rate,
and by limiting the area and duration of the composition that you preview. You can use color management features to preview how your movie will
look on another output device. For more information, see Previewing and Color management.

6. Render and export

Add one or more compositions to the render queue to render them at the quality settings you choose and to create movies in the formats that you
specify. In some cases, you export using the File > Export or Composition menu, rather than the Render Queue panel. For more information, see
Basics of rendering and exporting.

Adobe recommends B Have atutorial you would like to share?
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29


http://www.adobe.com/community/publishing/download.html
http://blogs.adobe.com/toddkopriva/2010/01/getting-started-with-after-eff.
http://blogs.adobe.com/toddkopriva/2010/01/getting-started-with-after-eff.
http://blogs.adobe.com/toddkopriva/2010/01/getting-started-with-after-eff.html
http://blogs.adobe.com/toddkopriva/2010/01/getting-started-with-after-eff.html
http://www.video2brain.com/en/videos-1443.htm

Online resources for general workflow in After Effects

This video from the “After Effects CS5: Learn by Video” series provides an introduction to the basic terminology, workflow, concepts, and user
interface items in After Effects.

See this page on the After Effects Region of Interest blog for a collection of resources for getting started with After Effects.
Read a basic step-by-step introduction to the general workflow in an excerpt from After Effects Classroom in a Book.

Read Trish and Chris Meyer’s step-by-step introduction to creating a basic animation in a PDF excerpt from their book, The After Effects
Apprentice.

. . . . To thet
Basic workflow tutorial: Create a simple movie et

This tutorial assumes that you have already started After Effects and have not modified the empty default project. This example skips the step of
importing footage and shows you instead how to create your own synthetic visual elements. After you have rendered a final movie, you can import
it into After Effects to view it and use it as you would any other footage item.

Some people prefer to use the mouse and menus to interact with After Effects, whereas others prefer to use keyboard shortcuts for common tasks.
For several steps in this example, two alternative commands are shown that produce the same result—the first demonstrating the discoverability of
menu commands and the second demonstrating the speed and convenience of keyboard shortcuts. You'll likely find that you use some
combination of keyboard shortcuts and menu commands in your work.

1. Create a new composition:
* Choose Composition > New Composition.
e Press Ctrl+N (Windows) or Command+N (Mac OS).

2. Change the Duration value in the Composition Settings dialog box by entering 5.00 (5 seconds), choose Web Video from the Preset menu,
and click OK.

3. Create a new text layer:
« Choose Layer > New > Text.
e Press Ctrl+Alt+Shift+T (Windows) or Command+Option+Shift+T (Mac OS).

4. Type your name. Press Enter on the numeric keypad or press Ctrl+Enter (Windows) or Command+Return (Mac OS) on the main keyboard
to exit text-editing mode.

5. Set an initial keyframe for the Position property:

« Click the triangle to the left of the layer name in the Timeline panel, click the triangle to the left of the Transform group name, and then
click the stopwatch button ™ to the left of the Position property name.

e Press Alt+Shift+P (Windows) or Option+Shift+P (Mac OS).
6. Activate the Selection tool:

e Click the Selection Tool button in the Tools panel.

e Press V.

7. Using the Selection tool, drag your text to the bottom-left corner of the frame in the Composition panel.
8. Move the current-time indicator to the last frame of the composition:

« Drag the current-time indicator in the Timeline panel to the far right of the timeline.
e Press End.
9. Using the Selection tool, drag your text to the top-right corner of the frame in the Composition panel.
A new keyframe is created at this time for the Position property. Motion is interpolated between keyframe values.

10. Preview your animation using standard preview:

« Click the Play button ® in the Preview panel. Click Play again to stop the preview.

« Press the spacebar. Press the spacebar again to stop the preview.
11. Apply the Glow effect:

« Choose Effect > Stylize > Glow.

« Type glow in the search field at the top of the Effects & Presets panel to find the Glow effect. Double-click the effect name.
12. Add your composition to the render queue:

* Choose Composition > Add To Render Queue.

« In After Effects CS5.5, and earlier, press Ctrl+Shift+/ (Windows) or Command+Shift+/ (Mac OS).

« In After Effects CS6, press Ctrl+M (Windows) or Ctrl+Command+M (Mac OS). The previous keyboard shortcuts also work.
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Note: In After Effects CS6, the Composition > Make Movie command has been removed. Use the Add to Render Queue command
instead.

« In After Effects CS6, choose File > Export > Add to Render Queue.

13. In the Render Queue panel, click the underlined text to the right of Output To. In the Output Movie To dialog box, choose a name and
location for the output movie file, and then click Save. For the location, choose something easy to find, like your desktop.

14. Click the Render button to process all items in the render queue. The Render Queue panel shows the progress of the rendering operation. A
sound is generated when rendering is complete.

You've created, rendered, and exported a movie.

You can import the movie that you've created and preview it in After Effects, or you can navigate to the movie and play it using a movie player
such as QuickTime Player, Windows Media Player, or Adobe Bridge.

More Help topics
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Planning and setup

Planning your work
Planning for playback on computer monitors and mobile devices
Cross-platform project considerations

. To the to
Planning your work ’
Correct project settings, preparation of footage, and initial composition settings can help you to avoid errors and unexpected results when
rendering your final output movie. Before you begin, think about what kind of work you’ll be doing in After Effects and what kind of output you
intend to create. After you have planned your project and made some basic decisions about project settings, you'll be ready to start importing
footage and assembling compositions from layers based on that footage.

The best way to ensure that your movie is suitable for a specific medium is to render a test movie and view it using the same type of equipment
that your audience will use to view it. It's best to do such tests before you have completed the difficult and time-consuming parts of your work, to
uncover problems early.

Aharon Rabinowitz provides an article on the Creative COW website about planning your project with the final delivery specifications in mind.
For a video tutorial on creating and organizing projects, go to the Adobe website.

For more information about encoding and compression options, see this FAQ entry: “FAQ: What is the best format for rendering and exporting
from After Effects?”

Storyboards and scripts (screenplays)
Before you begin shooting footage or creating animations, it is often best to start by planning your movie with storyboards and a script
(screenplay).

You can use Adobe Photoshop and Adobe lllustrator to create storyboards. You can use Adobe Story to collaboratively write and manage
screenplays. Adobe Story also converts information from a screenplay into XMP metadata that can automate the creation of shooting scripts, shot
lists, and more.

Note: To start the Adobe Story service from within After Effects, choose File > Go To Adobe Story.

Acquiring, choosing, and preparing footage
Before importing footage, first decide which media and formats you'll use for your finished movies, and then determine the best settings for your
source material. Often, it's best to prepare footage before importing it into After Effects.

For example, if you want an image to fill your composition frame, configure the image in Adobe Photoshop so that the image size and pixel aspect
ratio match the composition size and pixel aspect ratio. If the image is too large when you import it into After Effects, you'll increase the memory
and processor requirements of the compositions that use it. If the image is too small, you'll lose image quality when you scale it to the desired size.
See Pixel aspect ratio and frame aspect ratio.

If you can shoot footage with consistent lighting and colors—and otherwise prevent the need to do a lot of tedious utility work in post-production—
then you'll have more time for creative work. Consider using Adobe OnLocation while shooting footage to make sure that you get the most out of
your time and footage.

If possible, use uncompressed footage or footage encoded with lossless compression. Lossless compression means better results for many
operations, such as keying and motion tracking. Certain kinds of compression—such as the compression used in DV encoding—are especially bad
for color keying, because they discard the subtle differences in color that you depend on for good bluescreen or greenscreen keying. It's often best
to wait until the final rendering phase to use compression other than lossless compression. See Keying introduction and resources.

If possible, use footage with a frame rate that matches that of your output, so that After Effects doesn’t have to use frame blending or similar
methods to fill in missing frames. See Frame rate.

The kind of work that you'll be doing in After Effects and the kind of output movie that you want to create can even influence how you shoot and
acquire your footage. For example, if you know that you want to animate using motion tracking, consider shooting your scene in a manner that
optimizes for motion tracking—for example, using tracking markers. See Motion tracking workflow.

David Van Brink shows an excellent example on his omino pixel blog of why shooting in a high-definition format is useful even for standard-
definition delivery, because the extra pixels give you a lot of room for synthetic (fake) camera work, such as zooms and pans in post-production.

Trish and Chris Meyer provide tips for planning and delivering high-definition and widescreen work in articles on the ProVideo Coalition website:
e The High-Def Checklist

* Open Wide: Creating That Widescreen Look
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Project settings

Project settings fall into three basic categories: how time is displayed in the project, how color data is treated in the project, and what sampling rate
to use for audio. Of these settings, the color settings are the ones that you need to think about before you do much work in your project, because
they determine how color data is interpreted as you import footage files, how color calculations are performed as you work, and how color data is
converted for final output. See Color management and Timecode and time display units.

If you enable color management for your project, the colors that you see are the same colors that your audience will see when they view the
movie that you create.

Note: Click the color depth indicator at the bottom of the Project panel to open the Project Settings dialog box. Alt-click (Windows) or Option-click
(Mac OS) to cycle through color bit depths: 8 bpc, 16 bpc, and 32 bpc. See Color depth and high dynamic range color.

Composition settings

After you prepare and import footage items, you use these footage items to create layers in a composition, where you animate and apply effects.
When you create a composition, specify composition settings such as resolution, frame size, and pixel aspect ratio for your final rendered output.
Although you can change composition settings at any time, it's best to set them correctly as you create each new composition to avoid unexpected
results in your final rendered output. For example, the composition frame size should be the image size in the playback medium. See Composition
settings.

@ If you'll be rendering and exporting a composition to more than one media format, always match the pixel dimensions for your composition to
the largest pixel dimensions used for your output. Later, you can use output modules in the Render Queue panel to encode and export a
separate version of the composition for each format. See Output modules and output module settings.

Performance, memory, and storage considerations

If you work with large compositions, make sure that you configure After Effects and your computer to maximize performance. Complex
compositions can require a large amount of memory to render, and the rendered movies can take a large amount of disk space to store. Before
you attempt to render a three-hour movie, make sure that you have the disk space available to store it. See Storage requirements for output files.

If your source footage files are on a slow disk drive (or across a slow network connection), then performance will be poor. When possible, keep
the source footage files for your project on a fast local disk drive. Ideally, you'll have three drives: one for source footage files, one from which the
application runs, and one for rendered output.

For more information, see Improve performance and Memory & Multiprocessing preferences.

. . . . To thet
Planning for playback on computer monitors and mobile devices e
When you create a movie for playback on a personal computer—whether downloaded from the Web or played from a CD-ROM—specify
composition settings, render settings, and output module settings that keep file size low. Consider that a movie with a high data rate may not play
well from an older CD-ROM drive that cannot read data from the disc fast enough. Similarly, a large movie may take a long time to download over
a dial-up network connection.

When rendering your final movie, choose a file type and encoder appropriate for the final media. The corresponding decoder must be available on
the system used by your intended audience; otherwise they will not be able to play the movie. Common codecs (encoders/decoders) include the
codecs installed with media players such as Flash Player, Windows Media Player, and QuickTime Player.

Aharon Rabinowitz provides an article on the Creative COW website about planning your project with the final delivery specifications in mind.
Trish and Chris Meyer provide an article on the Artbeats website that describes some of the considerations for creating video for the Web.
For more information about encoding and compression options for After Effects, see this FAQ entry: “FAQ: What is the best format for rendering

and exporting from After Effects?”

Mobile devices

Many of the considerations for creating movies for playback on mobile devices, such as mobile phones and the Apple iPod, are similar to the
considerations for creating movies for playback on personal computers—but the limitations are even more extreme. Because the amount of
storage (disk space) and processor power are less for mobile phones than for personal computers, file size and data rate for movies must be even
more tightly controlled.

Screen dimensions, video frame rates, and color gamuts vary greatly from one mobile device to another. Adobe Device Central contains device
profiles that provide information about these characteristics. You can create a set of After Effects compositions tailored for a selected set of
devices by using the File > New Document In > After Effects command in Adobe Device Central. (See Create compositions for playback on mobile
devices.)

Use these tips when shooting video for mobile devices:
« Tight shots are better. It's hard to see a face on a tiny screen unless it's shot in relative close-up.

« Light your subjects well, and keep them separated from the background; the colors and brightness values between background and subject
should not be too similar.

» Avoid excessive zooming and rolling, which hinder temporal compression schemes.
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» Because stable (non-shaky) video is easier to compress, shoot video with a tripod to minimize the shaking of the camera.

« Avoid using auto-focus and auto-exposure features. When these features engage, they change the appearance of all of the pixels in an
image from one frame to the next, making compression using interframe encoding schemes less efficient.

Use these tips when working in After Effects:
* Use a lower frame rate (12-24 fps) for mobile devices.
« Use motion-stabilization tools and noise-reduction or blur effects before rendering to final output, to aid the compressor in reducing file size.

« Match the color palette to the mobile devices that you are targeting. Mobile devices, in general, have a limited color gamut. Previewing in
Adobe Device Central can help determine if the colors used are optimal for an individual device or range of devices.

« Consider using cuts and other fast transitions instead of zooming in and out or using fades and dissolves. Fast cuts also make compression
easier.

After you've rendered your movie, you can view it exactly as it will appear on any of a large variety of mobile devices, using Adobe Device Central.

. . . To the to
Cross-platform project considerations ’

After Effects project files are compatible with Mac OS and Windows operating systems, but some factors—mostly regarding the locations and

naming of footage files and support files—can affect the ease of working with the same project across platforms.

Project file paths

When you move a project file to a different computer and open it, After Effects attempts to locate the project’s footage files as follows: After Effects
first searches the folder in which the project file is located; second, it searches the file’s original path or folder location; finally, it searches the root
of the directory where the project is located.

If you are building cross-platform projects, it's best if the full paths have the same names on Mac OS and Windows systems. If the footage and the
project are on different volumes, make sure that the appropriate volume is mounted before opening the project and that network volume names
are the same on both systems.

It's best to store footage in the same folder as the project file or in another folder within that folder. Here's a sample hierarchy:
Inewproject/project_file.aep

/newproject/source/footagel.psd

/newproject/source/footage2.avi

You can then copy the newproject folder in its entirety across platforms, and After Effects will properly locate all of the footage.

Q Use the Collect Files feature to gather copies of all the files in a project into a single folder. You can then move the folder containing the copied

project to the other platform. See Collect files in one location.

File-naming conventions

Name your footage and project files with the appropriate filename extensions, such as .mov for QuickTime movies and .aep for After Effects
projects. Don't use high-ASCII or other extended characters in filenames to be used cross-platform. If files will be used on the Web, be sure that
filenames adhere to applicable conventions for extensions and paths.

Supported file types
Some file types are supported on one platform but not another. See Supported import formats and Supported output formats.

Resources
Ensure that all fonts, effects, codecs, and other resources are available on both systems. Such resources are often plug-ins.

If you use a native After Effects effect in a project on one operating system, the effect will still work on the other operating system to which you've
transferred your project. However, some third-party effects and other third-party plug-ins may not continue to operate, even if you have versions of
these plug-ins on the target system. In such cases, you may need to reapply some third-party effects.

More Help topics
Adobe Story workflow
& Analyzing lighting, exposure, and color

& Test content in Adobe Device Central
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Working with After Effects and other applications

Working with Adobe Bridge and After Effects
Working with Photoshop and After Effects

Working with Flash and After Effects

Working with Adobe Premiere Pro and After Effects
Working with Adobe Encore and After Effects

Edit audio in Adobe Soundbooth

Edit in Adobe Audition (CS5.5 and later)

To the top

Working with Adobe Bridge and After Effects

Adobe Bridge is the control center for Adobe Creative Suite software. Use Adobe Bridge to browse for project templates and animation presets;
run cross-product workflow automation scripts; view and manage files and folders; organize your files by assigning keywords, labels, and ratings to
them; search for files and folders; and view, edit, and add metadata.

« To open Adobe Bridge from After Effects, choose File > Browse In Bridge.

« To reveal a file in Adobe Bridge, select a file in the Project panel and choose File > Reveal In Bridge.

« To use Adobe Bridge to open template projects, choose File > Browse Template Projects.

* To use Adobe Bridge to browse for animation presets, choose Animation > Browse Presets.

For video tutorials on using Adobe Bridge, go to the Adobe website:
e What is Adobe Bridge?
+ New features in Adobe Bridge CS5

+ Metadata and keywords in Adobe Bridge

. . To the to
Working with Photoshop and After Effects 0
If you use Photoshop to create still images, you can use After Effects to bring those still images together and make them move and change. In
Atfter Effects, you can animate an entire Photoshop image or any of its layers. You can even animate individual properties of Photoshop images,
such as the properties of a layer style. If you use After Effects to create movies, you can use Photoshop to refine the individual frames of those
movies.

Comparative advantages for specific tasks

The strengths of After Effects are in its animation and automation features. This means that After Effects excels at tasks that can be automated
from one frame to another. For example, you can use the motion tracking features of After Effects to track the motion of a microphone boom, and
then automatically apply that same motion to a stroke made with the Clone Stamp tool. In this manner, you can remove the microphone from
every frame of a shot, without having to paint the microphone out by hand on each frame.

In contrast, Photoshop has excellent tools for painting and drawing.

Deciding which application to use for painting depends on the task. Paint strokes in Photoshop directly affect the pixels of the layer. Paint strokes
in After Effects are elements of an effect, each of which can be turned on or off or modified at any time. If you want to have complete control of
each paint stroke after you've applied it, or if you want to animate the paint strokes themselves, use the After Effects paint tools. If the purpose of
applying a paint stroke is to permanently modify a still image, use the Photoshop paint tools. If you are applying several paint strokes by hand to
get rid of dust, consider using the Photoshop paint tools.

The animation and video features in Photoshop Extended include simple keyframe-based animation. After Effects uses a similar interface, though
the breadth and flexibility of its animation features are far greater.

3D objects, 3D models, and 3D images

In general, After Effects 3D functionality is limited to the manipulation of two-dimensional layers in three dimensions. Photoshop, however, can
manipulate complete 3D models and output two-dimensional composites and cross-sections of these 3D models from any angle. After Effects can
import and render 3D object layers from PSD files. You can set a layer based on a PSD 3D object layer to honor the active camera in an After
Effects composition. When the camera moves around such a layer, it views the 3D object from various angles.

To see a video tutorial about using 3D object layers from Photoshop in After Effects, see the Adobe website.

After Effects can also automatically create 3D layers to mimic the planes created by the Photoshop Vanishing Point feature.
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To see video tutorials about using Vanishing Point data from Photoshop in After Effects, see the Adobe website:
« Working with Vanishing Point in Photoshop and After Effects

» Using Vanishing Point to map a 3D environment

Exchanging still images
After Effects can import and export still images in many formats, but you will usually want to use the native Photoshop PSD format when
transferring individual frames or still image sequences between After Effects and Photoshop.

When importing or exporting a PSD file, After Effects can preserve individual layers, masks, layer styles, and most other attributes. When you
import a PSD file into After Effects, you can choose whether to import it as a flattened image or as a composition with its layers separate and
intact.

It is often a good idea to prepare a still image in Photoshop before importing it into After Effects. Examples of such preparation include correcting
color, scaling, and cropping. It is often better for you to do something once to the source image in Photoshop than to have After Effects perform
the same operation many times per second as it renders each frame for previews or final output.

By creating your new PSD document from the Photoshop New File dialog box with a Film & Video preset, you can start with a document that is set
up correctly for a specific video output type. If you are already working in After Effects, you can create a new PSD document that matches your
composition and project settings by choosing File > New > Adobe Photoshop File.

Exchanging movies

You can also exchange video files, such as QuickTime movies, between Photoshop and After Effects. When you open a movie in Photoshop, a
video layer is created that refers to the source footage file. Video layers allow you to paint nondestructively on the movie's frames, much as After
Effects works with layers with movies as their sources. When you save a PSD file with a video layer, you save the edits that you made to the video
layer, not edits to the source footage itself.

You can also render a movie directly from Photoshop. For example, you can create a QuickTime movie from Photoshop that can then be imported
into After Effects.

Color

After Effects works internally with colors in an RGB (red, green, blue) color space. Though After Effects can convert CMYK images to RGB, you
should do video and animation work in Photoshop in RGB.

If relevant for your final output, it is better to ensure that the colors in your image are broadcast-safe in Photoshop before you import the image into
After Effects. A good way to do this is to assign the appropriate destination color space—for example, SDTV (Rec. 601)—to the document in
Photoshop. After Effects performs color management according to color profiles embedded in documents, including imported PSD files.

To the top

Working with Flash and After Effects

If you use Adobe® Flash® to create video or animation, you can use After Effects to edit and refine the video. For example, from Flash you can
export animations and applications as QuickTime movies or Flash Video (FLV) files. You can then use After Effects to edit and refine the video.

If you use After Effects to edit and composite video, you can then use Flash to publish that video. You can also export an After Effects composition
as XFL content for further editing in Flash.

Flash and After Effects use separate terms for some concepts that they share in common, including the following:
« A composition in After Effects is like a movie clip in Flash Professional.
« The composition frame in the Composition panel is like the Stage in Flash Professional.
« The Project panel in After Effects is like the Library panel in Flash Professional.
« Project files in After Effects are like FLA files in Flash Professional.
« You render and export a movie from After Effects; you publish a SWF file from Flash Professional.

Additional resources

The following video tutorials provide additional detailed information about using Flash together with After Effects:
« “Importing and exporting XFL files between Flash and After Effects” at www.adobe.com/go/Irvid4098_xp.
» “Exporting an After Effects composition to Flash Professional using SWF, F4V/FLV, and XFL" at www.adobe.com/go/Irvid4105_xp.
« “Converting metadata and markers to cue points for use in Flash” at www.adobe.com/go/Irvid4111_xp.

« Michael Coleman, product manager for After Effects, provides a video of a presentation from Adobe MAX on Adobe TV in which he
demonstrates the use of mocha for After Effects and Flash together to dynamically replace a video at run time in Flash Player:
http://www.adobe.com/go/learn_aefl_vid15383v1008_en

« Tom Green provides a brief video tutorial on the Layers Magazine website that shows how to use the XFL format to export an After Effects
composition for use in Flash Professional: http://www.layersmagazine.com/exporting-xfl-fomrat-from-after-effects-to-flash.html
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The following articles provide additional information about using Flash and After Effects together:

« Richard Harrington and Marcus Geduld provide an excerpt, "Flash Essentials for After EffectsUsers", of their book After Effects for Flash |
Flash for After Effects on the Peachpit website. In this chapter, Richard and Marcus explain Flash in terms that an After Effects user can
understand. http://www.peachpit.com/articles/article.aspx?p=1350895

« Richard Harrington and Marcus Geduld also provide "After Effects Essentials for Flash Users", another excerpt from their book After Effects
for Flash | Flash for After Effects. In this chapter, Richard and Marcus explain After Effects in terms that a Flash user can understand.
http://www.peachpit.com/articles/article.aspx?p=1350894

« Tom Green provides a detailed article titled IntegratingFlash Professional CS4 with After Effects CS4 in the Flash Developer Center:
http://www.adobe.com/go/learn_aefl_integrating_fl_ae_en

« Robert Powers provides a video tutorial on the Slippery Rock NYC website that shows the basics of usingAfter Effects from the perspective of
someone who is familiar withFlash Professional.

Exporting QuickTime video from Flash

If you create animations or applications with Flash, you can export them as QuickTime movies using the File > Export > Export Movie command in
Flash. For a Flash animation, you can optimize the video output for animation. For a Flash application, Flash renders video of the application as it
runs, allowing the user to manipulate it. This lets you capture the branches or states of your application that you want to include in the video file.

Rendering and exporting FLV and F4V files from After Effects
When you render finished video from After Effects, select FLV or F4V as the output format to render and export video that can play in Flash Player.
You can then import the FLV or F4V file into Flash and publish it in a SWF file, which can be played by Flash Player.

Importing and publishing video in Flash

When you import an FLV or F4V file into Flash, you can use various techniques, such as scripting or Flash components, to control the visual
interface that surrounds your video. For example, you might include playback controls or other graphics. You can also add graphic layers on top of
the FLV or F4V file for composite results.

Composite graphics, animation, and video
Flash and After Effects each include many capabilities that allow you to perform complex compositing of video and graphics. Which application you
choose to use will depend on your personal preferences and the type of final output you want to create.

Flash is the more web-oriented of the two applications, with its small final file size. Flash also allows for run-time control of animation. After Effects
is oriented toward video and film production, provides a wide range of visual effects, and is generally used to create video files as final output.

Both applications can be used to create original graphics and animation. Both use a timeline and offer scripting capabilities for controlling
animation programmatically. After Effects includes a larger set of effects, while the Flash ActionScript® language is the more robust of the two
scripting environments.

Both applications allow you to place graphics on separate layers for compositing. These layers can be turned on and off as needed. Both also
allow you to apply effects to the contents of individual layers.

In Flash, composites do not affect the video content directly; they affect only the appearance of the video during playback in Flash Player. In
contrast, when you composite with imported video in After Effects, the video file you export actually incorporates the composited graphics and
effects.

Because all drawing and painting in After Effects is done on layers separate from any imported video, it is always non-destructive. Flash has both
destructive and nondestructive drawing modes.

Exporting After Effects content for use in Flash

You can export After Effects content for use in Flash. You can export a SWF file that can be played immediately in Flash Player or used as part of
another rich media project. When you export content from After Effects in SWF format, some of the content may be flattened and rasterized in the
SWF file.

To edit your After Effects content further in Flash, export a composition as an XFL file. An XFL file is a type of Flash file that stores the same
information as a FLA file, but in XML format. When you export a composition from After Effects as XFL for use in Flash, some of the layers and
keyframes that you created in After Effects are preserved in the Flash version. When you import the XFL file in Flash, it unpacks the XFL file and
adds the assets from the file to your FLA file according to the instructions in the XFL file.

The following video tutorials provide detailed information about exporting XFL files from After Effects:
« Importing and exporting XFL files between Flash and After Effects (Adobe.com)
» Exporting XFL Format from After Effects to Flash (Tom Green, Layers Magazine)
Importing Flash SWF files into After Effects
Flash has a unique set of vector art tools that make it useful for a variety of drawing tasks not possible in After Effects or Adobe® lllustrator®. You

can import SWF files into After Effects to composite them with other video or render them as video with additional creative effects. Interactive
content and scripted animation are not retained. Animation defined by keyframes is retained.

Each SWF file imported into After Effects is flattened into a single continuously rasterized layer, with its alpha channel preserved. Continuous
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rasterization means that graphics stay sharp as they are scaled up. This import method allows you to use the root layer or object of your SWF files
as a smoothly rendered element in After Effects, allowing the best capabilities of each tool to work together.

To the top

Working with Adobe Premiere Pro and After Effects

Adobe Premiere Pro is designed to capture, import, and edit movies. After Effects is designed to create motion graphics, apply visual effects,
composite visual elements, perform color correction, and perform other post-production tasks for movies.

You can easily exchange projects, compositions, sequences, tracks, and layers between After Effects and Adobe Premiere Pro:
= You can import an Adobe Premiere Pro project into After Effects. (See Import an Adobe Premiere Pro project.)

« You can export an After Effects project as an Adobe Premiere Pro project. (See Export an After Effects project as an Adobe Premiere Pro
project.)

» You can copy and paste layers and tracks between After Effects and Adobe Premiere Pro. (See Copy between After Effects and Adobe
Premiere Pro.)

« There is copy and paste support of adjustment layers between Premiere Pro CS6 and After Effects CS6.
If you have Adobe Creative Suite Production Premium or Master Collection, you can also do the following:

« Start Adobe Premiere Pro from within After Effects and capture footage for use in After Effects. (See Use Adobe Premiere Pro for capture
(Production Premium and Master Collection only).)

Note: In After Effects CS6 and Premiere Pro CS6, the limitation of Dynamic Link to only work within a suite has been removed (for example,
Dynamic Link will now work between CS6 applications purchased as individual products). In After Effects CS6, starting Premiere Pro from
within After Effects and capturing footage is not supported. The File > Import > Capture in Premiere Pro command has been removed.

» Use Adobe Dynamic Link to work with After Effects compositions in Adobe Premiere Pro without first rendering them. A dynamically linked
composition appears as a clip in Adobe Premiere Pro.

« Use Adobe Dynamic Link to work with Adobe Premiere Pro sequences in After Effects without first rendering them. A dynamically linked
sequence appears as a footage item in After Effects.

« Start After Effects from within Premiere Pro and create a new composition with settings that match the settings of your Premiere Pro project.
» Select a set of clips in Adobe Premiere Pro and convert them to a composition in After Effects.

For information on using Dynamic Link with After Effects and Premiere Pro, see Dynamic Link and After Effects and the relevant sections of Adobe
Premiere Pro Help.

For a video tutorial about working with After Effects and Adobe Premiere Pro using Dynamic Link, go to the Adobe website.

To the top

Working with Adobe Encore and After Effects

You can use After Effects to quickly create buttons and button layers for use in Adobe Encore. Adobe Encore uses a haming standard to define a
button and the role of individual layers as subpicture highlights and video thumbnails. When you select a group of layers in After Effects to use as
an Adobe Encore button, After Effects precomposes the layers and names the precomposition according to the naming standards for buttons.

Highlight layer names receive the prefix (=1), (=2), or (=3), and video thumbnail names receive the prefix (%).

Note: In After Effects CS6, the Layer > Adobe Encore menu and submenu commands have been removed.
Q After Effects includes template projects that include entire DVD menus for you to use as a basis for your own DVD menus. To use Adobe
Bridge to browse and import these template projects, choose File > Browse Template Projects. (See Template projects and example projects.)

For information on using Dynamic Link with After Effects and Encore, see Dynamic Link and After Effects.
For video tutorials about using After Effects with Encore, go to the Adobe website:

« Creating Encore menus with After Effects

e Using Dynamic Link

Paul Tuersley provides a script on the After Effects script website for importing subtitles into After Effects and controlling their formatting.

Create a button for Adobe Encore
1. In the Timeline panel, select the layers for use in the button.
2. Choose Layer > Adobe Encore > Create Button.
3. Enter a name for the button.
4. Use the menus to assign up to three highlight layers and one video thumbnail layer, and then click OK.

A new composition is created with the button name. In keeping with the Adobe Encore naming standards, the prefix (+) is added to the name
of the composition to indicate that it is a button.
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Important: If you rename the button, be sure to retain the (+) prefix. The prefix ensures that Adobe Encore recognizes the file as a button.

Assign a subpicture highlight and video thumbnail to a layer
1. Select the layer.
2. Choose Layer > Adobe Encore > Assign To Subpicture [number] or Assign To Video Thumbnail.

Export a button for use in Adobe Encore
1. Open the composition that represents the button, and move the current-time indicator to the desired frame.

2. Choose Composition > Save Frame As > Photoshop Layers.

To the top

Edit audio in Adobe Soundbooth

While working in After Effects, you may want to use the more comprehensive audio-editing capabilities of Adobe Soundbooth to fine-tune your
audio. You can use the Edit In Adobe Soundbooth command to start Soundbooth from within After Effects.

Note: In After Effects CS6, the Edit > Edit in Adobe Soundbooth menu and command have been removed. Use the Edit > Edit in Adobe Audition
command instead.

If you edit an audio-only file (for example, a WAV file) in Soundbooth, you change the original file. If you edit a layer that contains both audio and
video (for example, an AVI file), you edit a copy of the source audio file.

1. Select the layer that contains the audio that you want to edit. The item must be of a type that is editable in Soundbooth.
2. Choose Edit > Edit In Adobe Soundbooth to open the clip in Edit view in Soundbooth.
3. Edit the file, and then do one of the following:

« If you're editing an audio-only layer, choose File > Save to apply your edits to the original audio file, or choose File > Save As to apply
your edits to a copy of the audio file. If you choose File > Save As, you need to re-import the copy of the file into After Effects.

« If you're editing a layer that contains both audio and video, choose File > Save As. After you save the file, import it into After Effects, add
it to the composition, and mute the original audio in the audio-video clip by deselecting the Audio switch in the Timeline panel.

Note: Any effects applied to audio in After Effects aren’t included in the copy that is sent to Soundbooth.

To the top

Edit in Adobe Audition (CS5.5 and later)

While working in After Effects, you can use the more comprehensive audio-editing capabilities of Adobe Audition to fine-tune your audio. You can
use the Edit in Adobe Audition command to start Adobe Audition from within After Effects.

If you edit an audio-only file (for example, a WAV file) in Adobe Audition, you change the original file. If you edit a layer that contains both audio
and video (for example, an AVI file), you edit a copy of the source audio file.

1. Select the layer that contains the audio that you want to edit. The item must be of a type that is editable in Adobe Audition.
2. Choose Edit > Edit In Adobe Audition to open the clip in Edit view in Adobe Audition.
3. Edit the file, and then do one of the following:

« If you're editing an audio-only layer, choose File > Save to apply your edits to the original audio file. You can also choose file > Save As
to apply your edits to a copy of the audio file. If you choose File > Save As, import the copy of the file into After Effects.

« If you're editing a layer that contains both audio and video, choose File > Save As. After you save the file, import it into After Effects.
Then, add it to the composition, and mute the original audio in the audio-video clip by deselecting the Audio switch in the Timeline panel.

Note: Any effects applied to audio in After Effects aren't included in the copy that is sent to Adobe Audition.

Tutorials and resources about using Adobe Audition to modify audio from After Effects can be found on this post from the After Effects Region of
Interest blog.

More Help topics
E Adobe Bridge

B video and animation overview

@ s

& Vanishing Point

[ | Opening XFL files

& Importing After Effects compositions
& Using After Effects to enhance menus

& Button subpictures for highlighting
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Importing from Adobe After Effects
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Dynamic Link and After Effects

About Dynamic Link

Create and link to After Effects compositions with Dynamic Link
Modify a dynamically linked composition in After Effects

Delete a dynamically linked composition or clip

Create a linked sequence in Adobe Premiere Pro with Dynamic Link
Dynamic Link performance

Dynamic Link features of After Effects are available only with Adobe Creative Suite Production Premium edition and Adobe Creative Suite Master
Collection edition.

To the top

About Dynamic Link

In the past, sharing media assets among post-production applications has required you to render and export your work from one application before
importing it into another. This workflow was inefficient and time-consuming. If you wanted to change the original asset, you rendered and exported
the asset again. Multiple rendered and exported versions of an asset consume disk space, and they can lead to file-management challenges.

Dynamic Link offers an alternative to this workflow. You can create dynamic links between After Effects, Adobe Premiere Pro, and Encore.
Creating a dynamic link is as simple as importing any other type of asset. Dynamically linked assets appear with unique icons and label colors to
help you identify them. Dynamic links are saved in projects generated by these applications.

Create and link to After Effects compositions with Dynamic Link fothetop

You can create After Effects compositions, and dynamically link to them, from Adobe Premiere Pro or Encore. You can also dynamically link to
existing After Effects compositions from Adobe Premiere Pro or Encore.

Create a composition from clips in Adobe Premiere Pro
You can replace selected clips in Adobe Premiere Pro with a dynamically linked After Effects composition based on those clips. The new
composition inherits the sequence settings from Adobe Premiere Pro.

1. In a sequence, select the clips you want in the composition.

2. Right-click any of the selected clips.

3. Select Replace With After Effects Composition.

Create a dynamically linked composition from Adobe Premiere Pro or Encore
Creating a new dynamically linked composition from Adobe Premiere Pro or Encore launches After Effects.After Effects then creates a project and
composition with the dimensions, pixel aspect ratio, frame rate, and audio sample rate of the originating project. (If After Effects is already running,
it creates a composition in the current project.) The new composition name is based on theAdobe Premiere Pro or Encore project name, followed
by Linked Comp [X].

1. In Adobe Premiere Pro or Adobe Encore, choose File > Adobe Dynamic Link > New After EffectsComposition.

2. If the After EffectsSave As dialog box appears, enter a name and location for the After Effects project, and click Save.
& When you create a dynamically linked After Effects composition, the composition duration is set to 30 seconds. To change the duration,
select the composition in After Effects, choose Composition > Composition Settings. Click the Basic tab, and specify a new value for
Duration.

Link to an existing composition

For best results, match composition settings (such as dimensions, pixel aspect ratio, and frame rate) to the settings in the Adobe Premiere Pro or
Encore project.

% Do one of the following:

« In Adobe Premiere Pro or Encore, choose File > Adobe Dynamic Link > Import After Effects Composition. Choose an After Effects project file
(.aep), and then choose one or more compositions.

« In Adobe Premiere Pro or Encore, choose an After Effects project file and click Open. Then choose a composition in the displayed dialog box
and click OK.

« Drag one or more compositions from the After EffectsProject panel to the Adobe Premiere Pro Project panel or the Encore Project panel.
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« Drag an After Effects project file into the AdobePremiere Pro Project panel. If the After Effects project file contains multiple compositions, the
Import Composition dialog box opens.

Note: You can link to a single After Effects composition multiple times in a single Adobe Premiere Pro project. In an Adobe Encore project,
however, you can link to an After Effects composition only once.

If you create a dynamically linked composition from Encore, turn off subpicture highlight layers in After Effects, so that you can control their display
in Encore.

Drum-FankasyOpenil_Drummer-DY-001. aep

DY _Model_ SloMo-Graph_001. aep

Techton Flu Video_04.aep

Dynamically linked After Effects compositions

Modify a dynamically linked composition in After Effects fothetop

Use the Edit Original command in Adobe Premiere Pro or Encore to modify a linked After Effectscomposition. Once the composition is open in
After Effects, you can change the composition without having to use the Edit Original command again.

1. Select the After Effects composition in the AdobePremiere Pro or Encore Project panel, or choose a linked clip in the Timeline, and choose
Edit > Edit Original.

2. Change the composition in After Effects. Then, switch back to Adobe Premiere Pro or Encore to view your changes.

The changes made in After Effects appear in Adobe Premiere Pro. Adobe Premiere Pro stops using any preview files rendered for the clip before
the changes.

Note: You can change the name of the composition in After Effects after creating a dynamic link to it from Adobe Premiere Pro.
Adobe Premiere Pro does not update the linked composition name in the Project panel. Adobe Premiere Pro does retain the dynamic link,
however.
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Delete a dynamically linked composition or clip

You can delete a linked composition from an Encore project if the composition isn’t used in the project. You can delete a linked composition from
an Adobe Premiere Pro project at any time, even if the composition is used in a project.

You can delete linked clips from the timeline of an Adobe Premiere Prosequence or from an Encore menu or timeline at any time.
% In Adobe Premiere Pro or Encore, select the linked composition or clip and press the Delete key.

Create a linked sequence in Adobe Premiere Pro with Dynamic Link fothetop

Link to anew sequence

Creating an Adobe Premiere Pro sequence from After Effects launches Adobe Premiere Pro. Adobe Premiere Pro then creates a project and
sequence with the dimensions, pixel aspect ratio, frame rate, and audio sample rate of the originating project. (If Adobe Premiere Pro is already
running, it creates a sequence in the current project.)

% In After Effects, choose File > Adobe Dynamic Link > New Premiere Pro Sequence.

Link to an existing sequence
For best results, match sequence settings and project settings in Adobe Premiere Pro (such as dimensions, pixel aspect ratio, and frame rate) to
those settings in the After Effects project.

Do one of the following:

« In After Effects, choose File > Adobe Dynamic Link > Import Premiere Pro Sequence. Choose an Adobe Premiere Proproject, and then
choose one or more sequences.

« Drag one or more sequences from the Adobe Premiere Pro Project panel to the After Effects Project panel.

. . To thet
Dynamic Link performance omen

A linked clip can refer to a complex source composition. Actions you perform on the complex source composition require additional processing
time. After Effects takes time to apply the actions and make the final data available to Adobe Premiere Pro or Encore. In some cases, the
additional processing time delays preview or playback.

To reduce playback delays, do one of the following:
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« take the linked composition offline

« disable a linked clip to temporarily stop referencing a composition

« render the composition and replace the dynamically linked composition with the rendered file
If you commonly work with complex source compositions, try adding RAM or a faster processor.

Note: A linked After Effects composition will not support Render Multiple Frames Simultaneously multiprocessing. See Improve performance by
optimizing memory, cache, and multiprocessing settings.
More Help topics
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Workspaces, panels, and viewers

Workspaces and panels
Viewers

To thet
Workspaces and panels e

Adobe video and audio applications provide a consistent, customizable user interface. Although each application has its own set of panels, you
move and group panels in the same way in each application.

The main window of a program is the application window. Panels are organized in this window in an arrangement called a workspace.

Each application includes several predefined workspaces that optimize the layout of panels for specific tasks. You can also create and customize
your own workspaces by arranging panels in the layout that best suits your working style for specific tasks.

You can drag panels to new locations, move panels into or out of a group, place panels alongside each other, and undock a panel so that it floats
in a new window above the application window. As you rearrange panels, the other panels resize automatically to fit the window.

Example workspace
A. Application window B. Grouped panels C. Individual panel

To increase the available screen space, use multiple monitors. When you work with multiple monitors, the application window appears on the main
monitor, and you place floating windows on the second monitor. Monitor configurations are stored in the workspace.

Workspaces are stored in XML files in the preferences folder. With some caveats regarding monitor size and layout, these workspaces can be
moved to another computer and used there.

« (Windows) [drive]:\Users\[user_name]\AppData\Roaming\Adobe\After Effects\10.5\ModifiedWorkspaces
* (Mac OS) [drive]/Users/[user_name]/Library/Preferences/Adobe/After Effects/10.5/ModifiedWorkspaces
Chris and Trish Meyer provide a video overview of the After Effects user interface on the Focal Press website.

See this video tutorial about workspaces by Andrew Devis on the Creative Cow website for more details.

Online resources about panels and workspaces
For a video about panels and workspaces, go to the Adobe website: www.adobe.com/go/vid0249.

Chris and Trish Meyer provide a video overview of the After Effects user interface on the Focal Press website.

Choose aworkspace

« Choose Window > Workspace, and select the desired workspace.
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« Choose a workspace from the Workspace menu in the Tools panel.
« If the workspace has a keyboard shortcut assigned, press Shift+F10, Shift+F11, or Shift+F12.

Q To assign a keyboard shortcut to the current workspace, choose Window > Assign Shortcut To [Workspace Name] Workspace.

Save, reset, or delete workspaces

Save a custom workspace
As you customize a workspace, the application tracks your changes, storing the most recent layout. To store a specific layout more permanently,
save a custom workspace. Saved custom workspaces appear in the Workspace menu, where you can return to and reset them.

+* Arrange the frames and panels as desired, and then choose Window > Workspace > New Workspace. Type a name for the workspace, and
click OK.

Note: (After Effects, Premiere Pro, Encore) If a project saved with a custom workspace is opened on another system, the application looks for a
workspace with a matching name. If it can’t find a match (or the monitor configuration doesn’t match), it uses the current local workspace.

Reset a workspace

Reset the current workspace to return to its original, saved layout of panels.

#* Choose Window > Workspace > Reset workspace name.

Delete a workspace
1. Choose Window > Workspace >Delete Workspace.
2. Choose the workspace you want to delete, and then click OK.

Note: You cannot delete the currently active workspace.

Dock, group, or float panels

You can dock panels together, move them into or out of groups, and undock them so they float above the application window. As you drag a
panel, drop zones—areas onto which you can move the panel—become highlighted. The drop zone you choose determines where the panel is
inserted, and whether it docks or groups with other panels.

Docking zones
Docking zones exist along the edges of a panel, group, or window. Docking a panel places it adjacent to the existing group, resizing all groups to
accommodate the new panel.

1
[y
Re,
A
B
1
=

1

Dragging panel (A) onto docking zone (B) to dock it (C)

Grouping zones
Grouping zones exist in the middle of a panel or group, and along the tab area of panels. Dropping a panel on a grouping zone stacks it with other
panels.
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Dragging panel (A) onto grouping zone (B) to group it with existing panels (C)

Dock or group panels
1. If the panel you want to dock or group is not visible, choose it from the Window menu.
2. Do one of the following:

« To move an individual panel, drag the gripper area in the upper-left corner of a panel’s tab onto the desired drop zone.

RS

|

Drag panel gripper to move one panel

« To move an entire group, drag the group gripper in the upper-right corner onto the desired drop zone.

N

J

]

i

Drag group gripper to move entire group

The application docks or groups the panel, according to the type of drop zone.

Undock a panel in a floating window
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When you undock a panel in a floating window, you can add panels to the window and modify it similarly to the application window. You can use
floating windows to use a secondary monitor, or to create workspaces like the workspaces in earlier versions of Adobe applications.

% Select the panel you want to undock (if it's not visible, choose it from the Window menu), and then do one of the following:
e Choose Undock Panel or Undock Frame from the panel menu. Undock Frame undocks the panel group.

» Hold down Ctrl (Windows®) or Command (Mac OS®), and drag the panel or group from its current location. When you release the mouse
button, the panel or group appears in a new floating window.

« Drag the panel or group outside the application window. (If the application window is maximized, drag the panel to the Windows taskbar.)

Resize panel groups
Q To quickly maximize a panel beneath the pointer, press the * (accent grave) key. (The accent grave is the unshifted character under the tilde, ~,
on standard US keyboards.) Press the key again to return the panel to its original size.

When you drag the divider between panel groups, all groups that share the divider are resized.
1. Do either of the following:
» To resize either horizontally or vertically, position the pointer between two panel groups. The pointer becomes a double arrow b
« To resize in both directions at once, position the pointer at the intersection between three or more panel groups. The pointer becomes a
four-way arrow "I"

2. Hold down the mouse button, and drag to resize the panel groups.

N

Dragging divider between panel groups to resize them horizontally
A. Original group with resize pointer B. Resized groups

Open, close, and show panels and windows
Even if a panel is open, it may be out of sight, beneath other panels. Choosing a panel from the Window menu opens it and brings it to the front of
its group.

When you close a panel group in the application window, the other groups resize to use the newly available space. When you close a floating
window, the panels within it close, too.

« To open or close a panel, choose the panel from the Window menu.
e To close a panel or window, click its Close button =.
« To open or close a panel, use its keyboard shortcut.

« If a frame contains multiple panels, place the pointer over a tab and roll the mouse scroll wheel forward or backward to change which panel
is active.

« If a frame contains more grouped panels than can be shown at once, drag the scroll bar that appears above the tabs.
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Scroll bar for showing tabs of other panels

. To theto
Viewers .

A viewer is a panel that can contain multiple compositions, layers, or footage items, or multiple views of one such item. The Composition, Layer,
Footage, Flowchart, and Effect Controls panels are viewers.

Locking a viewer prevents the currently displayed item from being replaced when you open or select a new item. Instead, when a viewer is locked
and a new item is opened or selected, After Effects creates a new viewer panel for that item. If you select the item from the viewer menu of a
locked viewer, a new viewer isn't created; the existing viewer is used.

Instead of housing multiple items in a single viewer and using the viewer menu to switch between them, you can choose to open a separate
viewer for each open composition, layer, or footage item. When you have multiple viewers open, you can arrange them by docking or grouping
them, like any other panels.

For example, you can create one Composition viewer each for different 3D views (Top, Bottom, Back, Front, custom views) so that you can
maximize each of the views with the * (accent grave) keyboard shortcut, which maximizes or restores the panel under the pointer.

Q To create a custom workspace with multiple viewers, ensure that all viewers are unlocked before you save the workspace. Locked viewers are
associated with a specific project context and are therefore not saved in the preferences file.

« To create a new viewer, choose New from the viewer menu. (See Open panel, viewer, and context menus.)
« To lock or unlock a viewer, choose Locked from the viewer menu, or click the Toggle Viewer Lock E button.

« To lock the current viewer, split the current frame, and create a new viewer of the same type in the new frame, press Ctrl+Alt+Shift+N
(Windows) or Command+Option+Shift+N (Mac OS).

To cycle forward or backward through the items in the viewer menu list for the active viewer, press Shift+period (.) or Shifttcomma (,).

Edit this, look at that (ETLAT) and locked Composition viewers

If a Composition viewer is locked, the Timeline panel for another composition is active, and the Composition viewer for the active composition is
not shown, then most commands that affect views and previews operate on the composition for which the viewer is shown. For example, pressing
the spacebar can start a standard preview for the composition visible in a locked Composition viewer rather than the composition associated with
the active Timeline panel.

This behavior facilitates a working setup sometimes referred to as edit-this-look-at-that (ETLAT). The most common scenario in which this
behavior is useful is the scenario in which you make a change in the Timeline panel for a nested (upstream) composition and want to preview the
result of the change in a containing (downstream) composition.

Note: ETLAT behavior works for keyboard shortcuts for zooming, fitting, previewing, taking and viewing snapshots, showing channels, showing
and hiding grids and guides, and showing the current frame on a video preview device.

To prevent this behavior, unlock the Composition viewer or show the Composition viewer for the composition that you want to view or preview.

See this video on the Video2Brain website to learn about the improvements in ETLAT (edit-this-look-at-that) workflow in After Effects CS5.5 and
later.

More Help topics
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General user interface items

Activate a tool

Open panel, viewer, and context menus

Columns

Search and filter in the Timeline, Project, and Effects & Presets panels
Scroll or zoom with the mouse wheel

Undo changes

After Effects user interface tips

. To theto
Activate a tool ’

The Tools panel can be displayed as a toolbar across the top of the application window or as a normal, dockable panel.
Note: Controls related to some tools appear only when the tool is selected in the Tools panel.

« Click the button for the tool. If the button has a small triangle at its lower-right corner, hold down the mouse button to view the hidden tools.
Then, click the tool you want to activate.

» Press the keyboard shortcut for the tool. (Placing the pointer over a tool button displays a tool tip with the name and keyboard shortcut for the
tool.)

« To cycle through hidden tools within a tool category, repeatedly press the keyboard shortcut for the tool category. (For example, press G
repeatedly to cycle through the pen tools.)

« To momentarily activate a tool, hold down the key for the desired tool; release the key to return to the previously active tool. (This technique
does not work with all tools.)

« To momentarily activate the Hand tool, hold down the spacebar, the H key, or the middle mouse button. (The middle mouse button does not
activate the Hand tool under a few circumstances, including when the Unified Camera tool is active.)

Q To pan around in the Composition, Layer, or Footage panel, drag with the Hand tool. Hold Shift, too, to pan faster.

To show or hide panels most relevant to the active tool, click the panel button 3 if available. For example, clicking this button when a paint tool is
active opens or closes the Paint and Brushes panels. Select the Auto-Open Panels option in the Tools panel to automatically open the relevant
panels when certain tools are activated.

. To thet
Open panel, viewer, and context menus ometep

Panel menus provide commands relative to the active panel or frame. Viewer menus provide lists of compositions, layers, or footage items that
can be shown in the viewer, as well as commands for closing items and locking the viewer. Context menus provide commands relative to the item
that is context-clicked. Many items in the After Effects user interface have associated context menus. Using context menus can make your work
faster and easier.

« To open a panel menu, click the button == in the upper-right corner of the panel.
« To open a viewer menu, click the name of the active composition, layer, or footage item in the viewer tab.
« To open a context menu, right-click (Windows) or Control-click (Mac OS). This action is sometimes referred to as context-clicking.

To theto
Columns p

The Project, Timeline, and Render Queue panels contain columns.

» To show or hide columns, right-click (Windows) or Control-click (Mac OS) a column heading (or choose Columns from the panel menu), and
select the columns that you want to show or hide. A check mark indicates that the column is shown.

Note: In general, the search and filter functions in the Project and Timeline panels only operate on the content of columns that are shown.
» To reorder columns, select a column name and drag it to a new location.
« To resize columns, drag the bar next to a column name. Some columns cannot be resized.

« In After Effects CS5.5 and later, sort footage items in the Project panel, click the column heading. Click once more to sort them in reverse
order.
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Search and filter in the Timeline, Project, and Effects & Presets panels fothetop

The Project, Timeline, and Effects & Presets panels each contain search fields that you can use to filter items in the panel.
» To place the insertion point in a search field, click in the search field.
« To place the insertion point in the search field for the active panel, choose File > Find or press Ctrl+F (Windows) or Command+F (Mac OS).
« To clear the search field, click the B button that appears to the right of the text in the search field.

When you type in the search field, the list of items in the panel is filtered, showing some items and hiding others. Only items with entries that
match the search query that you've typed are shown. The folders, layers, categories, or property groups that contain the matched items are also
shown, to provide context.

In general, only text in columns that are shown is searched for this filtering operation. For example, you may need to show the Comments column
to search and filter by the contents of comments. (See Columns.)

If one or more layers are selected in a composition, the filtering operation in the Timeline panel only affects selected layers. In this case,
unselected layers are not filtered out (hidden) if they don’t match the search query. However, if no layers are selected in the composition, the
filtering operation applies to all layers in the composition. This behavior matches that for showing and hiding of layer properties by pressing their
property shortcut keys. (See Show or hide properties in the Timeline panel.)

Q Clearing the search field and ending the search causes expanded folders and property groups to collapse (close). Therefore, it's easier to work
with the items that are found by the filter operation if you operate on them before you clear the search field and end the search.

If the text that you type in the search field in the Project or Timeline panel contains spaces, the spaces are treated as and-based operators. For
example, typing dark solid matches footage items or layers named Dark Red Solid and Dark Gray Solid. In the Effects & Presets panel, spaces
are treated as space characters in the search field. For example, typing change color matches the Change Color effect, but not the Change To

Color effect.

Project, Timeline, and Effects & Presets panels accept or-based searching in After Effects CS5.5 and later. In an or-based search, a comma
denotes an or, with and-based operators taking precedence over or-based ones. For example, sometimes the name of the property that
determines the amount for a blur effect is Amount, sometimes it is Blurriness, and sometimes it is Blur Radius. If you search for Amount,
Blurriness, Radius, then you will see the equivalent values for all of your blur effects.

Project, Timeline, and Effects and Presets panels accept mru-based (most recently used) searching in After Effects CS5.5 and later. When you
type in a search field, recent search strings that match your input appear.

This search method also allows a way to save items you use often via a menu that opens when you click the search icon in the search field. The
search menu consists of two lists, separated by a divider. The top list contains the six most recent searches, with the most recent one at the top.
The bottom list contains saved search items. As you type, the top list filters to show matching terms.

« To save a search item, Shift-click it in the top list of the search menu. Up to ten items may be saved.
« To delete a saved search item from either list, hover the mouse over the the item to highlight it, and then press Delete or Backspace.

See this video on the Video2Brain website to learn about the new features for searching and filtering in panels in After Effects CS5.5.

Examples of searches in the Project panel
« To show only footage items for which the name or comment contains a specific string, start typing the string.

« To show only footage items for which the source file is missing, type the entire word missing. (This search works whether or not the File Path
column is shown, which is an exception to the general rule that only shown columns are searched.)

« To show only unused footage items, type the entire word unused.
« To show only used footage items, type the entire word used.

« To show only Cineon footage items, type Cineon with the Type column shown.

Examples of searches in the Timeline panel

« To show only layers and properties for which the name or comment contains a specific string, type the string. For example, type starch to
show pins created by the Puppet Starch tool.

« To show only properties that have an expression that uses a specific method, type the method name.
« To show only layers with a specific label, type the label name. (See Color labels for layers, compositions, and footage items.)

Q Click the swatch for a label to see the context menu that lists the label names. Alternatively, drag the right edge of the Label column
heading to expand the column to read the label names.

. To theto
Scroll or zoom with the mouse wheel .

You can use the mouse wheel to zoom in the Timeline, Composition, Layer, and Footage panels. You can use the mouse wheel to scroll in the
Timeline, Project, Render Queue, Flowchart, Effect Controls, Metadata, and Effects & Presets panels.
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« To zoom into the center of the panel, or into the feature region when tracking, roll the mouse wheel forward.
« To zoom out of the center of the panel, or out of the feature region when tracking, roll the mouse wheel backward.

« To zoom into the area under the pointer, hold down Alt (Windows) or Option (Mac OS) as you roll the mouse wheel forward. In the Timeline,
Footage, and Layer panels, this action zooms in time when the pointer is over the time navigator or time ruler.

e To zoom out of the area under the pointer, hold down Alt (Windows) or Option (Mac OS) as you roll the mouse wheel backward. In the
Timeline, Footage, and Layer panels, this action zooms in time when the pointer is over the time navigator or time ruler.

« To scroll vertically, roll the mouse wheel forward or backward.

« To scroll horizontally, hold down Shift as you roll the mouse wheel backward or forward. In the Timeline, Footage, and Layer panels, Shift-
rolling backward moves forward in time and vice versa when the pointer is over the time navigator or time ruler.
Q You can scroll or zoom with the mouse wheel in a panel even if it is not currently active, as long as the pointer is over it.

To the t
Undo changes et

You can undo only those actions that alter the project data. For example, you can undo a change to a property value, but you cannot undo the
scrolling of a panel or the activation of a tool.

You can sequentially undo as many as 99 of the most recent changes made to the project, depending on the Levels Of Undo setting (Edit >
Preferences > General (Windows) or After Effects > Preferences > General (Mac OS)). The default is 32.

Q To avoid wasting time undoing accidental modifications, lock a layer when you want to see it but do not want to modify it.

« To undo the most recent change, choose Edit > Undo [action].
e To undo a change and all changes after it, choose Edit > History, and select the first change that you want to undo.

» To revert to the last saved version of the project, choose File > Revert. All changes made and footage items imported since you last saved
are lost. You cannot undo this action.

After Effects user interface tips fothetop

« Use ClearType text anti-aliasing on Windows. ClearType makes the outlines of system text, such as menus and dialog boxes, easier to read.
See Windows Help for information on how to enable ClearType text anti-aliasing.

« To show tool tips, select the Show Tool Tips preference (Edit > > General (Windows) or After Effects > Preferences > General (Mac OS)).

« Use a workspace that contains the Info panel, and leave that panel in front of other panels in its panel group whenever possible. The Info
panel shows messages about what After Effects is doing, information about items under the pointer, and much more.

« In Windows, disable the Aero compositing mode. Hardware acceleration of panels and OpenGL features perform better in After Effects when
Windows is operating in Basic mode. For information, see the Microsoft website.

+ Use context menus.
« Use keyboard shortcuts.

More Help topics
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Keyboard shortcuts reference

General (keyboard shortcuts)
Projects (keyboard shortcuts)
Preferences (keyboard shortcuts)

Panels, viewers, workspaces, and windows (keyboard shortcuts)

Activating tools (keyboard shortcuts)

Compositions and the work area (keyboard shortcuts)

Time navigation (keyboard shortcuts)
Previews (keyboard shortcuts)

Views (keyboard shortcuts)

Footage (keyboard shortcuts)

Effects and animation presets (keyboard shortcuts)

Layers (keyboard shortcuts)

Showing properties and groups in the Timeline panel (keyboard shortcuts)
Showing properties in the Effect Controls panel (keyboard shortcuts)
Modifying layer properties (keyboard shortcuts)

3D layers (keyboard shortcuts)

Keyframes and the Graph Editor (keyboard shortcuts)

Text (keyboard shortcuts)

Masks (keyboard shortcuts)

Paint tools (keyboard shortcuts)
Shape layers (keyboard shortcuts)
Markers (keyboard shortcuts)

Motion tracking (keyboard shortcuts)

Saving, exporting, and rendering (keyboard shortcuts)

General (keyboard shortcuts)

Result
Select all
Deselect all

Rename selected layer, composition,
folder, effect, group, or mask

Open selected layer, composition, or
footage item

Move selected layers, masks, effects, or
render items down (back) or up (forward)
in stacking order

Move selected layers, masks, effects, or
render items to bottom (back) or top (front)
of stacking order

Extend selection to next item in Project
panel, Render Queue panel, or Effect
Controls panel

Extend selection to previous item in
Project panel, Render Queue panel, or
Effect Controls panel

Duplicate selected layers, masks, effects,
text selectors, animators, puppet meshes,
shapes, render items, output modules, or

Windows
Ctrl+A
F2 or Ctrl+Shift+A

Enter on main keyboard

Enter on numeric keypad

Ctrl+Alt+Down Arrow or Ctrl+Alt+Up Arrow

Ctrl+Alt+Shift+Down Arrow or

Ctrl+Alt+Shift+Up Arrow

Shift+Down Arrow

Shift+Up Arrow

Ctrl+D
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Mac OS
Command+A
F2 or Command+Shift+A

Return

Enter on numeric keypad

Command+Option+Down Arrow or
Command+Option+Up Arrow

Command+Option+Shift+Down Arrow or

Command+Option+Shift+Up Arrow

Shift+Down Arrow

Shift+Up Arrow

Command+D

To the top



compositions
Quit

Undo

Redo

Purge all

Interrupt running a script

Projects (keyboard shortcuts)

Result

New project

Open project

Open most recent project

New folder in Project panel
Open Project Settings dialog box
Find in Project panel

Cycle through color bit depths for project

Open Project Settings dialog box

Preferences (keyboard shortcuts)

Result
Open Preferences dialog box

Restore default preferences settings

Ctrl+Q

Ctrl+z

Ctrl+Shift+Z

Ctrl+Alt+/ (on numeric keypad)

Esc

Windows
Ctrl+Alt+N
Ctrl+O
Ctrl+Alt+Shift+P
Ctrl+Alt+Shift+N
Ctri+Alt+Shift+K
Ctrl+F

Alt-click bit-depth button at bottom of
Project panel

Click bit-depth button at bottom of Project
panel

Windows
Ctrl+Alt+; (semicolon)

Hold down Ctrl+Alt+Shift while starting
After Effects

Panels, viewers, workspaces, and windows (keyboard shortcuts)

Command+Q

Command+Z

Command+Shift+Z

Command+Option+/ (on numeric keypad)

Esc

To the top

Mac OS
Command+Option+N
Command+O
Command+Option+Shift+P
Command+Option+Shift+N
Command+Option+Shift+K
Command+F

Option-click bit-depth button at bottom of
Project panel

Click bit-depth button at bottom of Project
panel

To the top

Mac OS
Command+Option+; (semicolon)

Hold down Command+Option+Shift while
starting After Effects

To the top

Note: (Mac OS) Shortcuts involving function keys F9-F12 may conflict with shortcuts used by the operating system. See Mac OS Help for
instructions to reassign Dashboard & Expose shortcuts.

Result

Open or close Project panel

Open or close Render Queue panel
Open or close Tools panel

Open or close Info panel

Open or close Preview panel

Open or close Audio panel

Windows

Ctrl+0

Ctrl+Alt+0

Ctrl+1

Ctrl+2

Ctrl+3

Ctrl+4
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Mac OS
Command+0
Command+Option+0
Command+1
Command+2
Command+3

Command+4



Open or close Effects & Presets panel
Open or close Character panel

Open or close Paragraph panel

Open or close Paint panel

Open or close Brushes panel

Open or close Effect Controls panel for
selected layer

Open Flowchart panel for project flowchart
Switch to workspace

Close active viewer or panel (closes
content first)

Close active panel or all viewers of type of
active viewer (closes content first). For
example, if a Timeline panel is active, this
command closes all Timeline panels.

Split the frame containing the active
viewer and create a new viewer with
opposite locked/unlocked state

Maximize or restore panel under pointer

Resize application window or floating
window to fit screen. (Press again to

resize window so that contents fill the
screen.)

Move application window or floating
window to main monitor; resize window to
fit screen. (Press again to resize window
so that contents fill the screen.)

Toggle activation between Composition
panel and Timeline panel for current
composition

Cycle to previous or next item in active
viewer (for example, cycle through open
compositions)

Cycle to previous or next panel in active
frame (for example, cycle through open
Timeline panels)

Activate a view in a multi-view layout in
the Composition panel without affecting
layer selection

Ctrl+5
Ctrl+6
Ctrl+7
Ctrl+8
Ctrl+9

F3 or Ctrl+Shift+T

Ctrl+F11
Shift+F10, Shift+F11, or Shift+F12

Ctrl+W

Ctrl+Shift+W

Ctrl+Alt+Shift+N

" (accent grave)

Ctrl+\ (backslash)

Ctrl+Alt+\ (backslash)

\ (backslash)

Shift+, (comma) or Shift+. (period)

Alt+Shift+, (comma) or Alt+Shift+. (period)

click with middle mouse button

Activating tools (keyboard shortcuts)

Command+5
Command+6
Command+7
Command+8
Command+9

F3 or Command+Shift+T

Command+F11
Shift+F10, Shift+F11, or Shift+F12

Command+W

Command+Shift+W

Command+Option+Shift+N

" (accent grave)

Command+\ (backslash)

Command+Option+\ (backslash)

\ (backslash)

Shift+, (comma) or Shift+. (period)

Option+Shift+, (comma) or Option+Shift+.

(period)

click with middle mouse button

To the top

Note: You can activate some tools only under certain circumstances. For example, you can activate a camera tool only when the active

composition contains a camera layer.

Q To momentarily activate a tool with a single-letter keyboard shortcut, hold down the key; release the key to return to the previously active tool.
To activate a tool and keep it active, press the key and immediately release it.

Result

Windows
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Cycle through tools
Activate Selection tool
Activate Hand tool

Temporarily activate Hand tool

Activate Zoom In tool
Activate Zoom Out tool
Activate Rotation tool
Activate Roto Brush tool

Activate and cycle through Camera tools
(Unified Camera, Orbit Camera, Track XY
Camera, and Track Z Camera)

Activate Pan Behind tool

Activate and cycle through mask and
shape tools (Rectangle, Rounded
Rectangle, Ellipse, Polygon, Star)

Activate and cycle through Type tools
(Horizontal and Vertical)

Activate and cycle through pen tools (Pen,
Add Vertex, Delete Vertex, and Convert
Vertex) (CS5.5, and earlier)

Activate and cycle between the Pen and
Mask Feather tools (CS6)

Temporarily activate Selection tool when a
pen tool is selected

Temporarily activate pen tool when the
Selection tool is selected and pointer is
over a path (Add Vertex tool when pointer
is over a segment; Convert Vertex tool
when pointer is over a vertex)

Activate and cycle through Brush, Clone
Stamp, and Eraser tools

Activate and cycle through Puppet tools

Temporarily convert Selection tool to
Shape Duplication tool

Temporarily convert Selection tool to
Direct Selection tool

Alt-click tool button in Tools panel
\%
H

Hold down spacebar or the middle mouse
button.

z
Alt (when Zoom In tool is active)
w

Alt+W

Ctrl+T

Ctrl

Ctrl+Alt

Ctrl+B

Ctrl+P

Alt (in shape layer)

Ctrl (in shape layer)

Compositions and the work area (keyboard shortcuts)

Result
New composition

Open Composition Settings dialog box for
selected composition

Set beginning or end of work area to

Windows

Ctrl+N

Ctrl+K

B orN
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Option-click tool button in Tools panel
\%
H

Hold down spacebar or the middle mouse
button.

z

Option (when Zoom In tool is active)
W

Option+W

C

Command+T

Command

Command+Option

Command+B

Command+P

Option (in shape layer)

Command (in shape layer)

To the top

Mac OS
Command+N

Command+K

B or N



current time

Set work area to duration of selected
layers or, if no layers are selected, set
work area to composition duration

Open Composition Mini-Flowchart for
active composition

Note: If you tap Shift several times
without any intervening keystrokes, you
may invoke a feature of your operating
system’s StickyKeys or Sticky Keys
accessibility software. See your operating
system’s documentation for disabling this
feature.

Activate the most recently active
composition that is in the same
composition hierarchy (network of nested
compositions) as the currently active
composition

Ctrl+Alt+B

Tap Shift

Shift+Esc

Time navigation (keyboard shortcuts)

Result
Go to specific time
Go to beginning or end of work area

Go to previous or next visible item in time
ruler (keyframe, layer marker, work area
beginning or end)

Note: Also goes to beginning, end, or
base frame of Roto Brush span if viewing
Roto Brush in Layer panel.

Go to beginning of composition, layer, or
footage item

Go to end of composition, layer, or
footage item

Go forward 1 frame

Go forward 10 frames

Go backward 1 frame

Go backward 10 frames

Go to layer In point

Go to layer Out point

Go to previous In point or Out point
Go to next In point or Out point

Scroll to current time in Timeline panel

Previews (keyboard shortcuts)

Windows
Alt+Shift+J
Shift+Home or Shift+End

Jor K

Home or Ctrl+Alt+Left Arrow

End or Ctrl+Alt+Right Arrow

Page Down or Ctrl+Right Arrow

Shift+Page Down or Ctrl+Shift+Right
Arrow

Page Up or Ctrl+Left Arrow

Shift+Page Up or Ctrl+Shift+Left Arrow

(@)
Ctrl+Alt+Shift+Left Arrow
Ctrl+Alt+Shift+Right Arrow

D
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Command+Option+B

Tap Shift

Shift+Esc

To the top

Mac OS
Option+Shift+J
Shift+Home or Shift+End

Jor K

Home or Command+Option+Left Arrow

End or Command+Option+Right Arrow

Page Down or Command+Right Arrow

Shift+Page Down or
Command+Shift+Right Arrow

Page Up or Command+Left Arrow

Shift+Page Up or Command+Shift+Left
Arrow

o
Command+Option+Shift+Left Arrow
Command+Option+Shift+Right Arrow

D

To the top



Result
Start or stop standard preview

RAM preview

RAM preview with alternate settings

Save RAM preview

Save RAM preview with alternate settings

Preview only audio, from current time

Preview only audio, in work area

Manually preview (scrub) video

Manually preview (scrub) audio

RAM preview number of frames specified
by Alternate RAM Preview preference
(defaults to 5)

Show current frame on video preview
device

Toggle Output Device preference between
Desktop Only and video preview device

Take snapshot
Display snapshot in active viewer

Purge snapshot

Windows
spacebar

0 on numeric keypad*

Shift+0 on numeric keypad*

Ctrl-click RAM Preview button or press
Ctrl+0 on numeric keypad*

Ctrl+Shift-click RAM Preview button or
press Ctrl+Shift+0 on numeric keypad*

. (decimal point) on numeric keypad*

Alt+. (decimal point) on numeric keypad*

Drag or Alt-drag current-time indicator,
depending on Live Update setting

Ctrl-drag current-time indicator

Alt+0 on numeric keypad*

/ (on numeric keypad)

Ctrl+/ (on numeric keypad)

Shift+F5, Shift+F6, Shift+F7, or Shift+F8
F5, F6, F7, or F8

Ctrl+Shift+F5, Ctrl+Shift+F6,
Ctrl+Shift+F7, or Ctrl+Shift+F8

Mac OS
spacebar

0 on numeric keypad* or Control+0 (zero)
on main keyboard

Shift+0 on numeric keypad* or
Shift+Control+0 (zero) on main keyboard

Command-click RAM Preview button or
press Command+0 on numeric keypad*

Command+Shift-click RAM Preview button
or press Command+Shift+0 on numeric

keypad*

. (decimal point) on numeric keypad* or
Control+. (period) on main keyboard

Option+. (decimal point) on numeric
keypad* or Control+Option+. (period) on

main keyboard

Drag or Option-drag current-time indicator,
depending on Live Update setting

Command-drag current-time indicator
Option+0 on numeric keypad* or
Control+Option+0 (zero) on main keyboard
/ (on numeric keypad)

Command+/ (on numeric keypad)

Shift+F5, Shift+F6, Shift+F7, or Shift+F8
F5, F6, F7, or F8
Command+Shift+F5, Command+Shift+F6,

Command+Shift+F7, or
Command+Shift+F8

Note: Some shortcuts are marked with an asterisk (*) to remind you to make sure that Num Lock is on when you use the numeric keypad.

Views (keyboard shortcuts)

Result

Turn display color management on or off
for active view

Show red, green, blue, or alpha channel
as grayscale

Show colorized red, green, or blue
channel

Toggle showing straight RGB color
Show alpha boundary (outline between

transparent and opaque regions) in Layer
panel

Windows

Shift+/ (on numeric keypad)

Alt+1, Alt+2, Alt+3, Alt+4

Alt+Shift+1, Alt+Shift+2, Alt+Shift+3

Alt+Shift+4

Alt+5
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Mac OS

Shift+/ (on numeric keypad)

Option+1, Option+2, Option+3, Option+4

Option+Shift+1, Option+Shift+2,
Option+Shift+3
Option+Shift+4

Option+5



Show alpha overlay (colored overlay on
transparent regions) in Layer panel

Reset view in the Composition panel to
100% and center composition in the panel

Zoom in in Composition, Layer, or Footage
panel

Zoom out in Composition, Layer, or
Footage panel

Zoom to 100% in Composition, Layer, or
Footage panel

Zoom to fit in Composition, Layer, or
Footage panel

Zoom up to 100% to fit in Composition,
Layer, or Footage panel

Set resolution to Full, Half, or Custom in
Composition panel

Open View Options dialog box for active
Composition panel

Zoom in time

Zoom out time

Zoom in Timeline panel to single-frame
units (Press again to zoom out to show
entire composition duration.)

Zoom out in Timeline panel to show the
entire composition duration (Press again
to zoom back in to the duration specified
by the Time Navigator.)

Suspend image updates

Show or hide safe zones

Show or hide grid

Show or hide proportional grid

Show or hide rulers

Show or hide guides

Turn snapping to grid on or off

Turn snapping to guides on or off

Lock or unlock guides

Show or hide layer controls

Footage (keyboard shortcuts)

Result
Import one file or image sequence

Import multiple files or image sequences

Alt+6

Double-click Hand tool

. (period) on main keyboard

, (comma)

/ (on main keyboard)

Shift+/ (on main keyboard)

Alt+/ (on main keyboard)

Ctrl+J, Ctrl+Shift+J, Ctrl+Alt+J

Ctrl+Alt+U

= (equal sign) on main keyboard
- (hyphen) on main keyboard

; (semicolon)

Shift+; (semicolon)

Caps Lock

' (apostrophe)

Ctrl+' (apostrophe)

Alt+' (apostrophe)

Ctrl+R

Ctrl+; (semicolon)
Ctrl+Shift+' (apostrophe)
Ctrl+Shift+; (semicolon)
Ctrl+Alt+Shift+; (semicolon)

Ctrl+Shift+H

Windows
Ctrl+l

Ctrl+Alt+l
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Option+6

Double-click Hand tool

. (period) on main keyboard

, (comma)

/ (on main keyboard)

Shift+/ (on main keyboard)

Option+/ (on main keyboard)

Command+J, Command+Shift+J,
Command+Option+J

Command+Option+U

= (equal sign) on main keyboard
- (hyphen) on main keyboard

; (semicolon)

Shift+; (semicolon)

Caps Lock

' (apostrophe)

Command+' (apostrophe)

Option+' (apostrophe)

Command+R

Command+; (semicolon)
Command+Shift+' (apostrophe)
Command+Shift+; (semicolon)
Command+Option+Shift+; (semicolon)

Command+Shift+H

To the top

Mac OS
Command-+|

Command+Option+|



Open movie in an After Effects Footage
panel

Add selected items to most recently
activated composition

Replace selected source footage for
selected layers with footage item selected
in Project panel

Replace source for a selected layer

Delete a footage item without a warning

Open Interpret Footage dialog box for
selected footage item

Remember footage interpretation

Edit selected footage item in application
with which it's associated (Edit Original)

Replace selected footage item
Reload selected footage items

Set proxy for selected footage item

Alt-double-click

Ctrl+/ (on main keyboard)

Ctrl+Alt+/ (on main keyboard)

Alt-drag footage item from Project panel
onto selected layer

Ctrl+Backspace

Ctrl+Alt+G

Ctrl+Alt+C

Ctrl+E

Ctrl+H
Ctrl+Alt+L

Ctrl+Alt+P

Effects and animation presets (keyboard shortcuts)

Result
Delete all effects from selected layers

Apply most recently applied effect to
selected layers

Apply most recently applied animation
preset to selected layers

Layers (keyboard shortcuts)

Windows

Ctrl+Shift+E

Ctrl+Alt+Shift+E

Ctrl+Alt+Shift+F

Note: Some operations do not affect shy layers.

Result

New solid layer

New null layer

New adjustment layer

Select layer (1-999) by its number (enter
digits rapidly for two-digit and three-digit

numbers)

Toggle selection of layer (1-999) by its
number (enter digits rapidly for two-digit
and three-digit numbers)

Select next layer in stacking order

Windows
Ctrl+Y
Ctrl+Alt+Shift+Y
CtrI+Alt+Y

0-9 on numeric keypad*

Shift+0-9 on numeric keypad*

Ctrl+Down Arrow
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Option-double-click

Command+/ (on main keyboard)

Command+Option+/ (on main keyboard)

Option-drag footage item from Project
panel onto selected layer

Command+Delete

Command+Option+G

Command+Option+C

Command+E

Command+H
Command+Option+L

Command+Option+P

Mac OS
Command+Shift+E

Command+Option+Shift+E

Command+Option+Shift+F

Mac OS

Command+Y
Command+Option+Shift+Y
Command+Option+Y

0-9 on numeric keypad*

Shift+0-9 on numeric keypad*

Command+Down Arrow

To the top

To the top



Select previous layer in stacking order

Extend selection to next layer in stacking
order

Extend selection to previous layer in
stacking order

Deselect all layers

Scroll topmost selected layer to top of
Timeline panel

Show or hide Parent column

Show or hide Layer Switches and Modes
columns

Turn off all other solo switches

Turn Video (eyeball) switch on or off for
selected layers

Turn off Video switch for all video layers
other than selected layers

Open settings dialog box for selected
solid, light, camera, null, or adjustment
layer

Paste layers at current time

Split selected layers (If no layers are
selected, split all layers.)

Precompose selected layers

Open Effect Controls panel for selected
layers

Open layer in Layer panel (opens source
composition for precomposition layer in
Composition panel)

Open source of a layer in Footage panel
(opens precomposition layer in Layer
panel)

Reverse selected layers in time

Enable time remapping for selected layers

Move In point or Out point of selected
layers to current time

Trim In point or Out point of selected
layers to current time

Add or remove expression for a property

Add an effect (or multiple selected effects)
to selected layers

Set In point or Out point by time-stretching

Move In point of selected layers to
beginning of composition

Move Out point of selected layers to end

Ctrl+Up Arrow

Ctrl+Shift+Down Arrow

Ctrl+Shift+Up Arrow

Ctrl+Shift+A

X

Shift+F4

F4

Alt-click solo switch

CtrI+Alt+Shift+V

Ctrl+Shift+V

Ctrl+Shift+Y

Ctrl+Alt+V

Ctrl+Shift+D

Ctrl+Shift+C

Ctrl+Shift+T

Double-click a layer

Alt-double-click a layer

Ctrli+Alt+R
Ctri+Alt+T

[ (left bracket) or ] (right bracket)

Alt+[ (left bracket) or Alt+] (right bracket)

Alt-click stopwatch

Double-click effect selection in Effects &
Presets panel

Ctrl+Shift+, (comma) or Ctrl+Alt+,
(comma)
Alt+Home

Alt+End
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Command+Up Arrow

Command+Shift+Down Arrow

Command+Shift+Up Arrow

Command+Shift+A

X

Shift+F4

F4

Option-click solo switch

Command+Option+Shift+V

Command+Shift+V

Command+Shift+Y

Command+Option+V

Command+Shift+D

Command+Shift+C

Command+Shift+T

Double-click a layer

Option-double-click a layer

Command+Option+R
Command+Option+T

[ (left bracket) or ] (right bracket)
Option+[ (left bracket) or Option+] (right
bracket)

Option-click stopwatch

Double-click effect selection in Effects &
Presets panel

Command+Shift+, (comma) or
Command+Option+, (comma)

Option+Home

Option+End



of composition
Lock selected layers
Unlock all layers

Set Quality to Best, Draft, or Wireframe for
selected layers

Cycle forward or backward through
blending modes for selected layers

Find in Timeline panel

Ctrl+L

Ctrl+Shift+L

Ctrl+U, Ctrl+Shift+U, or Ctrl+Alt+Shift+U
Shift+ - (hyphen) or Shift+= (equal sign)
on the main keyboard

Ctrl+F

Command+L
Command+Shift+L

Command+U, Command+Shift+U,
Command+Option+Shift+U

Shift+ - (hyphen) or Shift+= (equal sign)
on the main keyboard

Command+F

Note: Some shortcuts are marked with an asterisk (*) to remind you to make sure that Num Lock is on when you use the numeric keypad.

Showing properties and groups in the Timeline panel (keyboard shortcuts)

To the top

Note: This table contains double-letter shortcuts (for example, LL). To use these shortcuts, press the letters in quick succession.

Result
Find in Timeline panel

Toggle expansion of selected layers to
show all properties

Toggle expansion of property group and
all child property groups to show all

properties

Show only Anchor Point property (for
lights and cameras, Point Of Interest)

Show only Audio Levels property
Show only Mask Feather property
Show only Mask Path property
Show only Mask Opacity property

Show only Opacity property (for lights,
Intensity)

Show only Position property

Show only Rotation and Orientation
properties

Show only Scale property

Show only Time Remap property
Show only instances of missing effects
Show only Effects property group
Show only mask property groups

Show only Material Options property
group

Show only expressions
Show only modified properties

Show only paint strokes, Roto Brush

Windows
Ctri+F

Ctrl+* (accent grave)

Ctrl-click triangle to the left of the property
group name

T

RR

FF

MM

EE
uu

PP
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Mac OS
Command+F

Command+" (accent grave)

Command-click triangle to the left of the
property group name

T

RR

FF

MM

AA

EE
uu

PP



strokes, and Puppet pins
Show only audio waveform

Show only properties with keyframes or
expressions

Show only selected properties and groups
Hide property or group

Add or remove property or group from set
that is shown

Add or remove keyframe at current time

Showing properties in the Effect Controls panel (keyboard shortcuts)

Result

Toggle expansion of selected effects to
show all properties

Toggle expansion of property group and
all child property groups to show all
properties

LL

SS
Alt+Shift-click property or group name

Shift+property or group shortcut

Alt+property shortcut

Windows

Ctrl+* (accent grave)

Ctrl-click triangle to the left of the property
group name

Modifying layer properties (keyboard shortcuts)

Result

Modify property value by default
increments

Modify property value by 10x default
increments

Modify property value by 1/10 default
increments

Open Auto-Orientation dialog box for
selected layers

Open Opacity dialog box for selected
layers

Open Rotation dialog box for selected
layers

Open Position dialog box for selected
layers

Center selected layers in view (modifies
Position property to place anchor points of
selected layers in center of current view)

Move selected layers 1 pixel at current
magnification (Position)

Move selected layers 10 pixels at current
magnification (Position)

Move selected layers 1 frame earlier or
later

Windows

Drag property value

Shift-drag property value

Ctrl-drag property value

Ctrl+Alt+O

Ctrl+Shift+O

Ctrl+Shift+R

Ctrl+Shift+P

Ctrl+Home

arrow key

Shift+arrow key

Alt+Page Up or Alt+Page Down
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LL

SS
Option+Shift-click property or group name

Shift+property or group shortcut

Option+property shortcut

To the top

Mac OS

Command+" (accent grave)

Command-click triangle to the left of the

property group name

To the top

Mac OS

Drag property value

Shift-drag property value

Command-drag property value

Command+Alt+O

Command+Shift+O

Command+Shift+R

Command+Shift+P

Command+Home

arrow key

Shift+arrow key

Option+Page Up or Option+Page Down



Move selected layers 10 frames earlier or
later

Increase or decrease Rotation (Z
Rotation) of selected layers by 1°

Increase or decrease Rotation (Z
Rotation) of selected layers by 10°

Increase or decrease Opacity (or Intensity

for light layers) of selected layers by 1%

Increase or decrease Opacity (or Intensity
for light layers) of selected layers by 10%

Increase Scale of selected layers by 1%

Decrease Scale of selected layers by 1%

Increase Scale of selected layers by 10%

Decrease Scale of selected layers by 10%

Modify Rotation or Orientation in 45°
increments

Modify Scale, constrained to footage
frame aspect ratio

Reset Rotation to 0°
Reset Scale to 100%

Scale and reposition selected layers to fit
composition

Scale and reposition selected layers to fit
composition width, preserving image
aspect ratio for each layer

Scale and reposition selected layers to fit

composition height, preserving image
aspect ratio for each layer

3D layers (keyboard shortcuts)

Alt+Shift+Page Up or Alt+Shift+Page
Down

+ (plus) or - (minus) on numeric keypad
Shift++ (plus) or Shift+- (minus) on
numeric keypad

Ctrl+Alt++ (plus) or Ctrl+Alt+- (minus) on

numeric keypad

Ctrl+Alt+Shift++ (plus) or Ctrl+Alt+Shift+-
(minus) on numeric keypad

Ctrl++ (plus) or Alt++ (plus) on numeric
keypad

Ctrl+- (minus) or Alt+- (minus) on numeric
keypad

Ctrl+Shift++ (plus) or Alt+Shift++ (plus) on
numeric keypad

Ctrl+Shift+- (minus) or Alt+Shift+- (minus)
on numeric keypad
Shift-drag with Rotation tool

Shift-drag layer handle with Selection tool

Double-click Rotation tool
Double-click Selection tool

Ctrl+Alt+F

Ctrl+Alt+Shift+H

CtrI+Alt+Shift+G

Option+Shift+Page Up or
Option+Shift+Page Down

+ (plus) or - (minus) on numeric keypad
Shift++ (plus) or Shift+- (minus) on
numeric keypad

Control+Option++ (plus) or
Control+Option+- (minus) on numeric
keypad

Control+Option+Shift++ (plus) or
Control+Option+Shift+- (minus) on numeric

keypad

Command++ (plus) or Option++ (plus) on
numeric keypad

Command+- (minus) or Option+- (minus)
on numeric keypad

Command+Shift++ (plus) or
Option+Shift++ (plus) on numeric keypad

Command+Shift+- (minus) or
Option+Shift+- (minus) on numeric keypad
Shift-drag with Rotation tool

Shift-drag layer handle with Selection tool

Double-click Rotation tool
Double-click Selection tool

Command+Option+F

Command+Option+Shift+H

Command+Option+Shift+G

To the top

Note: (Mac OS) Shortcuts involving function keys F9-F12 may conflict with shortcuts used by the operating system. See Mac OS Help for
instructions to reassign Dashboard & Expose shortcuts.

Result
Switch to 3D view 1 (defaults to Front)

Switch to 3D view 2 (defaults to Custom
View 2)

Switch to 3D view 3 (defaults to Active
Camera)

Return to previous view

Windows

F10

F11

F12

Esc

64

Mac OS

F10

F11

F12

Esc



New light
New camera

Move the camera and its point of interest
to look at selected 3D layers

With a camera tool selected, move the
camera and its point of interest to look at
selected 3D layers

With a camera tool selected, move the
camera and its point of interest to look at
all 3D layers

Turn Casts Shadows property on or off for
selected 3D layers

Ctrl+Alt+Shift+L

Ctrl+Alt+Shift+C

Ctrl+Alt+Shift+\

Ctrl+Shift+F

Alt+Shift+C

Keyframes and the Graph Editor (keyboard shortcuts)

Command+Option+Shift+L
Command+Option+Shift+C

Command+Option+Shift+\

Command+Shift+F

Option+Shift+C

To the top

Note: (Mac OS) Shortcuts involving function keys F9-F12 may conflict with shortcuts used by the operating system. See Mac OS Help for
instructions to reassign Dashboard & Expose shortcuts.

Result

Toggle between Graph Editor and layer
bar modes

Select all keyframes for a property
Select all visible keyframes and properties

Deselect all keyframes, properties, and
property groups

Move keyframe 1 frame later or earlier
Move keyframe 10 frames later or earlier
Set interpolation for selected keyframes
(layer bar mode)

Set keyframe interpolation method to hold
or Auto Bezier

Set keyframe interpolation method to
linear or Auto Bezier

Set keyframe interpolation method to
linear or hold

Easy ease selected keyframes
Easy ease selected keyframes in
Easy ease selected keyframes out
Set velocity for selected keyframes

Add or remove keyframe at current time
(For property shortcuts, see Showing
properties and groups in the Timeline
panel (keyboard shortcuts).)

Windows

Shift+F3

Click property name
Ctrl+Alt+A

Shift+F2 or Ctrl+Alt+Shift+A

Alt+Right Arrow or Alt+Left Arrow

Alt+Shift+Right Arrow or Alt+Shift+Left
Arrow

Ctrl+Alt+K

Ctrl+Alt+H

Ctrl-click in layer bar mode

Ctrl+Alt-click in layer bar mode

F9
Shift+F9
Ctrl+Shift+F9
Ctrl+Shift+K

Alt+property shortcut
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Mac OS

Shift+F3

Click property name
Command+Option+A

Shift+F2 or Command+Option+Shift+A

Option+Right Arrow or Option+Left Arrow

Option+Shift+Right Arrow or
Option+Shift+Left Arrow

Command+Option+K

Command+Option+H

Command-click in layer bar mode

Command+Option-click in layer bar mode

F9

Shift+F9
Command+Shift+F9
Command+Shift+K

Option+property shortcut



Text (keyboard shortcuts)

Result
New text layer

Align selected horizontal text left, center,
or right

Align selected vertical text top, center, or
bottom

Extend or reduce selection by one
character to right or left in horizontal text

Extend or reduce selection by one word to
right or left in horizontal text

Extend or reduce selection by one line up
or down in horizontal text

Extend or reduce selection by one line to
right or left in vertical text

Extend or reduce selection one word up or
down in vertical text

Extend or reduce selection by one
character up or down in vertical text

Select text from insertion point to
beginning or end of line

Move insertion point to beginning or end
of line

Select all text on a layer

Select text from insertion point to
beginning or end of text frame

Select text from insertion point to mouse
click point

In horizontal text, move insertion point one
character left or right; one line up or down;
one word left or right; or one paragraph up
or down

In vertical text, move insertion point one
character up or down; one left or right;

one word up or down; or one paragraph
left or right

Select word, line, paragraph, or entire text
frame

Turn All Caps on or off for selected text
Turn Small Caps on or off for selected text
Turn Superscript on or off for selected text
Turn Subscript on or off for selected text

Set horizontal scale to 100% for selected
text

Windows
Ctrl+Alt+Shift+T

Ctrl+Shift+L, Ctrl+Shift+C, or Ctrl+Shift+R

Ctrl+Shift+L, Ctrl+Shift+C, or Ctrl+Shift+R

Shift+Right Arrow or Shift+Left Arrow

Ctrl+Shift+Right Arrow or Ctrl+Shift+Left

Arrow

Shift+Up Arrow or Shift+Down Arrow

Shift+Right Arrow or Shift+Left Arrow

Ctrl+Shift+Up Arrow or Ctrl+Shift+Down

Arrow

Shift+Up Arrow or Shift+Down Arrow

Shift+Home or Shift+End

Home or End

Double-click text layer

Ctrl+Shift+Home or Ctrl+Shift+End

Shift-click

Left Arrow or Right Arrow; Up Arrow or
Down Arrow; Ctrl+Left Arrow or Ctrl+Right
Arrow; or Ctrl+Up Arrow or Ctrl+Down
Arrow

Up Arrow or Down Arrow; Left Arrow or
Right Arrow; Ctrl+Up Arrow or Ctrl+Down

Arrow; or Ctrl+Left Arrow or Ctrl+Right
Arrow

Double-click, triple-click, quadruple-click,
or quintuple-click with Type tool
Ctrl+Shift+K

Ctrl+Alt+Shift+K

Ctrl+Shift+= (equals)

Ctrl+Alt+Shift+= (equals)

Ctrl+Shift+X
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Mac OS
Command+Option+Shift+T

Command+Shift+L, Command+Shift+C, or
Command+Shift+R

Command+Shift+L, Command+Shift+C, or
Command+Shift+R

Shift+Right Arrow or Shift+Left Arrow
Command+Shift+Right Arrow or
Command+Shift+Left Arrow

Shift+Up Arrow or Shift+Down Arrow

Shift+Right Arrow or Shift+Left Arrow

Command+Shift+Up Arrow or

Command+Shift+Down Arrow

Shift+Up Arrow or Shift+Down Arrow

Shift+Home or Shift+End

Home or End

Double-click text layer

Command+Shift+Home or
Command+Shift+End

Shift-click

Left Arrow or Right Arrow; Up Arrow or
Down Arrow; Command-+Left Arrow or
Command+Right Arrow; or Command+Up
Arrow or Command+Down Arrow

Up Arrow or Down Arrow; Left Arrow or
Right Arrow; Command+Up Arrow or
Command+Down Arrow; or
Command+Left Arrow or Command+Right

Arrow

Double-click, triple-click, quadruple-click,
or quintuple-click with Type tool

Command+Shift+K
Command+Option+Shift+K
Command+Shift+= (equals)
Command+Option+Shift+= (equals)

Command+Shift+X



Set vertical scale to 100% for selected
text

Auto leading for selected text

Reset tracking to O for selected text
Justify paragraph; left align last line
Justify paragraph; right align last line
Justify paragraph; force last line

Decrease or increase font size of selected
text by 2 units

Decrease or increase font size of selected
text by 10 units

Increase or decrease leading by 2 units

Increase or decrease leading by 10 units

Decrease or increase baseline shift by 2
units

Decrease or increase baseline shift by 10
units

Decrease or increase kerning or tracking
20 units (20/1000 ems)

Decrease or increase kerning or tracking
100 units (100/1000 ems)

Toggle paragraph composer

Masks (keyboard shortcuts)

Result
New mask
Select all points in a mask

Select next or previous mask

Enter free-transform mask editing mode

Exit free-transform mask editing mode

Scale around center point in Free
Transform mode

Move selected path points 1 pixel at
current magnification

Move selected path points 10 pixels at
current magnification

Toggle between smooth and corner points

Redraw Bezier handles

Ctrl+Alt+Shift+X

Ctrl+Alt+Shift+A
Ctrl+Shift+Q
Ctrl+Shift+J
Ctrl+Alt+Shift+J
Ctrl+Shift+F

Ctrl+Shift+, (comma) or Ctrl+Shift+.
(period)

Ctrl+Alt+Shift+, (comma) or
Ctrl+Alt+Shift+. (period)

Alt+Down Arrow or Alt+Up Arrow
Ctrl+Alt+Down Arrow or Ctrl+Alt+Up Arrow
Alt+Shift+Down Arrow or Alt+Shift+Up
Arrow

Ctrl+Alt+Shift+Down Arrow or
Ctrl+Alt+Shift+Up Arrow

Alt+Left Arrow or Alt+Right Arrow

Ctrl+Alt+Left Arrow or Ctrl+Alt+Right
Arrow

Ctrl+Alt+Shift+T

Windows
Ctrl+Shift+N
Alt-click mask

Alt+" (accent grave) or Alt+Shift+" (accent
grave)

Double-click mask with Selection tool or
select mask in Timeline panel and press
Ctrl+T

Esc

Ctrl-drag

arrow key

Shift+arrow key

Ctrl+Alt-click vertex

Ctrl+Alt-drag vertex
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Command+Option+Shift+X

Command+Option+Shift+A
Command+Shift+Control+Q
Command+Shift+J
Command+Option+Shift+J
Command+Shift+F

Command+Shift+, (comma) or
Command+Shift+. (period)

Command+Option+Shift+, (comma) or
Command+Option+Shift+. (period)

Option+Down Arrow or Option+Up Arrow

Command+Option+Down Arrow or
Command+Option+Up Arrow

Option+Shift+Down Arrow or
Option+Shift+Up Arrow

Command+Option+Shift+Down Arrow or
Command+Option+Shift+Up Arrow

Option+Left Arrow or Option+Right Arrow

Command+Option+Left Arrow or
Command+Option+Right Arrow

Command+Option+Shift+T

To the top

Mac OS
Command+Shift+N
Option-click mask

Option+" (accent grave) or Option+Shift+"
(accent grave)

Double-click mask with Selection tool or
select mask in Timeline panel and press
Command+T

Esc

Command-drag

arrow key

Shift+arrow key

Command+Option-click vertex

Command+Option-drag vertex



Invert selected mask

Open Mask Feather dialog box for
selected mask

Open Mask Shape dialog box for selected
mask

Paint tools (keyboard shortcuts)

Result

Swap paint background color and
foreground colors

Set paint foreground color to black and
background color to white

Set foreground color to the color currently
under any paint tool pointer

Set foreground color to the average color
of a 4-pixel x 4-pixel area under any paint
tool pointer

Set brush size for a paint tool

Set brush hardness for a paint tool

Join current paint stroke to the previous
stroke

Set starting sample point to point currently
under Clone Stamp tool pointer

Momentarily activate Eraser tool with Last
Stroke Only option

Show and move overlay (change Offset
value of aligned Clone Stamp tool or
change Source Position value of unaligned
Clone Stamp tool)

Activate a specific Clone Stamp tool
preset

Duplicate a Clone Stamp tool preset in
Paint panel

Set opacity for a paint tool

Set opacity for a paint tool to 100%

Set flow for a paint tool

Set flow for a paint tool to 100%

Move earlier or later by number of frames
specified for stroke Duration

Ctrl+Shift+

Ctrl+Shift+F

Ctrl+Shift+M

Windows

X

Alt-click

Ctrl+Alt-click

Ctrl-drag

Ctrl-drag, then release Ctrl while dragging

Hold Shift while beginning stroke

Alt-click

Ctrl+Shift

Alt+Shift-drag with Clone Stamp tool

3, 4,5, 6, or 7 on the main keyboard

Alt-click the button for the preset

Digit on numeric keypad (for example,
9=90%, 1=10%)*

. (decimal) on numeric keypad*

Shift+a digit on numeric keypad (for
example, 9=90%, 1=10%)*

Shift+. (decimal) on numeric keypad*

Ctrl+Page Up or Ctrl+Page Down (or 1 or
2 on the main keyboard)

Command+Shift+l

Command+Shift+F

Command+Shift+M

Mac OS

Option-click

Command+Option-click

Command-drag

Command-drag, then release Command
while dragging

Hold Shift while beginning stroke

Option-click

Command+Shift

Option+Shift-drag with Clone Stamp tool

3, 4,5, 6, or 7 on the main keyboard

Option-click the button for the preset

Digit on numeric keypad (for example,
9=90%, 1=10%)*

. (decimal) on numeric keypad*

Shift+a digit on numeric keypad (for
example, 9=90%, 1=10%)*

Shift+. (decimal) on numeric keypad*

Command+Page Up or Command+Page
Down (or 1 or 2 on the main keyboard)

To the top

Note: Some shortcuts are marked with an asterisk (*) to remind you to make sure that Num Lock is on when you use the numeric keypad.
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Shape layers (keyboard shortcuts)

Result
Group selected shapes
Ungroup selected shapes

Enter free-transform path editing mode

Increase star inner roundness

Decrease star inner roundness

Increase number of points for star or
polygon; increase roundness for rounded
rectangle

Decrease number of points for star or
polygon; decrease roundness for rounded
rectangle

Reposition shape during creation

Set rounded rectangle roundness to 0
(sharp corners); decrease polygon and
star outer roundness

Set rounded rectangle roundness to
maximum; increase polygon and star outer
roundness

Constrain rectangles to squares; constrain
ellipses to circles; constrain polygons and

stars to zero rotation

Change outer radius of star

Markers (keyboard shortcuts)

Result

Set marker at current time (works during
RAM preview and audio-only preview)

Set marker at current time and open
marker dialog box

Set and number a composition marker (0-
9) at the current time

Go to a composition marker (0-9)

Display the duration between two layer
markers or keyframes in the Info panel

Remove marker

Windows
Ctri+G
Ctrl+Shift+G

Select Path property in Timeline panel and
press Ctrl+T

Page Up when dragging to create shape

Page Down when dragging to create
shape

Up Arrow when dragging to create shape

Down Arrow when dragging to create
shape

Hold spacebar when dragging to create
shape

Left Arrow when dragging to create shape

Right Arrow when dragging to create
shape

Shift when dragging to create shape

Ctrl when dragging to create shape

Windows

* (multiply) on numeric keypad

Alt+* (multiply) on numeric keypad

Shift+0-9 on main keyboard

0-9 on main keyboard

Alt-click the markers or keyframes

Ctrl-click marker

Motion tracking (keyboard shortcuts)
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To the top

Mac OS
Command+G
Command+Shift+G

Select Path property in Timeline panel and
press Command+T

Page Up when dragging to create shape

Page Down when dragging to create
shape

Up Arrow when dragging to create shape

Down Arrow when dragging to create
shape

Hold spacebar when dragging to create
shape

Left Arrow when dragging to create shape

Right Arrow when dragging to create
shape

Shift when dragging to create shape

Command when dragging to create shape

To the top

Mac OS

* (multiply) on numeric keypad or
Control+8 on main keyboard

Option+* (multiply) on numeric keypad or
Control+Option+8 on main keyboard

Shift+0-9 on main keyboard

0-9 on main keyboard

Option-click the markers or keyframes

Command-click marker

To the top



Result

Move feature region, search region, and
attach point 1 pixel at current
magnification

Move feature region, search region, and
attach point 10 pixels at current
magnification

Move feature region and search region 1
pixel at current magnification

Move feature region and search region 10
pixels at current magnification

Windows

arrow key

Shift+arrow key

Alt+arrow key

Alt+Shift+arrow key

Saving, exporting, and rendering (keyboard shortcuts)

Result

Save project

Increment and save project
Save As

Add active composition or selected items
to render queue

Add active composition or selected items
to render queue (After Effects CS6, and
earlier.)

Add current frame to render queue

Duplicate render item with same output
filename as original
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Windows
Ctrl+S
Ctrl+Alt+Shift+S
Ctrl+Shift+S

Ctrl+Shift+/ (on main keyboard)
Ctrl+M

Ctrl+Alt+S

Ctrl+Shift+D
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Mac OS

arrow key

Shift+arrow key

Option+arrow key

Option+Shift+arrow key

To the top

Mac OS

Command+S
Command+Option+Shift+S
Command+Shift+S

Command+Shift+/ (on main keyboard)

Ctrl+Command+M

Command+Option+S

Command+Shift+D
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Modify keyboard shortcuts

To modify keyboard shortcuts, use the KeyEd Up script from Jeff Almasol, which is available on the Adobe After Effects Exchange website.

Sebastien Perier provides instructions on his website for assigning keyboard shortcuts to scripts so that you can run a script with a single
keystroke. This technique relies on the KeyEd Up script.

For information on remapping keyboard shortcuts for keyboard layouts other than the standard US English layout, see Jonas Hummelstrand's
website.

For a reference of keyboard shortcuts, see Keyboard shortcuts reference.

Note: On Mac OS, some keyboard commands for interacting with the operating system conflict with keyboard commands for interacting with After
Effects. Select Use System Shortcut Keys in the General preferences to override the After Effects keyboard command in some cases in which
there’s a conflict with the Mac OS keyboard command.
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Preferences

General preferences

Previews preferences (CS5.5, and earlier)
Previews preferences (CS6)

Display preferences

Import preferences

Output preferences

Grids & Guides preferences

Labels preferences

Media & Disk Cache preferences

Video Preview preferences

Appearance preferences

Auto-Save preferences

Memory & Multiprocessing preferences
Audio Hardware and Audio Output Mapping preferences

« To open the Preferences dialog box, choose Edit > Preferences > [category name] (Windows) or After Effects > Preferences > [category
name] (Mac OS).

« To open the Preferences dialog box to the General category, press Ctrl+Alt+; (semicolon) (Windows) or Command+Option+; (Mac OS).

» To restore default preference settings, hold Ctrl+Alt+Shift (Windows) or Command+Option+Shift (Mac OS) while the application is starting. To
also restore default keyboard shortcuts, Alt-click (Windows) or Option-click (Mac OS) the OK button.

Preferences, including keyboard shortcuts and workspaces, are stored in files in the following locations:
* (Mac OS) <drive>/Users/<username>/Library/Preferences/Adobe/After Effects/10.0
« (Windows) <drive>\Users\<username>\AppData\Roaming\Adobe\After Effects\10.0

In After Effects CS6, preferences can be revealed without searching your hard drive for them. To reveal preferences, choose Edit > Preferences >
General (Windows), or After Effects > Preferences > Genereal (Mac OS) and do one of the following:

« Click the Reveal Preferences in Explorer button (Windows).
« Click the Reveal Preferences in Finder button (Mac OS).
Clicking the button opens the folder containing the After Effects preference files.

Note: You shouldn't need to modify the files in this directory manually. In general, modify preferences in the Preferences dialog box. For
information on modifying keyboard shortcuts, see Modify keyboard shortcuts. For information on managing workspaces, see Workspaces and
panels.

This section provides links to pages in which the various preferences that aren’t self-explanatory are explained in context.

To the to
General preferences ’

« Levels Of Undo: Undo changes

» Path Point Size: Specifies size of Bezier direction handles and vertices for masks and shapes, direction handles for motion paths, and other
similar controls.

« Show Tool Tips: After Effects user interface tips

« Create Layers At Composition Start Time: Layers overview

« Switches Affect Nested Comps: About precomposing and nesting

» Default Spatial Interpolation To Linear: About spatial and temporal keyframe interpolation

* Preserve Constant Vertex Count When Editing Masks: Designate the first vertex for a Bezier path
Note: Preserve Constant Vertex Count when Editing Masks has been renamed to “Preserve Constant Vertex and Feather Count when
Editing Masks” in After Effects CS6.

« Pen Tool Shortcut Toggles Between Pen and Mask Feather Tools (After Effects CS6): Variable-width mask feather (CS6)
« Synchronize Time Of All Related ltems: Preferences and composition settings that affect nested compositions

« Expression Pick Whip Writes Compact English: Edit an expression with the pick whip
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Previews preferences (CS5.5, and earlier)

Previews preferences (CS6)

Create Split Layers Above Original Layer: Split a layer

Allow Scripts To Write Files And Access Network: Loading and running scripts

Enable JavaScript Debugger: After Effects scripting guide at the Adobe After Effects Developer Center on the Adobe website
Use System Color Picker: Choose a color picker

Create New Layers At Best Quality: Layer image quality and subpixel positioning

Use System Shortcut Keys (Mac OS only): Keyboard shortcuts

Dynamic Link with After Effects Uses Project File Name with Highest Number (After Effects CS6): About Dynamic Link

To the top

Adaptive Resolution Limit: Preview modes and Fast Previews preferences

Enable OpenGL and Accelerate Effects Using OpenGL (When Possible): Render with OpenGL
Enable Adaptive Resolution With OpenGL: Preview modes and Fast Previews preferences
Viewer Quality (Zoom Quality and Color Management Quality): Viewer Quality preferences

Audio Preview Duration: Preview video and audio

To the top

Adaptive Resolution Limit: Preview modes and Fast Previews preferences
Also, see Fast Previews (CS6).

The OpenGL Information button and dialog box has been replaced with a GPU Information dialog box in After Effects CS6. The dialog box is
available for checking on texture memory for your GPU, and to set the ray-tracing preference to the GPU, if it is available. The OptiX version
number is available, as well as, Copy button to copy the general information at the top of the dialog box to the system clipboard.

Viewer Quality (Zoom Quality and Color Management Quality): Viewer Quality preferences

Audio Preview Duration: Preview video and audio

Display preferences fothetop
« Motion Path: Motion paths
« Disable Thumbnails In Project Panel: Composition thumbnail images
« Show Rendering Progress In Info Panel And Flowchart: Preview video and audio
« Hardware Accelerate Composition, Layer, And Footage Panels: Improve performance
To the top

Import preferences

Still Footage: Create layers from footage items or change layer source

Sequence Footage: Import a single still image or a still-image sequence

Interpret Unlabeled Alpha As: Alpha channel interpretation: premultiplied or straight
Drag Import Multiple ltems As: Import footage items by dragging

Adobe After Effects CS5.5 and later contains a dropdown menu to choose drop-frame or non-drop-frame timecode for Indeterminate Media
NTSC, which applies to imports like still image sequences in which timecode values are not present or are unknown.

To the to
Output preferences ’
* Segment Sequences At, Segment Movie Files At, and Audio Block Duration: Segment settings
» Use Default File Name And Folder: Name output files automatically
To the top

Grids & Guides preferences

Safe zones, grids, guides, and rulers
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To the to
Labels preferences ’ ’

« Color labels for layers, compositions, and footage items

. . To theto

Media & Disk Cache preferences 0

« Enable Disk Cache and Maximum Disk Cache Size: Caches: RAM cache, disk cache, and media cache

+ Conformed Media Cache and Clean Database & Cache: Media cache

« Create Layer Markers From Footage XMP Metadata and Write XMP IDs To Files On Import: XMP metadata in After Effects

. . To the top
Video Preview preferences

* Preview on an external video monitor

To the top

Appearance preferences

e Use Label Color For Layer Handles And Paths and Use Label Color For Related Tabs: Color labels for layers, compositions, and footage
items

» Cycle Mask Colors: Cycle through colors for mask paths
« Use Gradients: Use gradients in user interface.

» Brightness: Brightens or darkens user interface (Ul) colors.

To the to
Auto-Save preferences ’
« Save and back up projects in After Effects CS5
. . To the top
Memory & Multiprocessing preferences
« Memory & Multiprocessing preferences
To the top

Audio Hardware and Audio Output Mapping preferences

« Preview video and audio
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Projects and compositions
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Projects

About projects

Create and open projects

Save and back up projects

Template projects and example projects
Flowchart panel

About projects To the top

An After Effects project is a single file that stores compositions and references to all of the source files used by footage items in that project.
Compositions are collections of layers. Many layers use footage items (such as movies or still images) as a source, though some layers—such as
shape layers and text layers—contain graphics that you create within After Effects.

A project file has the filename extension .aep or .aepx. A project file with the .aep filename extension is a binary project file. A project file with the
.aepx filename extension is a text-based XML project file.

The name of the current project appears at the top of the application window.

A template project file has the filename extension .aet. (See Template projects and example projects.)

XML project files

Text-based XML project files contain some project information as hexadecimal-encoded binary data, but much of the information is exposed as
human-readable text in string elements. You can open an XML project file in a text editor and edit some details of the project without opening the
project in After Effects. You can even write scripts that modify project information in XML project files as part of an automated workflow.

For a video tutorial about the XML project file format, go to the Adobe website.

Elements of a project that you can modify in an XML project file:
» Marker attributes, including comments, chapter point parameters, and cue point parameters
» File paths of source footage items, including proxies
« Composition, footage item, layer, and folder names and comments

Note: Footage item names are exposed in string elements in XML project files only if the names have been customized. Footage item
names derived automatically from the names of source files and solid color names are not exposed in string elements

Some strings, such as workspace and view names, are exposed as human-readable strings, but modifications made to these strings are not
respected when After Effects opens the project file.

Important: Do not use the XML project file format as your primary file format. The primary project file format for After Effects is the binary project

file (.aep) format. Use the XML project file format to save a copy of a project and as an intermediate format for automation workflows.

Q To save an XML project (.aepx) file as a binary project (.aep) file, choose File > Save As and enter a file name ending with .aep, without the x.
(See Save and back up projects in After Effects CS5.)

Project links embedded in QuickTime, Video for Windows, FLV header, and F4V files
When you render a movie and export it to a container format, you can embed a link to the After Effects project in the container file. Container
formats include FLV, F4V, QuickTime (MOV), and Video for Windows (AVI).

To import the project, import the container file, and choose Project from the Import As menu in the Import File dialog box. If the container file
contains a link to a project that has been moved, you can browse to locate the project.
Note: After Effects CS5 can open projects using project links included in movies rendered and exported by After Effects CS4 and later.

. To the to
Create and open pl’OjeCtS 0

Only one project can be open at a time. If you create or open another project file while a project is open, After Effects prompts you to save
changes in the open project, and then closes it. After you create a project, you can import footage into the project.

Note: After Effects CS5 can open and import After Effects projects created by After Effects 6.0 and later.
Note: After Effects CS6 can open After Effects 7.0 projects or newer. After Effects 6.5 projects and older will not open in After Effects CS6.

« To create a project, choose File > New > New Project.

« To open a project, choose File > Open Project, locate the project, and then click Open.
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Jeff AlImasol provides a script on his redefinery website that creates and saves a new project for each selected composition in the current project.

Lloyd Alvarez provides a script on his After Effects Scripts website that gives you the ability to specify a project or template project that After
Effects opens each time that After Effects starts.

Save and back up projects To the top

Save and back up projects in After Effects CS5
« To save a project, choose File > Save.
« To save a copy of the project with a new automatically generated name, choose File > Increment And Save, or press Ctrl+Alt+Shift+S
(Windows) or Command+Option+Shift+S (Mac OS).

A copy of the current project is saved in the same folder as the original project. The name of the copy is the name of the original followed by
a number. If the name of the original ends with a number, that number is increased by 1.

« To save the project with a different name or to a different location, choose File > Save As.
The open project takes the new name and location; the original file remains unchanged.

« To save the project as a copy in the XML project file format, choose File > Save A Copy As XML. (See About projects.)
« To save a copy of the project with a different name or to a different location, choose File > Save A Copy.

The open project retains its original name and location, and a copy is created with the new settings but is not opened.

« To automatically save copies of projects at regular intervals, choose Edit > Preferences > Auto-Save (Windows) or After Effects >
Preferences > Auto-Save (Mac OS), and select Automatically Save Projects.

Auto-saved files are saved in the After Effects Auto-Save folder, which is located in the same folder as the original project file. Auto-saved
filenames are based on the project name: After Effects adds “auto-save n” (where n is the number of the file in the auto-save series) to the
end of the filename. Maximum Project Versions specifies how many versions of each project file you want to save. When the number of
versions saved reaches the maximum you specify, the Auto-Save feature overwrites them starting with the oldest file.

« To save a copy of the project and copies of assets used in the project to a single folder on disk, use the Collect Files command. (See Collect
files in one location.)

An After Effects CS5 project cannot be saved for use in After Effects CS4 or earlier.

Note: After Effects will only execute an auto-save when there are unsaved changes in the currently open project. This also applies when the
program is in the background or minimized. The potential consequence is leaving open with unsaved changes for a long enough period that
eventually all of the auto-save versions will be identical. For example, when auto-save is set to save every 10 minutes and to keep 10 versions,
after 1 hour and 40 minutes all auto-saves will be identically overwritten.

Save and back up projects in After Effects CS5.5 and After Effects CS6
Saving and backing up projects in After Effects CS5.5 or After Effects CS6 is similar to previous versions, however, there are new ways to do so.
For example, you can now save a project in the XML project file format, or as a previous project format.

« To save the project with a different name or to a different location, choose File > Save As > Save As.

» To save the project as a copy in the XML project file format, choose File > Save As > Save A Copy As XML.

« To save a copy of the project with a different name or to a different location, choose File > Save As > Save A Copy.

« In After Effects CS5.5, to save a project that can be opened in After Effects CS5, choose File > Save As > Save A Copy As CS5.

« In After Effects CS6, to save a project that can be opened in After Effects CS5.5, choose File > Save As > Save A Copy As CS5.5.

For details, tutorials, and resources about saving a project from After Effects CS5.5 as a copy that can be opened in After Effects CS5, see this
post on the After Effects Region of interest blog.

Note: New features from After Effects CS5.5 that are used in a project will be ignored after the project is saved as an After Effects CS5 project.
For example, the 3D Glasses effect has new parameters in After Effects CS5.5. If you used the 3D Glasses effect in an After Effects CS5.5 project,
the parameters from the newer effect would not carry over to the project when saved to disk. Likewise, new features from After Effects CS6 that
are used in a project are ignored after the project is saved as an After Effects CS5.5 project.

To the top

Template projects and example projects

A template project is a file with the filename extension .aet. You can use the many template projects included with After Effects—including DVD
menu templates—as the basis for your own projects, and you can create new templates base on your projects

Note: After Effects CS6 doesn't install template projects, however, you can download the same template projects that came with previous
versions of After Effects on the After Effects Exchange. For more information, see this post on the After Effects team blog.

When you open a template project, After Effects creates a new, untitled project based on the template. Saving changes to this new project does
not affect the template project.

Q A great way to see how advanced users use After Effects is to open one of the template projects included with After Effects, open a
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composition to activate it, and press U or UU to reveal only the animated or modified layer properties. Viewing the animated and modified
properties shows you what changes the designer of the template project made to create the template.

Often, the creator of a template project locks layers that should be left unmodified, and leaves layers that should be modified unlocked. This is a
convenient way to prevent accidental or inappropriate modifications.

You can download example projects and template projects from many websites, including the After Effects Exchange on the Adobe website. For
more sources of After Effects example projects and template projects, see After Effects community resources on the Adobe website.

See this video tutorial by Andrew Devis on the Creative Cow website for information about where to find template projects and sample
expressions included with After Effects.

Open atemplate project
« To browse and open template projects using Adobe Bridge, choose File > Browse Template Projects. Double-click a template project to
open it.
Note: In After Effects CS6, the File > Browse Template Projects command has been removed.

» To open a template project, choose File > Open Project. On Windows, choose Adobe After Effects Project Template from the Files Of Type
menu.

Create a template project
« To convert a project to a template project, change the filename extension from .aep to .aet.

« To save a copy of a project as a template project, choose File > Save A Copy, and then rename the copy with the filename extension .aet.

To the to
Flowchart panel ometon

In the flowchart for each project or composition, individual boxes (or tiles) represent each composition, footage item, and layer. Directional arrows
represent the relationships between components.

Note: The Flowchart panel shows you only the existing relationships. You cannot use it to change relationships between elements.
Nested compositions and other elements that make up the composition appear when you expand a composition tile.

Mid-gray lines between tiles in the flowchart indicate that the Video or Audio switch for those items is deselected in the Timeline panel. Black or
light gray lines indicate that the switch is selected, depending on the Brightness setting in the Appearance preferences.

« To open the project flowchart, press Ctrl+F11 (Windows) or Command+F11 (Mac OS), or click the Project Flowchart % button at the top of
the vertical scroll bar on the right edge of the Project panel.

« To open a composition flowchart, select the composition and choose Composition > Composition Flowchart, or click the Composition
Flowchart s button at the bottom of the Composition panel.

« To activate (select) an item, click its tile in the Flowchart panel.

When you click a composition in the flowchart, it becomes active in the Project panel and the Timeline panel. When you click a layer, it
becomes active in the Timeline panel. When you click a footage item, it becomes active in the Project panel.

« To customize the appearance of the flowchart, use the Flowchart panel menu and the buttons along the bottom of the panel.
Q For tool tips identifying the buttons in the Flowchart panel, let your pointer hover over a button until the tool tip appears.

« To delete elements, select them and press Delete. If the selected element is a footage item or composition, it is deleted from the project and
no longer appears in the Timeline and Project panels. If the selected element is a layer, it is deleted from the composition in which it appears.

« To access the context menu for a selected element, right-click (Windows) or Control-click (Mac OS) the icon to the left of the name in the
element tile. The icons have various appearances, depending on the element type, such as layers I and compositions = For example, you
can use the context menu for a layer to work with masks and effects, or to change switches, apply transformations, and adjust layer image
quality.
Note: When you change element properties in the Flowchart panel, be careful to context-click the icon in the tile, not the name of the
element. The context menu associated with the element icon is different from the one that opens from the element name.

Rich Young provides additional information about the Flowchart panel and the Composition Mini-flowchart on the After Effects Portal website.

More Help topics
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Timecode and time display units

Change time-display units in After Effects CS5

Change time-display units in After Effects CS5.5 and later
Options for time-display units in After Effects CS5

Options for time-display units in After Effects CS5.5 and later
Source timecode (CS5.5 and later)

Online resources about timecode

Many quantities in After Effects are either points in time or spans of time, including the current time, layer In and Out points, and durations of
layers, footage items, and compositions.

By default, After Effects displays time in Society of Motion Picture and Television Engineers (SMPTE) timecode: hours, minutes, seconds, and
frames. You can change to another system of time display, such as frames, or feet and frames of 16mm or 35mm film.

You may want to see time values in feet plus frames format, for example, if you are preparing a movie for eventual output to film; or in simple
frame numbers if you plan to use your movie in an animation program such as Flash. The format you choose applies to the current project only.

Important: Changing the time display format does not alter the frame rate of your assets or output—it changes only how frames are numbered
for display in After Effects.

Video-editing workstations often use SMPTE timecode that is recorded onto videotape for reference. If you are creating video that will be
synchronized with video that uses SMPTE timecode, use the default timecode display style.

In After Effects CS5.5 and later, timecode from source files can be displayed from a variety of file formats. Source timecode is found in several
areas of the interface including the Project panel, Project Settings dialog box, Composition Settings dialog box and Preferences dialog box. See
Source timecode (CS5.5 and later) for more information.

For details, tutorials, and resources about source timecode and Timecode effect changes in After Effects CS5.5, see this post on the After Effects
Region of Interest blog.

. . . . To the to
Change time-display units in After Effects CS5 ’
« To cycle through Timecode Base, Frames, and Feet + Frames, Ctrl-click (Windows) or Command-click (Mac OS) the current-time display.
The current-time display is in the upper-left corner of the Timeline panel and at the bottom of the Layer, Composition, and Footage panels.
(See Timeline panel.)

« To change time display units, choose File > Project Settings, and choose from the options in the Display Style section.

. . . . To the to
Change time-display units in After Effects CS5.5 and later ’
« To cycle through Timecode Base, or Frames / Feet + Frames (depending if you have the “Use Feet + Frames” option checked in the Project
Settings), Ctrl-click (Windows) or Command-click (Mac OS) the current-time display. The current-time display is in the upper-left corner of
the Timeline panel and at the bottom of the Layer, Composition, and Footage panels. (See Timeline panel.) The option that is not selected in
Project Settings will be displayed as smaller text underneath.

« To change time display units, choose File > Project Settings, and choose from the options in the Time Display Style section.

Options for time-display units in After Effects CS5 fothetop
Timecode Base Displays time as timecode, using the frame rate that you specify as the timecode base. Auto uses the rounded frame rate of the
footage item or composition. If an item doesn’t have timecode (such as an audio file), After Effects uses a default value (30 fps for English,
Japanese, and Korean versions of After Effects, or 25 fps for French, German, Spanish, and lItalian versions) or the last non-auto value you
specified in the Project Settings dialog box. You can also specify that After Effects use a specific frame rate.

Note: You can specify specific frame rates for display in the Timecode Base menu; however, in most cases, you should leave the timecode base
set to Auto.

Drop Frame versus Non-Drop Frame Two of the more commonly used combinations of time display settings are 30 fps drop-frame timecode
and 30 fps non-drop-frame timecode. When the frame rate is a non-integer number—as is the case with the NTSC frame rate of 29.97 frames per
second—a compromise of one sort or another must be made in displaying time. Either the time display can accurately show clock time (after one
hour, the time display shows 1:00:00:00) or the time display can be continuously numbered (frame n is always followed by frame n + 1, modulo the
number of frames per second). Drop-frame timecode does the former; non-drop-frame timecode does the latter. In the case of NTSC 30 fps drop-
frame timecode, two frame numbers are skipped for each minute, except for every tenth minute. Drop-frame timecode is conventionally indicated
by separating the time units with semicolons. The most common case for which drop-frame versus non-drop-frame timecode is relevant is 29.97
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fps NTSC, but it also applies to 23.976 fps (which After Effects treats as non-drop-frame timecode) and 59.94 fps.

Timecode for 59.94 fps compositions and footage items matches that in Premiere Pro: When the timecode base is 30 fps, each timecode value
repeats twice. When the timecode base is 60 fps drop-frame, frame numbers 0, 1, 2, and 3 are dropped in the same places as where 0 and 1 are
dropped for drop-frame timecode with a timecode base of 30 fps.

Frames Displays frame number instead of time. Use this setting for convenience when doing work that you are integrating with a frame-based
application or format, like Flash or SWF.

Feet + Frames Displays number of feet of film, plus frames for fractional feet, for 16mm or 35mm film. Numbering starts at the frame number that
you specify with the Start Numbering Frames At value.

Options for time-display units in After Effects CS5.5 and later fothetop
Timecode Displays time as timecode in the time rulers of the Timeline, Layer and Footage panels, using either Use Media Source (source
timecode) or starting at 00:00:00:00. Select the Timecode option to use timecode instead of Frames. Note that there are no options for choosing
frame rate or drop-frame / non-drop-frame, as source timecode is detected and used instead.

Note: In After Effects CS5.5 and later, timecode is no longer a global setting for projects. You may have both drop-frame and non-drop-frame
timecode in any composition within a project.

Frames Displays frame number instead of time. Use this setting for convenience when doing work that you are integrating with a frame-based
application or format, like Flash or SWF. To use Frames, select Frames and deselect Feet + Frames.

Feet + Frames Displays the number of feet of film, plus frames for fractional feet, for 16mm or 35mm film. To use Feet + Frames, select Frames
and select Feet + Frames.

Frame Count Determines the starting number for the time display style for Frames.

Timecode Conversion Timecode value of the item is used for the starting number (if the item has source timecode). If there is no
timecode value, counting begins with zero. Timecode Conversion causes After Effects to behave as it has in previous versions, where the
frame count and the timecode count of all assets are mathematically equivalent.

Start at 0 The counting for frames begins at zero.

Start at 1 The counting for frames begins at one.

Note: The new options of “Start at 0" and “Start at 1" allow you to specify different frame counting schemes between the “Frames” and
“Timecode.” For example, you might choose to honor the source timecode of footage items, but count frames beginning at zero or one.

Source timecode (CS5.5 and later) fothetop

Source timecode support file formats After Effects can read and use timecode for most formats including: QuickTime, DV, AVI, P2, MPEG-2,
MPEG-4, h.264, AVCHD, RED, XDCAM EX, XDCAM HD, WAV and DPX image sequence importers.

Project panel Source timecode is displayed in columns in the Project panel: Media Start, Media End, Media Duration and Tape Name. These
refer to the source’s start, end and total duration. In addition, columns have been added for In, Out, and Duration, which reflect the In and Out
points set by the user in the Footage panel for footage item, or the work area for compositions.

Project Settings The Project Settings dialog box has been substantially reworked to accommodate the source timecode feature set. For details,
see Options for time-display units in After Effects CS5.5 and later.

Composition Settings dialog box The Composition Settings dialog box has been changed to accomodate the source timecode feature set. For
details, see Frame rate.

Preferences dialog box The Preferences dialog box’s Import pane has been changed to support source timecode features. See Import
preferences.

For details, tutorials, and resources about source timecode and Timecode effect changes in After Effects CS5.5, see this post on the After Effects
Region of Interest blog.

. . To thet
Online resources about timecode et

Trish and Chris Meyer provide an article on the ProVideo Coalition website that describes the difference between drop-frame and non-drop-frame
timecode.

Chris Pirazzi provides technical details about timecode on his Lurker's Guide to Video website.

(@) v-ro-sn |

Legal Notices | Online Privacy Policy
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Composition basics

About compositions

Create a composition

Create compositions for playback on mobile devices
Timeline panel

Composition settings

Composition thumbnail images

For more information about creating compositions, see this video by Andrew Devis on the Creative Cow website.

s To the to
About composmons .

A composition is the framework for a movie. Each composition has its own timeline. A typical composition includes multiple layers that represent
components such as video and audio footage items, animated text and vector graphics, still images, and lights. You add a footage item to a
composition by creating a layer for which the footage item is the source. You then arrange layers within a composition in space and time, and
composite using transparency features to determine which parts of underlying layers show through the layers stacked on top of them. (See Layers
and properties and Transparency and compositing.)

A composition in After Effects is similar to a movie clip in Flash Professional or a sequence in Premiere Pro.

You render a composition to create the frames of a final output movie, which is encoded and exported to any nhumber of formats. (See Basics of
rendering and exporting.)

Simple projects may include only one composition; complex projects may include hundreds of compositions to organize large amounts of footage
or many effects.

In some places in the After Effects user interface, composition is abbreviated as comp.

Each composition has an entry in the Project panel. Double-click a composition entry in the Project panel to open the composition in its own
Timeline panel. To select a composition in the Project panel, right-click (Windows) or Control-click (Mac OS) in the Composition panel or Timeline
panel for the composition and choose Reveal Composition In Project from the context menu.

Use the Composition panel to preview a composition and modify its contents manually. The Composition panel contains the composition frame and
a pasteboard area outside the frame that you can use to move layers into and out of the composition frame. The offstage extents of layers—the
portions not in the composition frame—are shown as rectangular outlines. Only the area inside the composition frame is rendered for previews and
final output.

The composition frame in the Composition panel in After Effects is similar to the Stage in Flash Professional.

When working with a complex project, you may find it easiest to organize the project by nesting compositions—putting one or more compositions
into another composition. You can create a composition from any number of layers by precomposing them. If you are finished modifying some
layers of your composition, you can precompose those layers and then pre-render the precomposition, replacing it with a rendered movie. (See
Precomposing, nesting, and pre-rendering.)

You can navigate within a hierarchy of nested compositions using the Composition Navigator and Composition Mini-Flowchart. (See Opening and
navigating nested compositions.)

Use the Flowchart panel to see the structure of a complex composition or network of compositions.

Timeline button I Click this button at the bottom of the Composition panel to activate the Timeline panel for the current composition.
§ Press the backslash (\) key to switch activation between the Composition panel and Timeline panel for the current composition.

Comp button & Click this button in the upper-right corner of the Timeline panel to activate the Composition panel for the current composition.
Flowchart button & Click this button at the bottom of the Composition panel to activate the Flowchart panel for the current composition.
To the top

Create a composition

You can change composition settings at any time. However, it's best to specify settings such as frame aspect ratio and frame size when you create
the composition, with your final output in mind. Because After Effects bases certain calculations on these composition settings, changing them late
in your workflow can affect your final output.

For more information about creating compositions, see this video by Andrew Devis on the Creative Cow website.
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Note: You can override some composition settings when rendering to final output. For example, you can use different frame sizes for the same
movie. For more information see Render settings and Output modules and output module settings.

When you create a composition without changing settings in the Composition Settings dialog box, the new composition uses the settings from the
previous time that composition settings were set.

Note: New compositions do not inherit the previous Preserve Frame Rate When Nested Or In Render Queue and Preserve Resolution When
Nested settings.

You can create a set of After Effects compositions tailored for a selected set of devices by using the File > New Document In > After Effects
command in Adobe Device Central. See Create compositions for playback on mobile devices.

In After Effects CS6, you can create a ray-traced 3D composition for working with extruded text and shape layers. See Creating a ray-traced 3D
composition.

Jeff AlImasol provides a script on his redefinery website that creates and saves a new project for each selected composition in the current project. If
a folder is selected in the Project panel when you create a new composition, the new composition is placed in the selected folder.

Create a composition and manually set composition settings
» Choose Composition > New Composition, or press Ctrl+N (Windows) or Command+N (Mac OS).

Create a composition from a single footage item
« Drag the footage item to the Create A New Composition button E at the bottom of the Project panel or choose File > New Comp From
Selection.

Composition settings, including frame size (width and height) and pixel aspect ratio, are automatically set to match the characteristics of the
footage item.

Create a single composition from multiple footage items
1. Select footage items in the Project panel.

2. Drag the selected footage items to the Create A New Composition button B at the bottom of the Project panel, or choose File > New Comp
From Selection.

3. Select Single Composition and other settings in the New Composition From Selection dialog box:
Use Dimensions From Choose the footage item from which the new composition gets composition settings, including frame size (width and
height) and pixel aspect ratio.
Still Duration The duration for the still images being added.

Add To Render Queue Add the new composition to the render queue.

Sequence Layers, Overlap, Duration, and Transition Arrange the layers in a sequence, optionally overlap them in time, set the duration
of the transitions, and choose a transition type.

Create multiple compositions from multiple footage items
1. Select footage items in the Project panel.

2. Drag the selected footage items to the Create A New Composition button B at the bottom of the Project panel, or choose File > New Comp
From Selection.

3. Select Multiple Compositions and other settings in the New Composition From Selection dialog box:

Still Duration The duration of the compositions created from still images.

Add To Render Queue Add the new compositions to the render queue.

Duplicate a composition
1. Select the composition in the Project panel.
2. Choose Edit > Duplicate or press Ctrl+D (Windows) or Command+D (Mac OS).

e . . To the t
Create compositions for playback on mobile devices et

Screen dimensions and video frame rates vary from one mobile device to another. Adobe Device Central contains a database of device profiles
that provide information about these characteristics. Using this information, you can create movies that play correctly and look as you intend on the
mobile devices that you choose.

For information on acquiring footage for playback on mobile devices, see Planning for playback on computer monitors and mobile devices.
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For a video tutorial about creating compositions for mobile devices, go to the Adobe website at www.adobe.com/go/Irvid4110_xp.
1. In Adobe Device Central, choose File > New Document In > After Effects.
2. Select one or more devices.
3. In the New Composition tab, select Create Master Composition.

4. Click Create in the lower-right corner of the New Composition tab.

If After Effects is already running, then the new compositions are created in the existing project. If After Effects is not already running, then
After Effects starts and the new compositions are created in a new project.

You do your design, animation, and other work in the Device Master composition. You use the device-specific compositions for previews and to
render for final output.

The Device Master composition is nested and centered in each of the device-specific compositions. The frame rate, height, and width settings for
the Device Master composition are each set to the maximum of the values for the device-specific compositions. You can resize or move the
nested Device Master composition within each device-specific composition—for example, to tweak layout for different frame aspect ratios. A guide
layer for each device in the Device Master composition facilitates your design work.

A Preview composition is also created. The Preview composition consists of a grid of device-specific compositions so that you can preview your
master composition in the context of several mobile devices simultaneously.

After you render and export the compositions, you can preview and test the resulting movies on the simulated devices within Adobe Device
Central.

. . To thet
Timeline panel e

Each composition has its own Timeline panel. You use the Timeline panel to perform many tasks, such as animating layer properties, arranging
layers in time, and setting blending modes. The layers at the bottom of the layer stacking order in the Timeline panel are rendered first and—in the
case of 2D image layers— appear farthest back in the Composition panel and in the final composite.

Q To cycle forward through Timeline panels, press Alt+Shift+period (.) (Windows) or Option+Shift+period (.) (Mac OS). To cycle backward through
Timeline panels, press Alt+Shifttcomma (,) (Windows) or Option+Shift+tcomma (,) (Mac OS).

The current time for a composition is indicated by the current-time indicator (CTI), the vertical red line in the time graph. The current time for a
composition also appears in the current time display in the upper-left corner of the Timeline panel. For more information on moving the current-time
indicator, see Move the current-time indicator.

The left side of the Timeline panel consists of columns of controls for layers. The right side of the Timeline panel—the time graph—contains a time
ruler, markers, keyframes, expressions, duration bars for layers (in layer bar mode), and the Graph Editor (in Graph Editor mode).

A. Current-time display B. Current-time indicator (CTI) C. Time ruler D. Layer switches E. Time graph

Q Press the backslash (\) key to switch activation between the Composition panel and Timeline panel for the current composition.

L . To the to
Composmon settlngs .

You can enter composition settings manually, or you can use composition settings presets to automatically set frame size (width and height), pixel
aspect ratio, and frame rate for many common output formats. You can also create and save your own custom composition settings presets for
later use. Resolution, Start Timecode (or Start Frame), Duration, and Advanced composition settings are not saved with composition settings
presets.

Note: The limit for composition duration is three hours. You can use footage items longer than three hours, but time after three hours does not
display correctly. The maximum composition size is 30,000x30,000 pixels. A 30,000x30,000 8-bpc image requires approximately 3.5 GB; your
maximum composition size may be less, depending on your operating system and available RAM.

Working with composition settings

« To open the Composition Settings dialog box to change composition settings, do one of the following:
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« Select a composition in the Project panel or activate the Timeline or Composition panel for a composition, and choose Composition >
Composition Settings, or press Ctrl+K (Windows) or Command+K (Mac OS).

« Right-click (Windows) or Control-click (Mac OS) a composition in the Project panel or Composition panel (not on a layer), and choose
Composition Settings from the context menu.

« To save a custom composition settings preset, set Width, Height, Pixel Aspect Ratio, and Frame Rate values in the Composition Settings
dialog box, and then click the Save button fl.

« To delete a composition settings preset, choose it from the Preset menu in the Composition Settings dialog box, and click the Delete button

.

« To restore default composition settings presets, Alt-click (Windows) or Option-click (Mac OS) the Delete button T or the Save button &l in the
Composition Settings dialog box.

Note: You cannot move custom composition settings presets from one system to another, as they are embedded into the preferences file.

« To scale an entire composition, choose File > Scripts > Scale Composition.jsx.

Note: Ensure all layers are unlocked in the selected composition or the script will fail.

Jeff AlImasol provides a script on his redefinery website to set the frame rate and duration of the current composition and all compositions nested
within it.

Christopher Green provides a script (Selected_Comps_Changer.jsx) on his website with which you can change the composition settings for
compositions selected in the Project panel.

Basic composition settings

Start Timecode or Start Frame Timecode or frame number assigned to the first frame of the composition. This value does not affect rendering; it
merely specifies where to start counting from.

Background Color Use the color swatch or eyedropper to pick a composition background color. (See Select a color or edit a gradient.)

note: When you add one composition to another (nesting), the background color of the containing composition is preserved, and the background
of the nested composition becomes transparent. To preserve the background color of the nested composition, create a solid-color layer to use as a
background layer in the nested composition.

For information on specific Basic composition settings not listed here, see the related sections:

« Pixel aspect ratio and frame aspect ratio
¢ Frame rate

« Resolution

Advanced composition settings
Anchor Click an arrow button to anchor layers to a corner or edge of the composition as it is resized.
For information on specific Advanced composition settings not listed here, see the related sections:

» Specify resolution to use for rendering shadows

« Preferences and composition settings that affect nested compositions
» Motion blur

Advanced composition settings (CS6)
Atfter Effects CS6 includes an updated advanced section to allow for ray-traced 3D renderer options. The 3D renderer plug-in has been renamed
as, "Renderer" for these choices because you are choosing one renderer or another for a composition.

To choose a composition type, select one of the following from the Renderer menu:

« Classic 3D
» Ray-traced 3D

Click the Options button to launch the Ray-traced 3D Renderer Options dialog box. You can also Ctrl-click (Windows) or Command-click (Mac OS)
the Current Renderer Indicator button in the upper-right of the Composition panel to launch the dialog box.

Here you can choose:

« Ray-tracing quality: Click the Ray-tracing quality setting to change it according to your workflow.
« Higher values for ray-tracing quality decrease noise but greatly increase render time.
« Ray-tracing quality controls the number of rays fired per pixel (for example, a value of 4 fires 16 or 4x4 rays, and 8 fires 64 rays).
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A larger number produces a more accurate pixel at the expense of computation time.
« A value of 1 will provide better performance, but there won't be any reflection blur (for example, it is always sharp), soft shadow, depth of
field, or motion blur.

Increasing the Ray-tracing Quality value will not increase the sharpness. Instead it decreases the noise inherent in point sampling. You should use
the lowest value that produces an acceptable amount of noise or no noise.

« Anti-aliasing Filter: Controls the method of averaging the fired rays for a pixel. None fires all rays within the bounds of a pixel, whereas the
others spreads the grid of fired rays partially across adjacent pixels to produce a better average. Box, Tent, and Cubic (which is not bicubic)
are listed in the order of better quality.

+ None

* Box

« Tent

« Cubic
The anti-aliasing filter controls the amount of blurriness. None gives the sharpest result but the edges of the projection catcher may look aliased,
with Box blur, Triangle, and Cubic giving blurrier results.
Note: Ray-traced 3D layers use Ray-tracing Quality to control the appearance of motion blur.

Depth of field calculations in Ray-traced 3D are more accurate than they are in Classic 3D (and previously in Advanced 3D).

Anchor Click an arrow button to anchor layers to a corner or edge of the composition as it is resized.

For information on specific Advanced composition settings not listed here, see the related sections:

» Specify resolution to use for rendering shadows
« Preferences and composition settings that affect nested compositions

« Motion blur

s - To the to
Composition thumbnail images ’

You can choose which frame of a composition to show as a thumbnail image (poster frame) for the composition in the Project panel. By default,
the thumbnail image is the first frame of the composition, with transparent portions shown as black.

» To set the thumbnail image for a composition, move the current-time indicator to the desired frame of the composition in the Timeline panel,
and choose Composition > Set Poster Time.

» To add a transparency grid to the thumbnail view, choose Thumbnail Transparency Grid from the Project panel menu.

« To hide the thumbnail images in the Project panel, choose Edit > Preferences > Display (Windows) or After Effects > Preferences > Display
(Mac OS) and select Disable Thumbnails In Project Panel.

e Flowchart panel

e Basics of rendering and exporting

e About precomposing and nesting

e Test content in Adobe Device Central

e Show and hide layers in the Timeline panel

e Layer switches and columns in the Timeline panel
e The Graph Editor

e Columns
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Precomposing, nesting, and pre-rendering

About precomposing and nesting
Precompose layers

Opening and navigating nested compositions
Pre-render a nested compaosition

Render order and collapsing transformations

About precomposing and nesting fothetop
If you want to group some layers that are already in a composition, you can precompose those layers. Precomposing layers places them in a new
composition, which replaces the layers in the original composition. The new nested composition becomes the source for a single layer in the
original composition. The new composition appears in the Project panel and is available for rendering or use in any other composition. You can
nest compositions by adding an existing composition to another composition, just as you would add any other footage item to a composition.
Precomposing a single layer is useful for adding transform properties to a layer and influencing the order in which elements of a composition are
rendered.

Nesting is the inclusion of one composition within another. The nested composition appears as a layer in the containing composition.

A nested composition is sometimes called a precomposition, which is occasionally abbreviated in casual use to precomp or pre-comp. When a
precomposition is used as the source footage item for a layer, the layer is called a precomposition layer.

During rendering, the image data and other information can be said to flow from each nested composition into the composition that contains it. For
this reason, nested compositions are sometimes referred to as being upstream of the compositions that contain them, and the containing
compositions are said to be downstream of the nested compositions that they contain. A set of compositions connected through nesting is called a
composition network. You can navigate within a composition network using the Composition Navigator and Mini-Flowchart. (See Opening and
navigating nested compositions.)

Precompositions in After Effects are similar to Smart Objects in Adobe Photoshop.

Uses for precomposing and nesting

Precomposing and nesting are useful for managing and organizing complex compositions. By precomposing and nesting, you can do the following:
Apply complex changes to an entire composition You can create a composition that contains multiple layers, nest the composition within the
overall composition, and animate and apply effects to the nested composition so that all of the layers change in the same ways over the same
time period.

Reuse anything you build You can build an animation in its own composition and then drag that composition into other compositions as many
times as you want.

Update in one step When you make changes to a nested composition, those changes affect every composition in which it is used, just like
changes made to a source footage item affect every composition in which it is used.

Alter the default rendering order of a layer You can specify that After Effects render a transformation (such as rotation) before rendering effects,
so that the effect applies to the rotated footage.

Add another set of transform properties to a layer The layer that represents the composition has its own properties, in addition to the
properties of the layers that it contains. This allows you to apply an additional set of transformations to a layer or set of layers.

For example, you can use nesting to make a planet both rotate and revolve (moving like the Earth, which spins on its own axis and also travels
around the Sun). To create such a system, animate the Rotation property of the planet layer, precompose that layer, modify the Anchor Point
property of the precomposition layer, and then animate the Rotation property of the precomposition layer.

Preferences and composition settings that affect nested compositions

Because a precomposition is itself a layer, you can control its behavior using layer switches and composition switches in the Timeline panel. You
can choose whether changes made to the switches in the containing composition are propagated to the nested composition. To prevent layer
switches from affecting nested compositions, choose Edit > Preferences > General (Windows) or After Effects > Preferences > General (Mac OS),
and then deselect Switches Affect Nested Comps.

In the Advanced tab of the Composition Settings dialog box (Composition > Composition Settings), choose Preserve Resolution When Nested or
Preserve Frame Rate When Nested Or In Render Queue for a composition to retain its own resolution or frame rate, and not inherit those settings
from the containing composition. For example, if you deliberately used a low frame rate in a composition to create a jerky, hand-animated result,
you should preserve the frame rate for that composition when it is nested. Similarly, the results of rotoscoping may look wrong when converted to
a different frame rate or resolution. Use this setting instead of the Posterize Time effect, which is less efficient.

Q Jeff Almasol provides a script on his redefinery website that makes toggling the Preserve Resolution When Nested or Preserve Frame Rate
When Nested Or In Render Queue preference setting more convenient.
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Changing the current time in one panel updates the current time in other panels associated with that composition. By default, the current time is
also updated for all compositions related to the current composition by nesting. To prevent compositions related by nesting from updating their
current times when you change the current time in one composition, deselect the Synchronize Time Of All Related Items preference (Edit >
Preferences > General (Windows) or After Effects > Preferences > General (Mac OS)).

Online resources about precomposing and nesting
Angie Taylor provides an extensive discussion and explanation of animation using nesting, parenting, expressions, and null object layers in a PDF
excerpt from her book Creative After Effects 7: Workflow Techniques for Animation, Visual Effects, and Motion Graphics.

Chris and Trish Meyer provide an introduction to precomposing and nesting in a PDF excerpt from the “Parenting and Nesting” chapter of their
book After Effects Apprentice: Real-World Skills for the Aspiring Motion Graphics Artist.

Chris and Trish Meyer share tips on setting up a composition hierarchy so that making changes in a project is easier in this article from the
ProVideo Coalition website.

See this page on aescripts website for the Un-Precompose script, which extracts layers from a precomposition.

See this page on aescripts website for the Zorro-The Layer Tagger script, which allows you to group layers in your composition using tags rather
than precomposing.

To the top
Precompose Iayers

Precomposing layers places them in a new composition (sometimes called a precomposition), which replaces the layers in the original composition.
Precomposing a single layer is useful for adding transform properties to a layer and influencing the order in which elements of a composition are
rendered.

1. Select the layers in the Timeline panel, and choose Layer > Pre-compose or press Ctrl+Shift+C (Windows) or Command+Shift+C (Mac OS).

2. Select one of the following:
Leave All Attributes In Leaves the properties and keyframes of the precomposed layer in the original composition, applied to the new layer
that represents the precomposition. The frame size of the new composition is the same as the size of the selected layer. This option is not
available when you select more than one layer, a text layer, or a shape layer.

Move All Attributes Into The New Composition Moves the properties and keyframes of the precomposed layers one level further from the
root composition in the composition hierarchy. When you use this option, changes you applied to the properties of the layers remain with the
individual layers within the precomposition. The frame size of the new composition is the same as the frame size of the original

composition.

Jeff Almasol provides a script on his redefinery website that precomposes selected layers to the duration of the selected layers, with options for
head and tail durations for more editing flexibility.

Opening and navigating nested compositions fothetop

Nested compositions are sometimes referred to as being upstream of the compositions that contain them, and the containing compositions are
said to be downstream of the nested compositions that they contain. The root composition is the most downstream; the most deeply nested
composition is the most upstream. A composition flow path is a chain of compositions that are related to one another by containing or being
nested within one another. A composition network is the entire set of compositions that are related to one another through nesting.

After Effects provides several ways to open a nested composition (precomposition):
« Double-click the composition entry in the Project panel.

« Double-click a precomposition layer in the Timeline panel. Alt-double-click (Windows) or Option-double-click (Mac OS) to open the
precomposition layer as a layer in the Layer panel.

Note: Double-clicking a precomposition layer when a paint tool or the Roto Brush tool is active opens the layer in the Layer panel.
« To open the most recently active composition in the same composition network as the currently active composition, press Shift+Esc.
» Use the Composition Navigator.
» Use the Composition Mini-Flowchart.
The Composition Navigator
The Composition Navigator is a bar along the top edge of the Composition panel that shows the composition active in that viewer in relation to

other compositions in the same composition network. The compositions shown are the most recently active compositions in the flow path of the
currently active composition.
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Arrows between the composition names indicate the direction in which pixel information flows for this flow path. The default is to show
compositions in the Composition Navigator bar with downstream compositions on the left and upstream compositions on the right. This default is
indicated by the Flow Right To Left option in the Composition panel menu. To show compositions in the other order, choose Flow Left To Right.
This setting is a global preference; it applies to all compositions and to the Composition Mini-Flowchart view.

The names of downstream compositions are dim to indicate that their contents are not used or shown in the active composition.
» To show or hide the Composition Navigator bar, choose Show Composition Navigator from the Composition panel menu.

« To activate any composition shown in the Composition Navigator bar, click the composition name.

« If the flow path is too long to show in the Composition panel, an ellipsis . button appears at the left or right edge of the Composition
Navigator bar. To temporarily show the entire flow path, click the ellipsis button.
Q To scroll through a long flow path, place the pointer over a composition button in the Composition Navigator and roll the mouse scroll
wheel.

The Composition Mini-Flowchart
The Composition Mini-Flowchart is a transient control that you can use to quickly navigate within a composition network. When you open the

Composition Mini-Flowchart, it shows the compositions immediately upstream and downstream of the selected composition.
A B C o
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A. Indicator that composition does not flow into other compositions B. Flow direction C. Active (current) composition D. Upstream
compositions E. Indicators that other compositions flow into these compositions

Colors in the Composition Mini-Flowchart are based on the label colors assigned to compositions in the Project panel. If a composition is used
multiple times within one composition, the multiple instances of the nested composition appear as one entry with a number in parentheses
indicating the number of instances.

To open the Composition Mini-Flowchart, do one of the following:
« Tap the Shift key when a Composition, Layer, or Timeline panel is active.

Note: Do not hold the Shift key down; press it briefly. Tapping the Shift key to open the Composition Mini-Flowchart doesn’t work if the
insertion point is in a search field, text field, or expression field.

« Click the arrow to the right of a composition name in the Composition Navigator bar.

» Choose Composition Mini-Flowchart from the Composition menu, the Composition panel menu, or the Timeline panel menu.

« Click the Composition Mini-Flowchart 22 putton at the top of the Timeline panel.

As with the Composition Navigator, you can choose whether to show the flow direction from left to right or from right to left. Arrows indicate the

direction of the flow. If a composition has a - next to it instead of an arrow, then the composition either does not have any compositions flowing
into it or it does not flow into any compositions.

Upstream compositions in the Composition Mini-Flowchart are sorted from top to bottom either alphabetically or by layer order. To switch between
these sorting orders, press the S key when the Composition Mini-Flowchart is open. When sorting by layer order, a composition used multiple
times is sorted according to its topmost instance in the stacking order. Downstream compositions are always sorted alphabetically.

To navigate among and select compositions in the Composition Mini-Flowchart, use the arrow keys or click the arrow or - buttons on either
side of a composition. To activate the selected composition, press the spacebar or Enter (Windows) or Return (Mac OS). To close the
Composition Mini-Flowchart without taking any action, press Esc, tap Shift, or click outside the Composition Mini-Flowchart.

Rich Young provides additional information about the Flowchart panel and the Composition Mini-flowchart on the After Effects Portal website.

ey To thet
Pre-render a nested composition e

A complex nested composition can take a long time to render, either for previews or for final output. If you have a nested composition that you do
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not expect to work on further, you can save time during each rendering operation by pre-rendering the nested composition into a movie and
replacing the composition with the rendered movie. You can still modify the original nested composition, because it remains in the Project panel. If
you make a significant change to the original nested composition, render it again.

Pre-rendering a nested composition is especially beneficial when you will use it multiple times in a project.

Note: Apply your final output settings when you pre-render the nested composition.
1. Select the composition in the Project or Composition panel.

2. Choose Composition > Pre-render.

The Pre-render command adds the composition to the render queue and sets the Import & Replace Usage post-render action to replace the
composition with the rendered movie.

3. In the Render Queue panel, adjust settings as necessary, and click the Render button to render the composition.
See this video tutorial on the Video2Brain website about how to save time with pre-rendering and proxies in After Effects.

Note: An alternative to replacing the composition with the movie is to use the rendered movie as a proxy for the nested composition.

. . To the to
Render order and collapsing transformations ’
A composition consists of layers stacked on top of one another in the Timeline panel. When the composition is rendered—either for previewing or
for final output—the bottom layer is rendered first. Within each raster (non-vector) layer, elements are applied in the following order: masks,
effects, transformations, and layer styles. For continuously rasterized vector layers, the default rendering order is masks, followed by
transformations, and then effects.

Transformations are changes to those properties grouped under the Transform category in the Timeline panel, including Anchor Point, Position,
Scale, Rotation, and Opacity. What you see in the Layer panel is the result of the rendering before transformations are performed.

Note: For additional control over when transformations are performed, you can apply the Transform effect and reorder it with respect to other
effects.

In a group of effects or masks, items are processed from top to bottom. For example, if you apply the Circle effect and then apply the Magnify
effect, the circle is magnified. However, if you drag the Magnify effect above (before) the Circle effect in the Effect Controls or Timeline panel, the
circle is drawn after the magnification and isn’t magnified.

After a layer has been rendered, rendering begins for the next layer. The rendered layer below may be used as input to the rendering of the layer
above—for example, for determining the result of a blending mode.

If a composition contains other compositions nested within it, the nested composition is rendered before other layers in the containing composition.

Note: Some effects ignore masks on the layer to which they’re applied. To have such an effect operate on a masked layer, pre-compose the
layer with the mask applied, and then apply the effect to the pre-composed layer. (See About precomposing and nesting.)

Collapsing transformations

If the Collapse Transformations switch # is selected for a nested composition, then the transformations for the nested composition are not
performed until after the masks and effects for the containing composition are rendered. This render order allows the transformations for the
nested composition and the containing composition to be combined—or collapsed—and performed together. The same is true for vector layers
that are not continuously rasterized.

Note: Instead of a Collapse Transformations switch, vector layers have a Continuously Rasterize switch in the same location. Vector layers
include shape layers, text layers, and layers with vector graphic files as the source footage. Text layers and shape layers are always continuously
rasterized.

Collapsing transformations can, for example, preserve resolution when a layer is scaled down by half in a nested composition, and the nested
composition is scaled up by a factor of two in the containing composition. In this case, rather than performing both transformations and losing
image data in the process, one transformation can be performed—doing nothing, because the individual transformations cancel each other.

If transformations are not collapsed, a nested composition that contains 3D layers is rendered as a 2D image of the 3D arrangement, using the
default composition camera. This rendering prevents the nested composition from intersecting with 3D layers, casting shadows on 3D layers, and
receiving shadows from 3D layers in the containing composition. The nested composition is also not controlled by the cameras and lights of the
containing composition.

If transformations are collapsed, the 3D properties of the layers in the nested composition are exposed to the containing composition. Thus, the
nested composition can intersect with 3D layers, cast shadows on 3D layers, and receive shadows from 3D layers in the containing composition.
The containing composition's camera and lights can also control the nested composition.

Essentially, collapsing transformations for a nested composition tells After Effects to not flatten and crop the layers in the precomposition. Because
an adjustment layer operates on the composite of all of the layers beneath it within the same composition, an adjustment layer within a nested
composition with collapsed transformations will force the flattening and cropping that collapsing transformations would normally prevent.

When a closed mask (with mask mode other than None), a layer style, or an effect is applied to a nested composition with collapsed
transformations, the layers in the nested composition are first rendered on their own, then masks and effects are applied, and then the result is
composited into the main composition. This rendering order means that the blending modes of the nested layers are not applied to any underlying
layers in the main composition, and that 3D layers above and below the collapsed layer cannot intersect or cast shadows on each other.
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Online resources
This video from the “After Effects CS5: Learn by Video” series provides a detailed visual demonstration of the render order and how to work with
(and around) it.

Chris and Trish Meyer explain collapsing transformations and continuous rasterization in this article on the ProVideo Coalition website.

More Help topics
I About Smart Objects

(@) ev-rvo-sn |
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Importing footage
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Importing and interpreting video and audio

Interlaced video and separating fields
Remove 3:2 or 24Pa pulldown from video
Import assets in Panasonic P2 format

Interlaced video and separating fields fothetop
Interlacing is a technique developed for transmitting television signals using limited bandwidth. In an interlaced system, only half the number of
horizontal lines for each frame of video are transmitted at a time. Because of the speed of transmission, the afterglow of displays, and the
persistence of vision, the viewer perceives each frame in full resolution. All of the analog television standards use interlacing. Digital television
standards include both interlaced and noninterlaced varieties. Typically, interlaced signals are generated from interlaced scanning, whereas
noninterlaced signals are generated from progressive scanning.

Each interlaced video frame consists of two fields. Each field contains half the number of horizontal lines in the frame; the upper field (or Field 1)
contains the odd-numbered lines, and the lower field (or Field 2) contains the even-numbered lines. An interlaced video monitor displays each
frame by first drawing all of the lines in one field and then drawing all of the lines in the other field. Field order specifies which field is drawn first. In
NTSC video, new fields are drawn to the screen approximately 60 times per second, corresponding to a frame rate of approximately 30 frames per
second.

iR

Interlaced scanning of interlaced video fields compared with progressive scanning of noninterlaced video frame.

A. For interlaced video, entire upper field (odd-numbered lines) is drawn to screen first, from top to bottom, in one pass. B. Next, entire lower
field (even-numbered lines) is drawn to screen, from top to bottom, in one pass. C. For noninterlaced video, entire frame (all lines in counting
order) is drawn to screen, from top to bottom, in one pass.

Noninterlaced video frames aren’t separated into fields. A progressive-scan monitor displays a noninterlaced video frame by drawing all the
horizontal lines, from top to bottom, in one pass. Computer monitors are almost all progressive-scan monitors, and most video displayed on
computer monitors is noninterlaced.

The terms progressive and noninterlaced are thus closely related and are often used interchangeably, but progressive scanning refers to the
recording or drawing of the scan lines by a camera or monitor, whereas noninterlaced refers to the fact that the video data itself isn't separated into
fields.

Separate video fields

If you want to use interlaced or field-rendered footage (such as NTSC video) in an After Effects project, you get the best results if you separate the
video fields when you import the footage. After Effects separates video fields by creating a full frame from each field, preserving all of the image
data from the original footage.

Separating fields is critical if you plan to make significant changes to the image. When you scale, rotate, or apply effects to interlaced video,
unwanted artifacts, such as crossed fields, are often introduced. By separating fields, After Effects accurately converts the two interlaced frames in
the video to noninterlaced frames, while preserving the maximum amount of image quality. Using noninterlaced frames allows After Effects to apply
edits and effects consistently and at the highest quality.
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After Effects creates field-separated footage from a single formerly interlaced frame by splitting it into two independent frames. Each new frame has
only half the information of the original frame, so some frames may appear to have a lower resolution than others when viewed at Draft quality.
When you render the final composition, After Effects reproduces high-quality interlaced frames for output. When you render a movie at Best
quality, After Effects interpolates between the scan lines of a field to produce maximum image quality.

If your output will not be interlaced, it's best to use noninterlaced source footage, to avoid the need to separate fields. However, if a noninterlaced
version of your source footage is not available, interlaced footage will work fine.

Always separate fields for interlaced footage. Never separate fields for noninterlaced footage items.
You can only remove pull-down after you have separated fields.

When you render a composition containing field-separated footage, set the Field Rendering option to the same field order as your video
equipment. If you don't field-render the composition, or if you field-render with the incorrect settings, the final movie may appear too soft, jerky, or
distorted.

Q To quickly give video footage a more film-like appearance, import the footage twice, and interpret each footage item with a different field order.
Then add them both to the same composition and blend them together. The misinterpreted layer adds some film-like blur.

After Effects automatically separates fields for D1 and DV video footage items. You can manually separate fields for all other types of video
footage in the Interpret Footage dialog box.

1. Select the footage item in the Project panel.

2. Choose File > Interpret Footage > Main.

3. Choose an option from the Separate Fields menu.
4

. Click Preserve Edges (Best Quality Only) to increase image quality in nonmoving areas when the image is rendered at Best quality. Then
click OK.

Note: If the field settings in the Interpret Footage dialog box are correct for the input footage and the field settings in the Render Settings dialog
box are correct for the output device, you can mix footage items of different field orders in a composition. If either of these settings is incorrect,
however, the frames will be in the correct order, but the field order may be reversed, resulting in jerky, unacceptable images.

Determine the original field order

The field order for an interlaced video footage item determines the order in which the two video fields (upper and lower) are displayed. A system
that draws the upper lines before the lower lines is called upper-field first; one that draws the lower lines before the upper lines is called lower-field
first. Many standard-definition formats (such as DV NTSC) are lower-field first, whereas many high-definition formats (such as 1080i DVCPRO HD)
are upper-field first.

The order in which the fields are displayed is important, especially when the fields contain motion. If you separate video fields using the wrong field
order, motion does not appear smooth.

Some programs, including After Effects, label the field order when rendering interlaced video files. When you import a labeled video file, After
Effects honors the field order label automatically. You can override this field order by applying different footage interpretation settings.

If a file does not contain a field order label, you can match the original field order of your footage. If you are not sure which field order was used to
interlace a footage item, use this procedure to find out.

1. Select the item in the Project panel.
. Choose File > Interpret Footage > Main.

. In the Interpret Footage dialog box, select Upper Field First from the Separate Fields menu, and then click OK.

2
3
4. In the Project panel, press Alt (Windows) or Option (Mac OS) as you double-click the footage to open it in the Footage panel.
5. If the Preview panel is not visible, choose Window > Preview.

6. In the Footage panel, find a segment that contains one or more moving areas.

7

. Using the Next Frame button I* in the Preview panel, step forward at least five frames in the Footage panel. Moving areas should move
consistently in one direction. If the moving areas move backward every other frame, the wrong field-separation option has been applied to
the footage.

Online resources about fields and interlaced video
Chris Pirazzi provides technical details of fields and interlacing on his Lurker's Guide to Video website.

This video from the “After Effects CS5: Learn by Video” series provides an introduction to fields and interlacing, and shows how to avoid common
problems.

Trish and Chris Meyer provide a variety of materials about interlacing, field order, field dominance, field rendering, and separating fields:
« article (PDF) introducing interlacing and field separation on the Artbeats website
« article introducing interlacing and field order on the ProVideo Coalition website

« article clarifying meanings of the terms field order and field dominance on the ProVideo Coalition website
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» video overview of fields and interlacing on the Lynda.com website

. To the to
Remove 3:2 or 24Pa pulldown from video ’
When you transfer 24-fps film to 29.97-fps video, you use a process called 3:2 pulldown, in which the film frames are distributed across video
fields in a repeating 3:2 pattern. The first frame of film is copied to fields 1 and 2 of the first frame of video, and also to field 1 of the second video
frame. The second frame of film is then spread across the next two fields of video—field 2 of the second video frame and field 1 of the third frame
of video. This 3:2 pattern is repeated until four frames of film are spread over five frames of video, and then the pattern is repeated.

The 3:2 pulldown process results in whole frames (represented by a W) and split-field frames (represented by an S). The three whole video frames
contain two fields from the same film frame. The remaining two split-field frames contain a video frame from two different film frames. The two split-
field frames are always adjacent to each other. The phase of 3:2 pulldown refers to the point at which the two split-field frames fall within the first
five frames of the footage.

Phase occurs as a result of two conversions that happen during 3:2 pulldown: 24-fps film is redistributed through 30-fps video, so each of four
frames of 24-fps film is spread out over five frames of 30(29.97)-fps video. First, the film is slowed down 0.1% to match the speed difference
between 29.97 fps and 30 fps. Next, each film frame is repeated in a special pattern and mated to fields of video.

l
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When you apply 3:2 pulldown to footage, one frame of the film (A) is separated into two or three interlaced video fields (B) which are grouped into
video frames containing two fields each.

When importing interlaced video that was originally transferred from film, you can remove the 3:2 pulldown that was applied during the transfer
from film to video as you separate fields so that effects you apply in After Effects don't appear distorted.

It's important to remove 3:2 pulldown from video footage that was originally film so that effects you add in After Effects synchronize perfectly with
the original frame rate of film. Removing 3:2 pulldown reduces the frame rate by 1/5—from 30 to 24 fps or from 29.97 to 23.976 fps, which also
reduces the number of frames you have to change. To remove 3:2 pulldown, you must also indicate the phase of the 3:2 pulldown.

After Effects also supports Panasonic DVX100 24p DV camera pulldown, called 24P Advance (24Pa). Some cameras use this format to capture
23.976 progressive-scan imagery using standard DV tapes.

Before you remove 3:2 pulldown, separate the fields as either upper-field first or lower-field first. Once the fields are separated, After Effects can
analyze the footage and determine the correct 3:2 pulldown phase and field order. If you already know the phase and field order, choose them
from the Separate Fields and the Remove menus in the Interpret Footage dialog box.

1. In the Project panel, select the footage item from which to remove 3:2 pulldown.

2. Choose File > Interpret Footage > Main.

3. In the Fields and Pulldown section, select Upper Field First or Lower Field First from the Separate Fields menu.

4. Do one of the following and click OK:

 If you know the phase of the 3:2 or 24Pa pulldown, choose it from the Remove menu.
* To have After Effects determine the correct settings, click Guess 3:2 Pulldown or Guess 24Pa Pulldown.

Note: If your footage file contains frames from different sources, the phase may not be consistent. If the phase is inconsistent, import
the footage multiple times, once for each phase, and interpret each footage item with a different setting. Then, add each footage item to
your composition and trim each layer to use only the appropriate frames. In other words, if you have an asset that has multiple pulldown
phases, then you need to cut that asset into pieces and remove pulldown separately for each of the pieces. This can come up if the
asset is a movie that has been edited together from several sources in an NLE.

Online resources about pulldown
Chris Meyer provides a video tutorial on identifying pulldown on the Lynda.com website.

Chris and Trish Meyer provides an overview of 3:2 pulldown in an article on the Artbeats website.

Chris Meyer provides links to resources about pulldown on the ProVideo Coalition website.
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. . To the to
Import assets in Panasonic P2 format ’
A P2 card is a solid-state memory device that plugs into the PCMCIA slot of a Panasonic P2 video camera. The digital video and audio data from
the video camera is recorded onto the card in a structured, codec-independent format known as MXF (Media eXchange Format). Specifically,
Adobe Premiere Pro and After Effects support the Panasonic Op-Atom variant of MXF, with video in AVC-Intra 50, AVC-Intra 100, DV, DVCPRO,
DVCPRO50, and DVCPRO HD formats. A clip is said to be in the P2 format if its audio and video are contained in Panasonic Op-Atom MXF files,
and these files are located in a specific folder structure.

The root of the P2 folder structure is a CONTENTS folder. Each essence item (an item of video or audio) is contained in a separate MXF wrapper
file; the video MXF files are in the VIDEO subfolder, and the audio MXF files are in the AUDIO subfolder. The relationships between essence files
and the metadata associated with them are tracked by XML files in the CLIP subfolder.

Note: Adobe Premiere Pro and After Effects do not support proxies recorded by Panasonic P2 camcorders in P2 card PROXY folders.

The video and audio on a P2 card are already in a digital form, as if the P2 card were a hard disk, so no capture step is involved in importing
media from a P2 card. The process of reading the data from the card and converting it to a format that can be used in a project is sometimes
referred to as ingest.

For your computer to read P2 cards, you must install the appropriate driver, which you can download from the Panasonic website. Panasonic also
provides the P2 Viewer application, with which you can browse and play media stored on a P2 card. See the Panasonic website for details.

Because Panasonic P2 cards use the FAT32 file system, each file is limited to a size of 4 GB. When a shot is recorded that requires more than
the 4 GB, a P2 camera creates another file and continues recording the shot to the new file without interruption. This is referred to as clip
spanning, because the shot spans more than one file or clip. Similarly, a camera may span a shot across files on different P2 cards: if the camera
has more than one P2 card loaded, it will record the shot until it runs out of room on the first P2 card, create a new file on the next P2 card with
available space, and continue recording the shot to it. Although a single shot can be recorded to a group of multiple spanned clips, the multiple-file
shot is designed to be treated as a single clip or footage item in a video editing application. For After Effects to automatically import a group of
spanned clips simultaneously and assemble them into a single footage item, they must all have been recorded to the same P2 card and none of
the files can be missing, including the associated XML metadata file.

1. (Optional) Copy the entire contents of the P2 card to a hard disk.

Though it is possible to import assets into Adobe Premiere Pro or After Effects directly from a P2 card, it is usually more efficient to copy the
contents of the P2 card to a hard disk before importing.

2. Choose File > Import.
3. Navigate to the CONTENTS folder.
4. Select one or more MXF files:

» To import a video essence item and its associated audio essence items, select the MXF files from the VIDEO folder.
« To import only the audio essence items, select the MXF files from the AUDIO folder.

» To import a group of spanned clips for a shot that were recorded onto the same P2 card, select only one of the MXF files in the group
from the VIDEO folder. The group is imported as a single footage item with a duration equal to the total duration of all the spanned clips
it includes. If you select more than one of these spanned clips, you import duplicates of the whole group of spanned clips, as duplicate
footage items in the Project panel.

You cannot import spanned clips from a shot that spans two different cards as a single footage item. Rather, you must select a single MXF
file belonging to the shot from each card to create a separate footage item for the part of the shot recorded on each card. For example, if a
group of spanned clips for a single shot itself spans two cards, you must select a spanned clip from the group on card 1 and another from
the group on card 2. This imports the contents of the shot into two footage items in the Project panel.

The Date column in the Project panel shows when each source clip was acquired. After you import spanned clips, you can use the Date value to
determine their correct chronological order within the shot.

Note: After Effects can’t directly export to the P2 format. To render and export to the P2 format, use Adobe Media Encoder or Premiere Pro.
For additional information on the Panasonic P2 format and workflows with Adobe digital video software, see the Adobe website:

* Adobe workflow guides for P2, RED, XDCAM, AVCCAM, and DSLR cameras and footage
+ P2 workflow guide for Adobe digital video products
« Dave Helmly’s video introduction to the P2 workflow in After Effects

More Help topics
@ Importing assets from tapeless formats

Export to Panasonic P2 format
File formats supported for export
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Working with footage items

Organize, view, manage, and trim footage items
Edit footage in its original application

Remove items from a project

Placeholders and proxies

Loop a footage item

. . . . To thet
Organize, view, manage, and trim footage items ometep

Compositions and footage items are listed in the Project panel. Unlike items in the Timeline panel and Effect Controls panel, the order of items in
the Project panel has no influence on the appearance of the movies that you create. You can organize footage items and compositions however
you like, including organizing them using folders. Solid-color footage items are automatically placed in the Solids folder.

Folders that you create in the Project panel exist only in the Project panel. You can expand a folder to reveal its contents, and put folders inside
other folders. To move a file or folder to the top level of the Project panel, drag it to the gray information area at the top of the panel.

You can use the search field in the Project panel to find footage items that meet various criteria, such as those with missing source files. See
Search and filter in the Timeline, Project, and Effects & Presets panels.

Scripts for managing footage items
Jeff Almasol provides a script on his redefinery website that automatically writes specified information about footage items or layers to the
Comment fields for the respective items in the Project panel or Timeline panel.

Christopher Green provides a script (Project_ltems_Renamer.jsx) on his website with which you can rename compositions and footage items
selected in the Project panel. You can search and replace text in the names, append characters to the beginning or end of the names, or trim a
specified number of characters from the beginning or end of the names.

Lloyd Alvarez provides a script on the After Effects Scripts website with which you can search an After Effects project and replace the file paths for
the sources of footage items. This is convenient for swapping out source files, updating a project after moving sources, or updating a project after
moving it to a different computer system.

Show information for items

« To show information about a footage item or composition, select it in the Project panel. Information is displayed at the top of the Project
panel next to the thumbnail image.

« To show the file creator ID for a footage item, Alt-click (Windows) or Option-click (Mac OS) it in the Project panel.

Create a folder
% Choose File > New > New Folder, or click the Create A New Folder icon M at the bottom of the Project panel.

Rename and sort items
« To rename a composition, footage item, or folder, do one of the following:

« Select the item in the Project panel, press Enter (Windows) or Return (Mac OS), and enter the new name.
« Right-click (Windows) or Control-click (Mac OS) the item, choose Rename, and enter the new name.

e To rename the Comment column, right-click (Windows) or Control-click (Mac OS) the column heading and choose Rename This.
Q You can use the Comment column to create a custom sorting option. Rename the column, enter corresponding information for each item
(for example, camera number), and then sort by that column.

« To sort items by entries in any column, click the column name in the Project panel.

Copy items
« To duplicate or copy an item in the Project panel, select it and choose Edit > Duplicate or Edit > Copy.
« To copy a footage item to Windows Explorer (Windows) or the Finder (Mac OS), drag the footage item from the Project panel to the desktop.

Reveal footage items
« To reveal where a footage item is used in a composition, right-click (Windows) or Control-click (Mac OS) the footage item in the Project
panel and choose Reveal In Composition; then select the specific instance you want to reveal (composition name, layer name).

97


http://www.adobe.com/go/learn_ae_jeffcommentron
http://www.crgreen.com/aescripts/
http://aescripts.com/batch-search-n-replace-paths/

« To reveal the source footage item for a layer in the Project panel, right-click (Windows) or Control-click (Mac OS) the layer in the Timeline
panel, and then choose Reveal Layer Source In Project.

« To reveal the location of a footage item in Adobe Bridge, Windows Explorer, or the Finder, right-click (Windows) or Control-click (Mac OS)
the footage item in the Project panel and choose Reveal In Bridge, Reveal In Windows Explorer, or Reveal In Finder.

Refresh footage items
#* To refresh footage items selected in the Project panel to use the current versions of the source footage files, choose File > Reload Footage.

View footage item in the Footage panel or media player assigned by operating system
When items are previewed in the Footage panel, they show the results of the footage interpretation operations. (See Interpret footage items.)

« To open a footage item in a Footage panel, double-click the footage item in the Project panel.
« To open selected footage items in the Footage panel, press Enter on the numeric keypad when the Project panel is active.

Note: To open the source for a footage item using the player application associated with that file type, Alt-double-click (Windows) or Option-
double-click (Mac OS) the footage item in the Project panel. See the documentation for your operating system for instructions for changing the
associations between applications and file types.

Trim footage items in the Footage panel

You can use the Set In Point 1, Set Out Point t, Ripple Insert Edit &%, and Overlay Edit &= controls in the Footage panel to trim a footage item
and insert it into a composition. Trimming in the Footage panel can be more convenient than adding the footage item to a composition and then
trimming its layer in the Timeline panel.

Edit footage in its original application To the top

You can open and edit a footage item in the application in which it was created, directly from an After Effects project. The original application must
be installed on the computer that you are using, which must have enough available RAM for it to run. When you edit and save changes to the
footage in the original application, the changes are applied to all instances of the footage when After Effects becomes the active application.

Note: If you're editing footage that has an alpha channel, make sure that you're viewing and editing all of the channels, including the alpha
channel, in the other application. Otherwise, changes you make may not be applied to the alpha channel, and it may become misaligned with the
color channels.

When you edit a still-image sequence selected in the Timeline or Composition panel, the individual image that is currently displayed opens. When
you edit a still-image sequence selected in the Project panel, the first image in the sequence opens.

1. In the Project panel, Composition panel, or Timeline panel, select the footage item or a layer that uses the footage item as its source. If you
selected a still-image sequence from the Composition or Timeline panel, move the current-time indicator to the frame displaying the still
image you want to edit.

2. Choose Edit > Edit Original.
3. Edit the footage in its original application, and save the changes.

. . To thet
Remove items from a project e

Before reducing your project, removing unused footage, or consolidating footage, consider making a backup by incrementing and saving your
project first. (See Save and back up projects in After Effects CS5.)

Carl Larsen demonstrates the use of the Collect Files command and the Consolidate All Footage command in a video tutorial on the Creative
COW website that shows how to organize, consolidate, and archive project files and footage.
« To remove an item from a project, select the item in the Project panel and press Delete.
« To remove all unused footage items from a project, choose File > Remove Unused Footage.
« To remove all duplicate footage items from a project, Choose File > Consolidate All Footage. After Effects considers footage items to be
duplicates only if they use the same Interpret Footage settings.
When a duplicate item is removed, layers that refer to the duplicate item are updated to refer to the remaining copy.

« To remove unselected compositions and unused footage items from selected compositions in the Project panel, choose File > Reduce
Project. This command is available only when the Project panel is active.

This command removes both unused footage items and all other compositions that are not included within a selected composition as nested
(subordinate) compositions.

If the selected composition includes items that are turned off (that is, the Video or Audio switch is deselected in the Timeline panel), the
Reduce Project command does not remove those items.

If an expression in a selected composition refers to an element in a nonsubordinate composition, Reduce Project removes the nonsubordinate
composition and the applied expression. A message appears after you choose Reduce Project to remind you of this possibility, so you can
undo the command if needed. To avoid removing the expressions from a nonsubordinate composition, drag the nonsubordinate composition
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into the composition that refers to it. Then deselect the Audio and Video switches for the composition that you added.

The SaveCompAsProject script from Sebastian Perier on the AEScripts website saves selected compositions as individual projects.

. To the to
Placeholders and proxies ’

When you want to temporarily use a substitute for a footage item, use either a placeholder or a proxy.

Placeholder A still image of color bars used to temporarily take the place of a missing footage item. Use a placeholder when you are building a
composition and want to try out ideas for a footage item that is not yet available. After Effects generates placeholders automatically, so you do not
have to provide a placeholder footage item.

Proxy Any file used to temporarily replace a footage item, but most often a lower-resolution or still version of an existing footage item used to
replace the original. Often, storyboard images are used as proxies. You can use a proxy either before you have the final footage or when you
have the actual footage item but you want to speed up previewing or rendering of test movies. You must have a file available to use as a proxy.

Any masks, attributes, expressions, effects, and keyframes that you apply to the layer are retained when you replace its placeholder or proxy with
the final footage item.

In the Project panel, After Effects marks the footage name to indicate whether the actual footage item or its proxy is currently in use:

« A filled box indicates that a proxy item is currently in use throughout the project. The name of the proxy appears in bold type at the top of the
Project panel when the footage item is selected.

« An empty box indicates that the footage item is in use throughout the project, though a proxy has been assigned.

« No box indicates that no proxy is assigned to the footage item.
D

radial-orange.psd 0 radial-orange-lo.psd
(1.00) (1,000

A 5 radial-orange.psd

Proxy items in Project panel
A. Proxy assigned and in use B. Proxy assigned, but original in use C. No proxy assigned D. Proxy name

Work with placeholders and missing footage items

For best results, set the placeholder to the same size, duration, and frame rate as the actual footage.

If After Effects cannot find source footage when you open a project, the footage item appears in the Project panel labeled Missing, and the name
of the missing footage appears in italics. Any composition using that item replaces it with a placeholder. You can still work with the missing item in

the project, and any effects you applied to the original footage remain intact. When you replace the placeholder with the source footage, After
Effects places the footage in its correct location in all the compositions that use it.

Q You can find footage items for which the source items are missing by typing missing in the search field in the Project panel. See Search and
filter in the Timeline, Project, and Effects & Presets panels.

« To use a placeholder, choose File > Import > Placeholder.

« To replace the selected footage item with a placeholder, choose File > Replace Footage > Placeholder.

« To replace a placeholder with the actual footage item, select the placeholder you want to replace in the Project panel, choose File > Replace
Footage > File, and locate the actual footage.

Work with proxies for footage items
When you use a proxy, After Effects replaces the actual footage with the proxy in all compositions that use the actual footage item. When you

finish working, you can switch back to the actual footage item in the project list. After Effects then replaces the proxy with the actual footage item in
any composition.
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When you render your composition as a movie, you may choose to use either all the actual high-resolution footage items or their proxies. You may
want to use the proxies for a rendered movie if, for example, you simply want to test motion using a rough movie that renders quickly.

For best results, set a proxy so that it has the same frame aspect ratio as the actual footage item. For example, if the actual footage item is a
640x480-pixel movie, create and use a 160x120-pixel proxy. When a proxy item is imported, After Effects scales the item to the same size and
duration as the actual footage. If you create a proxy with a frame aspect ratio that is different from the frame aspect ratio of the actual footage
item, scaling takes longer.

+ In the Project panel, do any of the following:

« To locate and use a proxy, select a footage item, choose File > Set Proxy > File, locate, and select the file you want to use as a proxy, and
click Open.

« To toggle between using the original footage and its proxy, click the proxy indicator to the left of the footage name.

« To stop using a proxy, select the original footage item, and choose File > Set Proxy > None.

Create a proxy

Use the Create Proxy command to create a proxy from footage or compositions selected in the Project panel or the Timeline panel. This command
adds the selected footage to the Render Queue panel and sets the Post-Render Action option to Set Proxy.

1. Open a footage item or composition in the Project or Timeline panel.

2. Move the current-time indicator in the Footage panel to the frame that you want to use as the proxy still item, or for the poster frame for the
movie footage item.

3. Choose one of the following commands:
« File > Create Proxy > Still to create a still image proxy.
« File > Create Proxy > Movie to create a moving image proxy.

4. Specify a name and output destination for the proxy.
5. In the Render Queue panel, specify render settings, and click Render.

Create placeholders for output

You can create placeholder files that can be used in different compositions. For example, you can create a placeholder for an item in the render
queue that will create a 24-fps movie and then drag that placeholder into a 30-fps composition. Then, when you render the 30-fps composition,
After Effects first renders the placeholder at 24 fps and uses this rendered version as it renders the 30-fps composition.

#+ Drag the Output Module heading for a queued item from the Render Queue panel to the Project panel. After Effects creates a placeholder for
output in the Project panel and sets the Post-Render Action option for the item to Import & Replace Usage.

Additional resources for working with placeholders and proxies
Trish and Chris Meyer give tips on prerendering and proxies in After Effects in this article on the ProVideo Coalition website.

Andrew Kramer provides a video tutorial with tips for working with proxies, output modules, and output module templates on the Video Copilot
website.

Jeff Almasol provides a script on his redefinery website that creates, sets, and unsets proxies and placeholders.
Charles Bordenave (nab) provides a script on the After Effects Scripts website with which you can create proxies for multiple selected items.
Chris and Trish Meyer explain how to use Footage Proxies with RED footage in After Effects with this article on the Pro Video Coalition website.

See this video tutorial on the Video2Brain website by Todd Kopriva for information about saving time by pre-rendering and using proxies in After
Effects.

Loop a footage item To the top

If you intend to loop a visual footage item continuously in your project, you only need to create one cycle of the footage item in After Effects.

1. In the Project panel, select the footage item to loop.
2. Choose File > Interpret Footage > Main.

3. Type an integer value for Loop and click OK.
Lloyd Alvarez provides a script on the After Effects Scripts website that automatically loops a footage item, composition, or layer.

More Help topics
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Importing from After Effects and Adobe Premiere Pro

Import an After Effects project

Import an Adobe Premiere Pro project

Use Adobe Premiere Pro for capture (Production Premium and Master Collection only)
Copy between After Effects and Adobe Premiere Pro

Import an After Effects project fothetop
You can import one After Effects project into another. Everything from the imported project—including footage items, compositions, and folders—
appears inside a new folder in the current Project panel.

Note: After Effects CS5 can open and import After Effects projects created by After Effects 6.0 and later. After Effects CS5.5 and later can open
and import an After Effects 6.5 project and later.

You can import an After Effects project from a different operating system, as long as you maintain the filenames, folder names, and either full or
relative paths (folder locations) for all files in the project. To maintain relative paths, the source footage files must reside on the same volume as
the project file. Use the File > Collect Files command to gather copies of all files in a project or composition into a single location. (See Cross-
platform project considerations.)

1. Choose File > Import > File.
2. Select the After Effects project to import, and click Open.

If the operating system that you are using does not support a file format, if the file is missing, or if the reference link is broken, After Effects
substitutes a placeholder item containing color bars. You can reconnect the placeholder to the appropriate file by double-clicking the entry in the
Project panel and navigating to the source file. In most cases, you need to relink only one footage file. After Effects locates other missing items if
they're in the same location.

Note: When you render a movie and export it to the QuickTime (MOV), Video for Windows (AVI), FLV, or F4V container format, you can embed a
link to the project in the container file. To import the project, import the MOV, AVI, FLV, or F4V file, and choose Project from the Import As menu in
the Import File dialog box. If the file contains a link to a project that has been moved, you can browse to locate the project. After Effects CS5 can
import projects using such links from movies created in After Effects CS4 and later.

Import an Adobe Premiere Pro project fotnetop
Important: Importing an Adobe Premiere Pro project into After Effects does not use Dynamic Link. After Effects can’t import a Premiere Pro
project if one or more sequences in it are already dynamically linked to After Effects. (See Working with Adobe Premiere Pro and After Effects.)
When you import an Adobe Premiere Pro project, After Effects imports it into the Project panel as both a new composition containing each Adobe
Premiere Pro clip as a layer, and as a folder containing each clip as an individual footage item. If your Adobe Premiere Pro project contains bins,
After Effects converts them to folders within the Adobe Premiere Pro project folder. After Effects converts nested sequences to nested
compositions.

Note: After Effects CS5 on Mac OS can import Adobe Premiere Pro CS3, CS4, and CS5 projects. After Effects CS5 on Mac OS can't import
Adobe Premiere Pro 1.0, 1.5, or 2.0 projects. After Effects CS5 on Windows can import projects from all Premiere Pro versions. After Effects CS5
can't directly import Premiere 6.5 projects. If you need to import a Premiere 6.5 project, first convert it to a Premiere Pro project using a version of
Premiere Pro that can import Premiere 6.5 projects. After Effects CS5.5 and later can import Premiere 6.5 projects and later.

Not all features of an Adobe Premiere Pro project are preserved when the project is imported into After Effects. The same features are preserved
when you import a Premiere Pro project into After Effects as when you copy and paste between Premiere Pro and After Effects. (See Importing
from After Effects and Adobe Premiere Pro.)

After Effects preserves the order of clips in the timeline, the footage duration (including all trimmed In and Out points), and marker and transition
locations. After Effects bases the arrangement of layers in the Timeline panel on the arrangement of clips in the Adobe Premiere Pro Timeline
panel. After Effects adds Adobe Premiere Pro clips to the Timeline panel as layers in the order in which they appeared—from the bottom up and
from left to right—in the Adobe Premiere Pro Timeline panel. After Effects preserves changes made to the speed of a clip, for example, with the
Clip > Speed command, and these changes appear as a value in the Stretch column in the After Effects Timeline panel.

After Effects imports effects common to Adobe Premiere Pro and After Effects, and preserves keyframes for these effects.

Transitions and titles (except for dissolves) included in your Adobe Premiere Pro project appear in the After Effects composition as solid layers with
their original location and duration.

Audio Level keyframes are preserved.
1. Choose File > Import > File or File > Import > Adobe Premiere Pro Project.

If you choose Import > Adobe Premiere Pro Project, then only Adobe Premiere Pro projects are shown.
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2. Select a project, and click OK.
3. Do any of the following:

« To import only one sequence, choose a sequence from the menu.
« To import audio, select Import Audio.

Q To add a single item from a track in an Adobe Premiere Pro project, copy the item in Adobe Premiere Pro, and choose Edit > Paste in
After Effects.

Use Adobe Premiere Pro for capture (Production Premium and Master Collection only) To the top

If you have Adobe Creative Suite Production Premium or Master Collection, you can start Adobe Premiere Pro from inside After Effects and use it
to Acrobat Capture footage for use in your After Effects project.

#* Choose File > Import > Capture In Adobe Premiere Pro.

Copy between After Effects and Adobe Premiere Pro fothetop

« From the After Effects Timeline panel, you can copy layers based on audio or video footage items (including solids) and paste them into the
Adobe Premiere Pro Timeline panel.

« From the Adobe Premiere Pro Timeline panel, you can copy assets (any items in a track) and paste them into the After Effects Timeline
panel.

» From either After Effects or Adobe Premiere Pro, you can copy and paste footage items to the other's Project panel.
Note: You can't, however, paste footage items from the After Effects Project panel into the Adobe Premiere Pro Timeline panel.

If you want to work with all clips or a single sequence from an Adobe Premiere Pro project, use the Import command instead to import the project

into After Effects.

Q Use Adobe Dynamic Link to create dynamic links, without rendering, between new or existing compositions in After Effects and Adobe Premiere
Pro. (See About Dynamic Link.)

Copy from After Effects to Adobe Premiere Pro

You can copy a layer based on a footage item from an After Effects composition and paste it into an Adobe Premiere Pro sequence. Adobe
Premiere Pro converts these layers to clips in the sequence and copies the source footage item to its Project panel. If the layer contains an effect
that is also used by Adobe Premiere Pro, Adobe Premiere Pro converts the effect and all of its settings and keyframes.

You can also copy nested compositions, Photoshop layers, solid-color layers, and audio layers. Adobe Premiere Pro converts nested compositions
to nested sequences, and solid-color layers to color mattes. You cannot copy shape, text, camera, light, or adjustment layers to Adobe Premiere
Pro.

1. Start Adobe Premiere Pro (you must start Adobe Premiere Pro before you copy the layer in After Effects).

2. Select a layer (or layers) from the After Effects Timeline panel.
Note: If you select multiple layers and the layers don't overlap in After Effects, they’'re placed on the same track in Adobe Premiere Pro. On
the other hand, if the layers overlap in After Effects, the order in which you select them determines the order of their track placement in
Adobe Premiere Pro. Each layer is placed on a separate track, and the last selected layer appears on Track 1. For example, if you select
layers from top to bottom, the layers appear in the reverse order in Adobe Premiere Pro, with the bottom-most layer on Track 1.

3. Choose Edit > Copy.

4. In Adobe Premiere Pro, open a sequence in the Timeline panel.

5. Move the current-time indicator to the desired location, and choose either Edit > Paste or Edit > Paste Insert.

Results of pasting into Adobe Premiere Pro
When you paste a layer into an Adobe Premiere Pro sequence, keyframes, effects, and other properties in the copied layer are converted as
follows:

After Effects item Converted to in Adobe Premiere Pro Notes
Audio volume property Channel Volume filter
Blending modes Blending modes supported by

Adobe Premiere Pro are converted

Effect properties and keyframes Effect properties and keyframes, if the Adobe Premiere Pro lists unsupported
effect also exists in Adobe Premiere Pro effects as offline in the Effect Controls

panel. Some After Effects effects have the

same names as those in Adobe Premiere
Pro, but since they're actually different
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Expressions

Layer markers

Masks and mattes
Stereo Mixer effect
Time Remap property

Time Stretch property

Transform property values and keyframes

Source settings for R3D source files

Not converted

Clip markers

Not converted

Channel Volume filter
Time Remapping effect

Speed property

Motion or Opacity values and keyframes

Source settings for R3D source files

Copy from Adobe Premiere Pro to After Effects

You can copy a video or audio asset from an Adobe Premiere Pro sequence and paste it into an After Effects composition. After Effects converts
assets to layers and copies the source footage items into its Project panel. If the asset contains an effect that is also used by After Effects, After

Effects converts the effect and all of its settings and keyframes.

You can copy color mattes, stills, nested sequences, and offline files, too. After Effects converts color mattes into solid-color layers and converts
nested sequences into nested compositions. When you copy a Photoshop still image into After Effects, After Effects retains the Photoshop layer
information. You cannot paste Adobe Premiere Pro titles into After Effects, but you can paste text with attributes from the Adobe Premiere Titler

into After Effects.

1. Select an asset from the Adobe Premiere Pro Timeline panel.

. Choose Edit > Copy.

2
3. In After Effects, open a composition in the Timeline panel.
4

effects, they aren’t converted.

Speed and time stretch have an inverse
relationship. For example, 200% stretch in
After Effects converts to 50% speed in
Adobe Premiere Pro.

The keyframe type—Bezier, Auto Bezier,
Continuous Bezier, or Hold—is retained.

. With the Timeline panel active, choose Edit > Paste. The asset appears as the topmost layer in the Timeline panel.
Note: To paste the asset at the current-time indicator, place the current-time indicator and press Ctrl+Alt+V (Windows) or

Command+Option+V (Mac OS).

Results of pasting into After Effects

When you paste an asset into an After Effects composition, keyframes, effects, and other properties in a copied asset are converted as follows:

Adobe Premiere Pro asset

Audio track

Bars and tone
Blending modes
Clip marker
Color mattes
Crop filter
Frame Hold

Motion or Opacity values and keyframes

Sequence marker

Converted to in After Effects

Audio layers

Not converted
Converted

Layer marker
Solid-color layers
Mask layer

Time Remap property

Transform property values and keyframes

Markers on a new solid-color layer
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Notes

Audio tracks that are either 5.1 surround
or greater than 16-bit aren’t supported.
Mono and stereo audio tracks are
imported as one or two layers.

Keyframe type—Bezier, Auto Bezier,
Continuous Bezier, or Hold—is retained.

To copy sequence markers, you must
either copy the sequence itself or import



the entire Adobe Premiere Pro project as
a composition.

Speed property Time Stretch property Speed and time stretch have an inverse
relationship. For example, 50% speed in
Adobe Premiere Pro is converted to 200%
stretch in After Effects.

Time Remapping effect Time Remap property

Titles Not converted

Universal counting leaders Not converted

Video and audio transitions Opacity keyframes (Cross dissolve only)

or solid-color layers

Video effect properties and keyframes Effect properties and keyframes, if the After Effects doesn’t display unsupported

effect also exists in After Effects effects in the Effect Controls panel.
Volume and Channel Volume audio filters Stereo mixer effect Other audio filters are not converted.
Source settings for R3D source files Source settings for R3D source files

Note: When you import a Premiere Pro project into After Effects, features are converted in the same manner as they are converted when copying
from Premiere Pro to After Effects.
More Help topics

[G3) v-rvo-s7 |

Legal Notices | Online Privacy Policy
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Importing and interpreting footage items

About imported files and footage items

Supported import formats

Import footage items

Interpret footage items

Alpha channel interpretation: premultiplied or straight
Frame rate

Pixel aspect ratio and frame aspect ratio

See this video tutorial on importing assets on the Creative COW website by Andrew Devis.

. . . To the to
About imported files and footage items ’
You import source files into a project as the basis for footage items and use them as sources for layers. The same file can be the source for
multiple footage items, each with its own interpretation settings. Each footage item can be used as the source for one or more layers. You work
with collections of layers in a composition.

You primarily work with footage items in the Project panel. You can use the Footage panel to evaluate footage and perform simple editing tasks,
such as trimming the duration of a footage item.

You can import many different kinds of files, collections of files, or components of files as sources for individual footage items, including moving
image files, still-image files, still-image sequences, and audio files. You can even create footage items yourself within After Effects, such as solids
and precompositions. You can import footage items into a project at any time.

When you import files, After Effects does not copy the image data itself into your project but creates a reference link to the source of the footage
item, which keeps project files relatively small.

If you delete, rename, or move an imported source file, you break the reference link to that file. When a link is broken, the name of the source file
appears in italics in the Project panel, and the File Path column lists it as missing. If the footage item is available, you can reestablish the link—
usually just by double-clicking the item and selecting the file again.

Q You can find footage items for which the source items are missing by typing missing in the search field in the Project panel. See Search and
filter in the Timeline, Project, and Effects & Presets panels.

To reduce rendering time and increase performance, it is often best to prepare footage before you import it into After Effects. For example, it is
often better to scale or crop a still image in Photoshop before you bring it into After Effects, rather than scaling and cropping the image in After
Effects. It is better to perform an operation once in Photoshop than to force After Effects to perform the same action many times per second—
once for each frame in which the image appears.

To save time and minimize the size and complexity of a project, import a source item as a single footage item and then use it multiple times in a
composition. It is occasionally useful, however, to duplicate a footage item and interpret each differently. For example, you can use the same
footage at two different frame rates.

If you use another application to modify a footage item that is used in a project, the changes appear in After Effects the next time that you open the
project or select the footage item and choose File > Reload Footage.

Q To replace the source footage item for a layer with another footage item, without affecting changes made to the layer properties, select the
layer and then Alt-drag (Windows) or Option-drag (Mac OS) the new footage item onto the layer in the Timeline panel.

Q To replace all uses of selected footage items with another footage item, select footage items in the Project panel, and then Alt-drag (Windows)
or Option-drag (Mac OS) the new footage item onto a selected footage item in the Project panel.

When After Effects imports video and audio in some formats, it processes and caches versions of these items that it can readily access when

generating previews. This caching greatly improves performance for previews, because the video and audio items do not need to be reprocessed

for each preview. See Media cache.

For more information about importing assets, see this video tutorial on the Creative COW website by Andrew Devis.

Supported import formats fothetop
Important: The trial version of After Effects CS5 doesn't include some features that depend on third-party software components that are only
included in the full version of After Effects. The import and export of some formats are not supported in the trial version: AVC-Intra, AVCHD, HDV,
MPEG-2, MPEG-2 DVD, MPEG-2 Blu-ray, and XDCAM. The trial version for Adobe After Effects CS5.5 and later includes all codecs that are in
the full version. Details of the free 30-day trial version of After Effects CS5.5.

Some filename extensions—such as MOV, AVI, MXF, FLV, and F4V—denote container file formats rather than denoting a specific audio, video, or
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image data format. Container files can contain data encoded using various compression and encoding schemes. After Effects can import these
container files, but the ability to import the data that they contain is dependent on which codecs (specifically, decoders) are installed.

By installing additional codecs, you can extend the ability of After Effects to import additional file types. Many codecs must be installed into the
operating system (Windows or Mac OS) and work as a component inside the QuickTime or Video for Windows formats. Contact the manufacturer
of your hardware or software for more information about codecs that work with the files that your specific devices or applications create.

Importing and using some files requires the installation of additional import plug-ins. (See Plug-ins.)

Adobe Premiere Pro can capture and import many formats that After Effects can’t import natively. You can bring data from Adobe Premiere Pro
into After Effects in many ways. (See Working with Adobe Premiere Pro and After Effects.)

For workflow guides and updates for P2, RED, XDCAM, AVCCAM, and DSLR cameras and footage, see the Adobe website.
This video from the "After Effects CS5: Learn by Video" series explains codecs, containers, and formats and shows how to get information about
source files and footage items.
Audio formats
* Adobe Sound Document (ASND; multi-track files imported as merged single track)
« Advanced Audio Coding (AAC, M4A)
« Audio Interchange File Format (AIF, AIFF)
« MP3 (MP3, MPEG, MPG, MPA, MPE)
« Video for Windows (AVI; requires QuickTime on Mac OS)
* Waveform (WAV)

Still-image formats
« Adobe lllustrator (Al, Al4, Al5, EPS, PS; continuously rasterized)
» Adobe PDF (PDF; first page only; continuously rasterized)
« Adobe Photoshop (PSD)
- Bitmap (BMP, RLE, DIB)
« Camera raw (TIF, CRW, NEF, RAF, ORF, MRW, DCR, MOS, RAW, PEF, SRF, DNG, X3F, CR2, ERF)
e Cineon/DPX (CIN, DPX; 10 bpc)
» Discreet RLA/RPF (RLA, RPF; 16 bpc; imports camera data)
« EPS
« GIF
« JPEG (JPG, JPE)
 Maya camera data (MA)
* Maya IFF (IFF, TDI; 16 bpc)
« OpenEXR (EXR, SXR, MXR; 32 bpc)

Note: 3D Channel effect plug-ins from fnord software are included with After Effects to provide access to multiple layers and channels of
OpenEXR files. (See Using channels in OpenEXR files.)

« PICT (PCT)

« Portable Network Graphics (PNG; 16 bpc)
» Radiance (HDR, RGBE, XYZE; 32 bpc)

« SGI (SGI, BW, RGB; 16 bpc)

« Softimage (PIC)
Note: After Effects can also read ZPIC files corresponding to imported PIC files. See Importing and using 3D files from other applications.)

« Targa (TGA, VDA, ICB, VST)
- TIFF (TIF)
Q You can import files of any still-image format as a sequence. See Preparing and importing still images.
Video and animation formats
e Animated GIF (GIF)
« Support for ARRIRAW files from the ARRI ALEXA, or ARRIFLEX D-21 cameras (After Effects CS6)

The following are known issues with ARRIRAW:
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« The importer works in 16 bit, so set your project to 16 or 32 bpc.
« There is no exposure or color space control in the importer, and no importer options at all.
« Footage is always decoded at full resolution, even if a lower frame size is needed.
* Metadata is not exposed as XMP, so is not available in After Effects.
« Collect Files does not work with ARRIRAW footage.
« CinemaDNG (After Effects CS5.5 and later)

Note: CinemaDNG is a subset of CameraRAW. A subset of CameraRAW settings can be accessed via More Options in the Interpret
Footage dialog box. Color management for CinemaDNG includes the same color spaces as After Effects existing CameraRAW: Adobe RGB,
SRGB IEC619662.1, ColorMatch RGB, and ProPhoto RGB.

For more information on CinemaDNG, and to download the CinemaDNG importer, go to the Adobe Labs website.
« DV (in MOV or AVI container, or as containerless DV stream)
« Electric Image (IMG, EI)

Note: After Effects can also read EIZ files corresponding to imported El files. See Importing and using 3D files from other applications.)

o FLV, FAV
Note: After Effects CS5 can import FLV files with video encoded using the On2 VP6 video codec; After Effects CS5 can’t import FLV files
with video encoded with the Sorenson Spark video codec. As with any unsupported format, transcode the file to a format that After Effects
can import.

* Media eXchange Format (MXF)

MXF is a container format. After Effects can only import some kinds of data contained within MXF files. After Effects can import the Op-Atom
variety of MXF files used by Panasonic video cameras to record to Panasonic P2 media. After Effects can import video from these MXF files
using the AVC-Intra 50, AVC-Intra 100, DV, DVCPRO, DVCPRO50, and DVCPRO HD codecs. After Effects can also import XDCAM HD files
in MXF format. After Effects CS5.5 and later can import the MXF OP1format, which contains MPEG-2 video that complies with the XDCAM
HD format.

« MPEG-1, MPEG-2, and MPEG-4 formats: MPEG, MPE, MPG, M2V, MPA, MP2, M2A, MPV, M2P, M2T, M2TS (AVCHD), AC3, MP4, M4V,
M4A

Note: Some MPEG data formats are stored in container formats with filename extensions that are not recognized by After Effects; examples
include .vob and .mod. In some cases, you can import these files into After Effects after changing the filename extension to one of the
recognized filename extensions. Because of variations in implementation in these container formats, compatibility is not guaranteed.

For information about MPEG formats, see the MPEG website and the MPEG page on the Wikipedia website.
« PSD file with video layer (requires QuickTime)

e QuickTime (MOV; 16 bpc, requires QuickTime)
Note: David Van Brink provides the gt_tools toolset on his omino website. This toolset is useful for converting and examining QuickTime
files.

« RED (R3D)

Note: R3D files are interpreted as containing 32-bpc colors in a non-linear HDTV (Rec. 709) color space. The RED R3D Source Settings
color adjustments don't preserve overbright values. Color adjustments done within After Effects do preserve overbright colors when you work
in 32-bpc (bits per channel) color. To avoid clipping, manipulate exposure in After Effects, rather than in the footage interpretation stage in
the RED R3D Source Settings dialog box. (For more information on using R3D files, see the RED website and the Adobe website.)

For information about changes and bug fixes regarding RED (R3D) footage in After Effects CS5 (10.0.1), see this post on the After Effects
Region of Interest blog.

* SWEF (continuously rasterized)

Note: SWEF files are imported with an alpha channel. Audio is not retained. Interactive content and scripted animation are not retained.
Animation defined by keyframes in the main, top-level movie is retained.

« Video for Windows (AVI, WAV; requires QuickTime on Mac OS)
« Windows Media File (WMV, WMA, ASF; Windows only)
« XDCAM HD and XDCAM EX

Note: After Effects can import Sony XDCAM HD assets if they were recorded to MXF files. After Effects cannot import XDCAM HD assets in
IMX format. After Effects can import Sony XDCAM EX assets stored as essence files with the .mp4 filename extension in a BPAV directory.
For information about the XDCAM format, see this PDF document on the Sony website.

Project formats

« Adobe Premiere Pro 1.0, 1.5, 2.0, CS3, CS4, CS5 (PRPROJ; 1.0, 1.5, and 2.0 Windows only)
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« Adobe After Effects 6.0 and later binary projects in After Effects CS5 (AEP, AET)
« Adobe After Effects 6.5 and later binary projects in After Effects CS5.5 and later (AEP, AET)
* Adobe After Effects CS4 and later XML projects (AEPX)

In After Effects CS5.5, and earlier, you can use the free Pro Import AE plug-in from Automatic Duck to import projects from other applications,
including Final Cut Pro, Apple Motion, and Avid Media Composer.

In After Effects CS6, the Automatic Duck Pro Import AE plug-in is now bundled with the application, and called Pro Import After Effects. With it, you
can import AAF and OMF files from an Avid system, XML files from Final Cut Pro 7, or earlier, and project files from Motion 4, or earlier. For more

information on using Pro Import After Effects, see its User Guide, accessible by choosing File > Import > Pro Import After Effects, then clicking the

Help button.

You can also import Final Cut Pro projects into Premiere Pro and then bring that project's components into After Effects.

In this video by Todd Kopriva and video2brain, learn how to import projects using Pro Import After Effects CS6. We demonstrate using a Final Cut
Pro project, but the same procedure works for other formats, such as XML, AAF, and OMF.

. To the to
Import footage items ’

You can import media files into your project either by using the Import dialog box or by dragging.

Imported footage items appear in the Project panel.
If the Interpret Footage dialog box appears after you import a footage item, it contains an unlabeled alpha channel, and you must select an alpha

channel interpretation method or click Guess to let After Effects determine how to interpret the alpha channel. (See Alpha channel interpretation:
premultiplied or straight.)

Import footage items using the Import dialog box
1. Choose File > Import > File, choose File > Import > Multiple Files, or double-click an empty area of the Project panel.

If you choose Import Multiple Files, then you can perform the next step more than once without needing to choose an Import command
multiple times.

Q To display only supported footage files (excluding project files), choose All Footage Files from the Files Of Type (Windows) or Enable
(Mac OS) menu.

2. Do one of the following:
« Select a file, and then click Open.
« Citrl-click (Windows) or Command-click (Mac OS) multiple files to select them, and then click Open.
« Click a file and then Shift-click another file to select a range of files, and then click Open.

« (Windows only) Select an entire folder, and then click Import Folder.
Note: If the Sequence option is selected, multiple files from the folder are imported as a sequence of still images.

Import footage items by dragging
Q If you always want the layered still-image files that you drag into After Effects to be imported as a composition, choose Edit > Preferences >
Import (Windows) or After Effects > Preferences > Import (Mac OS), and choose Composition or Composition - Retain Layer Sizes from the
Drag Import Multiple ltems As menu. (See Import a still-image sequence as a composition.)
« To import a single file, drag it from Windows Explorer (Windows) or the Finder (Mac OS) into the Project panel.

To import the contents of a folder as a sequence of still images that appear in the Project panel as a single footage item, drag a folder from
Windows Explorer (Windows) or the Finder (Mac OS) into the Project panel.

« To import the contents of the folder as individual footage items that appear in the Project panel in a folder, Alt-drag a folder from Windows
Explorer (Windows) or Option-drag a folder from the Finder (Mac OS) into the Project panel.

« To import a rendered output file from the Render Queue panel, drag the corresponding output module from the Render Queue panel into the
Project panel.
Note: If you drag an output module from the Render Queue panel into the Project panel before rendering, After Effects creates a

placeholder footage item. References to the placeholder footage item are automatically replaced when the output module is rendered; the
placeholder footage item itself is not replaced.

Interpret footage items To the top

After Effects uses a set of internal rules to interpret each footage item that you import according to its best guess for the source file’s pixel aspect
ratio, frame rate, color profile, and alpha channel type. If After Effects guesses wrong, or if you want to use the footage differently, you can modify
these rules for all footage items of a particular kind by editing the interpretation rules file (interpretation rules.txt), or you can modify the
interpretation of a specific footage item using the Interpret Footage dialog box.
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The interpretation settings tell After Effects the following about each footage item:
« How to interpret the interaction of the alpha channel with other channels (See Alpha channel interpretation: premultiplied or straight.)
« What frame rate to assume for the footage item (See Frame rate.)
« Whether to separate fields and, if so, what field order to assume (See Interlaced video and separating fields.)
« Whether to remove 3:2 or 24Pa pulldown (See Remove 3:2 or 24Pa pulldown from video.)
« The pixel aspect ratio of the footage item (See Pixel aspect ratio and frame aspect ratio.)
« The color profile of the footage item (See Interpret a footage item by assigning an input color profile.)

Important: In all of these cases, the information is used to make decisions about how to interpret data in the imported footage item—to tell After
Effects about the input footage. The interpretation settings in the Interpret Footage dialog box should match the settings used to create the source
footage file. Do not use the interpretation settings to try to specify settings for your final rendered output.

Generally, you don't need to change interpretation settings. However, if a footage item isn’t of a common kind, After Effects may need additional
information from you to interpret it correctly.

You can use the controls in the Color Management section of the Interpret Footage dialog box to tell After Effects how to interpret the color
information in a footage item. This step is usually only necessary when the footage item does not contain an embedded color profile.

When you preview in the Footage panel, you see the results of the footage interpretation operations.

Jeff Almasol provides a script on his redefinery website that you can use to make guessing the 3:2 pulldown, 24Pa pulldown, or alpha channel
interpretation more convenient.

Note: Select Preview in the Interpret Footage dialog box to preview the results of the settings made in this dialog box before you accept the

changes.

Interpret a single footage item using the Interpret Footage dialog box
++ Select a footage item in the Project panel and do one of the following:

e Click the Interpret Footage % button at the bottom of the Project panel.
« Drag the footage item to the Interpret Footage button.
« Choose File > Interpret Footage > Main.

e Press Ctrl+Alt+G (Windows) or Command+Option+G (Mac OS).

Interpret a proxy using the Interpret Footage dialog box
#* Select the original footage item in the Project panel and do one of the following:

« Alt-click (Windows) or Option-click (Mac OS) the Interpret Footage & putton at the bottom of the Project panel.
« Alt-drag (Windows) or Option-drag (Mac OS) the footage item to the Interpret Footage button.

+ Choose File > Interpret Footage > Proxy.

Apply Interpret Footage settings to multiple footage items
You can ensure that different footage items use the same settings by copying interpretation settings from one item and applying them to others.
1. In the Project panel, select the item with the interpretation settings that you want to apply.
2. Choose File > Interpret Footage > Remember Interpretation.
3. Select one or more footage items in the Project panel.
4. Choose File > Interpret Footage > Apply Interpretation.

Edit interpretation rules for all items of a specific kind

The interpretation rules file contains the rules that specify how After Effects interprets footage items. In most cases, you don’t need to customize
the interpretation rules file. When you import a footage item, After Effects looks for a match in the interpretation rules file, and then determines
interpretation settings for the footage item. You can override these settings after importing, using the Interpret Footage dialog box.

In most cases, the name of the interpretation rules file is interpretation rules.txt; however, some updates to After Effects install a new interpretation
rules file with a name that indicates the updated version number, and the updated application uses this new file. If you’ve made changes to the old
interpretation rules file, you may need to apply those changes to the new file, too.

Locations of the interpretation rules file in After Effects CS5:
« (Windows) C:\Program Files\Adobe\Adobe After Effects CS5\Support Files
* (Mac OS) Applications/Adobe After Effects CS5

Locations of the interpretation rules file in After Effects CS5.5 (note that the file is located in the Preferences folder).
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(Windows) <drive>\Users\<username>\Library\Preferences\Adobe\After Effects 10.5.
* (Mac OS) <drive>/Users/<username>/Libarary/Preferences/Adobe/After Effects 10.5
1. Quit After Effects.

2. As a precaution, make a backup copy of the interpretation rules file. By default, this file is in the same location as the After Effects
application.

3. Open the interpretation rules file in a text editor.

4. Modify the settings according to the instructions in the file.
Note: You must supply a four-character file-type code for each footage type or codec. If you don’t know the code for a file or codec in a
project, press Alt (Windows) or Option (Mac OS) as you select the file in the Project panel. The file-type code and codec code (if the file is
compressed) appear in the last line of the file description at the top of the Project panel.

5. Save interpretation rules.txt.

. . L . To the to
Alpha channel interpretation: premultiplied or straight 0
Image files with alpha channels store transparency information in one of two ways: straight or premultiplied. Although the alpha channels are the
same, the color channels differ.

With straight (or unmatted) channels, transparency information is stored only in the alpha channel, not in any of the visible color channels. With
straight channels, the results of transparency aren'’t visible until the image is displayed in an application that supports straight channels.

With premultiplied (or matted) channels, transparency information is stored in the alpha channel and also in the visible RGB channels, which are
multiplied with a background color. Premultiplied channels are sometimes said to be matted with color. The colors of semitransparent areas, such
as feathered edges, are shifted toward the background color in proportion to their degree of transparency.

Some software lets you specify the background color with which the channels are premultiplied; otherwise, the background color is usually black or
white. When After Effects creates FLV files with transparency, they are created as premultiplied with black.

Straight channels retain more accurate color information than premultiplied channels. Premultiplied channels are compatible with a wider range of
programs, such as Apple QuickTime Player. Often, the choice of whether to use images with straight or premultiplied channels has been made
before you receive the assets to edit and composite. Adobe Premiere Pro and After Effects recognize both straight and premultiplied channels, but
only the first alpha channel they encounter in a file containing multiple alpha channels.

Setting the alpha channel interpretation correctly can prevent problems when you import a file, such as undesirable colors at the edge of an image
or a loss of image quality at the edges of the alpha channel. For example, if channels are interpreted as straight when they are actually
premultiplied, semitransparent areas retain some of the background color. If a color inaccuracy, such as a halo, appears along the semitransparent
edges in a composition, try changing the interpretation method.

e | o |
A footage item with premultiplied channels (top) appears with a black halo when interpreted as Straight-Unmatted (lower-left). When the footage
item is interpreted as Premultiplied-Matted With Color and the background color is specified as black, the halo does not appear (lower-right).

You can use the Remove Color Matting effect to remove the fringes from the semi-transparent areas of a layer by unmultiplying it.

Aharon Rabinowitz provides a video tutorial on the Creative COW website that describes how and when to use the Remove Color Matting effect.

Set the alpha channel interpretation for a footage item
1. In the Project panel, select a footage item.
2. Choose File > Interpret Footage > Main.
3. If you want to switch the opaque and transparent areas of the image, select Invert Alpha.
4

. In the Alpha section, select an interpretation method:
Guess Attempts to determine the type of channels used in the image. If After Effects cannot guess confidently, it beeps.

111


http://cowcast.creativecow.net/podcast/ae-quicktips-6-remove-color--232

Ignore Disregards transparency information contained in the alpha channel.
Straight - Unmatted Interprets the channels as straight.

Premultiplied - Matted With Color Interprets channels as premultiplied. Use the eyedropper or color picker to specify the color of the
background with which the channels were premultiplied.

Set the default alpha channel preferences
1. Choose Edit > Preferences > Import (Windows) or After Effects > Preferences > Import (Mac OS).

2. Choose options from the Interpret Unlabeled Alpha As menu. The options in this menu are similar to the options in the Interpret Footage
dialog box. Ask User specifies that the Interpret Footage dialog box opens each time a footage item with an unlabeled alpha channel is
imported.

To the to

Frame rate ’
The composition frame rate determines the number of frames displayed per second, and how time is divided into frames in the time ruler and time
display. In other words, the composition frame rate specifies how many times per second images are sampled from the source footage items, and
it specifies the time divisions at which keyframes can be set.

Note: After Effects CS5.5 and later contains a menu for drop-frame or non-drop-frame timecode in the Composition Settings dialog box. In
previous releases, this option was a global setting per project.

This video form the “After Effects CS5: Learn by Video” series provides an introduction to frame rates for footage items, compositions, and
rendered movies, and how to modify each kind of frame rate to achieve the desired result.

Composition frame rate is usually determined by the type of output that you are targeting. NTSC video has a frame rate of 29.97 frames per
second (fps), PAL video has a frame rate of 25 fps, and motion picture film typically has a frame rate of 24 fps. Depending on the broadcast
system, DVD video can have the same frame rate as NTSC video or PAL video, or a frame rate of 23.976. Cartoons and video intended for CD-
ROM or the web are often 10-15 fps.

Q Setting the composition frame rate to twice the rate of the output format causes After Effects to display each field of interlaced source footage
as its own, separate frame in the Composition panel. This process lets you set keyframes on individual fields and gain precision when
animating masks.

When you render a movie for final output, you can choose to use the composition frame rate or another frame rate. The ability to set the frame
rate for each output module is useful when you are using the same composition to create output for multiple media.

Each motion-footage item in a composition can also have its own frame rate. The relationship between the footage-item frame rate and the
composition frame rate determines how smoothly the layer plays. For example, if the footage-item frame rate is 30 fps and the composition frame
rate is 30 fps, then whenever the composition advances one frame, the next frame from the footage item is displayed. If the footage-item frame
rate is 15 fps and the composition frame rate is 30 fps, then each frame of the footage item appears in two successive frames of the composition.
(This assumes, of course, the simple case in which no time stretching or frame blending has been applied to the layer.)

Ideally, use source footage that matches the final output frame rate. This way, After Effects renders each frame, and the final output does not omit,
duplicate, or interpolate frames. If, however, the source footage has a frame rate slightly different from what you want to output to (for example, 30-
fps footage and 29.97-fps final output), you can make the footage frame rate match the composition frame rate by conforming it.

Conforming the frame rate of a footage item does not alter the original file, only the reference that After Effects uses. When conforming, After
Effects changes the internal duration of frames but not the frame content. Afterward, the footage plays back at a different speed. For example, if
you conform the frame rate from 15 fps to 30 fps, the footage plays back twice as fast. In most cases, conform the frame rate only when the
difference between the footage frame rate and the output frame rate is small.

Note: Conforming can change the synchronization of visual footage that has an audio track, because changing the frame rate changes the
duration of the video but leaves the audio unchanged. If you want to stretch both audio and video, use the Time Stretch command. (See Time-
stretch a layer.) Keyframes applied to the source footage remain at their original locations (which retains their synchronization within the
composition but not the visual content of the layer). You may need to adjust keyframe locations after conforming a footage item.

You can change the frame rate for any movie or sequence of still images. For example, you can import a sequence of ten still images and specify
a frame rate for that footage item of 5 frames per second (fps); this sequence would then have a duration of two seconds when used in a
composition.

Note: When you import a sequence of still images, it assumes the frame rate specified by the Sequence Footage preference in the Import
category. The default rate is 30 frames per second (fps). You can change the frame rate after importing by reinterpreting the footage item. (See
Interpret footage items.)

Lower frame rates tend to give the impression of unreality, so many people prefer to work at a lower frame rate such as 24 frames per second for
creative work instead of working at the 29.97 frames per second that is standard for NTSC video.

Note: If you remove 3:2 pulldown from interlaced video footage, After Effects automatically sets the frame rate of the resulting footage item to
four-fifths of the original frame rate. When removing 3:2 pulldown from NTSC video, the resulting frame rate is 24 fps.

The frame rate of the composition should match the frame rate of the final output format. In most cases, you can simply choose a composition
settings preset. In contrast, set the frame rate for each footage item to the frame rate of the original source footage.

Trish and Chris Meyer provide tips and tricks regarding conforming footage items to a specific frame rate in an article (PDF) on Artbeats website.

112


http://www.peachpit.com/podcasts/episode.aspx?e=1a4d99ef-306b-4d9e-a332-3909d5a8f6eb
http://www.artbeats.com/assets/written_tutorials/pdfs/frame_rate_follies.pdf

Trish and Chris Meyer provide links to technical reference materials about frame rates and other details of digital video on the ProVideo Coalition
website.

John Dickinson provides a video tutorial on the Motionworks website that shows how and why to double the frame rate of a composition so that
you can work with individual fields when animating and rotoscoping with interlaced source footage.

Change frame rate for a footage item
1. Select the footage item in the Project panel.
2. Choose File > Interpret Footage > Main.
3. Select Conform To Frame Rate, enter a new frame rate for Frames Per Second, and then click OK.
Q Instead of using Interpret Footage to change a footage item’s frame rate, you can time-stretch a layer based on the footage item. For example,

time-stretch a layer by 100.1% to convert between 30fps and 29.97fps. Time-stretching modifies the speed of audio as well as video. (See
Time-stretch a layer.)

Change frame rate for a composition
1. Choose Composition > Composition Settings.
2. Do one of the following:
« Choose a composition settings preset from the Preset menu.

« Set the Frame Rate value.

Note: Jeff Almasol provides a script on is redefinery website to set the frame rate and duration of the current composition and all compositions
nested within it.

. . . To the t
Pixel aspect ratio and frame aspect ratio e

Pixel aspect ratio (PAR) is the ratio of width to height of one pixel in an image. Frame aspect ratio (sometimes called image aspect ratio or IAR) is
the ratio of width to height of the image frame.

4 16

A 4:3 frame aspect ratio (left), and a wider 16:9 frame aspect ratio (right)

Most computer monitors use square pixels, but many video formats—including ITU-R 601 (D1) and DV—use non-square rectangular pixels.

Some video formats output the same frame aspect ratio but use a different pixel aspect ratio. For example, some NTSC digitizers produce a 4:3
frame aspect ratio, with square pixels (1.0 pixel aspect ratio), and a frame with pixel dimensions of 640x480. D1 NTSC produces the same 4:3
frame aspect ratio but uses nonsquare pixels (0.91 pixel aspect ratio) and a frame with pixel dimensions of 720x486. D1 pixels, which are always
nonsquare, are vertically oriented in systems producing NTSC video and horizontally oriented in systems producing PAL video.

If you display nonsquare pixels on a square-pixel monitor without alteration, images and motion appear distorted; for example, circles distort into
ellipses. However, when displayed on a video monitor, the images are correct. When you import D1 NTSC or DV source footage into After Effects,
the image looks slightly wider than it does on a D1 or DV system. (D1 PAL footage looks slightly narrower.) The opposite occurs when you import
anamorphic footage using D1/DV NTSC Widescreen or D1/DV PAL Widescreen. Widescreen video formats have a frame aspect ratio of 16:9.

Note: To preview non-square pixels on a computer monitor, click the Toggle Pixel Aspect Ratio Correction button = at the bottom of the
Composition panel. The quality of the pixel aspect ratio correction for previews is affected by the Zoom Quality preference in the Previews
category. (See Viewer Quality preferences.)
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Square and nonsquare pixels
A. Square pixels and 4:3 frame aspect ratio B. Nonsquare pixels and 4:3 frame aspect ratio C. Nonsquare pixels displayed on a square-pixel
monitor

If a footage item uses nonsquare pixels, After Effects displays the pixel aspect ratio next to the thumbnail image for the footage item in the Project
panel. You can change the pixel aspect ratio interpretation for individual footage items in the Interpret Footage dialog box. By ensuring that all
footage items are interpreted correctly, you can combine footage items with different pixel aspect ratios in the same composition.

After Effects reads and writes pixel aspect ratios directly from QuickTime movies. For example, if you import a movie captured as widescreen (16:9
DV), After Effects automatically tags it correctly. Similarly, AVI and PSD files contain information that explicitly indicates the pixel aspect ratio of the
images.

If a footage item does not contain information that explicitly indicates the pixel aspect ratio of the image, After Effects uses the pixel dimensions of
the footage item frame to make a guess. When you import a footage item with either the D1 pixel dimensions of 720x486 or the DV pixel
dimensions of 720x480, After Effects automatically interprets that footage item as D1/DV NTSC. When you import a footage item with the D1 or DV
pixel dimensions of 720x576, After Effects automatically interprets that footage item as D1/DV PAL. However, you can make sure that all files are
interpreted correctly by looking in the Project panel or the Interpret Footage dialog box.

Note: Make sure to reset the pixel aspect ratio to Square Pixels when you import a square-pixel file that happens to have a D1 or DV pixel
dimensions—for example, a non-DV image that happens to have pixel dimensions of 720x480.

The pixel aspect ratio setting of the composition should match the pixel aspect ratio of the final output format. In most cases, you can simply
choose a composition settings preset. In contrast, set the pixel aspect ratio for each footage item to the pixel aspect ratio of the original source
footage.

Trish and Chris Meyer provide tips and tricks regarding pixel aspect ratio in two PDF documents on the Artbeats website:
» Pixel aspect ratio, part 1
* Pixel aspect ratio, part 2

Chris Pirazzi provides technical details about aspect ratios on his Lurker's Guide to Video website.

Upgrade pixel aspect ratios to correct values

After Effects CS3 and earlier used pixel aspect ratios for standard-definition video formats that ignore the concept of clean aperture. By not
accounting for the fact that clean aperture differs from production aperture in standard-definition video, the pixel aspect ratios used by After Effects
CS3 and earlier were slightly inaccurate. The incorrect pixel aspect ratios cause some images to appear subtly distorted.

Note: The clean aperture is the portion of the image that is free from artifacts and distortions that appear at the edges of an image. The
production aperture is the entire image.

The BBC provides technical details and guidelines on the BBC website regarding dimensions and aspect ratios for PAL video, including an
explanation of the discrepancy in pixel aspect ratios. The same concepts apply to NTSC video.

Chris Meyer explains why the corrected pixel aspect ratios are better and how some workflows are affected in the “New Pixel Aspect Ratios” video
in the After Effects CS4 New Creative Techniques series on the Lynda.com website.

Todd Kopriva summarizes information about the corrected pixel aspect ratios in a post on the Adobe website.

Pixel aspect ratio values in After Effects CS4 and later have been corrected as follows:

format value in After Effects CS4 and later previous value
D1/DV NTSC 0.91 0.9
D1/DV NTSC Widescreen 1.21 1.2
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D1/DV PAL 1.09 1.07

D1/DV PAL Widescreen 1.46 1.42

This discrepancy is limited to these older, standard-definition formats for which clean aperture differs from production aperture. This discrepancy
doesn'’t exist in newer formats.

New projects and compositions created in After Effects CS4 and later use the correct pixel aspect ratio values by default.

Projects and compositions created in After Effects CS3 or earlier are upgraded to use the correct pixel aspect ratios when these projects are
opened in After Effects CS4 and later.

Note: If you have a custom interpretation rules file, then you should update it with the correct pixel aspect ratio values.

If you use square-pixel footage items that are designed to fill the frame in a composition with non-square pixels, you may find that the change in
pixel aspect ratios causes a difference in behavior. For example, if you previously created 768x576 square-pixel footage items to use in a PAL
D1/DV composition, you should now create those items with square-pixel dimensions of 788x576.

Composition settings presets for square-pixel equivalents of standard definition formats have changed as follows:

format pixel dimensions in After Effects CS4 previous pixel dimensions
and later

NTSC D1 square-pixel equivalent 720x534 720x540

NTSC D1 Widescreen square-pixel 872x486 864x486

equivalent

PAL D1/DV square-pixel equivalent 788x576 768x576

PAL D1/DV Widescreen square-pixel 1050x576 1024x576

equivalent

Change pixel aspect ratio interpretation for a footage item
1. Select a footage item in the Project panel.
2. Choose File > Interpret Footage > Main.
3. Choose a ratio from the Pixel Aspect Ratio menu and click OK.

Change pixel aspect ratio for a composition
1. Choose Composition > Composition Settings.
2. Do one of the following:

« Choose a composition settings preset from the Preset menu.

« Choose a value from the Pixel Aspect Ratio menu.

Common pixel aspect ratios

Pixel aspect ratio When to use

Square pixels 1.0 Footage has a 640x480 or 648x486 frame
size, is 1920x1080 HD (not HDV or
DVCPRO HD), is 1280x720 HD or HDV,
or was exported from an application that
doesn’t support nonsquare pixels. This
setting can also be appropriate for footage
that was transferred from film or for
customized projects.

D1/DV NTSC 0.91 Footage has a 720x486 or 720x480 frame
size, and the desired result is a 4:3 frame
aspect ratio. This setting can also be
appropriate for footage that was exported
from an application that works with
nonsquare pixels, such as a 3D animation
application.
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D1/DV NTSC Widescreen

D1/DV PAL

D1/DV PAL Widescreen

Anamorphic 2:1

HDV 1080/DVCPRO HD 720, HD

Anamorphic 1080

DVCPRO HD 1080
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Footage has a 720x486 or 720x480 frame
size, and the desired result is a 16:9 frame
aspect ratio.

Footage has a 720x576 frame size, and
the desired result is a 4:3 frame aspect
ratio.

Footage has a 720x576 frame size, and
the desired result is a 16:9 frame aspect
ratio.

Footage was shot using an anamorphic
film lens, or it was anamorphically
transferred from a film frame with a 2:1
aspect ratio.

Footage has a 1440x1080 or 960x720
frame size, and the desired result is a 16:9
frame aspect ratio.

Footage has a 1280x1080 frame size, and
the desired result is a 16:9 frame aspect
ratio.
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Preparing and importing 3D image files

Importing 3D images from Photoshop Extended and lllustrator
Importing and using 3D files from other applications

Import RLA or RPF data into a camera layer

Baking and importing Maya data

Importing 3D images from Photoshop Extended and lllustrator fothetop

3D object layers in PSD files
Adobe Photoshop Extended can import and manipulate 3D models (3D objects) in several popular formats. Photoshop can also create 3D objects
in basic, primitive shapes.

After Effects CS5.5, and earlier can import these 3D object layers in PSD files and render them using the active camera in a composition. (See 3D
object layers from Photoshop.)

For a video tutorial about using 3D object layers from Photoshop in After Effects, go to the Adobe website.

After Effects CS6 cannot import 3D objects from PSD files.

Vanishing Point exchange

When you use the Vanishing Point feature in Photoshop Extended, you can then use the File > Export For After Effects (.vpe) command to save
the results as a collection of PNG files—one for each plane—and a .vpe file that describes the geometry of the scene. You can then import the
.vpe file into After Effects. After Effects uses the information in the .vpe file to re-create the scene as a composition containing a camera layer and
one perspective-corrected 3D layer for each PNG file.

The camera is on the negative z axis, at (X,y)=(0,0). The point of interest for the camera is in the center of the composition. The camera zoom is
set according to the field of view in the Vanishing Point scene.

The 3D layers for the planes in the scene have a parent layer with its anchor point at the center of the composition, so the whole scene can be
transformed together.

Vanishing Point exchange only works well for images that have square pixels in Photoshop.
For video tutorials about using Vanishing Point data from Photoshop in After Effects, go to the Adobe website:
» Working with Vanishing Point in Photoshop and After Effects
« Using Vanishing Point to map a 3D environment
Bob Donlon provides a tutorial on his blog that shows how to use Vanishing Point Exchange.
Aharon Rabinowitz provides a video tutorial on the Creative COW website that shows how to use Vanishing Point Exchange.

Lester Banks provides a video tutorial on his website that demonstrates how to use Vanishing Point in Photoshop Extended and then either bring
the 3D scene into After Effects as a .vpe file or bring the 3D scene in as a 3D object layer in a PSD file.

Andrew Kramer provides a video tutorial on his Video Copilot website that shows how to use Vanishing Point Exchange.

Importing PSD files as 3D scenes

Paul Tuersley provides a script on the AE Enhancers website that turns a layered PSD file into a 3D scene in After Effects. The script creates a
composition and adds expressions to the layers from the PSD file. When you move the layers along the z axis, the scene looks exactly like the
original artwork through the Active Camera view. You can animate the camera around the scene to see that the layers are at different depths in 3D
space.

Illustrator 3D effects

The effects in the 3D category in lllustrator—Extrude & Bevel, Revolve, and Rotate—give a three-dimensional appearance to any vector graphics
object, including text and drawings. If you want to add depth to your vector art and text, consider creating it in Illustrator, using the 3D effects, and
then importing the results into After Effects.

Importing and using 3D files from other applications fothetop

After Effects can import 3D-image files saved in Softimage PIC, RLA, RPF, OpenEXR, and Electric Image El format. These 3D-image files contain
red, green, blue, and alpha (RGBA) channels, as well as auxiliary channels with optional information, such as z depth, object IDs, texture
coordinates, and more.
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Though you can import composited files with 3D information into After Effects, you cannot modify or create 3D models directly with After Effects.

After Effects treats each composited 3D file from another application as a single 2D layer. That layer, as a whole, can be given 3D attributes and
treated like any After Effects 3D layer, but the objects contained within that 3D file cannot be manipulated individually in 3D space. To access the
3D depth information and other auxiliary channel information in 3D image files, use the 3D Channel effects. (See 3D Channel effects.)

3D Channel effect plug-ins from fnord software are included with After Effects to provide access to multiple layers and channels of OpenEXR files.
(See Using channels in OpenEXR files.)

After Effects can also import baked camera data, including focal length, film size, and transformation data, from Maya project files as a single
composition or two compositions. (See Baking and importing Maya data.)

After Effects imports camera data saved with RLA or RPF sequence files. (See Import RLA or RPF data into a camera layer.)

Softimage PIC files have a corresponding ZPIC file that contains the z-depth channel information. Although you can’t import a ZPIC file, you can
access the additional channel information as long as the ZPIC file is stored in the same folder as the imported PIC file.

Similarly, Electric Image (El) files can have associated EIZ files with z-depth channel data. As with ZPIC files, you cannot import EIZ files into After
Effects; instead, you simply store them in the same folder as the El files. For information about creating EIZ files, see your Electric Image
documentation.

Note: Some 3D applications, such as Cinema 4D, can export an After Effects composition directly.

A common technique when working in a 3D modeling application is to insert null objects, such as null lights or null locator nodes in the locations
where you want to composite in an image in After Effects. Then, after you have imported the 3D file into After Effects, you can use these null
objects as a reference for the placements of other visual elements.

Online resources about importing and using 3D files from other applications

Lutz Albrecht provides a two-part document on the Adobe website about integrating 3D applications with After Effects. These articles cover the
creation of UV maps, mattes, and channels from various 3D applications, including Maxon Cinema 4D, NewTek Lightwave, and Luxology modo.
The articles then show you how to use RE:Vision Effects RE:Map and fnord ProEXR plug-ins to use that data in After Effects.

Chris and Trish Meyer explain how to use data from 3D applications in After Effects in an excerpt from their book Creating Motion Graphics on
their website.

Tyson Ibele provides tutorials on his website that show how to use output from 3ds Max (3D Studio MAX) in After Effects.

Dave Scotland provides a pair of tutorials on the CG Swot website in which he demonstrates how to create RPF files in a 3D application and how
to use RPF files in After Effects. The first part explains the RPF format and how to create RPF files in 3DS Max. The second part shows how to
use the Object ID and Z depth information in an RPF file within After Effects, using the ID Matte, Depth of Field, Depth Matte, and Fog 3D effects.

Eran Stern provides a video tutorial on the Artbeats website that demonstrates the use of 3D tracking software that solves for camera movement
so that additional elements can be composited into the scene and appear to honor the same camera movement. This video tutorial uses Pixel
Farm PFHoe, but the techniques can be applied to almost any matchmoving software.

Bartek Skorupa provides a script on his website for exporting camera and object data from Blender for use in After Effects. He also provides a
sample project and a video tutorial that show how to use this script.

Harrison Ambs provides a two-part video tutorial on the CGTUTS+ website that demonstrates how to import data from Cinema 4D into After
Effects:

e partl
e part 2

Paul Tuersley provides a script on the AE Enhancers website for transferring a composition from After Effects to Cinema 4D.

. To thet
Import RLA or RPF data into a camera layer et
After Effects imports camera data saved with RLA or RPF sequence files. That data is incorporated into camera layers—one for each camera in
the sequence—that After Effects creates in the Timeline panel. You can access the camera data of an imported RLA or RPF sequence and create
a camera layer containing that data.

1. Add the sequence to a composition, and select its layer in the Timeline panel.

2. Choose Animation > Keyframe Assistant > RPF Camera Import.
Note: To create an RLA or RPF file with the camera data in 3D Studio Max, save your rendering in RPF format with Coverage, Z Depth,
and Alpha Channels enabled.

Dave Scotland provides a pair of tutorials on the CG Swot website in which he demonstrates how to create RPF files in a 3D application and
how to use RPF files in After Effects. The first part explains the RPF format and how to create RPF files in 3DS Max. The second part shows
how to use the Object ID and Z depth information in an RPF file within After Effects, using the ID Matte, Depth of Field, Depth Matte, and
Fog 3D effects.

Baking and importing Maya data To the top
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After Effects imports camera data from Maya project files. Before importing Maya camera information, you need to bake it. Baking camera data
makes animating with keyframes easier later in your project. Baking places a keyframe at each frame of the animation. You can have 0, 1, or a
fixed number of keyframes for each camera or transform property. For example, if a property is not animated in Maya, either no keyframes are set
for this property or one keyframe is set at the start of the animation. If a property has more than one keyframe, it must have the same number as
all of the other animation properties with more than one keyframe.

Reduce import time by creating or saving the simplest Maya file possible. In Maya, reduce keyframes by deleting static channels before baking,
and save a version of the Maya project that contains the camera animation only.

Note: The following transformation flags are not supported: query, relative, euler, objectSpace, worldSpace, worldSpaceDistance, preserve,
shear, scaleTranslation, rotatePivot, rotateOrder, rotateTranslation, matrix, boundingBox, boundingBoxInvisible, pivots, CenterPivots, and
zeroTransformPivots. After Effects skips these unsupported flags, and no warnings or error messages appeatr.

By default, After Effects treats linear units specified in the Maya file as pixels.

You can import camera data from Maya project files (.ma) and work with the data as a single composition or two compositions.
For each Maya file you import, After Effects creates either one or two compositions:

« If the Maya project has a square pixel aspect ratio, After Effects creates a single, square-pixel composition containing the camera data and
transformations.

« If the Maya project has a nonsquare pixel aspect ratio, After Effects creates two compositions. The first composition, which has a filename
prefixed by Square, is a square-pixel composition containing the camera data. The second, or parent, composition is a nonsquare-pixel
composition that retains the dimensions of the original file and contains the square-pixel composition. When working with imported camera
data, use 3D layers and square-pixel footage in the square-pixel composition, and use all nonsquare-pixel footage in the containing
composition.

When you import a Maya file with a 1-node camera, After Effects creates a camera in the square-pixel composition that carries the camera’s focal
length, film size, and transformation data.

When you import a Maya file with a 2-node or targeted camera, After Effects creates a camera and an additional parent node in the square-pixel
composition. The parent node contains only the camera’s transformation data. After Effects imports 2-node cameras automatically with the locator
node as the point of interest, with the Auto-Orientation option of the camera set to Orient Towards Point Of Interest.

After Effects doesn'’t read 3-node cameras.

Note: After Effects reads only the rendering cameras in Maya files and ignores the orthographic and perspective cameras. Therefore, always
generate a rendering camera from Maya, even if it's the same as the perspective camera. If you apply the FilmFit camera setting, make sure to
use either horizontal or vertical FilmFit, not fill.

After Effects can read Maya locator nodes, which enable you to track objects from the Maya scene as it is translated into After Effects. After
Effects creates a null layer and applies the relevant transformations to it if the name of a Maya locator node contains the word Null, NULL, or null.
Avoid parenting locator nodes to each other in Maya; instead, parent the locator nodes to geometry.

Note: After Effects doesn't read World or Underworld coordinates in the LocatorShape. Use a transform node to place them.
More Help topics
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Preparing and importing still images

Preparing still-image files for importing

Import a single still image or a still-image sequence
Preparing and importing Photoshop files

Preparing and importing lllustrator files

Importing camera raw files with Camera Raw
Cineon and DPX footage items

. - . . . To thet
Preparing still-image files for importing ometop
You can import individual still images into After Effects or import a series of still images as a sequence. For information about the still-image
formats that After Effects imports, see Supported import formats.

After Effects works internally in an RGB color space, but it can import and convert CMYK images. However, when possible, you should work in an
RGB color space in applications such as lllustrator and Photoshop when creating images for video, film, and other non-print media. Working in
RGB provides a larger gamut and more accurately reflects your final output.

Before you import a still image into After Effects, prepare it as completely as possible to reduce rendering time. It is usually easier and faster to
prepare a still image in its original application than to modify it in After Effects. Consider doing the following to an image before importing it into
After Effects:

» Make sure that the file format is supported by the operating system you plan to use.

« Crop the parts of the image that you do not want to be visible in After Effects.
Note: lllustrator files can have fractional dimensions (for example, 216.5x275.5 pixels). When importing these files, After Effects
compensates for the fractional dimensions by rounding up to the next whole number of pixels (for example, 217x278 pixels). This rounding
results in a black line at the right (width) or bottom (height) edge of the imported image. When cropping in lllustrator, make sure that the
dimensions of the cropped area are whole numbers of pixels.

« If you want to designate areas as transparent, create an alpha channel or use the transparency tools in applications such as Photoshop or
lllustrator.

« If final output will be broadcast video, avoid using thin horizontal lines (such as 1-pixel lines) for images or text because they may flicker as a
result of interlacing. If you must use thin lines, add a slight blur so that the image or text appears in both video fields instead of flickering
between them. (See Interlaced video and separating fields and Best practices for creating text and vector graphics for video.)

« If final output will be broadcast video, make sure that important parts of the image fall within the action-safe and title-safe zones. When you
create a document in lllustrator or Photoshop using a preset for film and video, the safe zones are shown as guide lines. (See Safe zones,
grids, guides, and rulers.)

« If the final output will be broadcast video, keep colors within the broadcast-safe ranges. (See Broadcast-safe colors.)

« Save the file using the correct naming convention. For example, if you plan to import the file into After Effects on Windows, use a three-
character filename extension.

« Set the pixel dimensions to the resolution and frame aspect ratio that you will use in After Effects. If you plan to scale the image over time,

set image dimensions that provide enough detail at the largest size the image has in the project. After Effects supports a maximum image
size of 30,000x30,000 pixels for importing and rendering files. The size of image that you can import or export is influenced by the amount of
physical RAM available to After Effects. The maximum composition dimensions are also 30,000x30,000 pixels.
Note: The image size or pixel dimensions setting in Photoshop (or other image-editing application) is relevant for the preparation of image
data for import into After Effects—not dpi (dots per inch) or ppi (pixels per inch) settings. The image size determines how many pixels wide
and tall an image is, whether those pixels are the tiny ones on a mobile device or the big ones on a motion billboard. The dpi or ppi settings
are relevant to printing an image and to the scale of copied and pasted paths.

. . - To the top
Import a single still image or a still-image sequence

You can import still image files as individual footage items, or you can import a series of still image files as a still-image sequence, which is a
single footage item in which each still image is used as a single frame.

To import multiple image files as a single still-image sequence, the files must be in the same folder and use the same numeric or alphabetic
filename pattern (such as Seql, Seq2, Seq?3).

When you import a file that appears to After Effects to be one file in a still-image sequence, After Effects by default imports all other files in the
same folder that appear to be in the same sequence. Similarly, when you select multiple files that appear to be in a sequence, After Effects by
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default imports them as a sequence. You can see what After Effects is about to import by looking at the bottom of the Import dialog box. You can

also import images and sequences by dragging files and folders into the Project panel.

Q To prevent After Effects from importing unwanted files when you want to import only a single file, or to prevent After Effects from interpreting
multiple files as a sequence, deselect the Sequence option in the Import dialog box. After Effects remembers this setting and thereafter uses it
as the default.

You can import multiple sequences from the same folder simultaneously by selecting files from different sequences and selecting Multiple
Sequences at the bottom of the Import dialog box.

When importing a sequence of still images, you can use the Force Alphabetical Order option in the Import dialog box to import a sequence with
gaps in its numbering (for example, Seql, Seq2, Seq3, Seq5). If you import a sequence with gaps in its numbering without selecting this option,
After Effects warns you of missing frames and replaces them with placeholders.

After Effects uses settings of the first image in the sequence to determine how to interpret the images in the sequence.

If the image files in a sequence are of a layered file type—such as Adobe Photoshop or Adobe lllustrator documents—then you can choose to
import the sequence as a standard footage item, or as a composition in which each layer in each file is imported as a separate sequence and
appears as a separate layer in the Timeline panel.

Note: When you render a composition that contains a numbered sequence, the output module uses the start frame number as the first frame
number. For example, if you start to render on frame 25, the name of the file is 00025.
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A sequence of still-image files (left) becomes one image sequence when imported into After Effects (right).

Import a still-image sequence as a single footage item
1. Choose File > Import > File.
2. Select any file in the sequence. To import a subset of files in a sequence, select the first file, hold down Shift, and then select the last file to
import.
3. Choose Footage from the Import As menu.
4. Click Open (Windows) or Import (Mac OS).
5. In the [filename] dialog box, choose one of the following from the Choose Layer menu:
Merged Layers Imports the sequence as a sequence footage item in which the layers in the file, if any, are merged into one layer.

Choose Layer Imports the sequence as a sequence footage item in which the same layer from each source file—for example, layer 3—is
imported and used in the sequence. If you choose this option for a PSD sequence, then you can also choose whether to ignore layer styles
or merge them into the layer. You must also choose a Footage Dimensions option: Layer Size matches the dimensions of the layer to the
content of the layer; Document Size matches the dimensions of the layer to the size of the original document.

6. Click OK.

If at any time you decide that you want access to the individual components of the footage item, you can convert it to a composition. See Convert
a merged footage item into a composition.

Import a still-image sequence as a composition

When you import a Photoshop or lllustrator file as a composition, you have access to the individual layers, blending modes, adjustment layers,
layer styles, masks, guides, and other features created in Photoshop or lllustrator. The imported composition and a folder containing each of its
layers as footage items appears in the Project panel.

1. Choose File > Import > File.
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2. Select any file in the sequence. To import a subset of files in a sequence, select the first file, hold down Shift, and then select the last file to
import.

3. Choose one of the following from the Import As menu:
Composition - Retain Layer Sizes Import the layers, each with its original dimensions.

One reason to import as a composition with layers at their original dimensions (rather than importing each layer at the composition frame
size) is so that each layer has its anchor point set at the center of the cropped graphics object, rather than at the center of the composition
frame. This more often makes transformations work more as you'd expect and prefer when animating individual layers of an imported
graphic item. For example, if you have a car with a separate layer for each wheel, importing as a composition with layers at their original
sizes puts the anchor point of each wheel in the center of the wheel, which makes rotating the wheels work as you’'d expect.

Composition Import layers and have the dimensions of each match the dimensions of the composition frame.

4. Click Open (Windows) or Import (Mac OS).

Convert a merged footage item into a composition
When you import a layered file, such as a Photoshop or lllustrator file, as footage, all of its layers are merged together. If at any time you decide
that you want access to the individual components of the footage item, you can convert it to a composition.

« To convert all instances of a footage item, select it in the Project panel and choose File > Replace Footage > With Layered Comp.

« To convert only one instance of the footage item, select the layer in the Timeline panel, and choose Layer > Convert To Layered Comp.
Note: It may take a few moments to convert a merged footage item to a layered composition.

Change the frame rate of a sequence
When you import a sequence of still images, it assumes the frame rate specified by the Sequence Footage preference in the Import category. The
default rate is 30 frames per second (fps). You can change the frame rate after importing by reinterpreting the footage item:

% Select the sequence in the Project panel, choose File > Interpret Footage > Main, and then enter a new value for Assume This Frame Rate.
For more information, see Frame rate.

Preparing and importing Photoshop files fothetop
Note: For information and instructions that apply to all kinds of still image files, see Preparing still-image files for importing and Import a single still
image or a still-image sequence.

Because After Effects includes the Photoshop rendering engine, After Effects imports all attributes of Photoshop files, including position, blending
modes, opacity, visibility, transparency (alpha channel), layer masks, layer groups (imported as nested compositions), adjustment layers, layer
styles, layer clipping paths, vector masks, image guides, and clipping groups.

Before you import a layered Photoshop file into After Effects, prepare it thoroughly to reduce preview and rendering time. Avoid problems importing
and updating Photoshop layers by doing the following:

« Organize and name layers. If you change a layer name in a Photoshop file after you have imported it into After Effects, After Effects retains
the link to the original layer. However, if you delete a layer, After Effects is unable to find the original layer and lists it as Missing in the
Project panel.

« Make sure that each layer has a unique name. This is not a requirement of the software, but helps to keep you from becoming confused.

« If you think that you might add layers to the Photoshop file in Photoshop after you have imported it into After Effects, go ahead and add a
small number of placeholder layers before you import the file into After Effects. When you refresh the file in After Effects, it will not pick up
any layers that have been added since the file was imported.

« Unlock layers in Photoshop before importing into After Effects. This is not necessary for most kinds of layers, but it is required for some kinds
of layers. For example, background layers that must be converted to RGB may not be imported correctly if they are locked.

A convenient command within After Effects is Layer > New > Adobe Photoshop File, which adds a layer to a composition and then opens the
source of that layer in Photoshop for you to begin creating a visual element, such as a background layer for your movie. The layer in Photoshop is
created with the correct settings for your After Effects composition. As with many of the Creative Suite applications, you can use the Edit Original
command in After Effects to open a PSD file in Photoshop, make and save changes, and have those changes appear immediately in the movie
that refers to the PSD source file. Even if you don’t use Edit Original, you can use the Reload Footage command to have After Effects refresh its
layers to use the current version of the PSD file. (See Create a layer and new Photoshop footage item and Edit footage in its original application.)

Note: One good way to prevent interlace flicker from thin horizontal lines in still images is to run the Interlace Flicker Removal action in Photoshop
before you bring the still images into After Effects. Photoshop includes several video actions for utility purposes such as this.

Online resources about preparing and importing Photoshop files

Richard Harrington provides a pair of video tutorials that show how to prepare an image in Photoshop for animation in After Effects with the Puppet
tools:

e Partl

e Part 2
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Richard Harrington and lan Robinson provide a free sample chapter from their “Motion Graphics with Adobe Creative Suite 5 Studio Techniques”
book on the Peachpit Press website. This chapter shows how to prepare lllustrator and Photoshop files.

See this video tutorial by Andrew Devis on the Creative Cow website about importing and using Photoshop PSD files in After Effects.

Color modes

Layered Photoshop (PSD) files need to be saved in RGB or Grayscale color mode for After Effects to import them as a composition and to
separate the layers. CMYK, LAB, Duotone, Monotone, and Tritone color modes are not supported for layered files; After Effects will import a file
that uses one of these color modes as a single, flattened image. (Regarding the other color modes available in Photoshop such as Bitmap and
Indexed: Photoshop does not support layers in these color modes.)

Q To determine or change the color mode of a document in Photoshop, choose Image > Mode. (The color mode is also displayed in the title bar
of the document window.)

Masks and alpha channels

Adobe Photoshop supports a transparent area and one optional layer mask (alpha channel) for each layer in a file. You can use these layer masks
to specify how different areas within a layer are hidden or revealed. If you import one layer, After Effects combines the layer mask (if present) with
the transparent area and imports the layer mask as a straight alpha channel.

If you import a layered Photoshop file as a merged file, After Effects merges the transparent areas and layer masks of all the layers into one alpha
channel that is premultiplied with white.

When you import a Photoshop file as a composition, vector masks are converted to After Effects masks. You can then modify and animate these
masks within After Effects.

Photoshop clipping groups, layer groups, and Smart Objects

If the layered Photoshop file contains clipping groups, After Effects imports each clipping group as a precomposition nested within the main
composition. After Effects automatically applies the Preserve Underlying Transparency option to each layer in the clipping-group composition,
maintaining transparency settings. These nested precompositions have the same dimensions as the main composition.

Q Paul Tuersley provides a script on the AE Enhancers forum that crops the precompositions to the size of their contents, while retaining their
correct position in the main composition.

Photoshop layer groups are imported as individual compositions.

It is often valuable to group layers into Smart Objects in Photoshop so that you can import meaningful collections of Photoshop layers as individual
layers in After Effects. For example, if you used 20 layers to create your foreground object and 30 layers to create your background object in
Photoshop, you probably don’t need to import all of those individual layers into After Effects if all that you want to do is animate your foreground
object flying in front of your background object; consider grouping them into a single foreground Smart Object and a single background Smart
Object before importing the PSD file into After Effects.

Photoshop layer styles and blending modes
After Effects also supports blending modes and layer styles applied to the file. When you import a Photoshop file with layer styles, you can choose
the Editable Layer Styles option or the Merge Layer Styles Into Footage option:

Editable Layer Styles Matches appearance in Photoshop and preserves supported layer style properties as editable.

Note: A layer with a layer style interferes with intersection of 3D layers and the casting of shadows.

Merge Layer Styles Into Footage Layer styles are merged into the layer for faster rendering, but the appearance may not match the appearance
of the image in Photoshop. This option doesn't interfere with intersection of 3D layers or casting of shadows.

Photoshop video layers

Photoshop files can contain video and animation layers. After Effects can import these files like any other Photoshop files, either as a footage item
with all layers merged together or as a composition with each Photoshop layer separate and editable in After Effects. (Working with Photoshop
video layers requires QuickTime 7.1 or later.)

Note: After Effects can’'t import a Photoshop video layer that uses an image sequence as its source.

In After Effects CS6, video layer support in Photoshop .psd documents has been removed. The layers will still have a duration, but won't play.
Animating layers with available properties in the Photoshop animation timeline (like Position and Opacity) are supported.

3D object layers in PSD files
Adobe Photoshop Extended can import and manipulate 3D models (3D objects) in several popular formats. Photoshop can also create 3D objects
in basic, primitive shapes.

After Effects CS5.5, and earlier, can import these 3D object layers in PSD files and render them using the active camera in a composition. (See 3D
object layers from Photoshop.)

For a video tutorial about using 3D object layers from Photoshop in After Effects, go to the Adobe website.

3D object layers in PSD files is no longer supported in After Effects CS6.

Scaling and resizing
Though it's not very well suited for movies, the content-aware scaling feature in Photoshop is very useful for extending and scaling still images.
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This feature can be useful when repurposing images for wide-screen formats that were created for standard-definition formats.

Preparing and importing lllustrator files fothetop

Note: For information and instructions that apply to all kinds of still image files, see Preparing still-image files for importing and Import a single still
image or a still-image sequence.
Before you save an lllustrator file for importing into After Effects, consider doing the following:

« Create your document in lllustrator CS5 using one of the Video And Film document profiles. In addition to creating a document at the
appropriate size for video or film work, this creates a document with two artboards: one at the appropriate frame size, and one much larger.
When you bring such a document into After Effects, the area outside the smaller artboard isn’t cropped and lost; it's retained outside of the
composition frame. This only works for an lllustrator document with multiple layers imported as a composition.

« To ensure that lllustrator files appear correctly in After Effects, select Create PDF Compatible File in the lllustrator Options dialog box.

» To copy paths between lllustrator and After Effects, make sure that the Preserve Paths option is selected in the Files & Clipboard section of
the Illustrator Preferences dialog box.

« To ensure that files rasterize most faithfully in After Effects, save your file in Al format instead of lllustrator 8.x or 9.x EPS format.

« To separate objects in an lllustrator file into separate layers, use the Release To Layers command in lllustrator. Then, you can import the
layered file into After Effects and animate the layers separately.

« If you will be working with Edit Original to move objects and layers in Illustrator, import the Illustrator document into After Effects as a
composition with document-sized layers (not using the Retain Layer Size option).

When you import an lllustrator file, After Effects makes all empty areas transparent by converting them into an alpha channel.

Note: When you've imported an lllustrator file, you can specify whether anti-aliasing is to be performed at higher quality or at higher speed. Select
the footage item in the Project panel and choose File > Interpret Footage > Main, and click the More Options button at the bottom of the dialog
box.

Atfter Effects does not read embedded color profiles from lllustrator files. To ensure color fidelity, assign an input color profile to the Illustrator
footage item that matches the color profile with which the lllustrator file was created.

Q After Effects can't read blending modes from Al documents saved as a version later than lllustrator CS2. If you need to retain blending mode
information when importing a file into After Effects from lllustrator, save the document as an lllustrator CS2 document.

For information on preserving sharpness of vector graphics (avoiding pixelation), see Continuously rasterize a layer containing vector graphics.

Online resources for preparing and importing lllustrator files
For a video tutorial that shows how to prepare artwork in lllustrator and import and use vector graphics in After Effects, see the Adobe website.

Eran Stern provides a video tutorial on the Creative COW website that shows how to create text in lllustrator for use in After Effects.

Dave Nagel provides instructions on the DMN website for importing an lllustrator document into After Effects with the lllustrator objects on separate
layers in After Effects.

In a thread on the After Effects user-to-user forum, JETalmage provides a script that converts sub-layers in lllustrator into top-level layers. This is a
necessary step in preparing an lllustrator file for importing into After Effects if you intend to animate these items independently.

Steve Holmes provides a tutorial on the Layers Magazine website that shows how to create and prepare vines, swirls, and flourishes in Illustrator
and then import, reveal, and animate them in After Effects using the Stroke effect.

Richard Harrington and lan Robinson provide a free sample chapter from their “Motion Graphics with Adobe Creative Suite 5 Studio Techniques”
book on the Peachpit Press website. This chapter shows how to prepare lllustrator and Photoshop files.

. . . To the t
Importing camera raw files with Camera Raw ometop

You can import sequences of camera raw files much as you import sequences of other kinds of still image files.

After Effects applies the settings for the first camera raw image in the sequence to all of the images in the sequence that do not have their own
XMP sidecar files. After Effects does not check the Camera Raw database for image settings.

Note: Camera raw files are uncompressed. Their large size may increase rendering time.
e Choose File > Import > File.
« Select the camera raw file, and click Open.
* Make any necessary adjustments in the Camera Raw dialog box, and click OK.

You can adjust a camera raw image after importing it. To open the image in the Camera Raw dialog box, select the footage item in the Project
panel, choose File > Interpret Footage > Main, and click More Options.
Note: You can't assign an input color profile to a camera raw image for use in a color-managed project. For information on how colors are

automatically interpreted, see Interpret a footage item by assigning an input color profile.
™
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Q Todd Kopriva provides links to free excerpts from books about Camera Raw by Conrad Chavez, Bruce Fraser, Jeff Schewe, Ben Willmore, and
Dan Ablan on his blog.

For more information about Camera Raw, see Camera Raw Help in the Creative Suite 5 component Help document.

. . To the to
Cineon and DPX footage items 0
A common part of the motion-picture film production workflow is scanning the film and encoding the frames into the Cineon or DPX file format. The
DPX (Digital Picture Exchange) format is a standard format closely related to the Cineon format.

You can import Cineon 4.5 or Digital Picture Exchange (DPX) files directly into an After Effects project as individual frames or as a sequence of
numbered stills. Once you have imported a Cineon or DPX file, you can use it in a composition and then render the composition as an image
sequence.

To preserve the full dynamic range of motion-picture film, Cineon files are stored using logarithmic 10-bpc color. However, After Effects internally
uses 8-bpc, 16-bpc, or 32-bpc color, depending on the color bit depth of the project. Work with Cineon files in a 16- or 32-bpc project—by default,
After Effects stretches the logarithmic values to the full range of values available.

Cineon data has a 10-bit white point of 685 and a 10-bit black point of 95. Values above 685 are retained, but are treated as highlights. Rather
than abruptly clipping highlights to white, After Effects interprets highlights using a gradual ramp defined by the Highlight Rolloff value. You can
modify the 10-bit white point and 10-bit black point input levels and the output (converted) white point and black point levels to match your specific
footage items or creative needs.

Use a project color depth of 32 bpc when working with Cineon footage items so that highlights are preserved, in which case you don’t need to roll
off the highlights.

When you choose DPX/Cineon Sequence from the Format menu in the Output Module Settings dialog box, you can then open the Cineon
Settings dialog box to set output options. Choose whether to output DPX (.dpx) files or FIDO/Cineon 4.5 (.cin) files in the File Format section of the
Cineon Settings dialog box.

After Effects provides three basic ways of working with the colors in Cineon footage items:

« The easiest—and recommended—way is to enable color management and assign an input color profile to a Cineon footage item in the Color
Management tab of the Interpret Footage dialog box, corresponding to the film stock on which the footage was recorded. If creating output for
film, use the same profile as the output color profile so that the output file matches the film stock. One advantage of using color management
features to work with Cineon footage items is that compositing with images from other footage types is made easier. See Interpret a footage
item by assigning an input color profile.

« If you need the settings for the interpretation of the Cineon footage item to change over time, then you can apply the Cineon Converter effect
to a layer that uses the Cineon footage item as its source. See Cineon Converter effect.

« If you need to manually modify the settings for a Cineon footage item, or if you don’t want to use color management, then you can use the
Cineon Settings dialog box. To open this dialog box, click the Cineon Settings button in the Color Management tab of the Interpret Footage
dialog box.

Manual settings in the Cineon Settings dialog box:

Converted Black Point Specifies the black point used for the layer in After Effects.

Converted White Point Specifies the white point used for the layer in After Effects.

10 Bit Black Point Specifies the black level (minimum density) for converting a 10-bit Cineon layer.

10 Bit White Point Specifies the white level (maximum density) for converting a 10-bit Cineon layer.

Current Gamma Specifies the target gamma value.

Highlight Rolloff Specifies the rolloff value used to correct bright highlights. To get over range values when working in 32 bpc, set the value to 0.
Logarithmic Conversion Converts the Cineon sequence from log color space to the target gamma specified by the Current Gamma setting.
When you're ready to produce output from the Cineon file, it is important that you reverse the conversion. (To convert from logarithmic to linear, set
Current Gamma to 1.)

Units Specifies the units After Effects uses to display dialog values.

Additional resources about Cineon and DPX footage items
Stu Maschwitz has a post on his ProLost blog that goes into some details of what it means to say that color values in Cineon files are in a
logarithmic color space.

Pete O’Connell provides an article on the Creative COW website that describes working with Cineon footage items.

Todd Kopriva provides links to information about troubleshooting color problems with imported DPX files in this post on the After Effects Region of
Interest blog.

More Help topics
¢ ] Change pixel dimensions of an image

B rbout Smart Objects

[ +:] Color fundamentals
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Creating layers

Layers overview

Create layers from footage items or change layer source
Solid-color layers and solid-color footage items
Adjustment layers

Create a layer and new Photoshop footage item

. To the top
Layers overview

Layers are the elements that make up a composition. Without layers, a composition is only an empty frame. Use as many layers as necessary to
create your composition. Some compositions contain thousands of layers, whereas some compositions contain only one layer.

Layers in After Effects are similar to tracks in Adobe Premiere Pro. The primary difference is that each After Effects layer can have no more than
one footage item as its source, whereas a Premiere Pro track typically contains multiple clips. Layers in After Effects are also similar to layers in
Photoshop, though the interface for working with layers differs. Working with layers in the Timeline panel in After Effects is similar to working with
layers in the Layers panel in Photoshop.

You can create several kinds of layers:

» Video and audio layers that are based on footage items that you import, such as still images, movies, and audio tracks

« Layers that you create within After Effects to perform special functions, such as cameras, lights, adjustment layers, and null objects
« Solid-color layers that are based on solid-color footage items that you create within After Effects

« Synthetic layers that hold visual elements that you create within After Effects, such as shape layers and text layers

« Precomposition layers, which use compositions as their source footage items

When you modify a layer, you do not affect its source footage item. You can use the same footage item as the source for more than one layer and
use the footage differently in each instance. (See Importing and interpreting footage items.)

Changes made to one layer do not affect other layers, unless you specifically link the layers. For example, you can move, rotate, and draw masks
for one layer without disturbing any other layers in the composition.

After Effects automatically numbers all layers in a composition. By default, these numbers are visible in the Timeline panel next to the layer name.
The number corresponds to the position of that layer in the stacking order. When the stacking order changes, After Effects changes all numbers
accordingly. The layer stacking order affects rendering order and therefore affects how the composition is rendered for previews and final output.
(See Render order and collapsing transformations.)

Note: By default, new layers begin at the beginning of the composition duration. You can instead choose to have new layers begin at the current
time by deselecting the Create Layers At Composition Start Time preference (Edit > Preferences > General (Windows) or After Effects >
Preferences > General (Mac OS)).

For a video tutorial on creating and managing layers, go to the Adobe website.

Layers in the Layer, Composition, and Timeline panels

After you add a layer to a composition, you can reposition the layer in the Composition panel. In the Timeline panel, you can change a layer's
duration, starting time, and place in the layer stacking order. You can also change any of the properties of a layer in the Timeline panel. (See
Layer properties in the Timeline panel.)

You can perform many tasks—such as drawing masks—in either the Composition panel or the Layer panel. However, other tasks—such as
tracking motion and using the paint tools—must be performed in the Layer panel.

The Layer panel shows you a layer before any transforms are applied to the layer. For example, the Layer panel does not show the result of
modifying the Scale property of a layer. To see a layer in context with other layers and with the results of transforms, use the Composition panel.

Layers that are not based on a source footage item are synthetic layers. Synthetic layers include text layers and shape layers. You cannot open a
synthetic layer in the Layer panel. You can, however, precompose a synthetic layer and open the precomposition in the Layer panel.

Q To view changes to a layer (such as masks or effects) in the Layer panel, select Render in the Layer panel. Deselect Render to view the
original, unaltered layer.

Opening layers and layer sources

« To open a layer other than a precomposition layer in the Layer panel, double-click the layer, or select the layer and choose Layer > Open
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Layer.

« To open the source composition of a precomposition layer in the Composition panel, double-click the layer, or select the layer and choose
Layer > Open Composition.

« To open the source footage item of a layer, Alt-double-click (Windows) or Option-double-click (Mac OS) the layer, or select the layer and
choose Layer > Open Layer Source.

Q If you right-click (Windows) or Control-click (Mac OS) a layer, you can choose Open Footage or Open Composition to open the layer’'s source
item.

« To open a precomposition layer in the Layer panel, Alt-double-click (Windows) or Option-double-click (Mac OS) the layer, or select the layer
and choose Layer > Open Layer.

. To the to
Create layers from footage items or change layer source ’

You can create a layer from any footage item in the Project panel, including another composition. After you add a footage item to a composition,
you can modify and animate the resulting layer.

When you add a composition to another composition, you create a layer that uses the composition that you added as its source. (See

Precomposing, nesting, and pre-rendering.)

The Still Footage preference setting (Preferences > Import) controls the default duration of layers that use still footage items as their sources. By
default, when you create a layer with a still image as its source, the duration of the layer is the duration of the composition. You can change the
duration of the layer after it's created by trimming the layer.

Note: By default, new layers begin at the beginning of the composition duration. You can instead choose to have new layers begin at the current
time by deselecting the Create Layers At Composition Start Time preference (Edit > Preferences > General (Windows) or After Effects >
Preferences > General (Mac OS)).

Often, the next step after adding a layer to a composition is scaling and positioning the layer to fit in the frame. (See Scale or flip a layer.)

Create layers from one or more footage items
When you create layers from multiple footage items, the layers appear in the layer stacking order in the Timeline panel in the order in which they
were selected in the Project panel.
1. Select one or more footage items and folders in the Project panel.
2. Do one of the following:
« Drag the selected footage items to the Composition panel.

Q Hold Shift while dragging to snap the layer to the center or edges of the composition.

» Drag the selected footage items to the Timeline panel. When you drag the item into the layer outline, a highlight bar indicates where the
layer will appear when you release the mouse button. If you drag the item over the time graph area, a time marker indicates where the In
point of the layer will be when you release the mouse button.

Q Hold Shift while dragging to shap the In point to the current-time indicator.

« Drag the selected footage items to the composition name or icon in the Project panel, or press Ctrl+/ (Windows) or Command+/ (Mac
OS). New layers are created at the top of the layer stack and at the center of the composition.

Create a layer from a trimmed footage item
You can trim a moving-image footage item in the Footage panel before inserting a layer based on that footage item into a composition.

1. Double-click a footage item in the Project panel to open it in the Footage panel. (See View footage items in the Footage panel.)
2. Move the current-time indicator in the Footage panel to the frame that you want to use as the In point of the layer, and click the Set In Point
button at the bottom of the Footage panel.

3. Move the current-time indicator in the Footage panel to the frame that you want to use as the Out point of the layer, and click the Set Out
Point button at the bottom of the Footage panel.

4. To create a layer based on this timmed footage item, click an Edit button at the bottom of the Footage panel:

Overlay Edit azh
Creates the new layer at the top of the layer stacking order, with the In point set at the current time in the Timeline panel.

Ripple Insert Edit Ee
Also creates the new layer at the top of the layer stacking order, with the In point set at the current time in the Timeline panel, but splits all
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other layers. Newly created split layers are moved later in time so that their In points are at the same time as the Out point of the inserted
layer.

Replace layer sources with references to another footage item
1. Select one or more layers in the Timeline panel
2. Alt-drag (Windows) or Option-drag (Mac OS) a footage item from the Project panel onto a selected layer in the Timeline panel.

. . . To thet
Solid-color layers and solid-color footage items e

You can create layers of any solid color and any size (up to 30,000x30,000 pixels). Solid-color layers have solid-color footage items as their
sources. Solid-color layers and solid-color footage items are both usually called solids.

Solids work just like any other footage item: You can add masks, modify transform properties, and apply effects to a layer that has a solid as its
source footage item. Use solids to color a background, as the basis of a control layer for a compound effect, or to create simple graphic images.

Solid-color footage items are automatically stored in the Solids folder in the Project panel.

Jeff Almasol provides a script on his redefinery website with which you can rename the selected solid footage items in the Project panel. You can
use this script to, for example, include the pixel dimensions, aspect ratio, and RGB color values in the name.

Note: In After Effects CS6, new solid layers are 17% gray (45/255) so they can contrast with the new default darker user interface brightness

Create a solid-color layer or solid-color footage item
» To create a solid footage item but not create a layer for it in a composition, choose File > Import > Solid.
« To create a solid footage item and create a layer for it in the current composition, choose Layer > New > Solid or press Ctrl+Y (Windows) or
Command+Y (Mac OS).

To create a layer that fits the composition when you create a solid-color layer, choose Make Comp Size.

Modify settings for solid-color layers and solid-color footage items
« To modify settings for the selected solid-color layer or footage item, choose Layer > Solid Settings.

To apply the changes to all solid-color layers that use the footage item, select Affect All Layers That Use This Solid. If you don't select this
option, you create a new footage item, which becomes the source for the selected layer.

Adjustment layers To the top

When you apply an effect to a layer, the effect applies only to that layer and no others. However, an effect can exist independently if you create an
adjustment layer for it. Any effects applied to an adjustment layer affect all layers below it in the layer stacking order. An adjustment layer at the
bottom of the layer stacking order has no visible result.

Because effects on adjustment layers apply to all layers beneath them, they are useful for applying effects to many layers at once. In other
respects, an adjustment layer behaves like other layers; for example, you can use keyframes or expressions with any adjustment layer property.

Note: A more accurate description is that the adjustment layer applies the effect to the composite created from all layers below the adjustment
layer in the layer stacking order. For this reason, applying an effect to an adjustment layer improves rendering performance compared with
applying the same effect separately to each of the underlying layers.

Q If you want to apply an effect or transformation to a collection of layers, you can precompose the layers and then apply the effect or
transformation to the precomposition layer. (See Precompose layers.)

Use masks on an adjustment layer to apply an effect to only parts of the underlying layers. You can animate masks to follow moving subjects in
the underlying layers.
« To create an adjustment layer, choose Layer > New > Adjustment Layer, or press Ctrl+Alt+Y (Windows) or Command+Option+Y (Mac OS).

« To convert selected layers to adjustment layers, select the Adjustment Layer switch # for the layers in the Timeline panel or choose Layer >
Switches > Adjustment Layer.

Note: You can deselect the Adjustment Layer switch for a layer to convert it to a normal layer.

Online resources about adjustment layers
Andrew Kramer provides a video tutorial on his Video Copilot website in which he shows how to use an adjustment layer to apply an effect to only
a short duration and to only specific portions of a movie.

Eran Stern provides a video tutorial on the Creative COW website that demonstrates the use of lights as adjustment layers, to precisely control
which layers are affected by which lights.

Lloyd Alvarez provides a script on his After Effects Scripts website that creates an adjustment layer above each selected layer, with each new
adjustment layer trimmed to the duration of the selected layer.
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Create a layer and new Photoshop footage item

To the top

When you create an Adobe Photoshop file from After Effects, Photoshop starts and creates a new PSD file. This PSD file consists of a blank
Photoshop layer that has the same dimensions as your composition, with the appropriate title-safe, and action-safe guides. The color bit depth of
the PSD file is the same as the color bit depth of your After Effects project.

The newly created PSD file is automatically imported into After Effects as a footage item. Any changes that you save in Photoshop appear in the
footage item in After Effects.

To create a Photoshop footage item and use it as the source for a new layer in the current composition, choose Layer > New > Adobe
Photoshop File. The Photoshop layer is added as the top layer in your composition.

To create a Photoshop footage item with the settings of the most recently open composition, without adding it to a composition, choose File >
New > Adobe Photoshop File.

Layers (keyboard shortcuts)
Precompose layers

Creating and editing text layers
Cameras, lights, and points of interest
Null object layers

Working with footage items

Trim, extend, or slip-edit a layer

Apply an effect or animation preset
Creating masks

Preparing and importing Photoshop files
Working with Photoshop and After Effects
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Selecting and arranging layers

Select layers

Change the stacking order for selected layers
Coordinate systems: composition space and layer space
Move layers in space

Separate dimensions of Position to animate components individually
Align or distribute layers in 2D space

Trim, extend, or slip-edit a layer

Remove part of the duration of a layer

Place or move a layer in time

Arrange layers in time sequentially

Copy or duplicate a layer

Split a layer

Auto-Orientation options

Additional resources for selecting and arranging layers

Select layers

To the top

Selected layers that also have properties selected are indicated with a hollow highlight in the Timeline panel. A selected layer that has no
properties selected is indicated with a solid highlight.

0’ = Source Name

[» Effeds
[ Transform

[» Effects

Forsom |

Anchor Point

« 7 Position

o E

Top layer selected, but no properties selected; bottom layer selected with properties selected.

Q To scroll the topmost selected layer to the top of the Timeline panel, press X.

To select a layer, click the layer in the Composition panel, click its name or duration bar in the Timeline panel, or click its name in the
Flowchart panel.

To select a layer that is obscured in the Composition panel, right-click (Windows) or Control-click (Mac OS) over the layer in the Composition
panel, and choose Select > [layer name].

To select a layer if the layer is open in its own Layer panel, choose the layer name from the Window menu or the Layer panel viewer menu.
To select a layer by position number, type the layer number on the numeric keypad. If the layer number has more than one digit, type the
digits quickly so that After Effects can recognize them as one number.

To select the next layer in the stacking order, press Ctrl+Down Arrow (Windows) or Command+Down Arrow (Mac OS). To select the previous
layer, press Ctrl+Up Arrow (Windows) or Command+Up Arrow (Mac OS).

To extend the selection to the next layer in the stacking order, press Ctrl+Shift+Down Arrow (Windows) or Command+Shift+Down Arrow
(Mac OS). To extend the selection to the previous layer in the stacking order, press Ctrl+Shift+Up Arrow (Windows) or Command+Shift+Up
Arrow (Mac OS).

To select all layers, choose Edit > Select All while the Timeline or Composition panel is active. To deselect all layers, choose Edit > Deselect
All. If the composition’s Hide Shy Layers switch is selected, using Select All when the Timeline panel is active doesn’t select shy layers. (See
Show and hide layers in the Timeline panel.)

To deselect any currently selected layers and select all other layers; with at least one layer selected, choose Invert Selection from the
context menu in the Composition or Timeline panel.

To select all layers that use the same color label, click the color label in the Timeline panel, and choose Select Label Group, or select a layer
with that color label and choose Edit > Label > Select Label Group.

To select all child layers assigned to a parent layer, select the parent layer and choose Select Children from the context menu in the
Composition or Timeline panel. The child layers are added to the existing selection.

You can select multiple layers in the Composition panel (After Effects CS5.5 and later). Drag with the Selection tool to create a selection box
(marquee) around the layers to select them. Hold Shift while clicking or dragging to select additional layers or to deselect layers.
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Lloyd Alvarez provides a script on his After Effects Scripts website with which you can tag layers and then select, shy, and solo layers according to
their tags. The tags are appended to comments in the Comments field in the Timeline panel.

. To thet
Change the stacking order for selected layers et
The vertical arrangement of layers in the Timeline panel is the layer stacking order, which is directly related to the render order. You can change
the order in which layers are composed with one another by changing the layer stacking order.
Note: Because of their depth properties, the stacking order of 3D layers in the Timeline panel does not necessarily indicate their spatial position
in the composition.
« In the Timeline panel, drag the layer names to a new position in the layer stacking order.
« To move the selected layers up one level in the layer stacking order, press Ctrl+Alt+Up Arrow (Windows) or Command+Option+Up Arrow
(Mac OS); to move the selected layers down one level, press Ctrl+Alt+Down Arrow (Windows) or Command+Option+Down Arrow (Mac OS).
« To move the selected layers to the top of the layer stacking order, press Ctrl+Alt+Shift+Up Arrow (Windows) or Command+Option+Shift+Up
Arrow (Mac OS); to move the selected layers to the bottom, press Ctrl+Alt+Shift+Down Arrow (Windows) or Command-+Option+Shift+Down
Arrow (Mac OS).
« Choose Layer > Arrange, and then choose Bring Layer Forward, Send Layer Backward, Bring Layer To Front, or Send Layer To Back.

Q When you copy (or cut) and paste layers, the layers are pasted so that they appear from top to bottom in the Timeline panel in the same order
in which they were selected before the copy (or cut) operation. You can Ctrl-click (Windows) or Command-click (Mac OS) layers to select them
in any arbitrary order, cut them, and then immediately paste them to reorder the layers in the order in which they were selected.

Jeff Almasol provides a script on his redefinery website with which you can change the stacking order of layers in a composition by sorting

according to In point, Out point, selection order, layer name, or random order.

. s To the top
Coordinate systems: composition space and layer space

The coordinate system for each layer is its layer space. The coordinate system for each composition is its composition space. Property values for
items that exist within a layer—such as effect control points and anchor points—exist in layer space and are measured from the origin in the layer
space of that layer. The Position property of a layer, however, describes where the layer is within a composition and is therefore measured in the
composition space of that composition.

As you move the pointer over the layer frame in the Layer panel, the Info panel displays the coordinates of the pixel under the pointer in layer
space. The X coordinate represents position on the horizontal axis, and the Y coordinate represents position on the vertical axis. Values for these
coordinates are in pixels. The X and Y coordinates are relative to the origin (0,0), which is fixed at the upper left corner of the layer.

You can modify the zero point of the rulers, but you can’t modify the origin of layer space. If the zero point differs from the origin, X' and Y'
coordinates appear in the Info panel below the X and Y coordinates, indicating coordinates based on the zero point of the rulers.

When you move the pointer over the composition frame in the Composition panel, the Info panel displays coordinates in composition space. As
you drag a layer, the lower portion of the Info panel displays the coordinates of the anchor point of the layer.

. To the top
Move Iayers In space

When you move a layer in space, you modify its Position property.

You can separate the components of a Position property into individual properties—X Position, Y Position, and (for 3D layers) Z Position—so that
you can modify or animate each independently. (See Separate dimensions of Position to animate components individually.)

Jeff Almasol provides a script on his redefinery website that places a new null layer on the line between the anchor points of two selected layers;
you use a slider control on the null layer to reposition the null layer along this line.

Q To move selected layers so that their anchor points are at the center in the current view, choose Layer > Transform > Center In View or press
Ctrl+Home (Windows) or Command+Home (Mac OS).

Q To move a layer so that its anchor point is at the center of the composition, right-click (Windows) or Control-click (Mac OS) the Position
property, choose Edit Value, choose % Of Composition in the Units menu, and enter 50 for each of the components of the Position property.

To avoid softening of an image that is not moving, make sure that a layer’s Position values are non-fractional values. This avoids resampling that
is used when a layer with image quality set to Best is placed on subpixels.

Move layers by dragging in the Composition panel
Q To snap the edges of a layer to grids or guides as you drag, choose View > Snap To Grid or View > Snap To Guides.

+ Select one or more layers, and then drag a selected layer using the Selection tool L3
When you move a layer by dragging it in the Composition panel, the Info panel shows the change in the Position property as you drag.

Move layers by directly modifying the Position property
1. Select one or more layers.
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2. Press P to show the Position property in the Timeline panel.
3. Modify the Position property in the Timeline panel.

Move layers with arrow keys
1. Select one or more layers.
2. To move selected layers one pixel left, right, up, or down, press an arrow key. To move 10 pixels, hold Shift as you press the arrow key.
Q The arrow keys move the layer one pixel at the current magnification. To move a layer more precisely with the arrow keys, zoom in the
Composition panel. (See Zoom an image for preview.)

. . S . . . To the to
Separate dimensions of Position to animate components individually ’
By default, each Position property has two or three components, with each holding the value for one of the spatial dimensions (axes). You can
separate the components of a Position property into individual properties—X Position, Y Position, and (for 3D layers) Z Position. Separating
dimensions allows you to modify or animate the position of a layer along the x axis, y axis, and z axis independently.

For a video tutorial about using the Separate Dimensions command, go to the Adobe website.
To decompose selected Position properties into individual X Position, Y Position, and (for 3D layers) Z Position properties, do one of the following:

« Choose Animation > Separate Dimensions.
« Right-click (Windows) or Control-click (Mac OS) a Position property and choose Separate Dimensions from the context menu.

« Click the Separate Dimensions 2= button at the bottom of the Graph Editor.

To recompose a set of individual Position properties into a single Position property with multiple components, use the same commands that you
use to separate dimensions.

Important: When you recompose separate Position properties into a single Position property, some information about the motion path and speed
is lost, because the multiple Bezier curves used to represent the individual components are collapsed into a single Bezier curve at each keyframe.
When you separate dimensions, some information about speed is lost, but the motion path does not change. You should work with separate
dimensions or without separate dimensions for each property for an entire project, rather than toggling back and forth.

The decision of whether to work with separate dimensions depends on what you're trying to accomplish. Using one property for position has the
advantage of providing smooth motion more easily. Also, using a single property for position enables the use of roving keyframes, which provides
uniform speed. Working with separate dimensions for position sacrifices some of this automatic smoothing to gain greater control of spatial
animation. Working with separate dimensions also makes some simulations easier, especially in cases in which the simulated forces acting on a
layer are orthogonal (perpendicular) to one another.

For example, if you are animating a ball flying horizontally and bouncing vertically, you can do so more easily by separating dimensions. The X
Position property can be animated with two keyframes, one for the start position and one for the end position. This horizontal animation represents
the speed of the throw. The Y Position property can be animated with a single expression that simulates the acceleration due to gravity and the
vertical bouncing from the floor. A similar example is a boat drifting down a river in a variable crosswind.

Note: After Effects CS3 included a Separate XYZ Position animation preset that accomplished something similar to the Separate Dimensions
feature, though the animation preset is not as robust.

Align or distribute layers in 2D space fothetop

Use the Align panel to line up or evenly space selected layers. You can align or distribute layers vertically or horizontally.

1. Select the layers to align or distribute.

2. Choose Selection or Composition from the Align Layers To menu.
Selection Aligns selected layers according to the layer boundaries of the selected layers.

Composition Aligns selected layers according to the boundaries of the composition frame.
3. In the Align panel, click the button representing the desired type of alignment or distribution.

« To distribute, you must select three or more layers. When Selection is chosen in the Align Layers To menu, you must select two or more
layers to align. When Composition is chosen in the Align Layers To menu, you must select one or more layers to align.

« When Selection is chosen in the Align Layers To menu, each alignment option aligns selected layers to the layer that most closely
represents the new alignment. For example, for right-edge alignment, all selected layers align to the selected layer with the edge that is
farthest to the right.

« A distribution option evenly spaces selected layers between the two most extreme layers. For example, for a vertical distribution option, the
selected layers are distributed between the topmost and bottommost selected layers.

« When you distribute layers of different sizes, the spaces between layers may not be uniform. For example, distributing layers by their centers
creates equal space between the centers—but different-sized layers extend by different amounts into the space between layers.

« Alignment or distribution options cannot move locked layers.

« The Align panel does not affect alignment of characters within a text layer.
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Q To move selected layers so that their anchor points are at the center in the current view, choose Layer > Transform > Center In View or press
Ctrl+Home (Windows) or Command+Home (Mac OS).

Charles Bordenave (nab) provides a script on the After Effects Scripts website, with which you can distribute layers in 3D space.

. . . To the to
Trim, extend, or slip-edit a layer ’

The beginning of the duration of a layer is its In point, and the end is its Out point. The duration is the span between the In point and the Out
point, and the bar that extends from the In point to the Out point is the layer duration bar.
To trim a layer is to modify its In or Out point so that the layer has a different duration. When you trim a layer that is based on moving source

footage, you affect which frames of the source footage item are shown in the layer; the first frame to appear is at the In point, and the last frame to
appear is at the Out point. Trimming a layer doesn'’t cut frames from the footage item; it only affects what frames are played for the layer.

A B C D

Trimming layers in the Timeline panel
A. Original In point B. Negative layer time indicator for still image layer C. Original In point D. Slip-edit bar, representing excluded frames for
motion footage layer E. New In points

When you use a footage item as a source for different layers, you can trim each layer differently to show different portions of the source. Trimming
a layer does not alter the footage item or the original source file.

You can trim a layer by changing the In and Out points in the Layer panel or the Timeline panel. (You can also trim a footage item before using it
to create a layer. See Create layers from footage items or change layer source.)

The In point 4, Out point ¥, and duration 4 values for a layer are shown at the bottom of the Layer panel. To show this information for all layers in
the Timeline panel, click the In/Out/Duration/Stretch button 1F in the lower-left corner of the Timeline panel. The duration, In point, and Out point
for the selected layer are also shown in the Info panel.

In the Layer panel, In and Out points are expressed in layer time. In the Timeline panel, In and Out points are expressed in composition time. The
duration is the same in both cases (unless time-remapping or time-stretching is enabled for the layer).

You can extend many kinds of layers for any duration, extending their In points and Out points out past their original times. This capability applies
to time-remapped layers, shape layers, layers based on still-image footage items, camera layers, light layers, and text layers. If you extend a layer
back in time so that the layer extends into negative layer time (past layer time zero), a series of hash marks on the bottom of the layer bar
indicates the portions of the layer that are in negative layer time. This indication is useful if you've applied effects to the layer—such as Particle
Playground or Shatter—that use layer time to calculate their results.

Online resources for trimming, extending, and editing layers
Lloyd Alvarez provides a script on his After Effects Scripts website that trims a layer to the duration of the layer above it in the layer stacking order.
This is useful, for example, for timming a layer to match a track matte or adjustment layer.

Jeff Almasol provides a script on his redefinery website that creates a panel with controls for moving various combinations of items in time: layer In
point, layer Out point, layer source frames, keyframes, and markers.

Trim or extend layers in the Timeline panel

i
Dragging the Out point of a layer duration bar.

1. Select one or more layers in the Timeline panel.
2. Do one of the following:

« Drag either end of a layer duration bar.

« Move the current-time indicator to the time at which you want to set the In point or Out point. To set the In point to the current time,
press Alt+[ (Windows) or Option+[ (Mac OS). To set the Out point to the current time, press Alt+] (Windows) or Option+] (Mac OS).
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Trim or extend a layer in the Layer panel
« Open the layer in the Layer panel and drag either end of the layer duration bar.

« Move the current-time indicator in the Layer panel to the time at which you want the footage to begin or end, and then click the In 4 or Out
button to set the In or Out point to the current time.

Slip-edit a layer

After you've trimmed a layer based on moving footage, a pale slip-edit bar represents the frames of the footage item that you are excluding from
the composition. This pale rectangle does not appear for a trimmed layer based on a still footage item. You can choose which frames are played
within a trimmed duration by dragging the slip-edit bar. The In and Out points of the layer are not affected.

Moving only the In or Out point of a layer doesn’'t move keyframes. Dragging the layer duration bar moves all keyframes. Dragging the slip edit bar
moves selected keyframes, but does not move unselected keyframes.

& When performing a slip edit, you probably want to move some keyframes with the source footage—such as mask keyframes. Other keyframes
should stay where they are in time. Press Shift+F2 to deselect keyframes and leave the layer selected.
« Drag the slip-edit bar to the left or right.
« Drag the layer to the left or right with the Pan Behind (Anchor Paoint) tool.

Remove part of the duration of a layer fothetop

1. In the Timeline panel, set the work area to include only the portion of the layers’ duration to remove: Move the current-time indicator to the
time that the work area is to begin, and press B. Move the current-time indicator to the time at which the work area is to end, and press N.
2. Do one of the following:

« Select the layers from which to remove a section.
« Select the Lock switch & for layers that you do not want affected by the extraction. Press F2 to deselect all layers.

Note: If no layers are selected, the following step removes the section from all unlocked layers.
3. Do one of the following:

« To remove the section and leave a gap of the same duration as the removed section, choose Edit > Lift Work Area.

« To remove the section, choose Edit > Extract Work Area. The gap is closed by ripple deletion.

. . To the top
Place or move a layer in time

The layer duration bar represents the layer duration visually. The In, Out, and Duration columns in the Timeline panel represent the layer duration
numerically.

Note: To choose which columns are visible in the Timeline panel, choose Columns from the panel menu, or right-click (Windows) or Control-click
(Mac OS) a column heading.
These procedures move the entire layer in time.

« To set the In point or Out point numerically, click the number in the In or Out column for the layer in the Timeline panel.

« To move the In point or Out point to the current time, Alt-click (Windows) or Option-click (Mac OS) the number in the In or Out column for
the layer in the Timeline panel.

« To move the In points of selected layers to the beginning of the composition, press Alt+Home (Windows) or Option+Home (Mac OS).

» To move the Out points of selected layers to the end of the composition, press Alt+End (Windows) or Option+End (Mac OS).

« To move selected layers one frame later, press Alt+Page Down (Windows) or Option+Page Down (Mac OS). To move selected layers 10
frames later, press Alt+Shift+Page Down (Windows) or Option+Shift+Page Down (Mac OS).

« To move selected layers one frame earlier, press Alt+Page Up (Windows) or Option+Page Up (Mac OS). To move selected layers 10 frames
earlier, press Alt+Shift+Page Up (Windows) or Option+Shift+Page Up (Mac OS).

« To move the entire layer in time by dragging, drag the layer duration bar to the left or right. To snap the layer duration bar to significant
points in time (such as markers, or the start or end of the composition), Shift-drag the layer duration bar.

Note: When you drag a layer in the Timeline panel, the Info panel displays the name, duration, change in time, and In and Out points for the
layer.

Before and after dragging the duration bar

Jeff AlImasol provides a script on his redefinery website with which you can move selected layers as a group, aligning the group to a specific time
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in the composition.

. . . To the to
Arrange layers in time sequentially ’
Use the Sequence Layers keyframe assistant to automatically arrange layers in a sequence. When you apply the keyframe assistant, the first layer
you select remains at its initial time, and the other selected layers move to new times in the Timeline panel based on the order in which you
selected them.

Overlapping layers can have Opacity keyframes set automatically to create a cross-dissolve.

For a layer to be put into a sequence, its duration must be less than the length of the composition so that it leaves time for other layers. (See Trim,
extend, or slip-edit a layer.)

1. In the Timeline panel, hold down Ctrl (Windows) or Command (Mac OS) and select layers in sequential order, beginning with the layer to
appear first.

2. Choose Animation > Keyframe Assistant > Sequence Layers.

3. In the Sequence Layers dialog box, do one of the following:

« To arrange the layers end to end, leave the Overlap option unselected.

« To overlap layers, select Overlap, enter a Duration value for the duration of the overlap, and select a transition. Select Cross Dissolve
Front And Back Layers to use the transparency of the selected layers; otherwise, choose Dissolve Front Layer.

« To leave gaps between the layers, select Overlap and enter a negative Duration value.

Copy or duplicate a layer To the top

When you copy a layer, you copy all of its properties, including effects, keyframes, expressions, and masks.

Duplicating a layer is a shortcut with which you copy and paste the layer with one command. Duplicating a layer with a track matte preserves the
relative ordering of the layer and its track matte.

When you paste layers, they are placed in the order in which you selected them before copying. The first layer selected is the last one to be
placed, so it ends up on the top in the layer stacking order. If you select layers from the top first, they end up in the same stacking order when
pasted.

& If you have a component of a layer—such as a mask or keyframe—selected when you copy, you copy only that component. Before copying,
press Shift+F2 to deselect all of the components of a layer and leave the layer itself selected.

» To copy selected layers and place the In points of the copies at the current time, choose Edit > Copy, and then press Ctrl+Alt+V (Windows)
or Command+Option+V (Mac OS).

« To copy selected layers and place the copies at the same times as the originals, choose Edit > Copy, and then choose Edit > Paste.
Q To place copies at the top of the layer stack in the Timeline panel instead of immediately above the originals, press F2 to deselect the
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originals before you paste.

« To duplicate selected layers, choose Edit > Duplicate or press Ctrl+D (Windows) or Command+D (Mac OS).

. To the to
Split a layer ’
In the Timeline panel, you can split a layer at any time, creating two independent layers. Splitting a layer is a time-saving alternative to duplicating
and trimming the layer—something you might do when you want to change the stacking-order position of the layer in the middle of the
composition.
Note: To make new split layers appear above the original layer in the Timeline panel, select Create Split Layers Above Original Layer (Edit >
Preferences > General (Windows) or After Effects > Preferences > General (Mac OS)). Deselect this option to make the layers appear below the
original layer.

1. Select one or more layers.

2. Move the current-time indicator to the time at which to split the layers.

3. Choose Edit > Split Layer.

When you split a layer, both resulting layers contain all of the keyframes that were in the original layer in their original positions. Any applied track
mattes retain their order, on top of the layer.

After you split a layer, the duration of the original layer ends at the point of the split, and the new layer starts at that point in time.
If no layer is selected when you choose Edit > Split Layer, all layers are split at the current time.
Paul Tuersley provides a script on the AE Enhancers forum for splitting layers at layer markers.

Lloyd Alvarez provides a script on his After Effects Scripts website that automatically detects edits in a footage layer and splits it into a separate
layer for each edit (or places a layer marker at each edit).

Auto-Orientation options To the top

The auto-orientation options (Layer > Transform > Auto-Orient) for each layer specify how its orientation depends on motion paths, points of
interest, and cameras.

Off The layer rotates freely, independent of the motion path, point of interest, or other layers.

Orient Along Path The layer faces in the direction of the motion path. For example, use this option for a camera to depict the perspective of a
driver who is looking at the road ahead while driving.

Orient Towards Camera The layer is always oriented so that it faces the active camera. This option is available for 3D layers; this option is not
available for 2D layers, cameras, or lights. 3D text layers have an additional option, Orient Each Character Independently, which orients each
character around its individual anchor point. Selecting Orient Each Character Independently enables per-character 3D properties for the text layer
if they aren’t already enabled. (See Per-character 3D text properties.)

Orient Towards Point Of Interest The camera or light always points at its point of interest. This option is not available for layers other than
cameras and lights. (See Cameras, lights, and points of interest.)

Note: If you specify an auto-orientation option for a layer, and then change its Orientation or X, Y, or Z Rotation properties, the layer orientation
is offset by the new values. For example, you can set a camera with Orient Along Path, and then rotate the camera 90 degrees to the right to
depict the perspective of a passenger looking out the side window of a car as it moves.

The automatic orientation to point to the point of interest occurs before the Rotation and Orientation transformations are applied. To animate a
camera or light with the Orient Towards Point Of Interest option to look temporarily away from the point of interest, animate the Rotation and
Orientation transform properties.

Dan Ebberts provides an expression on his MotionScript website that auto-orients a layer along only one axis. This is useful, for example, for
having characters turn from side to side to follow the camera while remaining upright.

L . . To the to
Additional resources for selecting and arranging layers ’

Jeff Almasol provides a script on his redefinery website that creates a panel with controls for moving various combinations of items in time: layer In
point, layer Out point, layer source frames, keyframes, and markers.

Trish and Chris Meyer provide an introduction to moving, trimming, reordering, and sequencing layers in a PDF excerpt from the “Layer Control”
chapter of their book After Effects Apprentice: Real-World Skills for the Aspiring Motion Graphics Artist.

More Help topics
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Managing layers

View and change layer information

Layer switches and columns in the Timeline panel
Toggle visibility or influence of a layer or property group
Solo a layer

Lock or unlock a layer

Color labels for layers, compositions, and footage items
Show and hide layers in the Timeline panel

Layer image quality and subpixel positioning
Continuously rasterize a layer containing vector graphics

Jeff Almasol provides a script on his redefinery website that renders and exports each of the selected layers separately. For example, use this

script if layers represent different versions of an effect or different parts of an effect that you want to render as separate passes for flexibility in how
they get composited.

. . . To thet
View and change layer information e

« To rename a layer or property group, do one of the following:
« Select the item in the Timeline panel, press Enter (Windows) or Return (Mac OS), and enter the new name.
« Right-click (Windows) or Control-click (Mac OS) the item in the Timeline panel, choose Rename, and enter the new name.

« To alternate between viewing the names of source footage items and the names of layers in the Timeline panel, click the Layer
Name/Source Name column heading in the Timeline panel.
Note: When the layer name and the source footage name are the same, square brackets appear around the layer name in the layer name
view, like this: [layer name]

« To show the name of the source footage file for a selected layer in the Info panel, press Ctrl+Alt+E (Windows) or Command+Option+E (Mac
0S).

» To see what footage item is the source for a layer, right-click (Windows) or Control-click (Mac OS) the layer in the Timeline panel and
choose Reveal Layer Source In Project.

The source footage item is selected in the Project panel.

You can filter layers in the Timeline panel to show only layers with properties that match a search string or certain other characteristics. See
Search and filter in the Timeline, Project, and Effects & Presets panels and Showing properties and groups in the Timeline panel (keyboard
shortcuts).

Jeff Almasol provides a script on his redefinery website that automatically writes specified information about footage items or layers to the
Comment fields for the respective items in the Project panel or Timeline panel.

Christopher Green provides a script (Selected_Layers_Renamer.jsx) on his website with which you can rename multiple layers selected in the
Timeline panel. You can search and replace text in the names, append characters to the beginning or end of the names, trim a specified number of
characters from the beginning or end of the names, or replace the names with numbers in a series.

. . . . To the to
Layer switches and columns in the Timeline panel ’

Many of characteristics of a layer are determined by its layer switches, which are arranged in the Timeline panel in columns. By default, the A/V
Features column appears to the left of the layer name, and the Switches and Modes (Transfer Controls) columns appear to the right, but you can
arrange columns in a different order. (See Columns.)

To show or hide columns in the Timeline panel, click the Layer Switches &, Transfer Controls ®, or In/Out/Duration/Stretch # button in the
lower-left corner of the Timeline panel. Press Shift+F4 to show or hide the Parent column. Press F4 to toggle the Switches and Modes columns.

The results of some layer switch settings depend on the settings of composition switches, which are in the upper right of the layer outline in the
Timeline panel.

Q Quickly change the state of a switch for multiple layers by clicking the switch for one layer and dragging up or down that column for the
adjacent layers.

Jeff Almasol provides a script on his redefinery website that creates a panel with which you can save and restore the layer switch settings for all
layers in a composition.

Switches in the A/V Features column
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Video ® Toggles layer visuals on or off. (See Toggle visibility or influence of a layer or property group.)

Audio ¥ Toggles layer sounds on or off.

Solo @ Includes the current layer in previews and renders, ignoring layers without this switch set. (See Solo a layer.)
Lock £ Locks layer contents, preventing all changes. (See Lock or unlock a layer.)

Switches in the Switches column

Shy «# Hides the current layer when the Hide Shy Layers composition switch “8 is selected. (See Show and hide layers in the Timeline panel.)
Collapse Transformations/Continuously Rasterize # Collapses transformations if the layer is a precomposition; continuously rasterizes if the
layer is a shape layer, text layer, or layer with a vector graphics file (such as an Adobe lllustrator file) as the source footage. Selecting this switch
for a vector layer causes After Effects to rerasterize the layer for each frame, which improves image quality, but also increases the time required
for previewing and rendering. (See Render order and collapsing transformations and Continuously rasterize a layer containing vector graphics.)
Quality  Toggles between Best and Draft options for layer quality for rendering, including rendering to the screen for previews. (See Layer image
quality and subpixel positioning.)

Effect & Select to render the layer with effects. The switch does not affect the setting for individual effects on the layer. (See Delete or disable
effects and animation presets.)

Frame Blend #¥ Sets frame blending to one of three states: Frame Mix #, Pixel Motion *, or off. If the Enable Frame Blending composition switch
@E is not selected, the frame blending setting of the layer is irrelevant. (See Frame blending.)

Motion Blur & Toggles motion blur on or off for the layer. If the Enable Motion Blur © composition switch is not selected, the motion blur setting
of the layer is irrelevant. (See Motion blur.)

Adjustment Layer # I|dentifies the layer as an adjustment layer. (See Adjustment layers.)

3D Layer @ Identifies the layer as a 3D layer. If the layer is a 3D layer with 3D sublayers—as is the case for a text layer with per-character 3D
properties—the switch uses this icon: %. (See 3D layers overview and resources.)

Toggle visibility or influence of a layer or property group fothetop

The Video ® (eyeball) switch for a layer controls whether the visual information for a layer is rendered for previews or final output. If the layer is an
adjustment layer, the Video switch controls whether the effects on the layer are applied to the composite of the layers below it. If the layer is a
camera or light, the Video switch controls whether the layer is on or off.

Several components of layers—such as paint strokes, path operations in shape layers, and text animators in text layers—each have their own
Video switches. You can use the Video switch to toggle the visibility and influence of these items individually.

« To turn off the visibility of a layer deselect the Video switch for the layer.
« To select the Video switch for all layers, choose Layer > Switches > Show All Video.
« To deselect the Video switch for all layers except the selected layers, choose Layer > Switches > Hide Other Video.

To the to
Solo a layer ’

You can isolate one or more layers for animating, previewing, or final output by soloing. Soloing excludes all other layers of the same type from
being rendered—both for previews in the Composition panel and for final output. For example, if you solo a video layer, any lights and audio layers
are unaffected, so they appear when you preview or render the composition. However, the other video layers do not appear.

« To solo one or more layers, select the layers in the Timeline panel, and click the Solo icon @ to the left of the layer names.
« To solo one layer and unsolo all other layers, Alt-click (Windows) or Option-click (Mac OS) the Solo icon @ to the left of the layer name.

The Video switch # is dimmed for other layers when a layer is soloed, indicating that the other layers are not visible.

Lloyd Alvarez provides a script on his After Effects Scripts website with which you can tag layers and then select, shy, and solo layers according to
their tags. The tags are appended to comments in the Comments column in the Timeline panel.

To the to
Lock or unlock a layer ’

The Lock switch prevents layers from being edited accidentally. When a layer is locked, you cannot select it in either the Composition or Timeline
panels. If you try to select or modify a locked layer, the layer flashes in the Timeline panel.

When a layer is locked, the Lock icon & appears in the A/V Features column, which appears by default to the left of the layer name in the
Timeline panel.

« To lock or unlock a layer, click the Lock switch for the layer in the Timeline panel.
« To unlock all layers in the active composition, choose Layer > Switches > Unlock All Layers.

L . To the to

Color labels for layers, compositions, and footage items ’
You can use labels (colored boxes in the Label column) in the Project panel and Timeline panel to organize and manage compositions, footage
items, and layers. By default, different label colors indicate different kinds of footage items, but you can assign label colors to indicate whatever
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categories you choose.

Q Rename label groups to help you to organize and categorize layers and footage items. To see label names in the Label column, widen the
column to greater than the default width.

To select all layers with the same label color, select a layer with that label color and choose Edit > Label > Select Label Group.

« To change the color of a label for one layer, click the label in the Timeline panel and choose a color.

» To change the color of a label for all layers with that label color, select one of the layers belonging to the label group, choose Edit > Label >
Select Label Group, and choose Edit > Label > [color name].

« To change the names and default colors for labels, choose Edit > Preferences > Labels (Windows) or After Effects > Preferences > Labels
(Mac OS).

« To change the default associations of label colors with source types, choose Edit > Preferences > Labels (Windows) or After Effects >

Preferences > Labels (Mac OS).

To disable the use of a layer’s label color for layer handles and motion paths, choose Edit > Preferences > Appearance (Windows) or After
Effects > Preferences > Appearance (Mac OS), and deselect Use Label Colors For Layer Handles And Paths.

To disable the use of a layer, footage item, or composition’s label color in the tabs of corresponding panels, choose Edit > Preferences >
Appearance (Windows) or After Effects > Preferences > Appearance (Mac OS), and deselect Use Label Colors For Related Tabs.

Note: By default, the panel label colors do not respond to the Brightness control in the Appearance preferences. To make the Brightness control
affect panel label colors, select the Affects Label Colors option in the Appearance preferences.

. . . . To the to
Show and hide layers in the Timeline panel ’
You can mark a layer as shy and then use the Hide Shy Layers - composition switch at the top of the Timeline panel to hide all shy layers in the
Timeline panel layer outline. Making layers shy is useful for making room in the Timeline panel to show the layers and layer properties that you
want to adjust.

The icon in the Switches column indicates whether a layer is shy = or not shy .

Shy layers are still rendered, both for previews and for final output. To exclude layers from previews or final output, use the Video switch or make
the layer a guide layer.

« To toggle a layer between shy and not shy, click the Shy switch for the layer, or select the layer in the Timeline panel and choose Layer >
Switches > Shy.

« To toggle between hiding and showing all shy layers, click to select or deselect the Hide Shy Layers e composition switch at the top of the
Timeline panel, or choose Hide Shy Layers from the Timeline panel menu.

You can also filter layers in the Timeline panel to show only layers with properties that match a search string or certain other characteristics. See
Search and filter in the Timeline, Project, and Effects & Presets panels and Showing properties and groups in the Timeline panel (keyboard
shortcuts).

Lloyd Alvarez provides a script on his After Effects Scripts website with which you can tag layers and then select, shy, and solo layers according to
their tags. The tags are appended to comments in the Comments field in the Timeline panel.

Layer image quality and subpixel positioning fothetop

The quality setting of a layer determines how precisely it is rendered, as well as influencing the precision of other calculations involving the layer,
such as motion tracking and the use of the layer as a control layer for a compound effect.

The default quality of new layers is determined by the Create New Layers At Best Quality preference in the General preferences category.
Duplicated or split layers retain the Quality setting of the original layer.

To toggle between Best and Draft quality of selected layers, click the Quality switch in the Timeline panel. To choose from all three options,
choose Layer > Quality:

Best Displays and renders a layer using subpixel positioning, anti-aliasing, 3D shading, and complete calculation of any applied effects. Best
requires the most time for rendering—both for previews and for final output.

Draft Displays a layer so that you can see it, but only at rough quality. Draft quality displays and renders a layer without anti-aliasing and subpixel
positioning, and some effects are not precisely calculated.

Wireframe Displays a layer as a box, without layer contents. Layer wireframes are displayed and rendered faster than layers rendered with Best
or Draft settings.

Subpixel positioning

Property values (like Position and Anchor Point) in After Effects are not restricted to integer values; they can have fractional values, too. This
allows for smooth animation, as a value is interpolated from one keyframe to another. For example, if a Position value goes from [0,0,0] at a
keyframe at time O to a value of [0,0,80] at time 1 second in a 25-frames-per-second composition, then the value at frame 1 is [0,0,3.2].

After Effects calculates all spatial values, like Position and effect control points, to a precision of 1/65,536 of a pixel. This is called subpixel
precision.
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If the pixels of a layer aren't positioned directly on the pixel boundaries of the composition, a small amount of blur occurs—very similar to anti-
aliasing. This blur is not a problem for an object in motion, because objects in motion have motion blur, but it can soften fine details in a static
image. Also, if an image is moving slowly or at just the wrong speed, the image can appear to oscillate between sharpness and blurriness.

Because the default anchor point for a layer is the center of an object, odd-sized objects have non-integer anchor points and appear soft when
positioned at integer values. To minimize blurriness and in-and-out of focus result, follow these guidelines:

« Create graphics with odd or even dimensions, based on the dimensions of the composition. For example, if the composition is 640x480
pixels, create graphics with even dimensions (such as 100x100 pixels); if the composition is 99x99 pixels, create graphics with odd
dimensions (such as 75x53 pixels).

» Set the position information for graphics (including the hold position and final position keyframes) to integers and not fractional numbers.

. . . . To the top
Continuously rasterize a layer containing vector graphics

When you import vector graphics, After Effects automatically rasterizes them. However, if you want to scale a layer that contains vector graphics
above 100%, then you need to continuously rasterize the layer to maintain image quality. You can continuously rasterize vector graphics in layers
based on lllustrator, SWF, EPS, and PDF files. Continuously rasterizing causes After Effects to rasterize the file as needed based on the
transformation for each frame. A continuously rasterized layer generally produces higher-quality results, but it may render more slowly.

Shape layers and text layers are always continuously rasterized.

When you apply an effect to a continuously rasterized layer, the results may differ from the results of applying the effect to a layer without
continuous rasterization. This difference in results is because the default rendering order for the layer changes. The default rendering order for a
layer without continuous rasterization is masks, followed by effects, and then transformations; whereas the default rendering order for a
continuously rasterized layer is masks, followed by transformations, and then effects.

Whether or not you continuously rasterize, if you view and render a composition using Best Quality, After Effects anti-aliases (smooths) the vector
graphics.
You cannot open or interact with a continuously rasterized layer in a Layer panel. A result of this limitation is that you can’t paint directly on a
continuously rasterized layer. However, you can copy and paste paint strokes from other layers.

A

B C
Image from imported lllustrator file
A. Original B. Enlarged with Continuously Rasterize switch turned off C. Enlarged with Continuously Rasterize switch turned on

4 In the Timeline panel, click the layer's Continuously Rasterize switch #, which is the same as the Collapse Transformations switch for

precomposition layers.
More Help topics
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Layer properties

Layer properties in the Timeline panel

Set a property value

Layer anchor points

Scale or flip a layer

Rotate a 2D layer

Adjust audio volume levels

Parent and child layers

Null object layers

Guide layers

Use Brainstorm to experiment and explore settings

Layer properties in the Timeline panel fothetop

Each layer has properties, many of which you can modify and animate. The basic group of properties that every layer has is the Transform group,
which includes Position and Opacity properties. When you add certain features to a layer—for example, by adding masks or effects, or by
converting the layer to a 3D layer—the layer gains additional properties, collected in property groups.

All layer properties are temporal—they can change the layer over time. Some layer properties, such as Opacity, have only a temporal component.
Some layer properties, such as Position, are also spatial—they can move the layer or its pixels across composition space.

You can expand the layer outline to display layer properties and change property values.

Most properties have a stopwatch 2. Any property with a stopwatch can be animated—that is, changed over time. (See About animation,
keyframes, and expressions.)

B B [disgon

Collapsed property group (left) compared to expanded property group (right) in layer outline

Properties in the Effects property group (effect properties) are also layer properties. Many effect properties can also be modified in the Effect
Controls panel.

Show or hide properties in the Timeline panel
« To expand or collapse a property group, click the triangle to the left of the layer name or property group name.
« To expand or collapse a property group and all of its children, Ctrl-click (Windows) or Command-click (Mac OS) the triangle.
« To expand or collapse all groups for selected layers, press Ctrl+* (accent grave) (Windows) or Command+" (accent grave) (Mac OS).
« To reveal an effect property in the Timeline panel, double-click the property name in the Effect Controls panel.
« To hide a property or property group, Alt+Shift-click (Windows) or Option+Shift-click (Mac OS) the name in the Timeline panel.

« To show only the selected properties or property groups in the Timeline panel, press SS.
Q The SS shortcut is especially useful for working with paint strokes. Select the paint stroke in the Layer panel, and press SS to open the
property group for that stroke in the Timeline panel.

« To show only a specific property or property group, press its shortcut key or keys. (See Showing properties and groups in the Timeline panel
(keyboard shortcuts).)

» To add a property or property group to the properties shown in the Timeline panel, hold Shift while pressing the shortcut key for the property
or property group.

« To show only properties that have been modified from their default values, press UU, or choose Animation > Reveal Modified Properties.

« To show only properties that have keyframes or expressions, press U, or choose Animation > Reveal Animating Properties.
Q The U and UU commands are especially useful for learning how animation presets, template projects, or other animated items work,
because they isolate the properties that were modified by the designer of those items.

You can also filter layers in the Timeline panel to show only layers with properties that match a search string. See Search and filter in the
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Timeline, Project, and Effects & Presets panels.

Select a property or property group in the Timeline panel
% To select a property or property group—including all values, keyframes, and expressions—click the name in the layer outline in the Timeline

BsY Anchor Point
- [Z] he Position %
- T Scale

- 1 Rotation

- ) Opadity

==
Anchor Point property selected

Copy or duplicate a property or property group in the Timeline panel
« To copy properties from one layer or property group to another, select the layer, property, or property group, press Ctrl+C (Windows) or
Command+C (Mac OS), select the target layer, property, or property group, and press Ctrl+V (Windows) or Command+V (Mac OS).

« To duplicate a property group, select the property group and press Ctrl+D (Windows) or Command+D (Mac OS).
You can only duplicate some property groups, including shapes, masks, and effects. However, you can’t duplicate top-level property groups

such as Contents, Masks, Effects, and Transforms. If you attempt to duplicate a top-level property group, the entire layer is duplicated,
instead.

Copy avalue from a layer property that contains no keyframes

You can copy the current value of a layer property to another layer, even when the original layer contains no keyframes.
1. In the Timeline panel, show the layer property containing the value you want to copy.

Click the name of the layer property to select it.

Choose Edit > Copy.

Select the layer into which you want to paste the value.

ok wnDn

If the target layer contains keyframes, move the current-time indicator to the time where you want to paste the value. If the target layer does
not contain keyframes, the new value applies to the entire duration of the layer.

6. Choose Edit > Paste.

To thet
Set a property value e

If multiple layers are selected and you change a property for one layer, then the property is changed for all selected layers. Sliders, angle controls,
and some other property controls are only available in the Effect Controls panel.

Q‘ To change the units for a property, right-click (Windows) or Control-click (Mac OS) the underlined value, choose Edit Value, and choose from
the Units menu. The available units are different for different property types. You can’t change the units for some properties.
« Place the pointer over the underlined value, and drag to the left or right.

e Click the underlined value, enter a new value, and then press Enter (Windows) or Return (Mac OS).
Note: You can enter simple arithmetic expressions for property values and other number entries. For example, you can enter 2*3 instead of
6, 4/2 instead of 2, and 2e2 instead of 200. Such entries can be especially useful when incrementing a value by a specific amount from its
original value.

* Right-click (Windows) or Control-click (Mac OS) the underlined value and choose Edit Value.
« Drag the slider left or right.

« Click a point inside the angle control & or drag the angle control line.
Note: After you click inside the angle control, you can drag outside it for more precision.

« To increase or decrease the property value by 1 unit, click the underlined value and press the Up Arrow or Down Arrow key. To increase or
decrease by 10 units, hold Shift while pressing the Up Arrow or Down Arrow key. To increase or decrease by 0.1 units, hold Ctrl (Windows)
or Command (Mac OS) while pressing the Up Arrow or Down Arrow key.

» To reset properties in a property group to their default values, click Reset next to the property group name. To reset an individual property,
right-click (Windows) or Control-click (Mac OS) the property name (not the value) and choose Reset from the context menu.
If the property contains keyframes, a keyframe is added at the current time with the default value.
Q Alan Shisko provides a video tutorial on his Motion Graphics 'n Such blog shows how to use label colors and multiple selections to rapidly
change properties for multiple layers simultaneously.

Charles Bordenave (nab) provides a script on the After Effects Scripts website that sets the properties in the Transform group for selected layers to
random values within constraints that you set.
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The LockProperties script, available from the After Effects Scripts website, locks only specified properties so that you can prevent accidental
changes.

. To the to
Layer anchor points ’

Transformations, such as rotation and scale, occur around the anchor point (sometimes called transformation point or transformation center) of the
layer. By default, the anchor point # for most layer types is at the center of the layer.

Though there are times when you’ll want to animate the anchor point, it's most common to set the anchor point for a layer before you begin
animating. For example, if you're animating an image of a person made up of one layer for each body part, you'll probably want to move the
anchor point of each hand to the wrist area so that the hand rotates around that point for the whole animation.

Q The easiest way to pan and scan over a large image is to animate Anchor Point and Scale properties.

Alan Shisko provides a detailed video tutorial on his website, demonstrating how to create a complex 3D environment from 3D layers, beginning
with simple 2D assets. Manipulating layer anchor points is a crucial part of this tutorial.

dikosion | PENsion

Anchor point in center of text layer (left) compared to anchor point moved to the end of the text layer (right)

When you use the Pan Behind (Anchor Point) tool to move the anchor point in the Composition panel (left), After Effects automatically
compensates for the move so that the layer maintains its position relative to the composition frame (right).

Note: If you don't see the anchor point in the Layer panel, select Anchor Point Path from the View menu at the lower-right area of the Layer
panel.

Move alayer anchor point
« Drag the anchor point using the Selection tool in the Layer panel.
Note: Layers of some types, such as text layers and shape layers, can’t be opened in the Layer panel.
« To move a layer anchor point 1 pixel, choose Anchor Point Path from the View menu at the lower-right area of the Layer panel, and press an
arrow key. To move 10 pixels, hold Shift as you press an arrow key. Pixel measurements are at the current magnification in the Layer panel.

« To move a layer anchor point in the Composition panel without moving the layer, select the layer and use the Pan Behind tool = to drag the
anchor point.
Note: In After Effects CS6, the Pan Behind tool is called the Pan Behind (Anchor Point) tool to indicate its use for anchor point operations.
Note: Moving an anchor point with the Pan Behind (Anchor Point) tool changes Position and Anchor Point values so that the layer remains
where it was in the composition before you moved the anchor point. To change only the Anchor Point value, Alt-drag (Windows) or Option-
drag (Mac OS) with the Pan Behind (Anchor Point) tool.

Charles Bordenave (nab) provides a script on the After Effects Scripts website that moves the anchor points of selected layers without moving the
layers in the composition frame.

Reset a layer anchor point
« To reset the anchor point to its default location in the layer, double-click the Pan Behind (Anchor Point) tool %% button in the Tools panel.

« To reset the anchor point to its default location in the layer, Alt-double-click (Windows) or Option-double-click (Mac OS) the Pan Behind
(Anchor Point) tool button. The layer moves to the center of the composition

. To thet
Scale or flip a layer et

As with other transformations, scaling of a layer occurs around the anchor point of the layer. If you move the anchor point away from the center of
the layer, the layer may move when you flip it. Some layers—such as camera, light, and audio-only layers—don’t have a Scale property.
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You can scale a layer beyond the composition frame.

For information on scaling exponentially, as with a zoom lens, see Use Exponential Scale to change the speed of scaling.

For information on scaling or resizing entire movies rather than a single layer, see Scaling a movie up and Scaling a movie down.

To flip a layer is to multiply the horizontal or vertical component of its Scale property value by -1. A layer flips around its anchor point.

» To flip selected layers, choose Layer > Transform > Flip Horizontal or Layer > Transform > Flip Vertical.
« To scale a layer proportionally in the Composition panel, Shift-drag any layer handle.

» To scale a layer freely in the Composition panel, drag a corner layer handle.

« To scale one dimension only in the Composition panel, drag a side layer handle.

« To increase or decrease Scale for a selected layer by 1%, hold down Alt (Windows) or Option (Mac OS) as you press + or — on the numeric
keypad.

» To increase or decrease Scale for selected layers by 10%, hold down Alt+Shift (Windows) or Option+Shift (Mac OS) as you press + or — on
the numeric keypad.

« To scale an entire composition, choose File > Scripts > Scale Composition.jsx.
« To scale and center selected layers to fit in the composition frame, choose Layer > Transform > Fit To Comp.

« To scale and center selected layers to fit the width or height of the composition frame, while preserving the aspect ratio of the layer, choose
Layer > Transform > Fit To Comp Width, or Layer > Transform > Fit To Comp Height.

» To scale a layer proportionally in the Timeline panel, select the layer, press S to display the Scale property, click the Constrain Proportions
icon @ to the left of the Scale values, and enter a new value for the X, y, or z scale.
§ To activate the Constrain Proportions icon and match the height to the width, Alt-click (Windows) or Option-click (Mac OS) it.

« To scale to a specific set of pixel dimensions, right-click (Windows) or Control-click (Mac OS) the Scale value in the Timeline panel, choose
Edit Value, and change the units to pixels in the Scale dialog box. Select Include Pixel Aspect Ratio to see and adjust dimensions in terms of
the composition’s pixel aspect ratio.

Scaling down a raster (non-vector) layer sometimes causes a slight softening or blurring of the image. Scaling up a raster layer by a large factor
can cause the image to appear blocky or pixelated.

Q Adobe Photoshop provides fine control over resampling methods used for scaling of images. For fine control of resampling, you can export
frames to Photoshop to change the image size and then import the frames back into After Effects.

Though it's not very well suited for movies, the content-aware scaling feature in Photoshop is very useful for extending and scaling still images.
This feature can be useful when repurposing images for wide-screen formats that were created for standard-definition formats.

For a list of plug-ins that provide high-quality scaling—including some designed to create high-definition images from standard-definition sources—
go to the Toolfarm website.

For a script that scales multiple compositions simultaneously, go to the AE Enhancers forum.

Lloyd Alvarez provides a script on the After Effects Scripts website that scales selected layers to fit the composition frame, and provides options for
cropping or letterboxing.

Aharon Rabinowitz provides a video tutorial on the Creative COW website that demonstrates the uses of changing and animating a 3D layer's
Scale property, including changing only the z dimension of Scale.

Rotate a 2D layer To the top

As with other transformations, rotation of a layer occurs around the anchor point of the layer.
Q To reveal the Rotation property value for selected layers in the Timeline panel, press R.
The first part of the Rotation property value is the number of whole rotations; the second part is the fractional rotation in degrees.

For information on rotating 3D layers, see Rotate or orient a 3D layer.

« To rotate a layer by dragging in the Composition panel, drag the layer using the Rotation tool 2. To constrain rotation to 45° increments,
hold down Shift as you drag.

« To rotate selected layers by 1 degree, press plus (+) or minus (-) on the numeric keypad.
« To rotate selected layers by 10 degrees, press Shift+plus (+) or Shift+minus (-) on the numeric keypad.

. . To thet
Adjust audio volume levels e

When you use footage containing audio, the default audio level for playback is 0 dB, meaning that the level is unadjusted in After Effects. Setting a
positive decibel level increases volume, and setting a negative decibel level decreases volume.

Note: Double-clicking an Audio Levels keyframe activates the Audio panel.
The VU meter in the Audio panel displays the volume range for the audio as it plays. The red blocks at the top of the meter represent the volume
limit of your system.
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Q For more precision in setting audio levels by dragging sliders, increase the height of the Audio panel.

#* In the Audio panel, to adjust volume, do one of the following:
« To set the level of the left and right channels together, drag the center slider up or down.
« To set the level of the left channel, drag the left slider up or down, or type a new value in the levels box at the bottom of the left slider.

« To set the level of the right channel, drag the right slider up or down, or type a new value in the levels box at the bottom of the right slider.

. To the to
Parent and child layers 0
To synchronize changes to layers by assigning one layer’s transformations to another layer, use parenting. After a layer is made a parent to
another layer, the other layer is called the child layer. When you assign a parent, the transform properties of the child layer become relative to the
parent layer instead of to the composition. For example, if a parent layer moves 5 pixels to the right of its starting position, then the child layer also
moves 5 pixels to the right of its position. Parenting is similar to grouping; transformations made to the group are relative to the anchor point of the
parent.

Parenting affects all transform properties except Opacity: Position, Scale, Rotation, and (for 3D layers) Orientation.

Note: When parenting layers in After Effects CS6, helpful text describing alternate parenting behaviors is displayed on the layer bar below the
mouse position and in the Info panel.
A layer can have only one parent, but a layer can be a parent to any number of layers in the same composition.

You can animate child layers independent of their parent layers. You can also parent using null objects, which are hidden layers.

You cannot animate the act of assigning and removing the parent designation—that is, you cannot designate a layer as a parent at one point in
time and designate it as a normal layer at a different point in time.

When you create a parenting relationship, you can choose whether to have the child take on the transform property values of the parent or retain
its own. If you choose to have the child take on the transform property values of the parent, the child layer jumps to the parent’s position. If you
choose to have the child retain its own transform property values, then the child stays where it is. In both cases, subsequent changes to the
transform property values of the parent are applied to the child. Similarly, you can choose whether the child jumps when the parenting relationship
is removed.

Note: In After Effects CS6, when parenting layers, you can use the Shift key to move the child layer to the location of the parent. This can be
useful when you want to attach a layer to a null, but have the layer move to the location of the parent null (for example, attaching a 3D text layer to
a null layer created from the 3D Camera Tracker).

Dragging the pick whip in the Timeline panel to designate the planet layer as the parent to the saucer layer

Note: To show or hide the Parent column in the Timeline panel, choose Columns > Parent from the Timeline panel menu.

« To parent a layer, in the Parent column, drag the pick whip from the layer that is to be the child layer to the layer that is to be the parent
layer.

« To parent a layer, in the Parent column, click the menu of the layer that you want to be the child, and choose a parent layer name from the
menu.

« To remove a parent from a layer, in the Parent column, click the menu of the layer to remove the parent from, and choose None.

» To extend the selection to include all child layers of a selected parent layer, right-click (Windows) or Control-click (Mac OS) the layer in the
Composition or Timeline panel, and choose Select Children.

« To make a child layer jump when a parent is assigned or removed, hold down Alt (Windows) or Option (Mac OS) as you assign or remove
the parent.

« To remove a parent from a layer (that is, set Parent to None), Ctrl-click (Windows) or Command-click (Mac OS) the parenting pick whip of
the child layer in the Timeline panel. Alt+Ctrl-click (Windows) or Option+Command-click (Mac OS) the parenting pick whip of the child layer
to remove the parent and cause the child layer to jump.

Online resources about parent and child layers
Paul Tuersley provides a script on the AE Enhancers forum for duplicating a parent layer and all of its children, preserving the parenting hierarchy.

Angie Taylor provides a character animation tutorial on her Creative After Effects website that shows how to use parenting and expressions. Angie
provides a more extensive discussion and explanation of animation using parenting, expressions, and null object layers in a PDF excerpt from her
book Creative After Effects 7: Workflow Techniques for Animation, Visual Effects, and Motion Graphics.

Trish and Chris Meyer provide an introduction to parenting in a PDF excerpt from the “Parenting and Nesting” chapter of their book After Effects
Apprentice: Real-World Skills for the Aspiring Motion Graphics Artist.

Guy Chen provides a simple project on the After Effects Exchange on the Adobe website that demonstrates the animation of several 3D layers
arranged as a cube, controlled by a parent null layer.
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Carl Larsen provides a video tutorial on the Creative COW website that demonstrates how to use expressions and parenting to relate the rotation
of a set of wheels to the horizontal movement of a vehicle.

Carl Larsen provides a pair of video tutorials on the Creative COW website in which he explains the basics of parenting and then uses an
expression involving the toWorld method to trace the path of an animated child layer:

e partl
e part 2

Robert Powers provides a video tutorial on the Slippery Rock NYC website that demonstrates the use of parenting and the Puppet tools to animate
a character.

Null object layers fothetop
To assign a parent layer, but keep that layer from being a visible element in your project, use a null object. A null object is an invisible layer that
has all the properties of a visible layer so that it can be a parent to any layer in the composition. Adjust and animate a null object as you would any
other layer. You use the same commands to modify settings for a null object that you use for a solid-color layer (Layer > Solid Settings).

Q You can apply Expression Controls effects to null objects and then use the null object as a control layer for effects and animations in other
layers. For example, when working with a camera or light layer, create a null object layer and use an expression to link the Point Of Interest
property of the camera or light to the Position property of the null layer. Then, you can animate the Point Of Interest property by moving the null
object. It is often easier to select and see a null object than it is to select and see the point of interest.

A composition can contain any number of null objects. A null object is visible only in the Composition and Layer panels and appears in the
Composition panel as a rectangular outline with layer handles. Effects are not visible on null objects.

#* To create a null object, select the Timeline or Composition panel and choose Layer > New > Null Object.

Note: The anchor point of a new null object layer appears in the upper-left corner of the layer, and the layer is anchored in the center of the
composition at its anchor point. Change the anchor point as you would for any other layer.

Q If a null object is visually distracting in your composition frame, consider dragging it out of the frame, onto the pasteboard.

Andrew Kramer provides a video tutorial on his Video Copilot website that demonstrates the use of a null object to animate a 3D stroke.

Guy Chen provides a simple project on the After Effects Exchange on the Adobe website that demonstrates the animation of several 3D layers
arranged as a cube, controlled by a parent null layer.

Angie Taylor provides an extensive discussion and explanation of animation using parenting, expressions, and null object layers in a PDF excerpt
from her book Creative After Effects 7: Workflow Techniques for Animation, Visual Effects, and Motion Graphics.

. To thet
Guide layers e

You can create guide layers from existing layers to use for reference in the Composition panel, to help you position and edit elements. For
example, you can use guide layers for visual reference, for audio timing, for timecode reference, or for storing comments to yourself.
A guide layer icon ® appears next to the name of a guide layer or its source in the Timeline panel.

By default, guide layers aren’t rendered when you create output but can be rendered when desired by changing the render settings for the
composition.
Note: Guide layers in nested compositions can'’t be viewed in the containing composition.

« To convert selected layers to guide layers, choose Layer > Guide Layer.

« To render a composition with its visible guide layers, click Render Settings in the Render Queue panel, and choose Current Settings from the
Guide Layers menu in the Render Settings dialog box.

« To render a composition without rendering guide layers, click Render Settings in the Render Queue panel, and choose All Off from the Guide
Layers menu in the Render Settings dialog box.

. . . To the to
Use Brainstorm to experlment and explore settlngs .

Brainstorm creates multiple temporary variants of your composition and displays them in a grid. You can save any number of these variants, apply
one to the current composition, or redo the Brainstorm operation using only the variants that you choose as input.

Brainstorm uses genetic algorithms to mutate and select property values used as input into each Brainstorm operation. You decide which variants
to include as input to each generation and how much mutation (randomness) to use.

Aharon Rabinowitz provides a video tutorial on the Creative COW website that demonstrates the use of Brainstorm.
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F H
Brainstorm dialog box in Randomness mode
A. Original composition (original in center tile when using Brainstorm on single numeric value) B. Maximize Tile C. Save As New
Composition D. Apply To Composition E. Use In Next Brainstorm F. Randomness control (Spread control when using Brainstorm on single
numeric value) G. Back and Forward to previous and next generations H. Playback controls

With Brainstorm, you can rapidly accomplish the following:
« Compare the results of multiple values for a single property so that you can find the value that works best.
« Explore the results of randomly modifying any number of properties to achieve a creative result.

Q Open a template project or apply an animation preset to a layer, select some properties (or entire property groups), and then use Brainstorm to
quickly modify these properties. Starting from such complete material, you can use Brainstorm to very quickly create your own projects and
animations.

You can use Brainstorm on any number of properties and property groups, from one or more layers in the same composition. For example, you
can use Brainstorm to refine the single Stroke Width property for a star on a shape layer; or you can select the entire Contents property group and
use Brainstorm to explore the entire space of properties for all shapes on the layer.

You can use Brainstorm on any property that has numeric values or options in a pop-up menu in the Timeline panel. Examples of properties on
which you can’t use Brainstorm are Source Text, Mask Path, and the Histogram property for the Levels effect; however, you can use Brainstorm
on the properties of the Levels (Individual Controls) effect.

Brainstorm operates on all selected keyframes. For a property with no keyframes, Brainstorm operates on the global, constant value.

If you use Brainstorm on a single one-dimensional property (such as Opacity, but not Position), the Randomness value that controls the amount of
variation (mutation) is replaced by a Spread value. The variants that are presented in the Brainstorm dialog box are then not random, but
represent a range of values around the central value. The original composition appears in the center tile of the dialog box, and you can only select
one variant on which to base the next Brainstorm operation.

& Though you can't directly use Brainstorm on expressions, you can use Brainstorm on the properties of Expression Control effects, to which
expressions can refer.

1. Set a work area and region of interest for the duration and spatial area of the composition that you want to preview during the Brainstorm
session. (See Work area and Region of interest (ROI).)
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2. Select one or more properties or property groups in the Timeline panel, and click the Brainstorm button E at the top of the Timeline panel.

The variant compositions all play in the Brainstorm dialog box simultaneously. Controls for each variant are only visible when the pointer is
over it. Use the playback controls at the bottom of the Brainstorm dialog box to play, pause, or rewind the previews.
3. In the Brainstorm dialog box, do any of the following:

R_A b=l
=]
« To get a better look at a variant, click its Maximize Tile & % button. Click the Restore Tile Size & & button to return to the grid view of all
variants.

« To show or hide the transparency grid, click the Toggle Transparency Grid 4 putton at the bottom of the Brainstorm dialog box.
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« To mark a variant for inclusion in the next Brainstorm operation, click the Include In Next Brainstorm #* = button for that variant.

« To save a variant as a new composition in the current project, click the Save As New Composition E& button for that variant.

« To increase the randomness or spread for the next generation, adjust the Randomness or Spread value at the bottom of the Brainstorm
dialog box. Make this number small for precision work; make it larger for experimentation and exploration.

4. (Optional) To create another generation of variants from the variants marked for inclusion in the next Brainstorm operation, click Brainstorm
at the bottom of the Brainstorm dialog box and return to step 2. If you click Brainstorm without marking any variants for inclusion, the
Brainstorm operation is repeated using the same input as the current generation.

If the Brainstorm operation uses Randomness, the variants marked for input into the next generation are included unchanged into the next
generation, and remain in their positions in the dialog box. If the Brainstorm operation uses Spread, only one variant is carried into the next
generation, and it appears in the center tile.

Repeat this cycle until you have found the variant that you want to save as the current composition.

You can move back or forward a generation by clicking the arrow buttons on either side of the Brainstorm button at the bottom of the
Brainstorm dialog box. If you move back a generation and then perform another Brainstorm operation, the later generations are lost.
Note: Press Esc to close the Brainstorm dialog box.

Note: If you use the Save As New Composition feature and the current composition contains expressions that refer to itself using the
comp("<name>") format, then the saved compositions’ expressions will refer to the original composition, not each saved composition. If your
expression needs to rely on the settings in its own composition, use the thisComp object instead.

More Help topics

& Image size and resolution

-] Content-aware scaling
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Blending modes and layer styles

Work with layer blending modes
Blending mode reference

Layer styles

Exclude channels from blending

Work with layer blending modes fothetop

Blending modes for layers control how each layer blends with or interacts with layers beneath it. Blending modes for layers in After Effects
(formerly referred to as layer modes and sometimes called transfer modes) are identical to blending modes in Adobe Photoshop.

Most blending modes modify only color values of the source layer, not the alpha channel. The Alpha Add blending mode affects the alpha channel
of the source layer, and the silhouette and stencil blending modes affect the alpha channels of layers beneath them.

You can'’t directly animate blending modes by using keyframes. To change a blending mode at a certain time, split the layer at that time and apply
the new blending mode to the part of the layer that continues. You can also use the Compound Arithmetic effect, the results of which are similar to
the results of blending modes but can change over time.

Each layer has a blending mode, even if that blending mode is the default Normal blending mode.

Note: To blend colors with a gamma value of 1, choose File > Project Settings and select Blend Colors Using 1.0 Gamma. Deselect this option to
blend colors in the working color space for the project. (See Linearize working space and enable linear blending.)
Blending modes for multiple masks on a single layer are called mask modes.

Some effects include their own blending mode options. For details, see the descriptions of the individual effects.

» To cycle through blending modes for selected layers, hold down the Shift key and press - (hyphen) or = (equal sign) on the main keyboard.
Note: These shortcuts provide a convenient way to experiment with the appearance of various blending modes.

« To apply a blending mode to selected layers, choose a blending mode from the menu in the Mode column in the Timeline panel or from the
Layer > Blending Mode menu.

e To show the Modes column in the Timeline panel, choose Columns > Modes from the panel menu, or click the Expand Or Collapse The
Transfer Controls button &2 at the lower-left corner of the Timeline panel.

Trish and Chris Meyer provide tips and tricks for using blending modes to achieve a filmic look in this PDF document on the Artbeats website.

Trish and Chris Meyer explain how to use blending modes, layer styles, and the Displacement Map effect to make text blend in to appear to be
part of a surface in the PDF article “Writing on the Wall” on the Artbeats website.

. To the to
Blending mode reference ’

All blending modes described in this section are available for blending between layers. Some of these options are available for paint strokes, layer
styles, and effects.

For in-depth information about the concepts and algorithms behind these blending modes as implemented in several Adobe applications, see
section 7.2.4 of version 1.7 of the PDF reference on the Adobe website.

The blending mode menu is subdivided into eight categories based on similarities between the results of the blending modes. The category names
do not appear in the interface; the categories are simply separated by dividing lines in the menu.

Normal category Normal, Dissolve, Dancing Dissolve. The result color of a pixel is not affected by the color of the underlying pixel unless Opacity
is less than 100% for the source layer. The Dissolve blending modes turn some of the pixels of the source layer transparent.

Subtractive category Darken, Multiply, Color Burn, Classic Color Burn, Linear Burn, Darker Color. These blending modes tend to darken colors,
some by mixing colors in much the same way as mixing colored pigments in paint.

Additive category Add, Lighten, Screen, Color Dodge, Classic Color Dodge, Linear Dodge, Lighter Color. These blending modes tend to lighten
colors, some by mixing colors in much the same way as mixing projected light.

Complex category Overlay, Soft Light, Hard Light, Linear Light, Vivid Light, Pin Light, Hard Mix. These blending modes perform different
operations on the source and underlying colors depending on whether one of the colors is lighter than 50% gray.

Difference category Difference, Classic Difference, Exclusion, Subtract, Divide. These blending modes create colors based on the differences
between the values of the source color and the underlying color.

HSL category Hue, Saturation, Color, Luminosity. These blending modes transfer one or more of the components of the HSL representation of
color (hue, saturation, and luminosity) from the underlying color to the result color.

Matte category Stencil Alpha, Stencil Luma, Silhouette Alpha, Silhouette Luma. These blending modes essentially convert the source layer into a
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matte for all underlying layers.

The stencil and silhouette blending modes use either the alpha channel or luma values of a layer to affect the alpha channel of all layers beneath
the layer. Using these blending modes differs from using a track matte, which affects only one layer. Stencil modes cut through all layers, so that
you can, for example, show multiple layers through the alpha channel of the stencil layer. Silhouette modes block out all layers below the layer
with the blending mode applied, so you can cut a hole through several layers at once. To keep the silhouette and stencil blending modes from
cutting through or blocking all layers underneath, precompose the layers that you want to affect and nest them in your composition.

Stencil (left) shows all layers below the stencil layer through the frame of the alpha channel of the stencil layer; silhouette (right) cuts a hole
through all layers below the silhouette layer.

Chris and Trish Meyer explain stencil blending modes in an article on the ProVideo Coalition website.

Utility category Alpha Add, Luminescent Premul. These blending modes serve specialized utility functions.

Blending mode descriptions
In the following descriptions, these terms are used:

« The source color is the color of the layer or paint stroke to which the blending mode is applied.

« The underlying color is the color of the composited layers below the source layer or paint stroke in the layer stacking order in the Timeline
panel.

« The result color is the output of the blending operation; the color of the composite.

Note: Some color values in the following descriptions are given in terms of the 0.0-1.0 scale from black to white.

Normal The result color is the source color. This mode ignores the underlying color. Normal is the default mode.

Dissolve The result color for each pixel is either the source color or the underlying color. The probability that the result color is the source color
depends on the opacity of the source. If opacity of the source is 100%, then the result color is the source color. If opacity of the source is 0%,
then the result color is the underlying color. Dissolve and Dancing Dissolve do not work on 3D layers.

Dancing Dissolve Same as Dissolve, except that the probability function is recalculated for each frame, so the result varies over time.

Darken Each result color channel value is the lower (darker) of the source color channel value and the corresponding underlying color channel
value.

Multiply For each color channel, multiplies source color channel value with underlying color channel value and divides by maximum value for 8-
bpc, 16-bpc, or 32-bpc pixels, depending on the color depth of the project. The result color is never brighter than the original. If either input color
is black, the result color is black. If either input color is white, the result color is the other input color. This blending mode simulates drawing with
multiple marking pens on paper or placing multiple gels in front of a light. When blending with a color other than black or white, each layer or paint
stroke with this blending mode results in a darker color.

Color Burn The result color is a darkening of the source color to reflect the underlying layer color by increasing the contrast. Pure white in the
original layer does not change the underlying color.

Classic Color Burn The Color Burn mode from After Effects 5.0 and earlier, renamed Classic Color Burn. Use it to preserve compatibility with
older projects; otherwise, use Color Burn.

Linear Burn The result color is a darkening of the source color to reflect the underlying color. Pure white produces no change.

Darker Color Each result pixel is the color of darker of the source color value and the corresponding underlying color value. Darker Color is
similar to Darken, but Darker Color does not operate on individual color channels.

Add Each result color channel value is the sum of the corresponding color channel values of the source color and underlying color. The result
color is never darker than either input color.

Lighten Each result color channel value is the higher (lighter) of the source color channel value and the corresponding underlying color channel
value.

Screen Multiplies the complements of the channel values, and then takes the complement of the result. The result color is never darker than
either input color. Using the Screen mode is similar to projecting multiple photographic slides simultaneously onto a single screen.

Color Dodge The result color is a lightening of the source color to reflect the underlying layer color by decreasing the contrast. If the source color
is pure black, the result color is the underlying color.

Classic Color Dodge The Color Dodge mode from After Effects 5.0 and earlier, renamed Classic Color Dodge. Use it to preserve compatibility
with older projects; otherwise, use Color Dodge.

Linear Dodge The result color is a lightening of the source color to reflect the underlying color by increasing the brightness. If the source color is
pure black, the result color is the underlying color.

Lighter Color Each result pixel is the color of lighter of the source color value and the corresponding underlying color value. Lighter Color is
similar to Lighten, but Lighter Color does not operate on individual color channels.
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Overlay Multiplies or screens the input color channel values, depending on whether or not the underlying color is lighter than 50% gray. The

result preserves highlights and shadows in the underlying layer.

Soft Light Darkens or lightens the color channel values of the underlying layer, depending on the source color. The result is similar to shining a

diffused spotlight on the underlying layer. For each color channel value, if the source color is lighter than 50% gray, the result color is lighter than

the underlying color, as if dodged. If the source color is darker than 50% gray, the result color is darker than the underlying color, as if burned. A

layer with pure black or white becomes markedly darker or lighter, but does not become pure black or white.

Hard Light Multiplies or screens the input color channel value, depending on the original source color. The result is similar to shining a harsh

spotlight on the layer. For each color channel value, if the underlying color is lighter than 50% gray, the layer lightens as if it were screened. If the

underlying color is darker than 50% gray, the layer darkens as if it were multiplied. This mode is useful for creating the appearance of shadows on

a layer.

Linear Light Burns or dodges the colors by decreasing or increasing the brightness, depending on the underlying color. If the underlying color is

lighter than 50% gray, the layer is lightened because the brightness is increased. If the underlying color is darker than 50% gray, the layer is

darkened because the brightness is decreased.

Vivid Light Burns or dodges the colors by increasing or decreasing the contrast, depending on the underlying color. If the underlying color is

lighter than 50% gray, the layer is lightened because the contrast is decreased. If the underlying color is darker than 50% gray, the layer is

darkened because the contrast is increased.

Pin Light Replaces the colors, depending on the underlying color. If the underlying color is lighter than 50% gray, pixels darker than the

underlying color are replaced, and pixels lighter than the underlying color do not change. If the underlying color is darker than 50% gray, pixels

lighter than the underlying color are replaced, and pixels darker than the underlying color do not change.

Hard Mix Enhances the contrast of the underlying layer that is visible beneath a mask on the source layer. The mask size determines the

contrasted area; the inverted source layer determines the center of the contrasted area.

Difference For each color channel, subtracts the darker of the input values from the lighter. Painting with white inverts the backdrop color; painting

with black produces no change.

Q If you have two layers with an identical visual element that you want to align, place one layer on top of the other and set the blending mode of
the top layer to Difference. Then, you can move one layer or the other until the pixels of the visual element that you want to line up are all black
—meaning that the differences between the pixels are zero and therefore the elements are stacked exactly on top of one another.

Classic Difference The Difference mode from After Effects 5.0 and earlier, renamed Classic Difference. Use it to preserve compatibility with older
projects; otherwise, use Difference.

Exclusion Creates a result similar to but lower in contrast than the Difference mode. If the source color is white, the result color is the
complement of the underlying color. If the source color is black, the result color is the underlying color.

Subtract Subtracts the source color from the underlying color. If the source color is black, the result color is the underlying color. Result color
values can be less than 0 in 32-bpc projects.

Divide Divides underlying color by source color. If the source color is white, the result color is the underlying color. Result color values can be
greater than 1.0 in 32-bpc projects.

Hue Result color has luminosity and saturation of the underlying color, and the hue of the source color.

Saturation Result color has luminosity and hue of the underlying color, and the saturation of the source color.

Color Result color has luminosity of the underlying color, and hue and saturation of the source color. This blending mode preserves the gray
levels in the underlying color. This blending mode is useful for coloring grayscale images and for tinting color images.

Luminosity Result color has hue and saturation of the underlying color, and luminosity of the source color. This mode is the opposite of the Color
mode.

Stencil Alpha Creates a stencil using the alpha channel of the layer.

Stencil Luma Creates a stencil using the luma values of the layer. The lighter pixels of the layer are more opaque than the darker pixels.
Silhouette Alpha Creates a silhouette using the alpha channel of the layer.

Silhouette Luma Creates a silhouette using the luma values of the layer. Creates transparency in painted areas of the layer, allowing you to see
underlying layers or background. The luminance value of the blend color determines opacity in the result color. The lighter pixels of the source
cause more transparency than the darker pixels. Painting with pure white creates 0% opacity. Painting with pure black produces no change.
Alpha Add Composites layers normally, but adds complementary alpha channels to create a seamless area of transparency. Useful for removing
visible edges from two alpha channels that are inverted relative to each other or from the alpha channel edges of two touching layers that are
being animated.

Note: Sometimes, when layers are aligned edge-to-edge, seams can appear between the layers. This is especially an issue with 3D layers that
are joined to one another at the edges to build a 3D object. When the edges of a layer are anti-aliased, there's some partial transparency at the
edges. When two areas of 50% transparency overlap, the result is not 100% opacity but 75% opacity, because the default operation is
multiplication. (50% of the light gets through one layer, and then 50% of the remainder gets through the next layer, so 25% gets through the
system.) This is like partial transparency in the real world. But, in some cases, you don't want this default blending. You want the two 50% opacity
areas to combine to make a seamless, opaque join. You want the alpha values to be added. In these cases, use the Alpha Add blending mode.
Luminescent Premul Prevents clipping of color values that exceed the alpha channel value after compositing by adding them to the composition.
Useful for compositing rendered lens or light effects (such as lens flare) from footage with premultiplied alpha channels. May also improve results
when compositing footage from matting software from other manufacturers. When applying this mode, you may get the best results by changing
interpretation of the premultiplied-alpha source footage to straight alpha.

To thet
Layer styles e

Photoshop provides a variety of layer styles—such as shadows, glows, and bevels—that change the appearance of a layer. After Effects can
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preserve these layer styles when importing Photoshop layers. You can also apply layer styles in After Effects and animate their properties.

Q You can copy and paste any layer style within After Effects, including layer styles imported into After Effects in PSD files. Richard Harrington
provides a video tutorial on the Creative COW website that shows how to bring a library of layer styles from Photoshop into After Effects so that
you can use, modify, copy, and paste the custom layer styles in After Effects.

In addition to the layer styles that add visual elements—Ilike a drop shadow or a color overlay—each layer’'s Layer Styles property group contains
a Blending Options property group. You can use the Blending Options settings for powerful and flexible control over blending operations.

Though layer styles are referred to as effects in Photoshop, they behave more like blending modes in After Effects. Layer styles follow
transformations in the standard render order, whereas effects precede transformations. Another difference is that each layer style blends directly
with the underlying layers in the composition, whereas an effect is rendered on the layer to which it's applied, the result of which then interacts with
the underlying layers as a whole.

When you import a Photoshop file that includes layers as a composition, you can retain editable layer styles or merge layer styles into footage.
When you import only one layer that includes layer styles, you can choose to ignore the layer styles or merge layer styles into footage. At any
time, you can convert merged layer styles into editable layer styles for each After Effects layer based on a Photoshop footage item.

After Effects can preserve all layer styles in imported Photoshop files, but you can only add and modify some layer styles and controls within After
Effects.

Note: For details about each layer style and its properties, see Photoshop Help.

Layer styles that you can apply and edit in After Effects

Drop Shadow Adds a shadow that falls behind the layer.

Inner Shadow Adds a shadow that falls inside the contents of the layer, giving the layer a recessed appearance.

Outer Glow Adds a glow that emanates outward from the contents of the layer.

Inner Glow Adds a glow that emanates inward from the contents of the layer.

Bevel And Emboss Adds various combinations of highlights and shadows.

Q Use the Bevel And Emboss layer style rather than the Bevel Alpha effect if, for example, you want to apply different blending modes to the
highlights and shadows of a bevel.

Satin Applies interior shading that creates a satiny finish.

Color Overlay Fills the contents of the layer with a color.

Gradient Overlay Fills the contents of the layer with a gradient.

Stroke Outlines the contents of the layer.

Add, remove, and convert layer styles
» To convert merged layer styles into editable layer styles, select one or more layers and choose Layer > Layer Styles > Convert To Editable
Styles.
« To add a layer style to selected layers, choose Layer > Layer Styles, and choose a layer style from the menu.
« To remove a layer style, select it in the Timeline panel and press Delete.
« To remove all layer styles from selected layers, choose Layer > Layer Styles > Remove All.

When a layer style is applied to a vector layer—such as a text layer, a shape layer, or a layer based on an lllustrator footage item—uvisual
elements that apply to the edges of the contents of the layer apply to the outlines of the vector objects, such as text characters or shapes. When a
layer style is applied to a layer based on a non-vector footage item, the layer style applies to the edges of the layer's bounds or masks.

You can apply a layer style to a 3D layer, but a layer with a layer style can't intersect with other 3D layers or interact with other 3D layers for
casting and receiving shadows. 3D layers on either side of a layer with a layer style can’t intersect one another or cast shadows on one another.

When you use the Layer > Convert To Editable Text command on a text layer from a Photoshop file, any layer styles on that layer are also
converted to editable layer styles.

Layer style settings
Each layer style has its own collection of properties in the Timeline panel.

Align With Layer Uses the bounding box of the layer to calculate the gradient fill.

Altitude For the Bevel And Emboss layer style, the elevation of the light source above the layer, in degrees.

Choke Shrinks the boundaries of the matte of an Inner Shadow or Inner Glow before blurring.

Distance The offset distance for a Shadow or Satin layer style

Highlight Mode, Shadow Mode Specifies the blending mode of a bevel or emboss highlight or shadow.

Jitter Varies the application of the colors and opacity of a gradient, which reduces banding.

Layer Knocks Out Drop Shadow Controls the visibility of a drop shadow in a semitransparent layer.

Reverse Flips the orientation of a gradient.

Scale Resizes the gradient.

Spread Expands the boundaries of the matte before blurring.

Use Global Light Set this option to On to use the Global Light Angle and Global Light Altitude in the Blending Options property group instead of
the Angle and Altitude settings for each individual layer style. This option is useful if you have multiple layer styles applied to the same layer and
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want to animate the position of the light for all of them.

Blending options for layer styles

Each layer style has its own blending mode, which determines how it interacts with underlying layers. The underlying layer in this context may or
may not include the layer to which the layer style is applied. For example, a drop shadow does not blend with the layer to which it's applied,
because the shadow falls behind the layer; whereas an inner shadow does blend with the layer to which it's applied.

Layer styles can be categorized as interior layer styles or exterior layer styles. Interior layer styles affect the opaque pixels of the layer to which
they're applied. Interior layer styles include Inner Glow, Inner Shadow, Color Overlay, Gradient Overlay, Satin, and Bevel And Emboss. Exterior
layer styles do not blend with the pixels of the layer to which they're applied, but only interact with the underlying layers. Exterior layer styles
include Outer Glow and Drop Shadow.

If Blend Interior Styles As Group is set to On, interior layer styles use the blending mode of the layer.

If you modify the Opacity property of a layer, the opacity of the contents of the layer and the opacity of the layer styles are all affected. If, however,
you modify the Fill Opacity property in the Blending Options property group, the opacity of the layer styles is unaffected. For example, if a text layer
has the Drop Shadow layer style applied, decreasing the Fill Opacity to O makes the text disappear, but the drop shadow remains visible.

Use the Blend Ranges From Source option to use the advanced blending options set for the Photoshop file that determine what blending
operations to perform based on the color characteristics of the input layer.

Online resources about layer styles
Dave Scotland provides a video tutorial on the CG Swot website that demonstrates how to create a metallic textured logo using layer styles in After
Effects.

. To thet
Exclude channels from blending e

You can exclude one or more of the color channels of a layer from blending operations.

Q The Blending Options property group is only included for a layer if the layer has had a layer style added to it. To add a Blending Options
property group without a layer style, add an arbitrary layer style and then immediately delete it; the Blending Options property group and its
containing Layer Styles property group remain.

1. Expand the Blending Options property group for the layer in the Layer Styles property group in the Timeline panel.
2. To exclude a channel from blending, set Red, Green, or Blue to Off in the Advanced Blending property group.

You can animate these properties, so you can exclude a channel from blending at some times but include the channel at other times.

More Help topics
& Layer effects and styles
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3D layers

3D layers overview and resources

Convert 3D layers

Show or hide 3D axes and layer controls

Move a 3D layer

Rotate or orient a 3D layer

Axis modes

3D layer interactions, render order, and collapsed transformations
3D object layers from Photoshop (CS5.5, and earlier)

. To the to
3D layers overview and resources ’

The basic objects that you manipulate in After Effects are flat, two-dimensional (2D) layers. When you make a layer a 3D layer, the layer itself
remains flat, but it gains additional properties: Position (z), Anchor Point (z), Scale (z), Orientation, X Rotation, Y Rotation, Z Rotation, and Material
Options properties. Material Options properties specify how the layer interacts with light and shadows. Only 3D layers interact with shadows, lights,
and cameras.

2D layers Eleft) and layers with 3D properties (right)

Any layer can be a 3D layer, except an audio-only layer. Individual characters within text layers can optionally be 3D sublayers, each with their
own 3D properties. A text layer with Enable Per-character 3D selected behaves just like a precomposition that consists of a 3D layer for each
character. All camera and light layers have 3D properties.

By default, layers are at a depth (z-axis position) of 0. In After Effects, the origin of the coordinate system is at the upper-left corner; x (width)
increases from left to right, y (height) increases from top to bottom, and z (depth) increases from near to far. Some video and 3D applications use a
coordinate system that is rotated 180 degrees around the x axis; in these systems, y increases from bottom to top, and z increases from far to
near.

You can transform a 3D layer relative to the coordinate space of the composition, the coordinate space of the layer, or a custom space by
selecting an axis mode.

You can add effects and masks to 3D layers, composite 3D layers with 2D layers, and create and animate camera and light layers to view or
illuminate 3D layers from any angle. When rendering for final output, 3D layers are rendered from the perspective of the active camera. (See
Create a camera layer and change camera settings.)

All effects are 2D, including effects that simulate 3D distortions. For example, viewing a layer with the Bulge effect from the side does not show a
protrusion.

As with all masks, mask coordinates on a 3D layer are in the 2D coordinate space of the layer.

Note: After Effects 7.0 and earlier included a Standard 3D rendering plug-in; this plug-in is not included with After Effects CS3 or later. In After
Effects 6.0 and later, the default plug-in for rendering 3D layers has been the Advanced 3D rendering plug-in. When you open a project that was
created with the Standard 3D rendering plug-in, the project is converted to use the Advanced 3D rendering plug-in. As third-party plug-ins become
available, you can choose them from the Advanced section of the Composition Settings dialog box.

Online resources for 3D layers
Alan Shisko provides a detailed video tutorial on his website, demonstrating how to create a complex 3D environment from 3D layers, beginning
with simple 2D assets.

Chris and Trish Meyer provide an overview of the various kinds of 3D layers and 3D objects that you can work with in After Effects in a PDF
excerpt from their book Creating Motion Graphics with After Effects (5th edition) on their website.

Trish and Chris Meyer provide a tutorial for using 3D layers, lights, and cameras in a PDF excerpt from their book After Effects Apprentice on the
Focal Press website.

Chris and Trish Meyer provide a tutorial on the Artbeats website that demonstrates how to create 3D reflections.
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Chris and Trish Meyer provide a demonstration of importing and using extruded 3D objects from Photoshop, including those created using the
Repoussé feature in Photoshop. See “Repoussé in After Effects CS5” on the Lynda.com website. (See 3D object layers from Photoshop.)

Paul Tuersley provides a pair of scripts on the AE Enhancers forum for converting a composition based on a layered Photoshop file into a set of 3D
layers.

Andrew Kramer provides a video tutorial on his Video Copilot website in which he demonstrates the creation of 3D reflections.

Andrew Kramer provides a video tutorial on his Video Copilot website in which he demonstrates the creation of a 3D room and the use of an
animated camera and lights.

You can download an example project from the AE Enhancers forum that shows how to arrange several 3D layers in the shape of a sphere,
control the layers with a null layer, and light them.

Several plug-ins add the ability to manipulate, warp, and extrude 3D shapes in After Effects. Rich Young provides information about Zaxwerks 3D
Warps and Zaxwerks Invigorator PRO, two such products on his AE Portal blog.

Rob Schofield provides a custom effect (a multi-part, packaged animation preset) on the AETUTS+ website that distributes and animates 3D
layers. This custom effect works especially well for animations that involve a large number of 3D layers dispersing or converging. In the video
tutorial accompanying the custom effect, Rob explains the installation of custom effects.

To the to
Convert 3D layers .

When you convert a layer to 3D, a depth (z) value is added to its Position, Anchor Point, and Scale properties, and the layer gains Orientation, Y
Rotation, X Rotation, and Material Options properties. The single Rotation property is renamed Z Rotation.

When you convert a 3D layer back to 2D, the Y Rotation, X Rotation, Orientation, and Material Options properties are removed, including all
values, keyframes, and expressions. (These values cannot be restored by converting the layer back to a 3D layer.) The Anchor Point, Position,
and Scale properties remain, along with their keyframes and expressions, but their z values are hidden and ignored.

Convert a layer to a 3D layer
- Select the 3D Layer switch @ for the layer in the Timeline panel, or select the layer and choose Layer > 3D Layer.

Convert atext layer to a 3D layer with per-character 3D properties enabled
e Choose Animation > Animate Text > Enable Per-Character 3D, or choose Enable Per-Character 3D from the Animate menu for the layer in
the Timeline panel.

Convert a 3D layer to a 2D layer
» Deselect the 3D Layer switch for the layer in the Timeline panel, or select the layer and choose Layer > 3D Layer.

. To the t
Show or hide 3D axes and layer controls o

3D axes are color-coded arrows: red for x, green for y, and blue for z.
« To show or hide 3D axes, camera and light wireframe icons, layer handles, and the point of interest, choose View > Show Layer Controls.

Q If the axis that you want to manipulate is difficult to see, try a different setting in the Select View Layout menu at the bottom of the Composition
panel.

« To show or hide a set of persistent 3D reference axes, click the Grid And Guides Options button 3 4t the bottom of the Composition panel,
and choose 3D Reference Axes.

Chris and Trish Meyer provide a video tutorial on the ProVideo Coalition website that demonstrates the use of the 3D axis layer controls.

To the to
Move a 3D layer ’

1. Select the 3D layer that you want to move.
2. Do one of the following:

« In the Composition panel, use the Selection tool X to drag the arrowhead of the 3D axis layer control corresponding to the axis along
which you want to move the layer. Shift-drag to move the layer more quickly.

« In the Timeline panel, modify the Position property values.

@ Press P to show Position.

« To move selected layers so that their anchor points are at the center in the current view, choose Layer > Transform > Center In View or
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press Ctrl+Home (Windows) or Command+Home (Mac OS).

Chris and Trish Meyer provide a video tutorial on the ProVideo Coalition website that demonstrates the use of the 3D axis layer controls.

. To thet
Rotate or orient a 3D layer e

You can turn a 3D layer by changing its Orientation or Rotation values. In both cases, the layer turns around its anchor point. The Orientation and
Rotation properties differ in how the layer moves when you animate them.

When you animate the Orientation property of a 3D layer, the layer turns as directly as possible to reach the specified orientation. When you
animate any of the X, Y, or Z Rotation properties, the layer rotates along each individual axis according to the individual property values. In other
words, Orientation values specify an angular destination, whereas Rotation values specify an angular route. Animate Rotation properties to make a
layer turn multiple times.

Animating the Orientation property is often better for natural, smooth motion, whereas animating the Rotation properties provides more precise
control.

Rotate or orient a 3D layer in the Composition panel
1. Select the 3D layer that you want to turn.

2. Select the Rotation tool “ and choose Orientation or Rotation from the Set menu to determine whether the tool affects Orientation or
Rotation properties.

3. In the Composition panel, do one of the following:
« Drag the arrowhead of the 3D axis layer control corresponding to the axis around which you want to turn the layer.

« Drag a layer handle. Dragging a corner handle turns the layer around the z axis; dragging a left or right center handle turns the layer
around the y axis; dragging a top or bottom handle turns the layer around the x axis.

« Drag the layer.

Q Shift-drag to constrain your manipulations to 45-degree increments.

Rotate or orient a 3D layer in the Timeline panel
1. Select the 3D layer that you want to turn.
2. In the Timeline panel, modify the Rotation or Orientation property values.

Q Press R to show Rotation and Orientation properties.

Online resources about rotating and orienting 3D layers
Donat Van Bellinghen provides some expressions on the AE Enhancers forum for placing and orienting a 3D layer in the plane defined by three
points.

Chris and Trish Meyer provide a video tutorial on the ProVideo Coalition website that demonstrates the use of the 3D axis layer controls.

. To theto
AXis modes ’

Axis modes specify on which set of axes a 3D layer is transformed. Choose a mode in the Tools panel.
Local Axis mode ¥ Aligns the axes to the surface of a 3D layer.

World Axis mode @ Aligns the axes to the absolute coordinates of the composition. Regardless of the rotations you perform on a layer, the axes
always represent 3D space relative to the 3D world.

View Axis mode ™ Aligns the axes to the view you have selected. For example, suppose that a layer has been rotated and the view changed to
a custom view; any subsequent transformation made to that layer while in View Axis mode happens along the axes corresponding to the direction
from which you are looking at the layer.

Differences between the axis modes are only relevant when you have a 3D camera in a composition.

Note: The Camera tools always adjust along the local axes of the view, so the action of the Camera tools is not affected by the axis modes.

Angie Taylor explains 3D axis modes in this tutorial.

. . . To thet
3D layer interactions, render order, and collapsed transformations ometep
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The positions of certain kinds of layers in the layer stacking order in the Timeline panel prevent groups of 3D layers from being processed together
to determine intersections and shadows.

A shadow cast by a 3D layer does not affect a 2D layer or any layer that is on the other side of the 2D layer in the layer stacking order. Similarly, a
3D layer does not intersect with a 2D layer or any layer that is on the other side of the 2D layer in the layer stacking order. No such restriction
exists for lights.

! i / .
1l 3 o ¥ F [ ] »

3D layers intersecting (Ie), and 3D layers prevented from intersecting by intervening 2D layer (right)

Just like 2D layers, other types of layers also prevent 3D layers on either side from intersecting or casting shadows on one another:

« An adjustment layer

« A 3D layer with a layer style applied

« A 3D precomposition layer to which an effect, closed mask (with mask mode other than None), or track matte has been applied
« A 3D precomposition layer without collapsed transformations

A precomposition with collapsed transformations (Collapse Transformations switch # selected) does not interfere with the interaction of 3D layers
on either side—as long as all of the layers in the precomposition are themselves 3D layers. Collapsing transformations exposes the 3D properties
of the layers that compose the precomposition. Essentially, collapsing transformations in this case allows each 3D layer to be composited into the
main composition individually, rather than creating a single 2D composite for the precomposition layer and compositing that into the main
composition. The tradeoff is that this setting removes your ability to specify certain layer settings for the precomposition as a whole—such as
blending mode, quality, and motion blur.

Shadows cast by continuously rasterized 3D layers (including text layers) are not affected by effects applied to that layer. If you want the shadow
to show the results of the effect, then precompose the layer with the effect.

Q To ensure that the shadow remains where expected on a 3D layer with a track matte, precompose the 3D layer and the track matte layer
together (but don't collapse transformations), and then apply the shadow to the precomposition.

Effects on continuously rasterized vector layers with 3D properties are rendered in 2D and then projected onto the 3D layer. OpenGL rendering
does not support this kind of projection, so results may differ when rendering using OpenGL. This projection does not occur for compositions with
collapsed transformations.

To the top

3D object layers from Photoshop (CS5.5, and earlier)

Note: Live Photoshop 3D support has been removed in After Effects CS6. The Convert to Live Photoshop 3D command in the Layer menu and
layer context menu has also been removed. Existing projects that were converted appears with a missing effect.

For a video tutorial about using 3D object layers from Photoshop in After Effects, go to the Adobe website.

Chris and Trish Meyer provide a demonstration of importing and using extruded 3D objects from Photoshop, including those created using the
Repoussé feature in Photoshop. See “Repousseé in After Effects CS5” on the Lynda.com website.

Adobe Photoshop Extended can import and manipulate 3D models (3D objects) in several popular formats, including the following:

« .3ds (3ds Max)
« .dae (Digital Asset Exchange, COLLADA)
« .kmz (compressed Keyhole Markup Language format, Google Earth)
e .0bj (common 3D object format)
e .u3d (Universal 3D)
Photoshop can also create 3D objects in basic, primitive shapes.

Photoshop places each 3D object on a separate layer. Within Photoshop, you can use the 3D tools to transform (move and scale) a 3D model,
change the lighting, change camera angles and positions, and change render modes—for example, from solid to wireframe mode. You can also
use Photoshop to modify, paint on, and replace textures for a 3D object.
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You can bring these 3D object layers in PSD files from Photoshop into After Effects for compositing and animation.

When you import a PSD file into After Effects as a composition and that PSD file contains a 3D object layer, you can choose to make the layer a
live Photoshop 3D layer. If you don't choose the Live Photoshop 3D option when you import the file, you can convert the layer to a live Photoshop
3D layer in After Effects by choosing Layer > Convert To Live Photoshop 3D. When a layer is a live Photoshop 3D layer, it contains an instance of
the Live Photoshop 3D effect. The Live Photoshop 3D effect on a layer renders the 3D object according to the active camera in the After Effects
composition. The Live Photoshop 3D effect works like other effects with a Comp Camera attribute. (See Effects with a Comp Camera attribute.)

When a live Photoshop 3D layer is imported, After Effects creates a camera that matches the camera used in Photoshop. The camera created in
After Effects is not animated, even if the camera for the 3D object in Photoshop is animated.

A 3D object and its camera may be animated within Photoshop. To make After Effects use the animation of the 3D object or camera from the PSD
file, choose Use Photoshop Transform or Use Photoshop Camera in the effect properties in the Effect Controls panel for the Live Photoshop 3D
effect for the layer. In general, you can create animations and camera moves with more flexibility and convenience within After Effects.

The live Photoshop 3D layer in After Effects contains several expressions, which are used to attach it to a null layer. Use the null layer to
manipulate the live Photoshop 3D layer, rather than directly manipulating the live Photoshop 3D layer’s Transform properties.

Q‘ To move selected layers so that their anchor points are at the center in the current view, choose Layer > Transform > Center In View or press
Ctrl+Home (Windows) or Command+Home (Mac OS). This command is especially useful for bringing a 3D object layer into the appropriate part
of a scene.

Q To reduce the amount of time that the 3D object requires to render for previews, change the layer's image quality setting to Draft. With this
setting, the Photoshop rendering engine built into After Effects creates a more simple rendered image from the 3D model. (See Layer switches
and columns in the Timeline panel.)

To paint on the textures of the 3D object, modify its material options, change its lighting, or otherwise edit the 3D object itself, you must return to
Photoshop. The most convenient way to edit the original PSD file is by opening it in Photoshop with the Edit Original command in After Effects.
(See Edit footage in its original application.)

Note: To edit the 3D model itself, you must use a 3D authoring program, not Photoshop or After Effects.

Lutz Albrecht provides tips on his blog for working with 3D object layers in Photoshop.

e Per-character 3D text properties

e Importing and using 3D files from other applications

e 3D layers (keyboard shortcuts)

e Cameras, lights, and points of interest

e Layer 3D attributes and methods

e Layer switches and columns in the Timeline panel

e Show or hide layer controls in the Composition panel

e Selecting and arranging layers

e Layer properties

¢ Coordinate systems: composition space and layer space
e Render order and collapsing transformations

e Precompose layers

o Continuously rasterize a layer containing vector graphics
e Preparing and importing Photoshop files

o Effects with a Comp Camera attribute

¢ 3D layers

e 3D
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Cameras, lights, and points of interest

Create a camera layer and change camera settings

Create a light and change light settings

Adjust a 3D view or move a camera, light, or point of interest
Material Options properties

Specify resolution to use for rendering shadows
Stereoscopic 3D

. To the to
Create a camera layer and change camera settings .
You can view 3D layers from any angle and distance using camera layers. Just as it's easier in the real world to move cameras through and
around a scene than it is to move and rotate the scene itself, it's often easiest to get different views of a composition by setting up a camera layer
and moving it around in a composition.

You can modify and animate camera settings to configure the camera to match the real camera and settings that were used to record footage with
which you’re compositing. You can also use camera settings to add camera-like behaviors—from depth-of-field blur to pans and dolly shots—to
synthetic effects and animations.

Cameras affect only 3D layers and 2D layers with an effect with a Comp Camera attribute. With effects that have a Comp Camera attribute, you
can use the active composition camera or lights to view or light an effect from various angles to simulate more sophisticated 3D effects. After
Effects can interact with Photoshop 3D layers by means of the Live Photoshop 3D effect, which is a special example of a Comp Camera effect.

Note: After Effects CS6 no longer supports the Live Photoshop 3D effect.

You can choose to view a composition through the active camera or through a named custom camera. The active camera is the topmost camera
in the Timeline panel at the current time for which the Video switch # is selected. The active camera view is the point of view used for creating
final output and nesting compositions. If you have not created a custom camera, then the active camera is the same as the default composition
view.

All cameras are listed in the 3D View menu at the bottom of the Composition panel, where you can access them at any time.

It's often easiest to adjust a camera when using one of the custom 3D views. You can’'t—of course—see the camera to manipulate it when you're
looking through the camera itself.

Example of a camera
A. Point of interest B. Frame C. Camera

Note: If you import or open an After Effects 5.x project containing a 3D composition that used a default camera, After Effects adds an AE 5.x
Default Camera to the composition.

Create a camera layer

% Choose Layer > New > Camera, or press Ctrl+Alt+Shift+C (Windows) or Command+Option+Shift+C (Mac OS).

Note: By default, new layers begin at the beginning of the composition duration. You can instead choose to have new layers begin at the current
time by deselecting the Create Layers At Composition Start Time preference (Edit > Preferences > General (Windows) or After Effects >
Preferences > General (Mac OS)).
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Change camera settings
You can change camera settings at any time.

#* Double-click the camera layer in the Timeline panel, or select the layer and then choose Layer > Camera Settings.
Note: By default, the Preview option in the Camera Settings dialog box is selected. This option shows the changes in the composition as you
make them in the Camera Settings dialog box.

Camera settings

You can change camera settings at any time by double-clicking the layer in the Timeline panel or selecting the layer and choosing Layer >
Camera Settings.

Q Select Preview in the Camera Settings dialog box to show results in the Composition panel as you modify settings in the dialog box.

Note: The three things that affect depth of field are focal length, aperture, and focus distance. Shallow (small) depth of field is a result of long
focal length, short focus distance, and a larger aperture (smaller F-stop). A shallower depth of field means a larger depth-of-field blur result. The
opposite of a shallow depth of field is deep focus—meaning a smaller depth-of-field blur because more is in focus.

Camera properties relating to camera lens blur and a shape are only available in After Effects CS5.5 and later. These properties include Iris
Shape, Iris Rotation, Iris Roundness, Iris Aspect Ratio, Iris Diffraction Fringe, Highlight Gain, Highlight Threshold, and Highlight Saturation. (see
Camera Lens Blur effect (CS5.5).)

Type One-Node Camera or Two-Node Camera. A one-node camera orients around itself, whereas a two-node camera has a point of interest and

orients around that point. Making a camera a two-node camera is the same as setting a camera’s auto-orientation option (Layer > Transform >

Auto-Orient) to Orient Towards Point Of Interest. (See Auto-Orientation options.)

Name The name of the camera. By default, Camera 1 is the name of first camera that you create in a composition, and all subsequent cameras

are numbered in ascending order. You should choose distinctive names for multiple cameras to make it easier to distinguish them.

Preset The type of camera settings you want to use. The presets are named according to focal lengths. Each preset is meant to represent the

behavior of a 35mm camera with a lens of a certain focal length. Therefore, the preset also sets the Angle Of View, Zoom, Focus Distance, Focal

Length, and Aperture values. The default preset is 50mm. You can also create a custom camera by specifying new values for any of the settings.

Zoom The distance from the lens to the image plane. In other words, a layer that is the Zoom distance away appears at its full size, a layer that is

twice the Zoom distance away appears half as tall and wide, and so on.

Angle Of View The width of the scene captured in the image. The Focal Length, Film Size, and Zoom values determine the angle of view. A wider

angle of view creates the same result as a wide-angle lens.

Depth Of Field Applies custom variables to the Focus Distance, Aperture, F-Stop, and Blur Level settings. Using these variables, you can

manipulate the depth of field to create more realistic camera-focusing effects. (The depth of field is the distance range within which the image is in

focus. Images outside the distance range are blurred.)

Focus Distance The distance from the camera to the plane that is in perfect focus.

Q Add this expression to the Focus Distance property to lock the focal plane to the camera's point of interest so that the point of interest is in
focus: length(position, pointOfinterest)

Lock To Zoom Makes the Focus Distance value match the Zoom value.

Note: If you change the settings of the Zoom or Focus Distance options in the Timeline panel, the Focus Distance value becomes unlocked from
the Zoom value. If you need to change the values and want the values to remain locked, then use the Camera Settings dialog box instead of the
Timeline panel. Alternatively, you can add an expression to the Focus Distance property in the Timeline panel: Select the Focus Distance property,
and choose Animation > Add Expression; then drag the expression pick whip to the Zoom property. (See Expression basics.)

Aperture The size of the lens opening. The Aperture setting also affects the depth of field—increasing the aperture increases the depth of field
blur. When you modify Aperture, the values for F-Stop change to match it.

Note: In areal camera, increasing the aperture also allows in more light, which affects exposure. Like most 3D compositing and animation
applications, After Effects ignores this result of the change in aperture values.

F-Stop Represents the ratio of the focal length to aperture. Most cameras specify aperture size using the f-stop measurement; thus, many
photographers prefer to set the aperture size in f-stop units. When you modify F-Stop, Aperture changes to match it.

Blur Level The amount of depth-of-field blur in an image. A setting of 100% creates a natural blur as dictated by the camera settings. Lower
values reduce the blur.

Film Size The size of the exposed area of film, which is directly related to the composition size. When you modify Film Size, the Zoom value
changes to match the perspective of a real camera.

Focal Length The distance from the film plane to the camera lens. In After Effects, the position of the camera represents the center of the lens.
When you modify Focal Length, the Zoom value changes to match the perspective of a real camera. In addition, the Preset, Angle Of View, and
Aperture values change accordingly.

Units The units of measurement in which the camera setting values are expressed.

Measure Film Size The dimensions used to depict the film size.

Note: For best results, work in 32-bpc with Linearize Working Space selected in the project settings. (see Camera Lens Blur effect (CS5.5).)

Camera Commands (CS5.5)

After Effects CS5.5 and later has camera commands that can be used separately or with the Create Stereo 3D Rig function. To use the camera
commands, select a camera layer, and then choose Layer > Camera.

Link Focus Distance to Point of Interest Creates an expression on the selected camera layer's Focus Distance property, setting the property’s
value to the distance between the camera and its point of interest.

Link Focus Distance to Layer Creates an expression on the selected camera layer's Focus Distance property to be the distance between the
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camera’s position and another layer. This method allows the focus to follow the other layer automatically.
Set Focus Distance to Layer Sets the value of the Focus Distance property at the current time to the distance at the current time between the
camera and the selected layer.

Online resources about cameras
For a video tutorial that shows how to create and modify a camera and use the Camera tools, see the Adobe website.

Dale Bradshaw provides a script and sample project for automating the rigging of a camera on the Creative Workflow Hacks website.

Mark Christiansen provides tips and detailed techniques for working with cameras in the “Virtual Cinematography in After Effects” chapter of After
Effects Studio Techniques on the Peachpit Press website. This chapter includes information about matching lens distortion, performing camera
moves, performing camera projection (camera mapping), using rack focus, creating boke blur, using grain, and choosing a frame rate to match
your story-telling.

Trish and Chris Meyer provide a tutorial for using 3D layers, lights, and cameras in a PDF excerpt from their book After Effects Apprentice on the
Focal Press website.

Richard Harrington provides a video tutorial on the Creative COW website that shows how to use the Camera tools and camera views in After
Effects to create a camera move with 3D layers. (This tutorial is the second in a two-part series. Part 1 concentrates on working with photographs
to isolate and create sky in Photoshop for use in After Effects.)

Andrew Kramer provides a two-part video tutorial on his Video Copilot website that demonstrates basic camera mapping and camera projection. In
this tutorial, he shows how to project an image onto 3D layers using lights and light transmission properties.

e partl
e part 2

Create a light and change light settings fothetop

A light layer can affect the colors of the 3D layers that it shines on, depending on the light's settings and the Material Options properties of the 3D
layers. Each light, by default, points to its point of interest.

Lights can be used to illuminate 3D layers and to cast shadows. You can use lights to match lighting conditions of the scene into which you are
compositing or to create more interesting visual results. For example, you can use light layers to create the appearance of light streaming through a
video layer as if it were made of stained glass.

You can animate all of the settings for a light, except for the light type and the Casts Shadows property.

Light types: Spot (upper-left); Point (upper-right); Parallel (lower-left); Ambient (lower-right)
A. Point of interest B. Light icon

You can specify which 3D layers a light affects by designating the light as an adjustment layer: place the light in the Timeline panel above the
layers on which you want it to shine. Layers that are above a light adjustment layer in the layer stacking order in the Timeline panel do not receive
the light, regardless of the positions of the layers in the Composition panel.

Create a light
% Choose Layer > New > Light, or press Ctrl+Alt+Shift+L (Windows) or Command+Option+Shift+L (Mac OS).
Note: By default, new layers begin at the beginning of the composition duration. You can instead choose to have new layers begin at the current
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time by deselecting the Create Layers At Composition Start Time preference (Edit > Preferences > General (Windows) or After Effects >
Preferences > General (Mac OS)).

Change light settings
“ Double-click a light layer in the Timeline panel or select the layer and choose Layer > Light Settings.
Q Select Preview in the Light Settings dialog box to show results in the Composition panel as you modify settings in the dialog box.

Light settings

Light Type Parallel emits directional, unconstrained light from an infinitely distant source, approximating the light from a source like the Sun. Spot
emits light from a source that is constrained by a cone, like a flashlight or a spotlight used in stage productions. Point emits unconstrained
omnidirectional light, like the rays from a bare light bulb. Ambient creates light that has no source but rather contributes to the overall brightness of
a scene and casts no shadows.

Note: Because the position in space of an Ambient light does not affect its influence on other layers, an Ambient light does not have an icon in
the Composition panel.

Intensity The brightness of the light. Negative values create nonlight. Nonlight subtracts color from a layer. For example, if a layer is already lit,
creating a directional light with negative values also pointing at that layer darkens an area on the layer.

Color The color of the light.

Cone Angle The angle of the cone surrounding the source of a light, which determines the width of the beam at a distance. This control is active
only if Spot is selected for Light Type. The cone angle of a Spot light is indicated by the shape of the light icon in the Composition panel.

Note: In After Effects CS6, a selected spot light's cone can be extended to the point of interest.

Cone Feather The edge softness of a spotlight. This control is active only if Spot is selected for Light Type.

Falloff (After Effects CS5.5 and later) The type of falloff for a parallel, spot or point light. Falloff describes how a light's intensity is lessened over
distance.

For details, tutorials, and resources about light falloff, see this article on the Adobe website.

Falloff types include the following:

None lllumination does not decrease as the distance between the layer and the light increases.
Smooth Indicates a smooth linear falloff starting at the Falloff Start radius and extending the length specified by Falloff Distance.
Inverse Square Clamped Indicates a physically accurate falloff starting at the Falloff Start radius and decreasing proportionally to the
inverse square of the distance away.
Radius (After Effects CS5.5 and later) Specifies the radius of falloff from a light. Inside this distance, the light is a constant light. Outside this
distance, the light falls off.
Falloff Distance (After Effects CS5.5 and later) Specifies the distance a light falls off from a light.
Casts Shadows Specifies whether the light source causes a layer to cast a shadow. The Accepts Shadows material option must be On for a layer
to receive a shadow; this setting is the default. The Casts Shadows material option must be On for a layer to cast shadows; this setting is not the
default.
Q Press Alt+Shift+C (Windows) or Option+Shift+C (Mac OS) to toggle Casts Shadows for selected layers. Press AA to show Material Options
properties in the Timeline panel.
Shadow Darkness Sets the darkness of the shadow. This control is active only if Cast Shadows is selected.
Shadow Diffusion Sets the softness of a shadow based on its apparent distance from the shadowing layer. Larger values create softer shadows.
This control is active only if Casts Shadows is selected.
Note: For After Effects CS5 and earlier, light falloff is not available. However, you can simulate light falloff using expressions or one of several
third-party plug-ins created for this purpose. Dan Ebberts provides an expression on his MotionScript website that uses expressions on the
Material Options properties of a layer to simulate the result of light falloff when the layer is further from the light.

Online resources about lights
Eran Stern provides a video tutorial on the Creative COW website that demonstrates the use of lights as adjustment layers, to precisely control
which layers are affected by which lights.

Chris Meyer provides a basic overview of lights and their properties in a video tutorial on the Lynda.com website.
Chris and Trish Meyer provide tips about shadows and lights in 3D in an article on the ProVideo Coalition website.

Trish and Chris Meyer provide a tutorial for using 3D layers, lights, and cameras in a PDF excerpt from their book After Effects Apprentice on the
Focal Press website.

Chris and Trish Meyer provide a tutorial on the Artbeats website that demonstrates how to use lights and 3D layers to project a video onto other
layers, such as onto a wall.

Adjust a 3D view or move a camera, light, or point of interest fothetop

Camera layers and light layers each include a Point Of Interest property, which specifies the point in the composition at which the camera or light
points. By default, the point of interest is at the center of the composition. You can move the point of interest at any time.

A one-node camera ignores the point of interest. (See Camera settings.)
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To make a light ignore its point of interest, select an option other than Orient Towards Point Of Interest in the light's Auto-Orientation options. (See
Auto-Orientation options.)

Note: As with all properties, you can also modify a camera or light's properties directly in the Timeline panel.

Move a camera, light, or point of interest with the Selection and Rotation tools
1. Select a camera or light layer.
2. Using the Selection or Rotation tool, do one of the following:

« To move the camera or light and its point of interest, position the pointer over the axis you want to adjust, and drag.

« To move the camera or light along a single axis without moving the point of interest, Ctrl-drag (Windows) or Command-drag (Mac OS)
the axis.

« To move the camera or light freely without moving the point of interest, drag the camera icon L or light icon.

« To move the point of interest, drag the point of interest icon +-.

Move or adjust a camera or working 3D view with the Camera tools
You can adjust the Position and Point Of Interest properties of a camera layer by using the Camera tools in the Composition panel.

You can also use the Camera tools to adjust a working 3D view, a 3D view that is not associated with a camera layer. You can think of 3D views
as being virtual cameras through which you can view and preview a composition. The working 3D views include the custom views and the fixed
orthographic views (Front, Left, Top, Back, Right, or Bottom). The working 3D views are useful for placing and previewing elements in a 3D scene.
If you use a Camera tool to adjust a working 3D view, no layer property values are affected.

After you've modified a 3D view, you can reset it by choosing View > Reset 3D View.
You can'’t use the Orbit Camera tool on the fixed orthographic views.
For information on choosing and using 3D views, see Choose a 3D view.

1. In the 3D View menu at the bottom of the Composition panel, choose the camera or 3D view to adjust.

2. Activate a Camera tool.

You can activate a Camera tool by selecting it in the Tools panel or pressing C to cycle through the Camera tools. The easiest way to switch
between the various Camera tools is to select the Unified Camera &= tool and use the buttons on a three-button mouse.
Orbit Camera Rotates the 3D view or camera by moving around the point of interest. (To temporarily activate the Orbit Camera tool when

the Unified Camera Tool is selected, hold the left mouse button.)
Q Shift-dragging with the Unified Camera tool selected temporarily activates the Orbit Camera tool and constrains rotation to one axis

Track XY Camera Adjusts the 3D view or camera horizontally or vertically. (To temporarily activate the Track XY Camera tool when the
Unified Camera Tool is selected, hold the middle mouse button.)

Track Z Camera Adjusts the 3D view or camera along the line to the point of interest. If you are using an orthographic view, this tool adjusts
the scale of the view. (To temporarily activate the Track Z Camera tool when the Unified Camera Tool is selected, hold the right mouse
button.)

Note: In After Effects CS5, the Track Z Camera tool behaves differently depending on whether it is selected in the Tools panel or activated
using the right mouse button when the Unified Camera tool is selected in the Tools panel. When selected directly, the Track Z Camera tool
also moves the point of interest; when activated using the right mouse button when the Unified Camera tool is selected, the Track Z Camera
tool doesn’'t move the point of interest. This inconsistency was fixed for After Effects CS5.5 and later.

3. Drag in the Composition panel. You can continue a drag operation outside the panel after you've begun dragging within the panel.

After you've modified a 3D view, you can reset it by choosing View > Reset 3D View.

Move or adjust a camera or working 3D view to look at layers
You can also move a camera or adjust a 3D view to look at selected layers or all layers. After Effects changes the point of view and direction of
view to include the layers that you have selected.

« To adjust a 3D view or move a camera to look at selected layers, choose View > Look At Selected Layers.
« To adjust a 3D view or move a camera to look at all layers, choose View > Look At All Layers.

For keyboard shortcuts for these commands, see 3D layers (keyboard shortcuts).

Tips and online resources for moving and animating cameras and lights
Before moving a camera, choose a view other than Active Camera. If you use Active Camera view, you are looking through the camera, which
makes it harder to manage.

By default, a camera's wireframe is only visible when the camera is selected. To always show the camera wireframe, set the view options for the
Composition panel (View > View Options). (See Show or hide layer controls in the Composition panel.)

When working with a camera or light layer, create a null object layer and use an expression to link the Point Of Interest property of the camera or
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light to the Position property of the null layer. Then, you can animate the Point Of Interest property by moving the null object. It is often easier to
select and see a null object than it is to select and see the point of interest.

In After Effects CS5.5 and later, there is a camera command, “Create Orbit Null.” This parents the selected camera layer to a new null layer. The
new null layer is renamed, based on the camera’s name appended with Orbit Null

Trish and Chris Meyer show you how to use the Create Orbit Null camera command in this video tutorial on Adobe TV.

This page includes resources for the new camera features in After Effects CS5.5, including the automatic creation of camera rigs using the Create
Orbit Null command.

For a video tutorial that shows how to create and modify a camera and use the Camera tools, see the Adobe website.

Trish and Chris Meyer provide a video tutorial on the ProVideo Coalition website that demonstrates the use of the Camera tools to adjust cameras
and 3D views.

Trish and Chris Meyer provide a tutorial for using 3D layers, lights, and cameras in a PDF excerpt from their book After Effects Apprentice on the
Focal Press website.

Mark Christiansen provides tips and detailed techniques for working with cameras in the “Virtual Cinematography in After Effects” chapter of After
Effects Studio Techniques on the Peachpit Press website. This chapter includes information about matching lens distortion, performing camera
moves, performing camera projection (camera mapping), using rack focus, creating boke blur, using grain, and choosing a frame rate to match
your story-telling.

Richard Harrington provides a video tutorial on the Creative COW website that shows how to use the Camera tools and camera views in After
Effects to create a camera move with 3D layers. (This tutorial is the second in a two-part series. Part 1 concentrates on working with photographs
to isolate and create sky in Photoshop for use in After Effects.)

Rich Young provides a set of expressions on his AE Portal website that use the toWorld method link a camera and light to a layer with the CC
Sphere effect.

Andrew Devis of Creative Cow has created a 3 tutorial series on Animating a Camera:
* Animating a Camera 1: Camera Difficulties
* Animating a Camera 2: Simple Rig
+ Animating a Camera 3: Controllers & Point of View

This video from video2brain demonstrates the command to create a new camera orbit null.

Material Options properties To the top

3D layers have Material Options properties, which determine how a 3D layer interacts with light and shadow.

Casts Shadows Specifies whether a layer casts shadows on other layers. The direction and angle of the shadows are determined by the direction

and angle of the light sources. Set Casts Shadows to Only if you want the layer to be invisible but still cast a shadow.

Q Use the Only setting and a nonzero Light Transmission setting to project the colors of an invisible layer onto another layer. Steve Holmes
provides a video tutorial on the Artbeats website in which he demonstrates how to use layers with Cast Shadows set to Only to cast shadows of
specific shapes within a 3D scene.

Light Transmission The percentage of light that shines through the layer, casting the colors of the layer on other layers as a shadow. 0%
specifies that no light passes through the layer, casting a black shadow. 100% specifies that the full values of the colors of the shadow-casting
layer are projected onto the layer accepting the shadow.

Q Use partial light transmission to create the appearance of light passing through a stained glass window.

Accepts Shadows Specifies whether the layer shows shadows cast on it by other layers.

In After Effects CS6, an “Only” option is available in Accepts Shadows for when you want to render only a shadow on a layer.

Accepts Lights Specifies whether the color of a layer is affected by light that reaches it. This setting does not affect shadows.

Ambient Ambient (nondirectional) reflectivity of the layer. 100% specifies the most reflectivity; 0% specifies no ambient reflectivity.

Diffuse Diffuse (omnidirectional) reflectivity of the layer. Applying diffuse reflectivity to a layer is like draping a dull, plastic sheet over it. Light that
falls on this layer reflects equally in all directions. 100% specifies the most reflectivity; 0% specifies no diffuse reflectivity.

Specular Specular (directional) reflectivity of the layer. Specular light reflects from the layer as if from a mirror. 100% specifies the most
reflectivity; 0% specifies no specular reflectivity.

Shininess Determines the size of the specular highlight. This value is active only if the Specular setting is greater than zero. 100% specifies a
reflection with a small specular highlight. 0% specifies a reflection with a large specular highlight.

Metal The contribution of the layer color to the color of the specular highlight. 100% specifies that the highlight color is the color of the layer. For
example, with a Metal value of 100%, an image of a gold ring reflects golden light. 0% specifies that the color of the specular highlight is the color
of the light source. For example, a layer with a Metal value of 0% under a white light has a white highlight.

. . . To thet
Specify resolution to use for rendering shadows e

The Advanced 3D rendering plug-in is used to render compositions containing intersecting 3D layers. To render shadows, the plug-in uses shadow
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maps, which are images rendered from the point of view of each light source. Normally, shadow resolution is computed automatically based on the
composition resolution and the quality settings of the layers. If normal resolution doesn'’t create the quality you want, odr renders too slowly, you
can adjust the shadow map resolution. For example, if shadows are blurry and the Shadow Diffusion material option is set to 0, increase the
shadow map resolution. Or, if shadows render too slowly, decrease the shadow map resolution.

When a shadow-casting layer intersects another layer, sometimes a small gap occurs behind the intersection that is supposed to be shadowed. To
decrease the size of the gap, increase the shadow map resolution.

1. In After Effects CS5.5, and earler, choose Composition > Composition Settings, click the Advanced tab, and click Options.
2. Choose a value (in pixels) from the Shadow Map Resolution menu.

Choose Comp Size or a resolution larger than the composition size for best results. Lower resolutions may result in shadows that appear
blurry.

. To the to
Stereoscopic 3D ’
Stereoscopic 3D video can be created with Adobe After Effects CS5, and there are new workflows and tools available for it in After Effects CS5.5
and later.

For tutorials, details, and resources about stereoscopic 3D in After Effects CS5.5, see this article on the Adobe website.
For an overview of stereoscopic 3D workflow in After Effects, see Understanding Stereoscopic 3D in After Effects.

Angie Taylor has a Workshop available on Stereoscopic 3D workflow for Motion Graphic Design. Here are some free movies available to watch
online.

Mark Christiansen shows compositing stereoscopic 3D footage (using free clip from Art Beats).

Stereoscopic 3D camera rig (CS5.5)

After Effects has a Create Stereo 3D Rig menu command, allowing you to turn a 3D composition into a stereoscopic 3D composition. The Stereo
3D Rig creates all the elements for you, including the 3D Glasses effect.

Make a stereoscopic 3D camera rig by first creating a composition with 3D elements in it. A composition that contains items such as a 3D
collapsed precomposition or 3D elements in the composition itself works well. If you already have a camera in use, you can select it when creating
the stereoscopic 3D camera rig. If no camera is selected, then a new camera (named Master Cam) is created. Choose Layer > Camera > Create
Stereo 3D Rig. The rig only works with two-node cameras.

The rig is produced by creating a master camera or by using the existing selected camera in the composition. There are left eye [compare Left
Eye] and right eye [compare Right Eye] compositions. Each composition has a camera linked to the master camera, the original composition
nested in them, and an output stereo 3D composition [compare Stereo 3D]. The output stereo 3D composition nests both eye compositions and
contains a layer called Stereo 3D Controls. This layer contains a Stereo 3D Controls effect for controlling the rig and a 3D Glasses effect that
combines the left and right eye compositions into a stereo image. (see 3D Glasses effect.)

Note: The Stereo 3D Controls effect is an effect built as part of the Stereo 3D Rig and does not reside in the Effects and Presets panel.

The Stereo 3D Controls effect has the following settings for Camera Separation and Convergence:

Configuration Center places the left and right camera on either side of the master camera. Hero Left places the left camera in the same spot as
the master camera with the right camera to the right. Conversely, Hero Right places the right camera at the master camera position with the left
camera to the left.

Stereo Scene Depth Controls the interaxial separation between the cameras as a percentage of the composition’s width. That way, if the
composition is resized, the separation amount is constant. This setting starts low at a value of 3% to keep the effect subtle. Ideally, this value does
not need to increase to more than 14%-30% for reasonable 3D footage. However, it can be bigger depending on the scene content (objects are
very close together) and the camera field of view, for example.

Note: Altering this value changes how deep the Stereo 3D appears to go into and out of the scene. It can cause eye strain if pushed too far,
however.

Converge Cameras When off, the cameras remain parallel to the master camera but offset to either side. When on, the position remains offset.
However, the Point of Interest of the left and right cameras are joined at the location based upon the following two properties.

Converge To and Convergence Z Offset Determines the Z distance away from the camera that the screen appears to be when looking through
3D glasses. Everything farther in Z space appears to be pushed into the screen, and everything closer appears to pop out of the screen. When
working without converge the cameras check box on, and cameras are parallel, changing the scene convergence has the same effect as changing
the Z offset. Use difference mode to set different elements in the scene to screen space in that case. (see 3D Glasses effect.)

Getting started with stereoscopic 3D

If you are working with stereoscopic 3D, you don’t necessarily need a 3D television. For example, you can use anaglyph (red-cyan) 3D glasses
and view 3D stereoscopic footage right in the Composition panel. However, you can use a 3D television for doing live editing with a 3D television
and active shutter glasses, as well. For that workflow, you'll need a few things before getting started:

= A monitor or television that supports 3D stereoscopic viewing.
» Glasses for viewing stereoscopic 3D television.

Note: For this workflow, use active shutter glasses that require an emitter device. Make sure that you are using the glasses that the
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television manufacturer recommends.

Stereoscopic footage or a 3D composition.

Once you have gathered these items, do the following:

1.
2.
3.
4.
5.

8.

Connect the 3D TV to your computer with an HDMI cable (DVI is acceptable if HDMI is not available).

Create a 3D composition in After Effects. Make sure that the composition size matches the current resolution of your output monitor.
Make a new Composition panel for your Stereo 3D composition. Lock the composition, and then drag it to your 3D TV monitor.
Ensure that the Composition panel is set to 100%.

Type Control + \(backslash) twice to set the composition to full screen for the 3D TV. Set the dimensions of the composition and the 3D TV
to be the same.

Switch the 3D view in the 3D Glasses effect to one of the following:
e Stereo Pair
e Over Under
« Interlaced

Turn on 3D mode for your 3D TV and match the format to what was set in 3D View for the 3D Glasses effect. (Stereo Pair, and Over Under
are supported on most 3D TVs.

Put on your 3D glasses, and edit your composition in true stereoscopic 3D.

Stereoscopic 3D tips

If you are working with3D stereoscopic footage in the Composition panel and you do not have a 3D television, you can work with the
anaglyph format. Ordinary red and cyan anaglyph 3D glasses work best for this 3D stereoscopic workflow.

Increase or decrease Stereo Scene Depth to change how deep the 3D environment appears.

Turn on Converge Cameras and change the Convergence Z Offset to move different objects behind and in front of the screen. Objects closer
to the camera than the Z offset appears in front of the screen, objects farther away appears behind it.

You can make your composition’s depth of field to match your stereoscopic camera’s convergence by doing one of the following:

« When using “Link Focus Distance to Point of Interest” on the master camera, and converge cameras for the rig, the depth of field and
stereoscopic 3D convergence matches.

« If you want the depth of field to change over time, you can animate the focus distance of the master camera. Then, set the convergence
point to converge from “Camera Position”, and set an expression linking the convergence Z offset to the master camera’s Focus Distance

More Help topics
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Views and previews
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Previewing

Preview video and audio
Use RAM preview to play video and audio
RAM preview a specified number of frames
Save a RAM preview as a movie
Loop options for previews
Preview only audio
Use standard preview to play video
Manually preview (scrub) video and audio
Audio panel options
Additional tips and options for previewing
Move the current-time indicator (CTI)
Zoom in or out in time for a composition
Choose a viewer to always preview
Preview modes and Viewer Quality preferences
Preview modes and Fast Previews preferences
Fast Previews (CS5.5, and earlier)
Fast Previews (CS6)
Keyboard shortcuts for Fast Previews
Viewer Quality preferences
Region of interest (ROI)
Work area
Snapshots
Preview on an external video monitor

. . . To theto
Preview video and audio ’

You can preview all or part of your composition as you work, without rendering to final output. Though it is common to speak of rendering as if this
term only applies to final output, the processes of creating previews to show in the Footage, Layer, and Composition panels are also kinds of
rendering.

Many of the controls for previewing are in the Preview panel.

Note: For additional keyboard shortcuts for Previews for use on a keyboard without numeric keypads in After Effect CS5.5, and earlier, see
Previews (keyboard shortcuts).

Use RAM preview to play video and audio
RAM preview allocates RAM to play video and audio in the Timeline, Layer, or Footage panel at real-time speed. The number of frames that can
be stored for real-time playback depends on the amount of RAM available to the application and the settings in the Preview panel.

In the Preview panel, you can specify two sets of RAM preview options: RAM Preview Options and Shift+RAM Preview Options. For example, you
may decide to set RAM Preview Options for full frame rate and full resolution, and set Shift+RAM Preview Options to skip one out of every two
frames and preview at half resolution.

In the Layer and Footage panels, RAM previews play untrimmed footage.

1. To modify RAM preview options, click the RAM Preview Options menu in the center of the Preview panel and choose RAM Preview Options
or Shift+RAM Preview Options. You can change any of the following:

Mute Audio 9" Include audio in or exclude audio from RAM preview.

Frame Rate Choose Auto to use the composition frame rate.

Skip The number of frames to skip between a rendered frame and the next rendered frame. Choose 0 to render all frames.
Resolution Choose Auto to use the resolution set in the Resolution/Down Sample Factor menu at the bottom of the viewer panel.

From Current Time Select From Current Time to play from the current time; otherwise, RAM Preview plays the work area or from the
beginning of the composition, layer, or footage item.

Full Screen Play RAM preview at the full size of the composition, layer, or footage item on a screen that is the panel background color. You
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can change the panel background color using the Brightness control in the Appearance preferences.

2. Do one of the following:
* To preview using RAM Preview Options, click the RAM Preview button ll* in the Preview panel or press 0 (zero) on the numeric keypad.
e To preview using Shift+RAM Preview Options, Shift-click the RAM Preview button Il in the Preview panel or press Shift+0 (zero) on the
numeric keypad.
3. To stop a RAM preview, do one of the following:
« To leave the current-time indicator at the last-played frame, press the spacebar.

« To leave the current-time indicator where it was before you started the RAM preview, click the RAM preview button or press any button
other than the spacebar.

Note: The performance of RAM previews performed with the Render Multiple Frames Simultaneously preference selected may be decreased if
antivirus software is running.

Q Press the asterisk key (*) on the numeric keypad during a RAM preview to place a marker at the currently previewed frame. This is a
convenient way to place markers corresponding to important points in an audio track. (See Layer markers and composition markers.)

RAM preview a specified number of frames

Press Alt (Windows) or Option (Mac OS) while initiating a RAM preview to preview the specified number of frames up to and including the current
frame. The default number of frames previewed with this command is 5. The preference for changing this number is in the Alternate RAM Preview
section of the Preview preferences. (See Previews preferences (CS5.5, and earlier) or Previews preferences (CS6).)

Note: If the current frame is within a backward-propagating Roto Brush span and the Layer panel View menu is set to Roto Brush, then this
command in the Layer panel previews the frames including and after the current frame. (See Roto Brush strokes, spans, and base frames.)

Save a RAM preview as a movie
After Effects can save RAM previews as uncompressed AVI files (Windows) or MOV files (Mac OS). When saving a RAM preview, keep in mind
the following:

» After Effects uses the composition frame size and the Resolution setting in the default render settings template to determine the final
dimensions in pixels of a saved RAM preview. If the Resolution setting in the render settings template is Current Settings, then the
Resolution setting in the Preview panel is used. If the Resolution setting in the Preview panel is Auto, then the Resolution setting in the
Composition Settings dialog box is used. The saved RAM preview doesn’t consider the zoom level.

* RAM preview doesn’t generate interlaced fields, so a saved RAM preview never contains fields.

Note: The 3D View of the active composition panel must be set to Active Camera for Save RAM Preview to work, even if the composition doesn’t
contain 3D layers.

1. After you generate a RAM preview, choose Composition > Save RAM Preview.
2. Enter a name, specify a location, and click Save.

Loop options for previews
Click the Loop Options button in the Preview panel until it shows the desired state:

Loop 5 Repeatedly plays preview from beginning to end.
Play Once — Plays preview once.

Ping Pong == Repeatedly plays preview, alternating between backward and forward play.

Preview only audio
When you preview only audio, it plays immediately at real-time speed, unless you've applied Audio effects other than Stereo Mixer, in which case
you may have to wait for audio to render before it plays.

Note: If audio must be rendered for a preview, then only the amount of audio specified by the Duration setting in the Previews preferences is
rendered and played for the preview. The default is 30 seconds.

Set the sample rate for audio for the entire project in the Project Settings dialog box (File > Project Settings). CD-quality sound is 44.1 KHz, 16-bit
stereo.

The Audio Hardware and Audio Output Mapping preferences determine the behavior of audio previews. These preferences do not affect final
output. The output module settings determine the quality of audio in final output. For best-quality audio previews, choose an ASIO device if one is
available in the Default Device menu in the Audio Hardware preferences. Otherwise, choose one of the devices for your system, such as the After
Effects WDM Sound device (Windows) or one of the Built-in devices (Mac OS).

« To preview only audio from the current time, choose Composition > Preview > Audio Preview (Here Forward) or press the decimal point key
() on the numeric keypad.

« To preview only audio in the work area, choose Composition > Preview > Audio Preview (Work Area) or press Alt+decimal point (.)
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(Windows) or Option+decimal point (.) (Mac OS) on the numeric keypad.

Use standard preview to play video
Standard preview (commonly called spacebar play) plays video in the active Composition, Layer, or Footage panel from the current time. Standard
preview does not play audio.

Standard previews play at a speed as close to the speed of real time as possible. However, for complex compositions, the speed of the preview
may be much less than real-time speed.

« Click the Play button ® in the Preview panel, or press the spacebar.

Manually preview (scrub) video and audio
« To manually preview (scrub) video in the Timeline panel or go to a specific frame, drag the current-time indicator.

e To scrub audio in the Timeline panel, Ctrl+Alt-drag (Windows) or Command+Option-drag (Mac OS) the current-time indicator.
e To scrub audio and video in the Timeline panel, Ctrl-drag (Windows) or Command-drag (Mac OS) the current-time indicator.

If you stop moving the current-time indicator while keeping the mouse button depressed, a short section of audio loops.

Q To manually preview (scrub) only the frames that are already rendered and cached into the RAM cache, press the Caps Lock key before
dragging the current-time indicator. This prevents After Effects from trying to render other frames when you drag over or past them. This
technique is useful when you want to manually preview some frames that you rendered using RAM preview settings that used an option to skip
every other frame.

Audio panel options
During previews, the Audio panel volume unit (VU) meter actively displays audio volume levels. At the top of the VU meter, signals indicate when
the audio is clipping—a distortion that occurs when the audio signal exceeds the maximum level that the audio device allows.

To view the VU meter and levels controls in more detail, increase the height of the Audio panel.

InFo = Audio = I i o

Audio panel
A. VU meter B. Level controls C. Level units D. Audio panel menu E. Level values

Choose Options in the Audio panel menu to specify the following options:

Units Choose whether to display audio levels in decibels or in percentages. 100% equals 0 decibels (0 dB).

Slider Minimum The minimum audio level to display in the Audio panel.

Additional tips and options for previewing
With all previewing methods—as with rendering to final output—a layer is only visible in rendered previews if its Video layer switch ® is selected.

Some factors that influence the speed with which previews are rendered include layer switches, Fast Previews settings, preference settings, and
composition settings.

One of the simplest and most influential of the preview settings controls is the Resolution/Down Sample Factor setting menu at the bottom of the
Composition panel. Choose a value other than Full from this menu to see all previews at a lower resolution. (See Resolution.)

Q To turn pixel-aspect ratio correction on or off for previews, click the Toggle Pixel Aspect Ratio Correction button at the bottom of the panel.
The quality of the pixel aspect ratio correction is determined by the Zoom Quality preference. (See Viewer Quality preferences.)

When possible, preview on the same kind of device that your audience will use to view your final output. For example, you can preview on an
external video monitor. To see your composition as it will appear on a mobile device—such as a mobile phone—first render your composition to
final output, and then use Adobe Device Central to view the movie.

If you create compositions for mobile devices using Device Central, you can preview the compositions within After Effects with guides and settings
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that simulate some aspects of the target mobile devices. (See Create compositions for playback on mobile devices.)

If color management is enabled, you can preview a composition, layer, or footage item as it will appear in the output color space. (See Simulate
how colors will appear on a different output device.)

Note: Select Show Rendering Progress In Info Panel And Flowchart (Edit > Preferences > Display (Windows) or After Effects > Preferences >
Display (Mac OS)) to see additional information in the Info panel or the project Flowchart panel during rendering, either for previews or for final
output.

Move the current-time indicator (CTI) fothetop

The most basic way of previewing frames is to manually preview by moving or dragging the current-time indicator (CTI).

The time ruler visually represents the time dimension of a composition, a layer, or a footage item. In a Layer or Footage panel, the time ruler
appears near the bottom of the panel. For a Composition panel, the time ruler appears in the corresponding Timeline panel. The time rulers in
different panels represent different durations. The time ruler in a Layer or Footage panel represents the duration of the contents of that panel; the
time ruler in the Timeline panel represents the duration of the entire composition.

On a time ruler, the current-time indicator indicates the frame you are viewing or modifying.

Y — W, 1 z ) o)

Current-time indicator in the time ruler in the Timeline panel (left) and in the Layer panel (right)

« To go forward or backward one frame, click the Next Frame I® or Previous Frame ! button in the Preview panel, or press Page Down or
Page Up.

« To go forward or backward ten frames, Shift-click the Next Frame or Previous Frame button, or press Shift+Page Down or Shift+Page Up.

» To go forward a specific period of time or number of frames, click the current-time display, and then enter the plus sign (+) followed by the
timecode or number of frames to advance. For example, enter +20 to go forward 20 frames or 1:00 to go forward one second. Precede the
value by the minus sign (-) to go backward. For example, enter +-20 to go backward 20 frames or +-1:00 to go backward one second.

« To go to the first or last frame, click the First Frame 4 or Last Frame ®! button in the Preview panel, or press Home or End.
« To go to the first or last frame of the work area, press Shift+Home or Shift+End.

« To go to a specific frame, click in the time ruler; click the current-time display in the Footage, Layer, Composition, or Timeline panel; or press
Alt+Shift+J (Windows) or Option+Shift+J (Mac OS). You can also drag the current-time display in the Timeline panel to modify the value.

« Shift-drag the current-time indicator to snap to keyframes, markers, In and Out points, the beginning or end of the composition, or the
beginning or end of the work area.

Jeff Almasol provides a script that creates a panel with controls for moving the current-time indicator to different times in the composition. The
panel provides buttons for jumping a specific number of frames forward or back from the current time, as well as buttons for capturing different
times and jumping to them easily. For more information, go to Jeff Almasol’s redefinery website.

You can scroll and zoom in time in the Timeline, Footage, and Layer panels. See Scroll or zoom with the mouse wheel.

. . . . To the to
Zoom in or out in time for a composmon .

« In the Timeline panel, click the Zoom In button 2 or the Zoom Out button =, or drag the zoom slider between the buttons.
« On the main keyboard, press the = (equal sign) key to zoom in or press the — (hyphen) key to zoom out in time.
» Drag the Time Navigator Start or Time Navigator End brackets to zoom in or out on a section of the composition time ruler.

= . =

Dragging TieNvigator End bracket to show more of time ruler.
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Note: When you click the Time Navigator in the Timeline panel, the Info panel shows the times of the beginning and end of the Time Navigator
duration.

« To zoom out to show the entire composition duration, press Shift+; (semicolon) with the Composition panel or Timeline panel active. Press
Shift+; again to zoom back in to the duration specified by the Time Navigator.

« To zoom out to show the entire composition duration, Shift-double-click the Time Navigator. Shift-double-click it again to zoom back in to the
duration specified by the Time Navigator.

e To zoom in to show individual frames in the time ruler, double-click the Time Navigator. Double-click the Time Navigator again to zoom out to
show the entire composition duration.

For additional ways to zoom and scroll in time using the mouse scroll wheel, see Scroll or zoom with the mouse wheel.

Q When zoomed in time, press D to center the time graph on the current time.

. . To the top
Choose a viewer to always preview

Designating a viewer as the default panel to preview is especially useful when you have a Composition viewer that represents your final output
and you always want to preview that viewer, even when you're changing settings in other panels.

The panel that's set to always preview appears frontmost for the duration of the preview.
« Click the Always Preview This View button B in the lower-left corner of the panel.

Note: When multiple views are open, previews use the frontmost composition view for 2D compositions and the Active Camera view for 3D
compositions. To turn off the Active Camera, deselect Previews Favor Active Camera in the Preview panel menu.

. . . To the to
Preview modes and Viewer Quality preferences ’

After Effects provides several options for previewing that make various tradeoffs between speed and fidelity.

Preview modes and Fast Previews preferences
Each preview mode provides a different balance between quality and speed for playback and for updating of images during interactions, such as
when you drag a layer in the Composition panel or modifying a property value in the Timeline panel.

Draft 3D and Live Update modes apply to all views of a composition.

Draft 3D Disables lights, shadows, and depth-of-field blur for cameras. To turn Draft 3D mode on or off, click the Draft 3D button " at the top of
the Timeline panel.

Live Update Updates images in the Composition or Layer panel during interactions. When Live Update is deselected, After Effects displays
wireframe representations during interactions. To turn Live Update mode on or off, click the Live Update button @ at the top of the Timeline
panel.

Q To temporarily toggle Live Update mode, hold Alt (Windows) or Option (Mac OS) while dragging to move a layer, modify a property value, or
move the current-time indicator.

Fast Previews (CS5.5, and earlier)

You can use a different Fast Previews mode for each view in the Composition panel. For example, in a 4 Views layout, you could use OpenGL for
the Active Camera view and Wireframe for Left, Right, and Top views. Click the Fast Previews button B, at the bottom of the Composition panel
to set Fast Previews preferences or choose from the following Fast Previews modes:

Wireframe Represents each layer as a wireframe outline, which increases playback speed and allows you to quickly reposition a layer
with large pixel dimensions or several effects applied.

Adaptive Resolution—OpenGL Off Decreases the preview resolution of layers when necessary to maintain speed of updating of images
during interactions. The Adaptive Resolution Limit value in the Fast Previews area in the Previews preferences category specifies the
minimum resolution to use.

OpenGL—Interactive or OpenGL—Always On OpenGL mode provides high-quality previews that require less rendering time than other
playback modes. OpenGL can also be used to speed up rendering to final output. OpenGL features in After Effects rely on OpenGL
features of your video hardware. When OpenGL does not support a feature, it simply creates a preview without using that feature. For
example, if your layers contain shadows and your OpenGL hardware does not support shadows, the preview will not contain shadows.
Select OpenGL-Interactive to use OpenGL only for interactions, such as manually previewing (scrubbing) in the Timeline panel or dragging
a layer in the Composition panel. You can tell that OpenGL is engaging by looking at the Fast Previews icon, which lights up. Select
OpenGL-Always On to use OpenGL for all previews. In this mode, “OpenGL” appears in the upper-left corner of each view in the
Composition panel.

Note: The Enable OpenGL option in the Fast Previews area of the Preview preferences category must be selected for you to use OpenGL for
previews. If you also select Enable Adaptive Resolution With OpenGL, then the preview resolution of layers rendered with OpenGL is decreased
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when necessary to maintain speed of updating of images during interactions.

Q To prevent After Effects from updating images in the Footage, Layer, and Composition panels, press Caps Lock. When you make a change that
would otherwise appear in a panel, After Effects adds a red bar at the bottom of the panel with a text reminder that image refresh is disabled.
After Effects continues to update panel controls such as motion paths, anchor points, and mask outlines as you move them. To resume panel
updates and display all changes, press Caps Lock again. Pressing Caps Lock is a good way to prevent views from being refreshed for each
frame during rendering for final output.

Note: When you are using OpenGL to render previews and are previewing on a video monitor, the preview shown on the video monitor doesn’t
update as you interact with elements of your composition until you have released the mouse at the end of an interaction. (See Preview on an
external video monitor.)

Fast Previews (CS6)

The Fast Previews button 2 works the same way as in previous versions of After Effects, however, the options have been reordered, and the
names of the options are new. The menu lists options ranging from higher quality but slower performance (Off), to lower quality but higher
performance (Wireframe).

Off (Final Quality) Fast Previews is off. Use this mode when previewing the final quality of your composition.

Adaptive Resolution Attempts to downsample footage while dragging a layer or scrubbing a property value. For the ray-traced 3D
compositions, Adaptive Resolution will reduce the ray-tracing quality based on the current adaptive resolution:

« At 1/2, the ray-tracing quality value is cut in half.
o at 1/4, it will be reduced to at most 4.
e at 1/8 or 1/16, it will be reduced to at most 2.

You can change the adaptive resolution limit in Edit > Preferences > Previews (Windows) or Premiere Pro > Preferences > Previews (Mac
0S).

Draft Available in Ray-traced 3D compositions only. This option reduces the ray-tracing quality (number of rays fired by the ray tracer) to
1.

Fast Draft When laying out a complex scene, or if you are working in a ray-traced 3D composition, you can use Fast Draft mode for
previewing. In ray-traced 3D compositions, Fast draft mode supports for beveled, extruded, and curved 3D layers. When previewing, the
scene is downsampled to speed up the loading of textures to the GPU. In Fast Draft mode, each frame of video is still read in to the
renderer as needed. The downsample factor is set at 1/4 resolution, and effects and track mattes are on.

Wireframe Useful for setting up and previewing complex compositions.

= In Draft, Fast Draft, and Wireframe modes, the Current Renderer menu button's lightning bolt appears orange. In Adaptive Resolution, it
appears orange when the composition is downsampled. In these modes, the name of the mode appears in the upper-right corner of the
Composition view.

« If adjusting a property or scrubbing through the Timeline takes a long time in Off, Adaptive Resolution, or Draft modes, the scene will
temporarily switch to show wireframes. The frame will finish rendering when you stop moving the mouse.

« If you are in a ray-traced 3D composition in Draft mode, and then switch to it to a Classic 3D composition, the fast preview mode
automatically switches to Adaptive Resolution.

« In After Effects CS5.5 (and earlier), projects with compositions set to the "OpenGL--Interactive" fast preview mode are automatically set to
"Adaptive Resolution".

» If you wish to update more than one active view when scrubbing while holding down the Ctrl (Windows) or Command (Mac OS) key, enable
the "Share View Options" option in the Select View Layout popup menu.

» Press the Current Renderer menu button in the upper right corner of the Composition panel to quickly open the current renderer settings in
the Composition Settings dialog box.

Q Changing the Fast Previews mode to match your workflow is important, especially when working with ray-traced 3D compositions.

Keyboard shortcuts for Fast Previews

Quality name

Shortcut
Off (Final Quality) Ctrl+Alt+1 (Windows) / Cmd+Option+1 (Mac OS)
Adaptive Resolution Ctrl+Alt+2 (Windows) / Cmd+Option+2 (Mac OS)
Draft Ctrl+Alt+3 (Windows) / Cmd+Option+3 (Mac OS)
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Fast Draft Ctrl+Alt+4 (Windows) / Cmd+Option+4 (Mac OS)
Wireframe Ctrl+Alt+5 (Windows) / Cmd+Option+5 (Mac OS)

In this video tutorial by Todd Kopriva and video2brain, learn how to use the Fast Previews menu. Look at a complex scene and see how different
settings affect your ability to manipulate elements.

Viewer Quality preferences
In the Previews preferences category, you can choose the quality and speed of color management and zoom operations used in previews. From
the Zoom Quality or Color Management Quality menu, choose Faster, More Accurate, or More Accurate Except For RAM Previews.

The More Accurate Except For RAM Previews option uses the more accurate operations for manual previews and standard previews, but uses the
faster operations for RAM previews. (See Preview video and audio.)

The Zoom Quiality preference affects the quality of scaling performed for pixel aspect ratio correction in the Composition and Layer panels. (See
Pixel aspect ratio and frame aspect ratio.)

Note: When the Show Channel menu is set to an option that shows straight colors ( RGB Straight, Alpha Overlay, or Alpha Boundary), the Viewer
Quality preference is ignored, and the preview is created as if the Viewer Quality settings were Faster.

Region of interest (ROI) To the top

The region of interest (ROI) is the area of the composition, layer, or footage item that is rendered for previews. Create a smaller region of interest
to use less processing power and memory when previewing, thereby improving interaction speed and increasing RAM preview duration.

By default, changing the region of interest does not affect file output. You can change the size of your composition and select what portion is
rendered by cropping to the region of interest.

Note: When the region of interest is selected, the Info panel displays the horizontal and vertical distances of the top (T), left (L), bottom (B), and
right (R) edges of the region from the top-left corner of the composition.

« To draw a region of interest, click the Region Of Interest button & at the bottom of the Composition, Layer, or Footage panel, and then drag
to select a viewable area of the panel.

Q To start over with the marquee tool, hold down Alt (Windows) or Option (Mac OS) and click the Region Of Interest button.

» To switch between using the region of interest and using the full composition, layer, or footage frame, click the Region Of Interest button.
« To move or resize the region of interest, drag its edges or handles. Shift-drag a corner handle to resize while preserving aspect ratio.

To crop the composition to the region of interest, choose Composition > Crop Comp To Region Of Interest.
» To crop the output to the region of interest, choose Use Region Of Interest in the Crop section of the Output Module Settings dialog box.
(See Output module settings.)

Q To create the equivalent of a region of interest for a single layer, you can draw a temporary mask around the part of the layer that you are
working with. The area outside of the mask will not be rendered. This can make working with a small portion of a large layer much faster. Be
careful, though, since not rendering the pixels outside of the mask can change the composition’s appearance significantly. (See Creating
masks.)

To thet
Work area ometep

The work area is the part of the duration of a composition that is rendered for previews or final output. In the Timeline panel, the work area
appears in a lighter shade of gray.

« To set the work area start time or end time to the current time, press B (begin) or N (end), respectively.
« To set the work area, move the start and end work area markers in the time ruler.

(4]

Work area markers indicate the composition duration rendered for previews or final output.

« To move the work area, drag the center of the work area bar left or right.
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Gl

Dragging center of work area bar to move work area

» To expand the work area to the size of the composition, double-click the center of the work area bar.

« To show the duration of the work and the times of its beginning and end in the Info panel, click the work area bar.

To the to
Snapshots ’

When you want to compare one view to another in a Composition, Layer, or Footage panel, take a snapshot. For example, you may want to
compare two frames at different times in a movie.

Snapshots taken in one kind of panel can be displayed in another kind. For example, you can take a snapshot of a Layer panel and display the
snapshot in a Composition or Footage panel. Displaying a snapshot does not replace the content of the panel. If the snapshot has a different size
or aspect ratio than the panel in which you display it, the snapshot is resized to fit the current view.

Snapshots are for reference only and do not become part of the layer, composition, or rendered movie.
A sound is generated when you take a snapshot.

« To take a snapshot, click the Take Snapshot button [l at the bottom of the panel or press Shift+F5, Shift+F6, Shift+F7, or Shift+F8.

« To view the most recent snapshot taken with the Take Snapshot button or Shift+F5, click and hold the Show Snapshot button i at the
bottom of the panel.

« To view a specific snapshot, press and hold F5, F6, F7, or F8.
« To purge a snapshot, hold down Ctrl+Shift (Windows) or Command+Shift (Mac OS) and press F5, F6, F7, or F8.
« To free all memory used to store snapshots, choose Edit > Purge > Snapshot.

. . . To the top
Preview on an external video monitor

You can preview the contents of your Layer, Footage, or Composition panel on an external video monitor. Previewing on a video monitor requires
additional hardware, such as a video capture card or a FireWire port. If you're using a video card to connect an external video monitor, follow the
directions that came with your video card to connect the monitor for viewing previews. If you're using a FireWire port, first connect a digital
camcorder or similar device to the port; then connect the video monitor to the device. For more information on setting up FireWire previews, see
the documentation that came with your digital camcorder, VCR, or other device.

1. Choose Edit > Preferences > Video Preview (Windows) or After Effects > Preferences > Video Preview (Mac OS).
2. Choose an external device from the Output Device menu. (If a device is available, it's automatically listed in this menu.)

3. Choose a mode from the Output Mode menu. The choices listed depend on the device you are using. The Frame Size value that appears
under the Output Mode menu is dependent on the value that you select from the Output Mode menu, and is not dependent on any other
After Effects settings.

4. Set any of the following options:
Previews Displays RAM previews or standard previews on the external monitor only.

Mirror On Computer Monitor Displays RAM previews or standard previews simultaneously on the external monitor and on the computer
screen. Using this option may slow down the previews.

Interactions Displays interactive previews—such as dragging in the Timeline panel or dragging in the Composition panel—on the computer
screen and simultaneously on the external monitor.

Renders Displays each frame on the computer screen and simultaneously on the external monitor as the frames render in the render
queue.

5. Select Scale And Letterbox Output To Fit Video Monitor if you are working with image sizes that don’t match your preview device frame size
and you want to see the entire image scaled to fit.

Q After choosing an output device in the Video Preview preferences, you can preview the current frame on the output device by pressing
the forward slash (/) key on the numeric keypad. Press Ctrl+/ (Windows) or Command+/ (Mac OS) to toggle the preference to Desktop
Only or to the output device you specified.

Whether or not color management is enabled for the project, After Effects does not manage the color of previews on an external video monitor.
The colors sent to the external video monitor are in the working color space for the project. You can manually enable color management for video
previews by nesting your composition and using the Color Profile Converter effect to convert from the working color space for the project to the
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color space of the video preview device. For more information, see Choose a working color space and enable color management.

Note: When you are using OpenGL to render previews, the preview shown on the video monitor doesn’t update as you interact with elements of
your composition until you have released the mouse at the end of an interaction. (See Preview modes.)

e Views (keyboard shortcuts)

e Layer switches and columns in the Timeline panel

e Time navigation (keyboard shortcuts)

o Viewers

o Preferences

e Render with OpenGL

e Basics of rendering and exporting
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Modifying and using views

Choose a view layout and share view settings
Choose a 3D view

Show or hide layer controls in the Composition panel
Zoom an image for preview

Resolution

View a color channel or alpha channel

Adjust exposure for previews

Safe zones, grids, guides, and rulers

Additional resources for viewing and previewing

. . . To thet
Choose a view layout and share view settings e

The Composition panel can show one, two, or four views at a time. By default, viewer options (such as grids and rulers) affect only the currently
active view.
» To choose a view layout, choose an option from the Select View Layout menu at the bottom of the Composition panel.
« To scroll through view layouts, place the pointer over the Select View Layout menu and roll the mouse wheel.
« To apply view settings to all views in the current layout, choose Share View Options from the Select View Layout menu. Hold Ctrl (Windows)
or Command (Mac OS) to temporarily reverse this behavior.

Q‘ To activate a view without affecting the selection of layers in a composition, use the middle mouse button to click within the view's pane in the
Composition panel.

. To thet
Choose a 3D view ometop

You can view your 3D layers from several angles, using orthographic views, custom views that employ perspective, or camera views.

The working 3D views include the custom views and the fixed orthographic views (Front, Left, Top, Back, Right, or Bottom). The orthographic
views show layer positions in the composition but do not show perspective. The working 3D views are not associated with a camera layer. The
working 3D views are useful for placing and previewing elements in a 3D scene. 3D layers appear in working 3D views; 2D layers do not appear in
working 3D views.

Note: The Composition panel displays a label within each view (such as Top or Right) to indicate which view is associated with which camera
perspective. To hide these labels, choose Show 3D Labels from the Composition panel menu.
You can adjust the point of view and direction of view for the custom views with the Camera tools, or you can look at selected layers or all layers.
(See Adjust a 3D view or move a camera, light, or point of interest.)

« Choose a view from the 3D View menu at the bottom of the Composition panel.

« Choose View > Switch 3D View, and choose a view from the menu.

« Choose View > Switch To Last 3D View.

» To switch to the previous 3D view, press Esc.

« To choose one of the 3D views with keyboard shortcuts, press F10, F11, or F12.
Q To change which 3D view is assigned to a keyboard shortcut, switch to a view and then press Shift and the keyboard shortcut. For
example, to make F12 the shortcut for Top view, switch to Top view and then press Shift+F12. You can also use the View > Assign
Shortcut To menu command for this purpose.

Show or hide layer controls in the Composition panel fotnetop

You can assign different options to each view in the Composition panel, so that you can see any combination of camera and light wireframes, layer
handles, mask and shape paths, effect control points, and motion path controls.

« To choose which layer controls to show in a view, choose View > View Options, or press Ctrl+Alt+U (Windows) or Command+Option+U (Mac
0S).

» To show or hide layer controls in a view, choose View > Show Layer Controls, or press Ctrl+Shift+H (Windows) or Command+Shift+H (Mac
0OS). This command also shows or hides the 3D reference axes.

- To show or hide mask paths and shape paths in a view, click the Toggle Mask And Shape Path Visibility button 3 at the bottom of the
Composition panel.
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. . To the top
Zoom an image for preview

Note: For information on scaling a layer, not just zooming in or out of the preview image, see Scale or flip a layer.
The Magnification Ratio control in the lower-left corner of a Composition, Layer, or Footage panel shows and controls the current magnification. By
default, the magnification is set to fit the current size of the panel. When you change magpnification, you change the appearance of the preview in
the panel that you are previewing, not the actual resolution and pixels of the composition.

The quality of zooming for previews can be set using the Zoom Quality preference. (See Viewer Quality preferences.)

Note: After Effects renders vector objects before zooming (scaling for preview), so some vector objects may appear jagged when you zoom in on
them. This apparent pixelation for zooms does not affect scaling of layers or rendering to final output.
« To zoom in to or out from the center of the active view, press the period (.) key or the comma (,) key. Each keypress additionally increases or
decreases the magnification.
» To zoom in to or out from the center of the view using the mouse scroll wheel, place the pointer over the panel and move the scroll wheel.
e To zoom in on or out from a specific point using the mouse scroll wheel, place the pointer over the panel and hold Alt (Windows) or Option
(Mac OS) as you move the scroll wheel.
e To zoom in on a specific point using the Zoom tool Q’ click the area in the panel you want to magnify. Each click additionally magnifies the
image, centering the display on the point you click. You can also drag the tool to magnify a specific area.
» To zoom out from a specific point using the Zoom tool, Alt-click (Windows) or Option-click (Mac OS) the point that you want to be the center
of the zoomed-out view. Each click additionally decreases the magnification of the image, centering the display on the point you click.
* To zoom the active view to 100%, double-click the Zoom tool button in the Tools panel.
» To zoom to fit or to zoom to a preset magnification, choose a zoom level from the Magnification Ratio menu. To change the magnification of
all views in a Composition panel, hold Ctrl (Windows) or Command (Mac OS) while choosing a zoom level from the menu. Choose Fit to
make the image fit the Composition panel; choose Fit Up To 100% to limit the zoom level to 100%.

Q To pan around in the Composition, Layer, or Footage panel while zoomed in, drag with the Hand tool, which you can activate by holding down
the spacebar, the H key, or the middle mouse button. Hold Shift, too, to pan faster.

For additional ways to zoom and scroll using the mouse scroll wheel, see Scroll or zoom with the mouse wheel.

. To the to
Resolution ’
In the context of printing and other media with fixed linear dimensions, resolution refers to linear pixel density: the number of pixels or dots in a
certain span, expressed in such terms as ppi (pixels per inch) and dpi (dots per inch).

In video, film, and computer graphics contexts, the linear measurements of the images are variable, so it doesn’t make sense to refer to the
number of pixels per inch or any other linear measure. Consider, for example, that the same 640x480 movie can be shown on the tiny screen of a
mobile device, the monitor of a desktop computer, and a huge motion billboard. The number of pixels per inch is different for each of these
presentation devices, even though the number of pixels may be the same.

In this context, the term resolution refers to a relative quantity: a ratio of the number of pixels that are rendered to the number of pixels in a source
image. For each view, there are two such ratios—one for the horizontal dimension and one for the vertical dimension.

Each composition has its own Resolution setting, which affects the image quality of the composition when it's rendered for previews and final
output. Rendering time and memory for each frame are roughly proportional to the number of pixels being rendered.

When you render a composition for final output, you can use the current Resolution settings for the composition or set a resolution value in the
Render Settings dialog box that overrides the composition settings. (See Render settings.)

You can choose from the following Resolution settings in the Composition Settings (Composition > Composition Settings) dialog box or from the
Resolution/Down Sample Factor menu at the bottom of the Composition panel:

Auto (available only for previews) Adapts the resolution of the view in the Composition panel to render only the pixels necessary to preview the
composition at the current zoom level. For example, if the view is zoomed out to 25%, then the resolution automatically adapts to a value of 1/4—
shown as (Quarter)—as if you had manually chosen Quarter. If a panel contains multiple views, the resolution adapts to the view with the highest
zoom level. This setting gives the best image quality while also avoiding rendering pixels unnecessary for the current zoom level.

Note: The Auto setting is ignored for compositions for which the Advanced composition setting Preserve Resolution When Nested is selected.
Full Renders each pixel in a composition. This setting gives the best image quality, but takes the longest to render.

Half Renders one-quarter of the pixels contained in the full-resolution image—half the columns and half the rows.

Third Renders one-ninth of the pixels contained in the full-resolution image.

Quarter Renders one-sixteenth of the pixels contained in the full-resolution image.

Custom Renders the image at the horizontal and vertical resolutions that you specify.

Note: The resolution (down-sample factor) of a Layer viewer is tied to the resolution of the Composition viewer for the composition in which the
layer is contained.

. To the to
View a color channel or alpha channel ’
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You can view red, green, blue, and alpha channels—together or separately—in a Footage, Layer, or Composition panel by clicking the Show
Channel button @ at the bottom of the panel and choosing from the menu. When you view a single color channel, the image appears as a
grayscale image, with the color value of each pixel mapped to a scale from black (0 value for the color) to white (maximum value for the color).

Q To see color values displayed in the channel’'s own color instead of white, choose Colorize from the Show Channel menu.

When you preview the alpha channel, the image appears as a grayscale image, with the transparency value of each pixel mapped to a scale from
black (completely transparent) to white (completely opaque).

Note: When you choose RGB Straight, which shows straight RGB values before they are matted (premultiplied) with the alpha channel, pixels
with complete transparency are undefined and therefore may contain unexpected colors.

You can view other channel values, such as saturation and hue, by applying the Channel Combiner effect and choosing Lightness from the To
menu.

Q To switch between showing the alpha channel and showing all RGB channels, Alt-click (Windows) or Option-click (Mac OS) the Show Channel
button.

Alpha Boundary and Alpha Overlay view modes are only available in the Layer panel, and they are intended for use with the Roto Brush effect.
For information on these modes, see Layer panel view options.

. . To thet
Adjust exposure for previews e

You can adjust the exposure (in f-stop units) for previews with the Adjust Exposure control, which is located to the right of the Reset Exposure
button EF at the bottom of a Composition, Layer, or Footage panel. Each viewer can have its own Adjust Exposure setting.

When the Adjust Exposure control is set to a value other than zero, the Reset Exposure button is orange .

The Adjust Exposure control doesn’t affect final output, only how video appears during previews. To make tonal adjustments to a layer that appear
in final output, use the Exposure effect.

Q The Adjust Exposure control is useful for finding the black point or white point in an image. For example, drag the value control to the right
(positive values) until the entire image is white except for one area; that area is the darkest area in the image.

Q To check the quality of a composite, drag the Adjust Exposure control far to the left and far to the right and look for places where the
composited elements differ too much in color or luminance. This technigue—sometimes called gamma slamming—is useful for ensuring that a
composite will look good and be convincing in contexts other than the one in which you're working. For example, a composite that is adequate
in a dark scene may be less convincing when the scene is color-corrected to brighten the scene.

« To adjust exposure for a viewer, drag the Adjust Exposure control to the left or right, or click the control and enter a value in the box.
« To reset exposure, click the Reset Exposure button. To return to the most recent nonzero setting, click the button again.

. . To the to
Safe zones, grids, guides, and rulers .

In the Footage, Layer, and Composition panels, you can display safe zone margins, grids, rulers, and guide lines to align and arrange visual
elements. After Effects preserves guides when importing Photoshop files saved with guides.

Safe-zone margins, grids, and guides are not rendered, either for RAM previews or for final output.

The size of proportional grids increases or decreases when the composition size changes; the size of standard grid squares remains the same
regardless of composition size.

« To change settings for safe-zone margins, grids, and guides, choose Edit > Preferences > Grids & Guides (Windows) or After Effects >
Preferences > Grids & Guides (Mac OS).

« To show or hide safe zones, grids, guides, or rulers, click the Grid And Guides Options button &3 and choose the appropriate item, or use a
menu command or keyboard shortcut in the View menu.

« To toggle between showing and hiding the safe zones, Alt-click (Windows) or Option-click (Mac OS) the Grid And Guide Options button.
« To make layer edges and mask edges snap to grids or guides, choose View > Snap To Grid or View > Snap To Guides.

« To create a guide line, drag from either ruler.

« To delete a guide line, drag it to a ruler using the Selection tool.

« To delete all guide lines, choose View > Clear Guides.

« To move a guide line, drag it using the Selection tool.

« To lock or unlock guides, choose View > Lock Guides. Locking a guide prevents it from being accidentally moved.

« To set the zero point (origin) for the rulers, drag the crosshair from the intersection of the two rulers (in the upper-left corner) into the image
area. Reset the zero point by double-clicking the intersection of the rulers. The position of the pointer measured from the new zero point is
shown in the Info panel as X' and Y' coordinates.
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Dragging the zero-point crosshair

About title-safe and action-safe zones

Television sets enlarge a video image and allow some portion of its outer edges to be cut off by the edge of the screen. This kind of cropping is
known as overscan. The amount of overscan is not consistent between television sets, so you should keep important parts of a video image within
certain margins, in areas known as safe zones. Safe-zone margins represent the percentage of image dimensions not included in the safe zone.
You should always design from one edge of the frame to the other, because computer monitors and some television sets may show the entire
frame.

The conventional action-safe zone is 90% of the width and height of the frame, which corresponds to a margin of 5% on each side. Keep
important visual elements within this zone.

The conventional title-safe zone is 80% of the width and height of the frame, which corresponds to a margin of 10% on each side. Keep text that
you intend for the audience to read within this zone.

Compositions with a frame aspect ratio equal to or near 16:9 have two additional center-cut safe-zone indicators. The center-cut indicators show
which parts of a 16:9 composition may be cut off when the image is shown on a 4:3 display. Such cropping is a concern when creating images for
high-definition displays that may also be shown on standard-definition television sets. By default, the center-cut action-safe margin is 32.5%
(16.25% on each side), and the center-cut title-safe margin is 40% (20% on each side).

Note: The center-cut safe-zone margins are only shown if the frame aspect ratio for the composition is equal to or near 16:9.

o N =

m

Safe zones and grids in Composition panel
A. Grid B. Center-cut title-safe zone C. Center-cut action-safe zone D. Title-safe zone E. Action-safe zone

Aharon Rabinowitz provides a video tutorial in the Multimedia 101 series on the Creative COW website that explains safe zones.

.. . . . . To the to
Additional resources for viewing and previewing ’

When you want to view certain crucial frames in a composition—such as when showing them to a client for interim approval—you may want to
create a contact sheet. Jeff Almasol provides a script that creates a contact sheet that consists of a grid of specific individual frames from a
composition. You specify which frames to show by setting layer markers. For more information, go to Jeff Almasol's redefinery website.

More Help topics
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Animation and Keyframes
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Animation basics

About animation, keyframes, and expressions
The Graph Editor

. . . To the to
About animation, keyframes, and expressions ’
Animation is change over time. You animate a layer or an effect on a layer by making one or more of its properties change over time. For example,
you can animate the Opacity property of a layer from 0% at time zero to 100% at time 1 second to make the layer fade in. Any property with a
stopwatch button ™ to the left of its name in the Timeline panel or Effect Controls panel can be animated.

A 2] be Position
B 7 Scale

- 7 Ratation
Stopwatch icons

A. Active stopwatch B. Inactive stopwatch

You animate layer properties using keyframes, expressions, or both.

Many animation presets include keyframes and expressions so that you can simply apply the animation preset to the layer to achieve a complex
animated result.

You work with keyframes and expressions in After Effects in one of two modes: layer bar mode or Graph Editor mode. Layer bar mode is the
default, which shows layers as duration bars, with keyframes and expressions aligned vertically with their properties in the Timeline panel. Graph
Editor mode does not show layer bars, and shows keyframes and expression results in value graphs or speed graphs. (See The Graph Editor.)

Keyframes

Keyframes are used to set parameters for motion, effects, audio, and many other properties, usually changing them over time. A keyframe marks
the point in time where you specify a value for a layer property, such as spatial position, opacity, or audio volume. Values between keyframes are
interpolated. When you use keyframes to create a change over time, you typically use at least two keyframes—one for the state at the beginning of
the change, and one for the new state at the end of the change. (See Set or add keyframes.)

When the stopwatch is active for a specific property, After Effects automatically sets or changes a keyframe for the property at the current time
whenever you change the property value. When the stopwatch is inactive for a property, the property has no keyframes. If you change the value
for a layer property while the stopwatch is inactive, that value remains the same for the duration of the layer.

Note: When Auto-keyframe mode is on, the stopwatch is activated automatically for a property when it's modified. (See Auto-keyframe mode.)

If you deactivate the stopwatch, all keyframes for that layer property are deleted, and the constant value for the property becomes the value at the
current time. Don’t deactivate the stopwatch unless you're sure that you want to permanently delete all of the keyframes for that property.

Q Change the keyframe icons in layer bar mode to numbers by choosing Use Keyframe Indices in the Timeline panel menu.

Keyframes as icons compared to keyframes as numbers

Note: When a layer property that contains keyframes is collapsed, gray dots (summary keyframe indicators) for the property group show that
there are keyframes contained within it.

Some tools, such as Motion Sketch and the Puppet tools, automatically set keyframes for you to match motion that you sketch.

Expressions
Expressions use a scripting language based on JavaScript to specify the values of a property and to relate properties to one another. You can
create simple expressions by connecting properties with the pick whip. (See About expressions.)
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Online animation resources

Aharon Rabinowitz provides some video tutorials that introduce animation as part of the Multimedia 101 series, including “How Does Computer
Animation Work?” and “What is interpolation?”

For a video tutorial on animating using keyframes and using the Timeline panel, go to the Adobe website.
Shaun Freeman's website provides links to information about the theory and practice of animation, especially character animation.

For a step-by-step tutorial that demonstrates the animation of individual layers from a Photoshop (PSD) file, see the “Animating Layers in After
Effects” chapter of the After Effects Classroom in a Book on the Peachpit Press website.

To the top

The Graph Editor

The Graph Editor represents property values using a two-dimensional graph, with composition time represented horizontally (from left to right). In
layer bar mode, on the other hand, the time graph represents only the horizontal time element, without showing a graphical, vertical representation
of changing values.

Q To toggle between layer bar mode and Graph Editor mode, click the Graph Editor button in the Timeline panel or press Shift+F3.

w2 o G - d

Two animated properties (Position and Scale) shown in the Graph Editor

Two types of graphs are available in the Graph Editor: value graphs, which show property values; and speed graphs, which show rates of change
of property values. For temporal properties, such as Opacity, the Graph Editor defaults to the value graph. For spatial properties, such as Position,
the Graph Editor defaults to the speed graph. For information on viewing and editing keyframe values, see View or edit a keyframe value.

In the Graph Editor, each property is represented by its own curve. You can view and work on one property at a time, or you can view multiple
properties simultaneously. When more than one property is visible in the Graph Editor, each property’s curve has the same color as the property’s
value in the layer outline.

When you drag a keyframe in the Graph editor with the Snap button ¥ selected, the keyframe snaps to keyframe values, keyframe times, the
current time, In and Out points, markers, the beginning and end of the work area, and the beginning and end of the composition. When the
keyframe snaps to one of these items, an orange line appears in the Graph Editor to indicate the object you're snapping to. Hold Ctrl (Windows) or
Command (Mac OS) after you've begun dragging to temporarily toggle snapping behavior.

Keyframes in Graph Editor mode may have direction handles attached to one or both sides. Direction handles are used to control Bezier
interpolation.

Keyframes in the Graph Editor with direction handles

You can use the Separate Dimensions 2= button at the bottom of the Graph Editor to separate the components of a Position property into
individual properties—X Position, Y Position, and (for 3D layers) Z Position—so that you can modify or animate each independently. (See
Separate dimensions of Position to animate components individually.)

Online resources about the Graph Editor
Lee Brimelow provides a video overview of the Graph Editor on the Adobe website.

Antony Bolante provides information, tips, illustrations about using the Graph Editor in an article on the Peachpit Press website.

Specify which properties are shown in the Graph Editor

%+ Click the Show Properties button . at the bottom of the Graph Editor, and select from the following options:
Show Selected Properties Displays selected properties in the Graph Editor.

Show Animated Properties Displays animated properties of selected layers in the Graph Editor.

Show Graph Editor Set Displays properties that have the Graph Editor switch i< selected. This switch is next to the stopwatch, to the left of the
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property name, when the stopwatch is active—that is, when the property has keyframes or expressions.
Note: Aharon Rabinowitz provides tips for using this control and showing the audio waveform for a deselected layer on the Creative COW
website.

Graph options in the Graph Editor

Click the Graph Type And Options button (2. at the bottom of the Graph Editor to select from the following options:

Auto-Select Graph Type Automatically selects the appropriate graph type for a property: speed graphs for spatial properties (such as Position),
and value graphs for other properties.

Edit Value Graph Displays the value graph for all properties.

Edit Speed Graph Displays the speed graph for all properties.

Show Reference Graph Displays the unselected graph type in the background for viewing only. (The gray numbers to the right of the Graph
Editor indicate the values for the reference graph.)

Show Audio Waveforms Displays the audio waveform for any layer that has at least one property in the Graph Editor.

Show Layer In/Out Points Displays In and Out points of all layers that have a property in the Graph Editor. In and Out points appear as curly
braces.

Show Layer Markers Displays layer markers in the Graph Editor, if they exist, for any layer that has at least one property in the Graph Editor.
Layer markers appear as small triangles.

Show Graph Tool Tips Toggles the graph tool tips on and off.
Show Expression Editor Shows or hides the expression editor field.
Allow Keyframes Between Frames Allows placement of keyframes between frames for fine-tuning animation.

Pan and zoom in the Graph Editor
« To pan vertically or horizontally, drag with the Hand tool {f)
Q To activate the Hand tool momentarily when using another tool, press and hold the spacebar or the middle mouse button.
« To pan vertically, roll the mouse scroll wheel.
« To pan horizontally, press the Shift key as you roll the mouse scroll wheel.
e To zoom in, click with the Zoom tool.
e To zoom out, Alt-click (Windows) or Option-click (Mac OS) with the Zoom tool.

« To zoom using the mouse scroll wheel, press Alt (Windows) or Option (Mac OS) while scrolling to zoom horizontally. Press Ctrl (Windows) or
Command (Mac OS) to zoom vertically.

* To zoom horizontally, Alt-drag (Windows) or Option-drag (Mac OS) to the left with the Zoom tool to zoom out or to the right to zoom in.

« To zoom vertically, Alt-drag (Windows) or Option-drag (Mac OS) up with the Zoom tool to zoom in or down to zoom out.
Note: You cannot pan or zoom vertically when Auto Zoom Height ¥4 is selected.

Auto Zoom Height and Fit
Auto Zoom Height ¥4 Toggles Auto Zoom Height mode, which automatically scales the height of the graph so that it fits the height of the Graph
Editor. The horizontal zoom must still be adjusted manually.

Fit Selection [™] Adjusts the value (vertical) and time (horizontal) scale of the graph to fit the selected keyframes in the Graph Editor.
Fit All 2= Adjusts the value (vertical) and time (horizontal) scale of the graph to fit all of the graphs in the Graph Editor.
More Help topics
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Setting, selecting, and deleting keyframes

Set or add keyframes

Move the current-time indicator (CTI) to a keyframe
Select keyframes

Keyframe menu commands

Delete or disable keyframes

Set or add keyframes To the top

When the stopwatch is active for a specific property, After Effects automatically adds or changes a keyframe for the property at the current time
whenever you change the property value.
To activate the stopwatch and enable keyframing, do one of the following

« Click the Stopwatch icon  next to the property name to activate it. After Effects creates a keyframe at the current time for that property
value.

« Choose Animation > Add [x] Keyframe, where [x] is the name of the property you are animating.

Add a keyframe without changing a value
+ Do one of the following:

« Click the keyframe navigator button < for the layer property.

« Choose Animation > Add [x] Keyframe, where [X] is the name of the property you are animating.

« Click a segment of the layer property’s graph in the Graph Editor with the Pen tool ‘3 .

Auto-keyframe mode
The Auto-keyframe button ™ is a switch located at the top of the Timeline panel, to the right of the composition switches. Click the Auto-keyframe
button to turn Auto-keyframe mode on or off.

When Auto-keyframe mode is on, modifying a property automatically activates its stopwatch and adds a keyframe at the current time.

Note: Auto-keyframe mode doesn’t automatically activate the stopwatch for properties that aren’t interpolated, such as menus, checkboxes, and
the Source Text property.

Auto-keyframe mode is off by default. When Auto-keyframe mode is off, modifying properties and animating with keyframes behave as in previous
versions of After Effects.

. L To thet
Move the current-time indicator (CTI) to a keyframe et
After you set the initial keyframe for a property, After Effects displays the keyframe navigator. You can use the keyframe navigator to move from
keyframe to keyframe or to set or remove keyframes. When the keyframe navigator box is filled with a yellow diamond 4 < ¥, the current-time
indicator lies precisely at a keyframe for that layer property. When the keyframe navigator box is not filled 4 * B, the current-time indicator lies
between keyframes.

Q To detach the keyframe navigator from the A/V Features column to function as its own column, choose Column > Keys from the Timeline panel
menu.
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Keyframe navigator in Timeline panel
A. Keyframe at current time B. No keyframe at current time C. No keyframes for layer property

» To move to the next or previous keyframe, click a keyframe navigator arrow.
« To snap to a keyframe or marker, Shift-drag the current-time indicator.
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« To move to the next or previous visible item in the time ruler (keyframe, marker, or work area end), press K or J.

For instructions for moving the current-time indicator to other elements and times, see Move the current-time indicator (CT]I).

To thet
Select keyframes e

In layer bar mode, selected keyframes are yellow. Unselected keyframes are gray.

In Graph Editor mode, the appearance of a keyframe icon depends on whether the keyframe is selected, unselected, or semi-selected (another
keyframe in the same property is selected). Selected keyframes are solid yellow. Unselected keyframes retain the color of their corresponding
graph. Semi-selected keyframes are represented by a hollow yellow box.

» To select a keyframe, click the keyframe icon.

« To select multiple keyframes, Shift-click the keyframes or drag a marquee (selection box) around the keyframes. If a keyframe is selected,
Shift-clicking it deselects it; Shift-dragging to draw a marquee around selected keyframes deselects them.
Note: To toggle viewing of the free-transform bounding box in the Graph Editor, click the Show Transform Box button £ at the bottom of the
Graph Editor.

« To select all keyframes for a layer property, Alt-click (Windows) or Option-click (Mac OS) a segment between two keyframes in the Graph
Editor, or click the layer property name in the layer outline.

« To select all keyframes for a property that have the same value, right-click (Windows) or Control-click (Mac OS) a keyframe, and choose
Select Equal Keyframes.

» To select all keyframes that follow or precede a selected keyframe, right-click (Windows) or Control-click (Mac OS) a keyframe, and choose
Select Previous Keyframes or Select Following Keyframes.
Note: The Select Previous/Following Keyframes commands aren’t available if more than one keyframe is selected.

To the to
Keyframe menu commands ’

When you select one or more keyframes, the keyframe menu <. becomes available at the bottom of the Graph Editor.

Q To open the keyframe menu, right-click (Windows) or Control-click (Mac OS) a keyframe.

[Value] Displays the value of the selected keyframe. If more than one keyframe is selected, the Display Value command is available, which
displays the value of the highlighted keyframe in the selection.

Edit Value Opens a dialog box in which you can edit the value of the keyframe.

Select Equal Keyframes Selects all keyframes in a property that have the same value.

Select Previous Keyframes Selects all keyframes preceding the currently selected keyframe.

Select Following Keyframes Selects all keyframes following the currently selected keyframe.

Toggle Hold Keyframe Holds the property value at the value of the current keyframe until the next keyframe is reached.
Keyframe Interpolation Opens the Keyframe Interpolation dialog box.

Rove Across Time Toggles Rove Across Time for spatial properties.

Keyframe Velocity Opens the Keyframe Velocity dialog box.

Keyframe Assistant Opens a submenu with the following options:

Convert Audio To Keyframes Analyzes amplitude within the composition work area and creates keyframes to represent the audio.
Convert Expression To Keyframes Analyzes the current expression and creates keyframes to represent the property values it
describes.

Easy Ease Automatically adjusts the influence into and out of a keyframe to smooth out sudden changes.

Easy Ease In Automatically adjusts the influence into a keyframe.

Easy Ease Out Automatically adjusts the influence out of a keyframe.

Exponential Scale Converts the rate of change in scale from linear to exponential.

RPF Camera Import Imports RPF camera data from third-party 3D modeling applications.

Sequence Layers Opens the Sequence Layers assistant.

Time-Reverse Keyframes Reverses selected keyframes in time.

. To the to
Delete or disable keyframes 0

« To delete any number of keyframes, select them, and then press the Delete key.
» To delete one keyframe in the Graph Editor, Ctrl-click (Windows) or Command-click (Mac OS) a keyframe with the Selection tool.
« To delete all keyframes for one layer property, click the stopwatch button  to the left of the name of the layer property to deactivate it.

When you click the stopwatch button to deactivate it, keyframes for that property are permanently removed and the value of that property
becomes the value at the current time. You cannot restore deleted keyframes by clicking the stopwatch button again. Deleting all keyframes
does not delete or disable expressions.

« To temporarily disable keyframes for a property, add an expression that sets the property to a constant value. For example, you can add this
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very simple expression to the Opacity property to set it to 100%: 100.
Q Click the Enable Expression button to toggle the expression on and off, which toggles the keyframes off and on as a side effect.

If you accidentally delete keyframes, choose Edit > Undo.

Jeff AlImasol provides a script on his redefinery website that automatically removes keyframes based on specified criteria—for example, all
keyframes in the work area, all odd-numbered keyframes.

More Help topics
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Editing, moving, and copying keyframes

View or edit a keyframe value

Copy and paste keyframes

Edit keyframe values using a spreadsheet or text editor
Move keyframes in time

Move a layer duration bar but not its keyframes
Change multiple keyframe values at once

Move or change keyframes in the Graph Editor

. . To the to
View or edit a keyframe value 0

Before you change a keyframe, make sure that the current-time indicator is positioned at an existing keyframe. If you change a property value
when the current-time indicator is not at an existing keyframe, After Effects adds a new keyframe. However, if you double-click a keyframe to
modify it, the current-time indicator location is not relevant, nor is it relevant when you change the interpolation method of a keyframe.

« Move the current-time indicator to the time of the keyframe. The value of the property appears next to the property name, where you can edit
it.

« Right-click (Windows) or Control-click (Mac OS) the keyframe. The keyframe value appears at the top of the context menu that appears.
Choose Edit Value to edit the value, if desired.

« Place the pointer over a keyframe in layer bar mode to see the time and value of the keyframe.

« Place the pointer over a keyframe in Graph Editor mode to see the layer name, property name, time, and value of the keyframe. Place the
pointer over a segment between keyframes to see the corresponding information at any time.

« Click a keyframe in layer bar mode to show the keyframe’s time and interpolation method in the Info panel.

« Click a keyframe or segment between keyframes in Graph Editor mode to show a property’s minimum and maximum values and the speed at
the current time in the Info panel.

« Alt-click (Windows) or Option-click (Mac OS) two keyframes in layer bar mode to display the duration between them in the Info panel.

Jeff AlImasol provides a script on his redefinery website that creates new layer markers (either on the selected layer or on a new null layer) with
comments that provide information about keyframes at the same times.

Copy and paste keyframes To the top

You can copy keyframes from only one layer at a time. When you paste keyframes into another layer, they appear in the corresponding property in
the destination layer. The earliest keyframe appears at the current time, and the other keyframes follow in relative order. The keyframes remain
selected after pasting, so you can immediately move them in the destination layer.

You can copy keyframes between layers for the same property (such as Position) or between different properties that use the same type of data
(such as between Position and Anchor Point).

Note: When copying and pasting between the same properties, you can copy from more than one property to more than one property at a time.
However, when copying and pasting to different properties, you can copy only from one property to one property at a time.
1. In the Timeline panel, display the layer property containing the keyframes you want to copy.

2. Select one or more keyframes.
3. Choose Edit > Copy.
4

. In the Timeline panel containing the destination layer, move the current-time indicator to the point in time where you want the keyframes to
appear.

5. Do one of the following:
« To paste to the same property of the copied keyframes, select the destination layer.
« To paste to a different property, select the destination property.

6. Choose Edit > Paste.

Edit keyframe values using a spreadsheet or text editor fothetop

You can copy and paste keyframe data as tab-delimited text for use in a spreadsheet program (such as Microsoft Excel) or other text-editing
program. You can use a spreadsheet program to perform numerical analysis on keyframe data or create or edit keyframe values.
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You can copy and paste most properties, including the Transform properties (such as Position and Opacity), Material Options properties, and
motion trackers.

Q You can use the motion tracking tools to track the motion of an object in a layer, and then paste the tracker data into a spreadsheet to perform
numerical analysis on the data.
Some utility applications, such as Imagineer Systems mocha for After Effects (mocha-AE), copy keyframe data to the clipboard so that you can
paste it into the appropriate layer in After Effects.
You can copy keyframes from only one layer at a time as tab-delimited text.
1. In the Timeline panel, select keyframes for one or more properties on the same layer. To select all keyframes for a property, click the name
of the property.
2. Move the current-time indicator to the first selected keyframe.
Q Place a composition marker at the time of the first selected keyframe so that you will know where to paste the modified keyframes in the
last step. (See Layer markers and composition markers.)
3. With the keyframes selected, choose Edit > Copy.

4. Paste keyframe data into the spreadsheet. Assuming that the first column in the spreadsheet is labeled A and the first row is labeled 1, you
should paste into cell A1l. Frame numbers appear in column B. Property values appear in columns C, D, and E, depending on the
dimensions of the property. (Position in a 3D layer has values in all three columns; Opacity has only a value in column C.)

5. Edit the numerical information for the keyframes. Do not change any text other than frame numbers and property values.

6. Select the cells that contain your data. The top-left cell in your selection should be Al. The bottom row of your selection should be the row
that contains the text End of Keyframe Data.

7. Copy the data from the spreadsheet.

8. In After Effects, move the current-time indicator to the time at which you want to paste the new keyframe data. This time is usually the time
of the first keyframe that you selected and copied at the beginning of this procedure.

9. Choose Edit > Paste.

. . To thet
Move keyframes in time o e

You can move keyframes in time, either individually or as a group.

Jeff AlImasol provides a versatile script on his redefinery website that creates a panel with controls for moving various combinations of items in time
—Ilayer In point, layer Out point, layer source frames, keyframes, and markers.

Move keyframes to another time
With multiple keyframes selected, you can copy or delete them simultaneously or move the keyframes together without changing their positions
relative to each other.
1. Select one or more keyframes.
2. Drag any of the selected keyframe icons to the desired time. If you selected multiple keyframes, then all of the selected keyframes maintain
their relative distance from the keyframe that you drag.

Q You can also move selected keyframes in time (one frame earlier or later) by pressing the Alt (Windows) or Option (Mac OS) key with the left
arrow or right arrow key.

Move a keyframe to a specific time
1. Move the current-time indicator to the desired time.
2. Do one of the following:

« In layer bar mode, hold down Shift after you begin to drag a keyframe icon to the current-time indicator.
« In Graph Editor mode, drag a keyframe to the current-time indicator.

When you drag over the current-time indicator, the keyframe snaps to the current-time indicator.

Expand or contract a group of keyframes in layer bar mode
1. Select at least three keyframes.
2. Hold down Alt (Windows) or Option (Mac OS) and drag the first or last selected keyframe to the desired time.

Move a layer duration bar but not its keyframes fothetop

1. Place a composition marker at the time at which the first keyframe appears. (See Composition markers.)
2. In the layer outline, click the name of one or more layer properties containing the keyframes you want to keep at the same times.
3. Choose Edit > Cut.
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4. Move or stretch the layer duration bar to its new In and Out points.
5. Move the current-time indicator to the composition marker at the time at which the first keyframe appeared before you cut the keyframes.
6. Choose Edit > Paste.

. To the to
Change multiple keyframe values at once 0
You can change the values of multiple keyframes on multiple layers at one time; however, all keyframes you select must belong to the same layer
property. The way the selected values change depends on the method you use to make the change:

« If you change a value numerically, all selected keyframes use the new value exactly. In other words, you make an absolute change. For
example, if you select several Position keyframes on a motion path and numerically specify a Position value for one of them, all selected
keyframes change to the same position value.

« If you change a value by dragging the underlined value, all selected keyframes change by the same amount. In other words, you make a
relative change. For example, if you select several Position keyframes on a motion path and drag the underlined value for one of them, all
selected keyframe values change by the same amount.

 If you change a value graphically in the Composition or Layer panel, all selected keyframes change using the difference between the old and
new values, not the values themselves. In other words, you make a relative change. For example, if you select several Position keyframes on
a motion path and then drag one of them 10 pixels to the left, they all move 10 pixels to the left of their original positions.

You can also change the value of several layers at once in layer bar mode by parenting them.

Mathias Mo6hl provides the KeyTweak script on his website, with which you can modify many keyframes on a property simultaneously. With
KeyTweak, you can modify a few keyframes manually, and the script modifies the remaining keyframes in between accordingly. KeyTweak is
especially useful for Mask Path keyframes in a rotoscoping workflow. (See Rotoscoping introduction and resources.)

. . To thet
Move or change keyframes in the Graph Editor e
A value graph in the Graph Editor displays the values for each keyframe and the interpolated values between keyframes. When the value graph of
a layer property is level, the value of the property is unchanged between keyframes. When the value graph goes up or down, the value of a layer
property increases or decreases between keyframes.

A B C D

0 %

b AN

Value graph
A. Keyframe. B. A level value graph indicates unchanging values. C. A rising graph indicates increasing values. D. A falling graph indicates
decreasing values.

You can change layer property values by moving the points (keyframes) on the value graph up or down. For example, you can increase the value
of a Rotation keyframe by dragging the keyframe marker on the Rotation property’s value graph higher up on the graph.

Note: Values for the Anchor Point, Mask Path, effect control points, 3D Orientation, and Position properties are spatial, so they use speed graphs
by default instead of value graphs.

Modify a single keyframe in the Graph Editor
1. In the Timeline panel, show a temporal property for a layer.
2. If necessary, click the Graph Editor button or press Shift+F3 to enter Graph Editor mode.
3. If necessary, add a keyframe at the point in time you want the change to occur.
4. Drag the keyframe up or down to set a new value for the layer property.

Modify multiple keyframes in the Graph Editor

You can edit and move multiple keyframes simultaneously using the Graph Editor. When you select multiple keyframes with the Show Transform
Box button selected, a free-transform bounding box surrounds the selected keyframes, and an anchor point appears in the center of the bounding
box to mark the center point for the transformation. You can move the selected keyframes in time or value by dragging the bounding box or its
handles. You can also change the position of the anchor point.

Adjusting a free-transform bounding box in a value graph moves the selected keyframes in time and value. Adjusting a free-transform bounding

193


http://aextensions.blogspot.com/2009/02/keytweak.html

box in a speed graph moves the selected keyframes in time only.

When you select muIthe keyframs in the Graph Editor, a free-transform bounding box appears.

1. Switch to the Graph Editor view and display the keyframes you want to adjust.
2. Using the Selection tool, do one of the following:

« To select keyframes, Shift-click the keyframes or drag to draw a marquee around the keyframes.

» To select all keyframes for a property, Alt-click (Windows) or Option-click (Mac OS) a segment between two keyframes.
3. Do any of the following:

« To move keyframes in time or value, place the pointer inside the bounding box and drag. Shift-drag to constrain the move horizontally or
vertically.

« To move keyframes in time or value by scaling the bounding box, place the pointer on a bounding box handle. When the pointer changes
to a straight, double-sided arrow ++*, drag the bounding box to a new size. Shift-drag to constrain the ratio of width to height. Ctrl-drag
(Windows) or Command-drag (Mac OS) to scale around the anchor point of the bounding box. When dragging a corner handle, Alt-drag
(Windows) or Option-drag (Mac OS) to move only that handle.

Q Scale by negative amounts to reverse the keyframes in time.

« To taper keyframe values vertically, Ctrl+Alt-drag (Windows) or Command+Option-drag (Mac OS). Tapering keyframe values allows you
to reduce or expand the amplitude of a repeated animation.

« To move one side of the bounding box up or down, Ctrl+Alt+Shift-drag (Windows) or Command+Option+Shift-drag (Mac OS).

« To move the anchor point of the bounding box, place the Selection tool over the anchor point until the tool changes to the Move Anchor
Point tool ™, and then drag.

More Help topics
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Assorted animation tools

Motion paths

Motion blur

Smooth motion and velocity by removing extra keyframes
Add randomness to a property with the Wiggler

Convert audio to keyframes

Motion paths To the top

When you animate spatial properties—including Position, Anchor Point, and effect control point properties—the motion is shown as a motion path.
A motion path appears as a sequence of dots, where each dot marks the position of the layer at each frame. A box in the path marks the position
of a keyframe.

Motion paths are simply an alternative visual, spatial way of viewing and working with spatial properties and their keyframes, in addition to the
ways that you work with properties in the Timeline panel. You can modify a motion path by changing an existing keyframe or adding a new
keyframe. You can modify the shape of a motion path by changing the spatial interpolation methods for its keyframes. (See About spatial and
temporal keyframe interpolation.)

The density of dots between the boxes in a motion path indicates the relative speed of the layer or effect control point. Dots close together
indicate a lower speed; dots farther apart indicate a greater speed.

Note: Right-click (Windows) or Command-click (Mac OS) a keyframe to open its context menu.

Using the Pen tool or Selection tool to edit keyframes for a spatial property in the Composition or Layer panel is like modifying a Bezier path for a
mask or for a shape on a shape layer. (See About paths.)

A motion path is less complex and generally easier to modify when you use fewer keyframes to describe the path. You can use the Smoother to
remove extraneous keyframes from a motion path.

Jonas Hummelstrand and Dan Ebberts provide an animation preset and instructions on the General Specialist website for scaling and rotating a
motion path.

Show motion path controls
Position motion paths appear in the Composition panel. Anchor Point and effect control point motion paths appear in the Layer panel.
« To show motion path controls in the Composition panel, choose View > View Options, and select Effect Controls, Keyframes, Motion Paths,
and Motion Handles. To see a Position motion path in the Composition panel, the Position property must be selected.
« To show motion path controls in the Layer panel, choose the property or effect from the View menu at the bottom of the Layer panel.

« To specify how many keyframes to show for a motion path, choose Edit > Preferences > Display (Windows) or After Effects > Preferences >
Display (Mac OS), and select an option in the Motion Path section.

« To specify the size of Bezier direction handles for motion paths, choose Edit > Preferences > General (Windows) or After Effects >
Preferences > General (Mac OS), and edit the Path Point Size value.

Move motion path keyframes
1. In the Timeline panel, select the layer for which to modify the motion path.
2. If you cannot see the keyframe you want to modify in the Composition panel or Layer panel, move the current-time indicator to the keyframe.

3. In the Composition panel or Layer panel, use the Selection tool to drag a keyframe or its handles.
Note: The current-time indicator does not need to be located on a keyframe before you drag it.
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Drag a keyframe in the Composition panel to move one Position keyframe.

You can move multiple keyframes at one time by selecting them in the Timeline panel before you drag them in the Composition panel or
Layer panel. To move the entire motion path, select all keyframes by clicking the property name in the Timeline panel before dragging a
keyframe in the Composition panel.

Dragging all keyframes on a motion path by one keyframe

Add a keyframe to a motion path using the Pen tool
1. Display the motion path that you want to modify in the Composition panel or Layer panel.

2. Select the Pen tool ‘5> or Add Vertex tool {T from the Tools panel.

3. In the Composition panel, place the Pen tool over the motion path where you want to add the new keyframe and click to add the keyframe.
A new keyframe appears at the frame you clicked, on the motion path and in the Timeline panel. To move the keyframe, use the Selection
tool.

Note: Though the results are different, the techniques for manipulating motion-path curves with the Pen tool work in much the same way as
the techniques used to create and modify other Bezier paths, such as mask and shape paths.

Sketch a motion path with Motion Sketch

You can draw a path for the motion of a selected layer using Motion Sketch, which records the position of the layer and the speed at which you
draw. As you draw, a Position keyframe is generated at each frame.

Motion Sketch does not affect keyframes that you have set for other properties. For example, if you set Rotation keyframes for an image of a ball,
you can use Motion Sketch to generate Position keyframes, so that the ball appears to roll along the path you created.
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John Dickinson provides a demonstration of Motion Sketch in a video tutorial on his Motionworks website.

1. In the Composition or Timeline panel, select the layer for which you want to sketch a motion path.

In the Timeline panel, set the work-area markers to the duration in which you want to sketch motion.

If you want to hear the audio in your composition as you sketch, make sure that the Mute Audio button is not selected in the Preview panel.
Choose Window > Motion Sketch.

a v

Select the appropriate Motion Sketch options:
Show Wireframe Displays a wireframe view of the layer as you sketch the motion path.

Show Background Displays the static contents of the frame at which you started sketching in the Composition panel while you sketch. This
option is useful if you want to sketch motion relative to other images in your composition.

Smoothing Eliminates unnecessary keyframes from the motion path. This setting has the same result as using the Tolerance setting with
the Smoother. Higher values produce smoother curves, but too high a value may not preserve the shape of the curve that you draw.
Note: You can smooth a motion path after it has been created by using the smooth expression or the Smoother.

Capture Speed At The ratio of the speed of the recorded motion to the speed of playback. If Capture Speed At is 100%, the motion is
played back at the speed at which it was recorded. If Capture Speed At is greater than 100%, the motion plays back slower than it was
recorded.

6. Click Start Capture and then drag in the Composition panel to create the motion path. Release the mouse button to stop capturing.
Note: After Effects automatically ends capturing when the capture time reaches the end of the work area (which, by default, is the
composition duration).

Create a motion path from a mask, shape, or paint path
You can create a motion path from any of several types of paths:

« A Mask Path property

« A shape Path property on a shape layer

« A Path property for a paint stroke

» A path copied from lllustrator or Photoshop

You can paste any of these paths into the Position or Anchor Point property for a layer, or into the position property of an effect control point. The
pasted keyframes are set to rove in time, except for the first and last ones, to create a constant velocity along the path.

By default, the duration of the pasted motion path is 2 seconds. You can adjust the duration by dragging the first or last keyframe in the Timeline
panel.

1. Copy a path to the clipboard:
« Select a Path property in the Timeline panel, and choose Edit > Copy.
« Select a path in lllustrator or Photoshop, and choose Edit > Copy.

2. In the Timeline panel, select the property into which to paste the path.
3. Place the current-time indicator at the time for the first keyframe of the motion path.
4. Choose Edit > Paste.

Andrew Devis shows how to use paths from Illustrator as motion paths in After Effects in this video on the Creative COW website.

. To the to
Motion blur ’
When you view one frame of motion-picture film or video containing a moving object, the image is often blurred, because a frame represents a
sample of time (in film, a frame is 1/24 of a second long). In that time, a moving object occupies more than one position as it travels across the
frame, so it doesn’'t appear as a sharp, still object. The faster the object moves, the more it is blurred. The camera shutter angle and shutter phase
also affect the appearance of the blur, determining how long the shutter stays open and when the shutter opens relative to the beginning of the
frame.

In contrast, in a single frame of a computer-generated animation, you may not be able to tell which objects are moving because all moving objects
may appear as sharp and clear as nonmoving objects. Without motion blur, layer animation produces a strobe-like effect of distinct steps instead
of an appearance of continuous change. Adding motion blur to layers that you animate in After Effects makes motion appear smoother and more
natural.

You enable motion blur for each layer individually, and you also determine whether the motion blur is rendered for previews and final output. Use

the Enable Motion Blur composition switch © at the top of the Timeline panel to enable or disable motion blur rendering for previews. Modify the
render settings in the Render Queue panel to enable or disable motion blur rendering for final output. If the Switches Affect Nested Comps
preference in the General preferences category is enabled, then nested compositions obey the setting for the compositions in which they’re
contained. (See About precomposing and nesting.)

Motion blur slows rendering, so you may want to disable the composition switch while working, and only enable it when you need to see the
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finished result.
To enable motion blur for a layer, do one of the following:

 Click the Motion Blur # layer switch for the layer in the Timeline panel.
« Select the layer and choose Layer > Switches > Motion Blur.

The number of samples that After Effects uses to calculate motion blur adapts for each layer, depending on the motion of that layer. This
adaptivity provides high-quality motion blur without unnecessarily sampling the motion of a slow-moving layer as frequently as the motion of a fast-
moving layer. High sampling rates decrease rendering performance.

When motion blur is enabled for a composition and the Timeline panel is zoomed in so that you can see individual frames, a light gray region
around the current-time indicator indicates the shutter phase and shutter angle. The width of the column shows the shutter angle, and the offset of
the column shows the shutter phase. This visual indication shows how individual frames are sampled to calculate motion blur within this
composition.

You can use motion blur when you animate a layer—for example, moving a layer of text across the screen. You cannot add motion blur to motion
that already exists within a layer by means of the Motion Blur layer switch and Enable Motion Blur composition switch.

If you want to smooth live-action video to which you assigned a frame rate much lower or higher than the original, use frame blending, not motion
blur.

Motion blur settings in the Advanced tab of Composition Settings

Samples Per Frame The minimum number of samples. This minimum is the number of samples used for frames for which After Effects is not

able to determine an adaptive sampling rate based on layer motion. This sample rate is used for 3D layers and shape layers.

Adaptive Sample Limit The maximum number of samples.

Shutter Angle The shutter angle is measured in degrees, simulating the exposure allowed by a rotating shutter. The shutter angle uses the

footage frame rate to determine the simulated exposure, which affects the amount of motion blur. For example, entering 90° (25% of 360°) for 24-

fps footage creates an effective exposure of 1/96 of a second (25% of 1/24 of a second). Entering 1° applies almost no motion blur, and entering

720° applies a large amount of blur.

Shutter Phase The shutter phase is also measured in degrees. It defines an offset that determines when the shutter opens relative to the

beginning of a frame. Adjusting this value can help if an object with motion blur applied appears to lag behind the position of the object without

motion blur applied.

Q A Shutter Phase value that is -1/2 of the Shutter Angle value is best for a layer that is composited on top of another using motion tracking data.
(For example, Shutter Phase = -90, Shutter Angle = 180.) This setting combination causes a blur that is centered on the original object.

Apply motion blur to a mask
Motion blur creates a blur based on the movement of a mask in the composition. You can apply motion blur to individual masks. Within each
composition, the Enable Motion Blur composition switch must be selected for any layer or any mask within a layer to exhibit motion blur.

1. Select one or more masks.

2. Choose Layer > Masks > Motion Blur, and choose one of the following options:
Same As Layer The mask will have motion blur only if the Motion Blur switch is selected for the layer.

On The mask will have motion blur regardless of the setting of the Motion Blur switch for the layer.

Off The mask will not have motion blur.

Additional resources about motion blur
Mark Christiansen explains some of the concepts surrounding motion blur, shutter speed, and shutter angle on the ProVideo Coalition website.

Trish and Chris Meyer provide instructions on the ProVideo Coalition website for shooting footage and using motion blur to smooth motion.

Andrew Kramer provides a video tutorial on his Video Copilot website in which he demonstrates the advantages of using 32-bpc color with motion
blur. (See Color depth and high dynamic range color.)

The ReelSmart Motion Blur effect from RE:Vision Effects analyzes motion from frame to frame within a layer and uses this information to add

motion blur to motion within the layer. For information, see the RE:Vision Effects website.

Q To achieve a result similar to the result of ReelSmart Motion Blur, apply the Timewarp effect, set Speed to 100, enable motion blur within the
effect, and use the manual shutter control features to adjust the motion blur.

Smooth motion and velocity by removing extra keyframes fothetop

Smooth motion paths, value curves, and velocity curves to eliminate bumpiness or excess keyframes using the Smoother, which adds keyframes
or removes unnecessary keyframes.

Q You can also use the smooth expression method for this purpose, without removing keyframes. (See Property attributes and methods
(expression reference).)

Although you can smooth a curve for any property, the Smoother is most useful when applied to curves that have been automatically generated by
Motion Sketch, where you may have excess keyframes. Applying the Smoother to keyframes that have been set manually may result in
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unexpected changes to the curve.

Note: To avoid the need to use the Smoother on a path generated by Motion Sketch, set the Smoothing option in the Motion Sketch panel before
sketching the motion path.

When you apply the Smoother to properties that change spatially (such as Position), you can smooth only the spatial curve (the curve defined by
the motion). When you apply the Smoother to properties that change only in time (such as Opacity), you can smooth only the value and velocity
curves (the curve defined by the value or the velocity).

In addition to adding keyframes or eliminating unnecessary keyframes, the Smoother also applies Bezier interpolation at each keyframe when
smoothing the temporal curve. (See Keyframe interpolation methods.)

1. In the Timeline panel, either select all the keyframes for a property to smooth the entire curve, or select at least three keyframes to smooth
only a portion of a curve.

2. Choose Window > Smoother. In the Apply To menu, the Smoother automatically selects Spatial Path or Temporal Graph, depending on the
type of property for which you selected keyframes in step 1.

3. Set a value for Tolerance. The units of Tolerance match the units of the property you are smoothing. New keyframe values will vary no more
than the specified value from the original curve. Higher values produce smoother curves, but too high a value may not preserve the original
shape of the curve.

4. Click Apply and preview the results.
5. If necessary, choose Edit > Undo Smoother to reset the keyframes, adjust the value for Tolerance, and then reapply the Smoother.

Add randomness to a property with the Wiggler To the top

You can add randomness to any property as it varies over time by using the Wiggler.

Q You can also use the wiggle expression method for this purpose. In most cases, it is easier to use the expression than to use the Wiggler. (See
Property attributes and methods (expression reference).)

Depending on the property and the options you specify, the Wiggler adds a certain number of deviations to a property by adding keyframes and

randomizing interpolations coming into or out of existing keyframes. You need at least two keyframes to use the Wiggler.

Using the Wiggler, you can more closely simulate natural movement within specified limits. For example, add randomness to an animated butterfly
to produce fluttering. Add it to brightness or opacity to simulate the flicker of an old projector.

1. Select a range of keyframes for the property.

2. Choose Window > Wiggler.

3. For Apply To, select the type of curve you want the Wiggler to change. If you selected keyframes for a property that varies spatially, you can
select Spatial Path to add deviations to the motion, or Temporal Graph to add deviations to the velocity. If you selected keyframes for a
property that does not vary spatially, you can select only Temporal Graph.

4. Select a Noise Type option to specify the type of deviation due to randomly distributed pixel values (noise):
Smooth Noise Produces deviations that occur more gradually, without sudden changes.

Jagged Noise Produces sudden changes.

5. Select the dimensions of the property you want to affect:
X, Y, or Z Adds deviations to only one dimension of the selected property. Choose the dimension from the menu.

All Independently Independently adds a different set of deviations to each dimension.
All The Same Adds the same set of deviations to all dimensions.

6. Set Frequency to specify how many deviations (keyframes) per second After Effects adds to the selected keyframes. A low value produces
only occasional deviations, while a high value produces more erratic results. A value less than 1 creates keyframes at intervals of less than
one per second. For example, a value of 0.5 creates one keyframe every 2 seconds.

7. Set Magnitude to specify the maximum size of the deviations. After Effects sets the specified magnitude to the units of the selected property,
so a value for one property may produce very different results in another property.

8. Click Apply and preview the results.

9. If necessary, choose Edit > Undo Wiggler to reset the keyframes, adjust the values for Frequency and Magnitude, and then reapply the
Wiggler.

. To the to
Convert audio to keyframes 0

The Convert Audio To Keyframes keyframe assistant analyzes audio amplitude within the work area and creates keyframes for audio amplitude.

+ With the composition active in the Composition panel or Timeline panel, choose Animation > Keyframe Assistant > Convert Audio To
Keyframes.

This keyframe assistant creates an Audio Amplitude layer representing all audio sources in the composition, with three Expression Controls effects
with Slider properties that contain the keyframes: Left Channel, Right Channel, and Both Channels.

To make use of the keyframes created by this keyframe assistant, link the changes in audio amplitude to other layer properties. For example, use
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an expression to link the audio keyframes to the Scale property of a layer to make the layer grow and shrink as the amplitude increases and
decreases.

Online resources for converting audio to keyframes

Aharon Rabinowitz provides a video tutorial on the Creative COW website that shows how to link the audio amplitude keyframes to other
properties—in this case the properties of the Wave Warp effect, to synchronize animation with sound.

John Dickinson provides a video tutorial on his Motionworks website that shows how to use the Convert Audio To Keyframes keyframe assistant to
animate the opacity of a layer and one of the properties of the Grid effect to the beat of the music in a soundtrack.

Satya Meka provides a tutorial and animation preset on his website with which you can generate animations based on separate audio frequency
ranges.

Nathan Gambles provides an expression on the Video Copilot website that ducks (reduces the volume of) audio on one layer when the volume of
audio on another layer increases. This technique is useful, for example, for automatically decreasing the volume of a soundtrack when dialog
occurs. This expression for the Stereo Mixer effect depends on the Convert Audio To Keyframes keyframe assistant having been applied to the
other audio layer.

Lloyd Alvarez provides a script on his After Effects Scripts website that adds markers, splits a layer, or adds a new text layer with incrementing
numbers based on audio intensity.

Maltaannon (Jerzy Drozda, Jr.) provides a video tutorial on his website that shows how to use expressions to create a volume meter using the
results of the Convert Audio To Keyframes command.

Andrew Devis provides a pair of video tutorials on the Creative COW website that show in detail how to use the linear expression method along
with the Convert Audio To Keyframes command.

More Help topics
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Keyframe interpolation

About spatial and temporal keyframe interpolation
Keyframe interpolation methods

Apply and change keyframe interpolation methods
Modify Bezier direction handles in the Graph Editor

. . . To the to
About spatial and temporal keyframe interpolation 0
Interpolation is the process of filling in the unknown data between two known values. You set keyframes to specify a property’s values at certain
key times. After Effects interpolates values for the property for all times between keyframes.

Because interpolation generates the property values between keyframes, interpolation is sometimes called tweening. Interpolation between
keyframes can be used to animate movement, effects, audio levels, image adjustments, transparency, color changes, and many other visual and
audio elements.

After you create keyframes and motion paths to change values over time, you may want to make more precise adjustments to the way that change
occurs. After Effects provides several interpolation methods that affect how the in-between values are calculated.

Temporal interpolation is the interpolation of values in time; spatial interpolation is the interpolation of values in space. Some properties—such as
Opacity—have only a temporal component. Other properties—such as Position—also have spatial components.

Temporal interpolation and the value graph

Using the value graph in the Graph Editor, you can make precise adjustments to the temporal property keyframes you've created for your
animation. The value graph displays x values as red, y values as green, and z values (3D only) as blue. The value graph provides complete
information about the value of keyframes at any point in time in a composition and allows you to control it. In addition, the Info panel displays the
temporal interpolation method of a selected keyframe.

Spatial interpolation and the motion path

When you apply or change spatial interpolation for a property such as Position, you adjust the motion path in the Composition panel. The different
keyframes on the motion path provide information about the type of interpolation at any point in time. The Info panel displays the spatial
interpolation method of a selected keyframe.

When you create spatial changes in a layer, After Effects uses Auto Bezier as the default spatial interpolation.

Q To change the default to linear interpolation, choose Edit > Preferences > General (Windows) or After Effects > Preferences > General (Mac
0S), and select Default Spatial Interpolation To Linear. Changing the preference setting does not affect keyframes that already exist or new
keyframes on properties for which keyframes already exist.

A B

Motion path interpolation
A. Linear B. Auto Bezier C. Continuous Bezier D. Bezier E. Hold

In some cases, the Auto Bezier spatial interpolation for Position keyframes can cause undesired back-and-forth (boomerang) motion between two
keyframes with equal values. In such a case, you can change the earlier keyframe to use Hold interpolation or change both keyframes to use

Linear interpolation.

201



Online resources about keyframe interpolation
Aharon Rabinowitz provides some video tutorials—including “How Does Computer Animation Work?” and “What is interpolation?”"—that introduce
animation as part of the Multimedia 101 series.

Aharon Rabinowitz provides a pair of video tutorials on the Creative COW website that describe the issue and solution for the boomerang motion
problem that arises from unintentionally having Auto Bezier spatial interpolation set for keyframes of equal value:

e Partl
e Part 2

Antony Bolante provides information and illustrations about keyframe interpolation in an article on the Peachpit Press website.

. . To the t
Keyframe interpolation methods oy
In layer bar mode, the appearance of a keyframe icon depends on the interpolation method you choose for the interval between keyframes. When
half of the icon is dark gray 4, the dark half indicates that no keyframe is adjacent to that side, or that its interpolation is overridden by the Hold
interpolation applied to the preceding keyframe.

By default, a keyframe uses one interpolation method, but you can apply two methods: the incoming method applies to the property value as the
current time approaches a keyframe, and the outgoing method applies to the property value as the current time leaves a keyframe. When you set
different incoming and outgoing interpolation methods, the keyframe icon in layer bar mode changes accordingly. It displays the left half of the
incoming interpolation icon and the right half of the outgoing interpolation icon.

Q To toggle between keyframe icons and keyframe numbers, select Use Keyframe Icons or Use Keyframe Indices from the Timeline panel menu.

¢ @ @ X «

B C D E

Examples of keyframe icons in Timeline panel in layer bar mode
A. Linear B. Linear in, Hold out C. Auto Bezier D. Continuous Bezier or Bezier E. Linear in, Bezier out

All interpolation methods used by After Effects are based on the Bezier interpolation method, which provides direction handles so that you can
control the transitions between keyframes. Interpolation methods that don't use direction handles are constrained versions of Bezier interpolation
and are convenient for certain tasks.

To learn more about how different interpolation methods affect temporal properties, experiment by setting up at least three keyframes with different
values for a temporal layer property—such as Opacity—and change the interpolation methods as you view the value graph in Graph Editor mode
in the Timeline panel.

To learn more about how different interpolation methods affect a motion path, experiment by setting up three keyframes for a spatial property—
such as Position—with different values on a motion path, and change the interpolation methods as you preview the motion in the Composition
panel.

Note: To change interpolation methods, right-click a keyframe, select Keyframe Interpolation from the menu that appears, and then select an
option from the Temporal Interpolation menu.

To clarify the examples in the following descriptions of interpolation methods, the result of each method is described as if you had applied it to all
of the keyframes for a layer property. In practice, you can apply any available interpolation method to any keyframe.

No interpolation

No interpolation is the state in which a layer property has no keyframes—when the stopwatch is turned off and the I-beam icon I appears in the
Timeline panel under the current-time indicator. In this state, when you set the value of a layer property, it maintains that value for the duration of
the layer, unless overridden by an expression. By default, no interpolation is applied to a layer property. If any keyframes are present for a layer
property, some type of interpolation is in use.

Linear interpolation
Linear interpolation creates a uniform rate of change between keyframes, which can add a mechanical look to animations. After Effects interpolates
the values between two adjacent keyframes as directly as possible without accounting for the values of other keyframes.

If you apply Linear interpolation to all keyframes of a temporal layer property, change begins instantly at the first keyframe and continues to the
next keyframe at a constant speed. At the second keyframe, the rate of change switches immediately to the rate between it and the third keyframe.
When the layer reaches the final keyframe value, change stops instantly. In the value graph, the segment connecting two keyframes with Linear
interpolation appears as a straight line.

Bezier interpolation
Bezier interpolation provides the most precise control because you manually adjust the shape of the value graph or motion path segments on
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either side of the keyframe. Unlike Auto Bezier or Continuous Bezier, the two direction handles on a Bezier keyframe operate independently in both
the value graph and motion path.

If you apply Bezier interpolation to all keyframes of a layer property, After Effects creates a smooth transition between keyframes. The initial
position of the direction handles is calculated using the same method used in Auto Bezier interpolation. After Effects maintains existing direction
handle positions as you change a Bezier keyframe value.

Unlike other interpolation methods, Bezier interpolation lets you create any combination of curves and straight lines along the motion path.
Because the two Bezier direction handles operate independently, a curving motion path can suddenly turn into a sharp corner at a Bezier
keyframe. Bezier spatial interpolation is ideal for drawing a motion path that follows a complex shape, such as a map route or the outline of a logo.

Existing direction handle positions persist as you move a motion-path keyframe. The temporal interpolation applied at each keyframe controls the
speed of motion along the path.

Auto Bezier interpolation
Auto Bezier interpolation creates a smooth rate of change through a keyframe. You may use Auto Bezier spatial interpolation to create the path of
a car turning on a curving road.

As you change an Auto Bezier keyframe @ value, the positions of Auto Bezier direction handles change automatically to maintain a smooth
transition between keyframes. The automatic adjustments change the shape of the value graph or motion path segments on either side of the
keyframe. If the previous and next keyframes also use Auto Bezier interpolation, the shape of the segments on the far side of the previous or next
keyframes also changes. If you adjust an Auto Bezier direction handle manually, you convert it to a Continuous Bezier keyframe I.

Auto Bezier is the default spatial interpolation.

Continuous Bezier interpolation

Like Auto Bezier interpolation, Continuous Bezier interpolation creates a smooth rate of change through a keyframe. However, you set the
positions of Continuous Bezier direction handles manually. Adjustments you make change the shape of the value graph or motion path segments
on either side of the keyframe.

If you apply Continuous Bezier interpolation to all keyframes of a property, After Effects adjusts the values at each keyframe to create smooth
transitions. After Effects maintains these smooth transitions as you move a Continuous Bezier keyframe I on either the motion path or the value
graph.

Hold interpolation
Hold interpolation is available only as a temporal interpolation method. Use it to change the value of a layer property over time, but without a
gradual transition. This method is useful for strobe effects, or when you want layers to appear or disappear suddenly.

If you apply Hold temporal interpolation to all keyframes of a layer property, the value of the first keyframe holds steady until the next keyframe,
when the values change immediately. In the value graph, the graph segment following a Hold keyframe [Z appears as a horizontal straight line.

Even though Hold interpolation is available only as a temporal interpolation method, the keyframes on the motion path are visible, but they are not
connected by layer-position dots. For example, if you animate the Position property of a layer using Hold interpolation, the layer holds at the
position value of the previous keyframe until the current-time indicator reaches the next keyframe, at which point the layer disappears from the old
position and appears at the new position.

You can easily freeze the current frame for the duration of the layer using the Freeze Frame command. To freeze a frame, position the current
time indicator at the frame you want to freeze. Make sure that the layer is selected and then choose Layer > Time > Freeze Frame. Time-
remapping is enabled, and a Hold keyframe is placed at the position of the current time indicator to freeze the frame.

Note: If you previously enabled time-remapping on the layer, any keyframes you created are deleted when you apply the Freeze Frame
command.

You can use Hold interpolation only for outgoing temporal interpolation (for the frames following a keyframe). If you create a keyframe following a
Hold keyframe, the new keyframe uses incoming Hold interpolation.

Q To apply or remove Hold interpolation as outgoing interpolation for a keyframe, select the keyframe in the Timeline panel, and choose
Animation > Toggle Hold Keyframe.

Apply and change keyframe interpolation methods fothetop

You can apply and change the interpolation method for any keyframe. You can apply changes using the Keyframe Interpolation dialog box, or you
can apply them directly to a keyframe in layer bar mode, in a motion path, or in the Graph Editor. You can also change the default interpolation
After Effects uses for spatial properties.

For information on using Easy Ease controls to automatically ease speed between keyframes, see Controlling speed between keyframes.

Change interpolation method with the Keyframe Interpolation dialog box
The Keyframe Interpolation dialog box provides options for setting temporal and spatial interpolation and—for spatial properties only—roving
settings.

1. In layer bar mode or in the Graph Editor, select the keyframes you want to change.
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2. Choose Animation > Keyframe Interpolation.

3. For Temporal Interpolation, choose one of the following options:
Current Settings Preserves the interpolation values already applied to the selected keyframes. Choose this option when multiple or
manually adjusted keyframes are selected and you do not want to change the existing settings.

Linear, Bezier, Continuous Bezier, Auto Bezier, and Hold Apply a temporal interpolation method using default values.

4. If you selected keyframes of a spatial layer property, choose one of the following options for Spatial Interpolation:
Current Settings Preserves the interpolation settings already applied to the selected keyframes.

Linear, Bezier, Continuous Bezier, and Auto Bezier Apply a spatial interpolation method using default values.

5. If you selected keyframes of a spatial layer property, use the Roving menu to choose how a keyframe determines its position in time, and
then click OK:
Current Settings Preserves the currently applied method of positioning the selected keyframes in time.

Rove Across Time Smooths the rate of change through the selected keyframes by automatically varying their position in time, based on the
positions of the keyframes immediately before and after the selection.

Lock To Time keeps the selected keyframes at their current position in time. They stay in place unless you move them manually.

For more information on smoothing the rate of change through selected keyframes, see Smooth motion with roving keyframes.

Change interpolation method with the Selection tool in layer bar mode
%+ Using the Selection tool, do one of the following:

« If the keyframe uses Linear interpolation, Ctrl-click (Windows) or Command-click (Mac OS) the keyframe to change it to Auto Bezier @,

« If the keyframe uses Bezier, Continuous Bezier, or Auto Bezier interpolation, Ctrl-click (Windows) or Command-click (Mac OS) the keyframe
to change it to Linear.

Change interpolation method in the Graph Editor
« Click the keyframe with the Convert Vertex tool M to toggle between linear and Auto Bezier interpolation.

« Select one or more keyframes, and then click the Hold, Linear, or Auto Bezier button at the bottom of the screen to change the interpolation

method.
|
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A B C
Interpolation buttons in the Graph Editor

A. Hold B. Linear C. Auto-Bezier

Modify Bezier direction handles in the Graph Editor fothetop

In the Graph Editor, keyframes that use Bezier interpolation have direction handles attached to them. You can retract, extend, or rotate the
direction handles to fine-tune the Bezier interpolation curve in a value graph. You can retract or extend the direction handles to fine-tune the curve
in a speed graph.

By default, when you retract or extend a direction handle, the opposite handle on the keyframe moves with it. Splitting direction handles makes the
two direction handles attached to a keyframe behave independently.
« To retract or extend direction handles, drag the direction handle toward or away from the center of its keyframe with the Selection tool.

» To split direction handles, Alt-drag (Windows) or Option-drag (Mac OS) a keyframe with the Selection tool. You can also Alt-drag (Windows)
or Option-drag (Mac OS) outside a keyframe to draw new handles, whether or not handles already exist.

« To manipulate the direction handles of two neighboring keyframes simultaneously, drag the value graph segment between the keyframes.
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Extending a Bezier direction handle in the speed graph

More Help topics
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Speed

Controlling speed between keyframes
Smooth motion with roving keyframes
Use Exponential Scale to change the speed of scaling

. To the t
Controlling speed between keyframes o et
When you animate a property in the Graph Editor, you can view and adjust the rate of change (speed) of the property in the speed graph. You can
also adjust speed for spatial properties in the motion path in the Composition or Layer panel.

In the Composition or Layer panel, the spacing between dots in a motion path indicates speed. Each dot represents a frame, based on the frame
rate of the composition. Even spacing indicates a constant speed, and wider spacing indicates a higher speed. Keyframes using Hold interpolation
display no dots because there is no intermediate transition between keyframe values; the layer simply appears at the position specified by the next
keyframe. (See Motion paths.)
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Motion path in Composition panel (top) compared to speed graph in Graph Editor (bottom)
A. Dots are close together, indicating lower speed (top); speed is constant (bottom). B. Dots are far apart, indicating greater speed (top); speed
is constant (bottom). C. Inconsistent spacing of dots indicates changing speed (top); speed decreases and then increases (bottom).

For information about keyframe interpolation, see Keyframe interpolation.
The following factors affect the speed at which a property value changes:

« The time difference between keyframes in the Timeline panel. The shorter the time interval between keyframes, the more quickly the layer
has to change to reach the next keyframe value. If the interval is longer, the layer changes more slowly, because it must make the change
over a longer period of time. You can adjust the rate of change by moving keyframes forward or backward along the timeline.

« The difference between the values of adjacent keyframes. A large difference between keyframe values, such as the difference between 75%
and 20% opacity, creates a faster rate of change than a smaller difference, such as the difference between 30% and 20% opacity. You can
adjust the rate of change by increasing or decreasing the value of a layer property at a keyframe.

« The interpolation type applied for a keyframe. For example, it is difficult to make a value change smoothly through a keyframe when the
keyframe is set to Linear interpolation, but you can switch to Bezier interpolation at any time, which provides a smooth change through a
keyframe. If you use Bezier interpolation, you can adjust the rate of change even more precisely using direction handles.
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Linear interpolation (top) causes sharp changes; Bezier interpolation (bottom) creates smoother changes.

Control speed between keyframes without using the speed graph
« In the Composition or Layer panel, adjust the spatial distance between two keyframes on the motion path. Increase speed by moving one
keyframe position farther away from the other, or decrease speed by moving one keyframe position closer to the other.

More spatial distance between keyframes increases layer speed.

« In layer bar mode or in the Graph Editor, adjust the time difference between two keyframes. Decrease speed by moving one keyframe farther
away from the other, or increase speed by moving one keyframe closer to the other.

Shorter temporal distance between keyframes increases layer speed.

« Apply the Easy Ease keyframe assistant, which automatically adjusts the speed of change as motion advances toward and retreats from a
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keyframe.

About the speed graph
You can fine-tune changes over time using the speed graph in the Graph Editor. The speed graph provides information about and control of the
value and rate of change for all spatial and temporal values at any frame in a composition.

In the speed graph, changes in the graph height indicate changes in speed. Level values indicate constant speed; higher values indicate increased
speed.

To view the speed graph, choose Edit Speed Graph from the Choose Graph Type menu E-.

Speed graph controls
A. Value at the current-time indicator B. Speed graph C. Direction handle (controls speed)

By adjusting the rise and fall of the speed graph, you can control how quickly or slowly a value changes from keyframe to keyframe. You can
control the values approaching and leaving a keyframe together, or you can control each value separately. The incoming handle increases the
speed or velocity when you drag it up, and decreases the speed or velocity when you drag it down. The outgoing handle influences the next
keyframe in the same way. You can also control the influence on speed by dragging the handles left or right.

A B C

irection handles in speed graphs
A. Incoming direction handle B. Speed control C. Outgoing direction handle

Note: If you want a handle to have influence over more than one keyframe, use roving keyframes.

Control speed with the speed graph

. In the Timeline panel, expand the outline for the keyframe you want to adjust.

. Click the Graph Editor button and select Edit Speed Graph from the Graph Type And Options menu .,
. Using the Selection tool, click the keyframe you want to adjust.

A W N R

. (Optional) Do one of the following:
« To split the incoming and outgoing direction handles, Alt-drag (Windows) or Option-drag (Mac OS) a direction handle.

« To join the direction handles, Alt-drag (Windows) or Option-drag (Mac OS) a split direction handle up or down until it meets the other
handle.

5. Do any of the following:
« Drag a keyframe with joined direction handles up to accelerate or down to decelerate entering and leaving the keyframe.
« Drag a split direction handle up to accelerate or down to decelerate the speed entering or leaving a keyframe.

« To increase the influence of the keyframe, drag the direction handle away from the center of the keyframe. To decrease the influence,
drag the direction handle toward the center of the keyframe.

Note: When you drag a direction handle beyond the top or bottom of the Graph Editor with Auto Zoom Graph Height {2 on, After Effects
calculates a new minimum or maximum value based on how far you dragged outside the graph, and it redraws the graph so that all the
values you specify for that layer property are visible in the graph by default.
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Create a bounce or peak
Use direction handles to simulate the type of acceleration seen in a bouncing ball. When you create this type of result, the speed graph appears to
rise quickly and peak.
1. In the Timeline panel, expand the outline for the keyframe you want to adjust.
Click the Graph Editor button and display the speed graph for the property.
Make sure the interpolation method for the keyframe you want to peak is set to Continuous Bezier or Bezier.
Drag the desired keyframe (with joined direction handles) up until it is near the top of the graph.

A N

Drag the direction handles on either side of the keyframe toward the center of the keyframe.

Dragging direction handle to create a peak

Start or stop change gradually
Direction handles can create gradual starts and stops, such as a boat slowing to a stop and then starting again. When you use this technique, the
speed graph resembles a smooth U shape.
1. In the Timeline panel, expand the outline for the keyframe you want to adjust.
. Click the Graph Editor button and display the speed graph for the property.
. Make sure the interpolation method for the keyframe you want to adjust is set to Continuous Bezier or Bezier.
. At the desired keyframe, drag the direction handle down until it is near the bottom of the graph.

a b~ 0N

. Drag the direction handles on either side of the keyframe away from the center of the keyframe.

e —_—r [ —— T

Dragging the direction handle to make a gradual change

Adjust influence of a direction handle on an adjacent keyframe

Along with controlling the level of acceleration and deceleration, you can also extend the influence of a keyframe outward or inward in relation to
an adjacent keyframe. Influence determines how quickly the speed graph reaches the value you set at the keyframe, giving you an additional
degree of control over the shape of the graph. The direction handle increases the influence of a keyframe value in relation to the neighboring
keyframe when you drag it toward the neighboring keyframe, and it decreases the influence on the neighboring keyframe when you drag it toward
the center of its own keyframe.
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1. In the Timeline panel, expand the outline for the keyframe you want to adjust.
2. Click the Graph Editor button and display the speed graph for the property.
3. Using the Selection tool, click a keyframe and drag the direction handle left or right.

Change speed numerically

You may want to specify speed more precisely than you can by dragging keyframes in the speed graph. In such cases, specify speed numerically
in the Keyframe Velocity dialog box.

The options and units in the dialog box vary depending on the layer property you are editing and may also vary for plug-ins.

1. Display the speed graph for the keyframe you want to adjust.

2. Select the keyframe you want to edit, and then choose Animation > Keyframe Velocity.

3. Enter values for Speed for Incoming and Outgoing Velocity.

4. Enter a value for Influence to specify the amount of influence toward the previous keyframe (for incoming interpolation) or the next keyframe
(for outgoing interpolation).

5. To create a smooth transition by maintaining equal incoming and outgoing velocities, select Continuous.

Note: By default, the proportions of the current Scale or Mask Feather values are preserved as you edit the values. If you don’t want to preserve
proportions, click the link icon next to the property values in the Timeline panel to remove the icon.

Automatically ease speed
Although you can manually adjust the speed of a keyframe by dragging direction handles, using Easy Ease automates the work.
After you apply Easy Ease, each keyframe has a speed of 0 with an influence of 33.33% on either side. When you ease the speed of an object,
for example, the object slows down as it approaches a keyframe, and gradually accelerates as it leaves. You can ease speed when coming into or
out of a keyframe, or both.

1. In the Graph Editor or in layer bar mode, select a range of keyframes.

2. Do one of the following:

« Choose Animation > Keyframe Assistant > Easy Ease (to ease speed coming both into and out of selected keyframes), Easy Ease In (to
ease speed coming into selected keyframes), or Easy Ease Out (to ease speed coming out of selected keyframes).

« Click the Easy Ease 7™, Easy Ease In _#°, or Easy Ease Out " button located at the bottom of the Graph Editor.

. . . To the to
Smooth motion with roving keyframes ’
Using roving keyframes, you can easily create smooth movement across several keyframes at once. Roving keyframes are keyframes that are not
linked to a specific time; their speed and timing are determined by adjacent keyframes. When you change the position of a keyframe adjacent to a
roving keyframe in a motion path, the timing of the roving keyframe may change.

Roving keyframes are available only for spatial layer properties, such as Position, Anchor Point, and effect control points. In addition, a keyframe
can rove only if it is not the first or last keyframe in a layer, because a roving keyframe must interpolate its speed from the previous and next
keyframes.

_|so

The original motion path (top) shows different velocities between keyframes. After the keyframes are set to rove (bottom), the motion path shows
consistent speed over the range of keyframes.

1. In layer bar mode or in the Graph Editor, set up the keyframes for the motion you want to smooth.
2. Determine the beginning and ending keyframes for the range you want to smooth.
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3. Do one of the following:
« For every keyframe in the range (except the beginning and ending keyframes), select Rove Across Time in the keyframe menu <.

« Select the keyframes you want to rove and choose Animation > Keyframe Interpolation. Then choose Rove Across Time from the Roving
menu.

The intermediate keyframes adjust their positions on the timeline to smooth the speed curve between the beginning and ending keyframes.

Revert to a nonroving keyframe
« Select the roving keyframe option from the keyframe menu, or drag the roving keyframe left or right.

« Select the keyframes you want to change, and choose Animation > Keyframe Interpolation. Then choose Lock To Time from the Roving
menu.

Use Exponential Scale to change the speed of scaling fothetop

You can simulate a realistic acceleration of a zoom lens when working with 2D layers by using Exponential Scale, which converts linear scaling of
a layer to exponential scaling. Exponential Scale is useful for creating a cosmic zoom, for example. Zooming optically with a lens is not linear—the
rate of change of scaling increases as you zoom in.

1. In layer bar mode or in the Graph Editor, hold down the Shift key and select starting and ending keyframes for the scale property.
2. Choose Animation > Keyframe Assistant > Exponential Scale.

Note: Exponential Scale replaces any existing keyframes between the selected starting and ending keyframes.
More Help topics
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Tracking and stabilizing motion

Resources for mocha for After Effects (mocha-AE)

Motion tracking overview and resources

Motion tracking workflow

Track or stabilize motion with the point tracker

Adjust the track point

Apply tracking data to a new target

Correct a motion track

Stabilize motion with the Warp Stabilizer effect (CS5.5 and later)

Resources for mocha for After Effects (mocha-AE) fothetop

Atfter Effects includes Imagineer Systems mocha for After Effects (mocha-AE), a stand-alone planar tracking application that can export tracking
data for use in compositions in After Effects. For many tracking tasks, mocha-AE provides superior results with greater convenience than do the
native After Effects tracking features. For more information, see the mocha-AE documentation, which is available from the Help menu in the
mocha-AE application.

mocha AE is launchable from within After Effects CS6. To use mocha AE in After Effects CS6, choose from the following:

« Animation > Track in mocha AE
« Edit > Paste mocha mask

Note: After Effects also includes the mocha shape for After Effects (mocha shape AE) plug-in, which converts paths from mocha-AE into mattes
in After Effects. (See Resources for Imagineer mocha shape for After Effects (mocha shape AE).)

Note: The free trial version of Adobe After Effects software does not include some features that depend upon software licensed from parties other
than Adobe. For example, mocha for After Effects, some effect plug-ins are available only with the full version of Adobe After Effects software.
(See Setup and installation.)

Todd Kopriva provides a basic introduction to using mocha-AE for motion tracking in "Overview of the mocha-AE interface and workflow" on the
video2brain website.

If you have questions and issues regarding mocha-AE, see the FAQ list for mocha for After Effects and the support forum for mocha for After
Effects.

The Imagineer website provides several video tutorials and other resources for learning to use mocha-AE with After Effects.
Adobe TV has a mocha-AE channel, which includes several video tutorials about using mocha planar tracking and rotoscoping utilities.
Chris and Trish Meyer provide a video tutorial that introduces mocha for After Effects on the Lynda.com website.

Chris and Trish Meyer provide tips about mocha-AE and mocha shape, including tips about variable-width feather, in an article on the ProVideo
Coalition website.

David Torno provides extensive video tutorials that show how to use mocha-AE as part of a workflow to replace one face with another in a movie.
Todd Kopriva provides links and details on his After Effects Region of Interest blog.

Mathias Mo6hl provides the Mochalmport script and a set of related tutorials on his website. Mochalmport automates common parts of the workflow
of using mocha-AE with After Effects.

Jeff Foster provides a tutorial on the ProVideo Coalition website that demonstrates the use of mocha for After Effects to replace a sign on the side
of a moving truck in a shaky video clip.

. . . To theto
Motion tracklng overview and resources ’

With motion tracking, you can track the movement of an object and then apply the tracking data for that movement to another object—such as
another layer or an effect control point—to create compositions in which images and effects follow the motion. You can also stabilize motion, in
which case the tracking data is used to animate the tracked layer to compensate for movement of an object in that layer. You can link properties to
tracking data using expressions, which opens up a wide variety of uses.

After Effects tracks motion by matching image data from a selected area in a frame to image data in each succeeding frame. You can apply the
same tracking data to different layers or effects. You can also track multiple objects in the same layer.

For information about Imagineer Systems mocha for After Effects, see Resources for mocha for After Effects (mocha-AE).

Note: In After Effects CS6, you can track camera motion and place 3D objects in 2D footage much more easily using the 3D camera tracker. For
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more information, see Tracking 3D camera movement (CS6).

Note: In After Effects CS5.5, and later, you can stabilize shaky footage a lot easier using the Warp Stabilizer. For more information, see Stabilize
motion with the Warp Stabilizer effect (CS5.5 and later).

Uses for motion tracking and stabilization

Motion tracking has many uses. Here are some examples:
« Combining elements filmed separately, such as adding video to the side of a moving city bus or a star to the end of a sweeping wand.
« Animating a still image to match the motion of action footage, such as making a cartoon bumblebee sit on a swaying flower.
« Animating effects to follow a moving element, such as making a moving ball glow.

« Linking the position of a tracked object to other properties, such as making stereo audio pan from left to right as a car races across the
screen.

« Stabilizing footage to hold a moving object stationary in the frame to examine how a moving object changes over time, which can be useful in
scientific imaging work.

« Stabilizing footage to remove the jostling (camera shake) of a handheld camera.

Q Depending on the encoder you use, it is possible to decrease the size of your final output file by stabilizing motion footage. Random motion,
such as from the jostling of a handheld camera, can make it difficult for many compression algorithms to compress your video.

Motion tracking user interface and terminology overview
You set up, initiate, and apply motion tracking with the Tracker panel.

As with all properties, you can modify, animate, manage, and link tracking properties in the Timeline panel.

You specify areas to track by setting track points in the Layer panel. Each track point contains a feature region, a search region, and an attach
point. A set of track points is a tracker.

0sf 10f 15t 2
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Layer panel with track point
A. Search region B. Feature region C. Attach point

Feature region The feature region defines the element in the layer to be tracked. The feature region should surround a distinct visual element,
preferably one object in the real world. After Effects must be able to clearly identify the tracked feature throughout the duration of the track, despite
changes in light, background, and angle.

Search region The search region defines the area that After Effects will search to locate the tracked feature. The tracked feature needs to be
distinct only within the search region, not within the entire frame. Confining the search to a small search region saves search time and makes the
search process easier, but runs the risk of the tracked feature leaving the search region entirely between frames.

Attach point The attach point designates the place of attachment for the target —the layer or effect control point to synchronize with the moving
feature in the tracked layer.

Note: When you begin tracking, After Effects sets the quality of the motion source layer to Best and the resolution to Full in the Composition and
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Layer panels, which makes the tracked feature easier to find and enables subpixel processing and positioning.

After Effects uses one track point to track position, two track points to track scale and rotation, and four points to perform tracking using corner
pinning.

Online resources for motion tracking and stabilization

Curtis Sponsler provides detailed instructions and explanations for tracking and stabilizing motion in a PDF excerpt from his book The Focal Easy
Guide to After Effects.

Chris and Trish Meyer provide a video tutorial on the ProVideo Coalition website that demonstrates and explains the basics of motion tracking.

This video from the After Effects CS5: Learn By Video series shows how to combine motion tracking and the Clone Stamp tool to remove an
object from a scene.

Angie Taylor provides a tutorial on the Digital Arts website that shows how to use tracking data and the Clone Stamp tool to apply copies of an
object in a scene while matching a camera move.

Michele Yamazaki provides a tutorial on the Toolfarm website that shows how to use motion tracking to obscure a logo in motion footage.

Sean Kennedy provides a set of detailed tutorials on the SimplyCG website that demonstrate advanced motion tracking techniques:

» Basic 2D tracking

e Planar tracking

* Motion tracking and compositing computer-generated elements into a scene
» Screen tracking and replacement

Sean Kennedy provides a free script, TrackerViz, that makes tracking motion and applying tracking data to masks easier. You can get TrackerViz
and a series of detailed instructions on the SimplyCG website.

Eran Stern provides a video tutorial on the Artbeats website that demonstrates the use of 3D tracking software that solves for camera movement
so that additional elements can be composited into the scene and appear to honor the same camera movement. This video tutorial uses Pixel
Farm PFHoe, but the techniques can be applied to almost any matchmoving software.

This post on the AE Enhancers forum describes and links to an animation preset from Donat van Bellinghen for scaling a set of Corner Pin effect
points.

This post on the AE Enhancers forum describes and links to a script from Paul Tuersley that takes a stabilized layer, precomposes it, and then
adds expressions that counter the stabilization.

This post on the AE Enhancers forum describes and links to a script from Paul Tuersley that can make a difficult tracking job easier by averaging
multiple sets of tracking data.

Jeff Almasol provides a script on his redefinery website that creates a null layer with an expression that sets the Position property to be the
average of the values of motion tracking track points for the selected layer.

Jorgen Persson provides a script on the After Effects Scripts website with which you can import tracking data from Apple Shake into After Effects.

Mathias Mo6hl provides useful scripts for motion tracking—including Mochalmport, KeyTweak, and Tracker2Mask—on his website. Mathias also
provides video tutorials explaining the use of the scripts.

Motion tracking workflow To the top

The implicit first step of any workflow is to determine the result that you want to achieve before you begin. What type of motion will you track, and
what will you apply the tracking data to?

As with many workflows in the real world, you may have to repeat some of these steps. You can track a layer as many times as desired and apply
any combination of tracking results.

Set up the shot
For motion tracking to go smoothly, you must have a good feature to track, preferably a distinctive object or region.

For best results, prepare the object or region that you are tracking before you begin shooting. Because After Effects compares image data from
one frame to the next to produce an accurate track, attaching high-contrast markers to the object or region lets After Effects more easily follow the
motion from frame to frame. Lightweight, brightly colored balls (such as ping-pong balls) placed on the feature work well, in part because their
appearance is the same from all angles. The number of markers that you use corresponds to the number of points you are tracking. For example,
if you're tracking four points using the Perspective Corner Pinning option, you'll track four features, to correspond to the four corners of the layer to
attach. The more markers you add to your subject before shooting, the more features you'll have for tracking—but the more items you may have to
remove later from the image with the Clone Stamp tool. You don’t need to add a marker for each feature if a distinctive object or region is already
at the appropriate location.

If you're tracking a large object or the set itsel—such as for matchmoving—you can get good results by using a grid of uniformly spaced triangles
of a uniform size as tracking markers.
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Add the appropriate number of track points

When you choose a mode from the Track Type menu in the Tracker panel, After Effects places the appropriate number of track points in the Layer
panel for that mode. You can add more track points to track additional features with one tracker.

Select features to track, and place feature regions

Before you begin tracking, view the entire duration of the shot to determine the best features to track. What is clearly identifiable in the first frame
may later blend into the background because the angle, lighting, or surrounding elements have changed. A tracked feature may disappear off the
edge of the frame or be obscured by another element at some point in the scene. Though After Effects can extrapolate the motion of a feature,
your chances for successful tracking are highest if you step through the entire shot to select the best candidates for tracking.

A good tracked feature has these characteristics:

« Visible for the entire shot
« A contrasting color from the surrounding area in the search region
« A distinct shape within the search region
« A consistent shape and color throughout the shot
Set the attach point offset

The attach point is where the target layer or effect control point will be placed. The default attach point position is in the center of the feature
region. You can move the attach point to offset the position of the target relative to the position of the tracked feature by dragging the attach point
in the Layer panel before tracking.

For example, to animate a cloud above a person’s head, position the feature region on the head and move the attach point above the head. If you
left the attach point centered in the feature region, the cloud would be attached to that point and would obscure the head.

Attach point centered in feature region

Attach point offset from feature region

Adjust the feature region, search region, and tracking options

Place each feature region control tightly around its tracked feature, completely enclosing the tracked feature, but including as little of the
surrounding image as possible.

The size and position of the search region depend on the movement of the feature you want to track. The search region must accommodate the
movement of the tracked feature, but only the frame-to-frame movement, not its movement throughout the shot. As After Effects locates the
tracked feature in a frame, both the feature region and search region move to the new location. Therefore, if the frame-to-frame movement of the
tracked feature is gradual, then the search region needs to be only slightly larger than the feature region. If the feature changes position and
direction quickly, then the search region needs to be big enough to encompass the largest position and direction change in any pair of frames.

You can also set tracking options that determine such things as which color channels are compared to find a match to the feature region.
Analyze

You perform the actual motion tracking step by clicking one of the Analyze buttons in the Tracker panel. When tracking a tricky set of features, you
may want to analyze a frame at a time.

Repeat as necessary

Because of the changing nature of an image in motion, automatic tracking is rarely perfect. In moving footage, the shape of a feature changes,
along with the lighting and surrounding objects. Even with careful preparation, a feature generally changes during a shot and at some point no
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longer matches the original feature. If the change is too great, After Effects may not be able to track the feature, and the track point will wander or
drift.

When the analysis begins to fail, return to the frame where tracking was still accurate and repeat steps 5 and 6: adjust and analyze.
Apply tracking data

If you're using any Track Type setting other than Raw, you apply tracking data by clicking Apply, after making sure that the correct target is shown
for Motion Target. You apply tracking data from a Raw tracking operation by copying keyframes from the trackers to other properties or by linking
properties with expressions.

You can also adjust the Attach Point or Attach Point Offset property after tracking in the Timeline panel, which can be useful when applying the
same tracking data to multiple targets that you want to distribute around the tracked feature.

Note: If the layer that you're attaching has motion blur enabled, make sure that the Shutter Phase value is set to -1/2 times the Shutter Angle
value. This combination of settings centers the motion blur on the attach point. Otherwise, the attached object may appear to lead or lag the object
that it's attached to.

Q You can apply the tracking data to a null object layer and parent the layer that you want to animate to the null object layer.

- . . . To the to

Track or stabilize motion with the point tracker 0
Tracking motion and stabilizing motion are essentially the same process, only with a different target and result. Use Track Motion to track motion
and apply the results to a different layer or effect control point. Use Stabilize Motion to track motion and apply the results to the tracked layer to

compensate for that motion (for example, to remove camera shake).

To stabilize a layer, After Effects tracks the motion of a feature in the layer that should be stationary in the frame, and then uses the tracking data
to set keyframes to perform the opposite motion. You can stabilize to remove any combination of changes in position, rotation, and scale, while
leaving desired motion unaffected. For example, if the camera is panning, deselect Position but select Scale and Rotation as the properties to
stabilize.

When you select Rotation or Scale in the Tracker panel, you set two track points in the Layer panel. A line connects the attach points; an arrow
points from the first attach point (the base) to the second. If possible, place the feature regions on opposite sides of the same object, or at least on
objects that are the same distance from the camera. The farther apart the regions, the more accurate the calculations and the better the result.

After Effects calculates rotation by measuring the change of angle of the line between the attach points. When you apply the tracking data to the
target, After Effects creates keyframes for the Rotation property.

After Effects calculates scale by comparing the distance between attach points on each frame with the distance between the attach points on the
start frame. When you apply the tracking data to the target, After Effects creates keyframes for the Scale property.

When you track motion using either parallel or perspective corner pinning, After Effects applies keyframes for the Corner Pin effect to the layer to
scale and skew the target layer as necessary to fit the four-sided area defined by the feature regions. The feature regions should lie in a single
plane in the real world—for example, on the side of a bus, on the same wall, or on the floor. The attach points should also all lie in a single plane,
but not necessarily the same plane as the feature regions.

Note: For parallel corner pinning only: To change which point is inactive, Alt-click (Windows) or Option-click (Mac OS) the feature region of the
point to make inactive. (One point must remain inactive to keep the lines parallel.)
1. Select the layer to track in the Timeline panel.

2. Do one of the following:
« Click Track Motion in the Tracker panel (or choose Animation > Track Motion), click Edit Target, and choose the target to apply the
tracking data to.

« Click Stabilize Motion in the Tracker panel (or choose Animation > Stabilize Motion). The target layer is the tracked (source) layer.

Select Position, Rotation, and/or Scale to specify what kinds of keyframes to generate for the target.
Move the current-time indicator to the frame from which to begin tracking.
Using the Selection tool, adjust the feature region, search region, and attach point for each track point.

o g~ w

In the Tracker panel, click either the Analyze Forward or Analyze Backward button to begin tracking.

If the tracking ceases to be accurate, click the Stop button B, correct the problem as described in Correct a motion track, and resume
analysis.

7. When you are satisfied with the position of the feature region and attach point throughout the track, click the Apply button to apply the
motion to the specified target.

After Effects creates keyframes for the target layer.

When tracking position and applying this position data to a target, you can choose to apply only the x (horizontal) or y (vertical) component
of motion. For example, you can apply the tracking data to the x axis to make a speech bubble (the motion target) remain at the top of the
frame even when the actor (the motion source) moves downward.
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X And Y (default) allows motion along both axes.
« X Only restricts the motion target to horizontal movement.
« Y Only restricts the motion target to vertical movement.
Q To bypass the Motion Tracker Apply Options dialog box and use the previous setting, hold Alt (Windows) or Option (Mac OS) as you
click Apply.
Note: You can change the order of steps 1-3 by first selecting the property to which to apply the tracking data (Scale, Position, or Rotation) and

then choosing Animation > Track This Property. After Effects prompts you to choose the layer to use as a motion source.

When you stabilize a layer, the compensating motion may itself cause the layer to move too far in one direction, exposing the background in the
composition or moving action out of the action-safe zone. You can correct this with a small change in scale for the layer. Find the frame where the
problem is most severe, and then increase or decrease the scale of the layer until the problem is resolved. This technique adjusts the scale for the
duration of the layer; you can also animate scale to correct this problem by zooming in and out at different times.

Motion tracking controls
You set up, initiate, and apply motion tracking with the Tracker panel.

Motion Source The layer that contains the motion to track.

Note: Layers are available in the Motion Source menu if they have source footage items that can contain motion or if they are composition layers.
You can precompose a layer to make it available in the Motion Source menu.

Current Track The active tracker. You can modify settings for a tracker at any time by selecting the tracker from this menu.

Track Type The tracking mode to use. The motion tracking itself is the same for each of these modes; they differ in the number of track points
and how the tracking data is applied to the target:

« Stabilize tracks position, rotation, and/or scale to compensate for movement in the tracked (source) layer. When tracking position, this mode
creates one track point and generates Anchor Point keyframes for the source layer. When tracking rotation, this mode creates two track
points and produces Rotation keyframes for the source layer. When tracking scale, this mode creates two track points and produces Scale
keyframes for the source layer.

» Transform tracks position, rotation, and/or scale to apply to another layer. When tracking position, this mode creates one track point on the
tracked layer and sets Position keyframes for the target. When tracking rotation, this mode creates two track points on the tracked layer and
sets Rotation keyframes for the target. When tracking scale, this mode creates two track points and produces Scale keyframes for the target.

« Parallel Corner Pin tracks skew and rotation, but not perspective; parallel lines remain parallel, and relative distances are preserved. This
mode uses three track points in the Layer panel—and calculates the position of the fourth—and sets keyframes for four corner points in a
Corner Pin effect property group, which is added to the target. The four attach points mark the placement of the four corner points.

» Perspective Corner Pin tracks skew, rotation, and perspective changes in the tracked layer. This mode uses four track points in the Layer
panel and sets keyframes for four corner points in a Corner Pin effect property group, which is added to the target. The four attach points
mark the placement of the four corner points. This option is useful for attaching an image to an opening door or the side of a bus that’s
turning a corner.

« Raw tracks position only. Use Raw to generate tracking data that you won't apply using the Apply button. For example, you can copy and
paste the keyframes for the Attach Point property to the Position property for a paint stroke; or, you can link effect properties for the Stereo
Mixer effect to the x coordinate of the Attach Point property using expressions. Tracking data is stored on the tracked layer. The Edit Target
button and the Apply button are not available with this tracking option. You can add track points to a tracker by choosing New Track Point
from the Tracker panel menu.

Motion Target The layer or effect control point that the tracking data is applied to. After Effects adds properties and keyframes to the target to
move or stabilize it. Change the target by clicking Edit Target. No target is associated with a tracker if Raw is selected for Track Type.

Analyze buttons Begins the frame-to-frame analysis of the track point in the source footage:
« Analyze 1 Frame Backward «l: Analyze the current frame by moving back to the previous frame.
« Analyze Backward «: Analyze from the current-time indicator backward to the beginning of the trimmed layer duration.
« Analyze Forward #¥: Analyze from the current-time indicator to the end of the trimmed layer duration.
» Analyze 1 Frame Forward I¥: Analyze the current frame by advancing to the next frame.

Note: While analysis is in progress, the Analyze Backward and Analyze Forward buttons change to a Stop button, with which you can stop
analysis when the track drifts or otherwise fails.

Reset Restores the feature region, search region, and attach point to their default positions and deletes the tracking data from the currently
selected track. Tracker control settings and keyframes already applied to the target layer remain unchanged.
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Apply Sends the tracking data (in the form of keyframes) to the target layer or effect control point.

Motion tracking options

These settings apply to a tracker, a group of track points that is generated in one tracking session. You can modify these settings by clicking
Options in the Tracker panel.

Track Name The name for a tracker. You can also rename a tracker by selecting it in the Timeline panel and pressing Enter on the main
keyboard (Windows) or Return (Mac OS).

Tracker Plug-in The plug-in used to perform motion tracking for this tracker. By default, this option displays Built-in, the only tracking plug-in
included with After Effects.

Channel The components of the image data to use for comparison when searching for a match for the feature region. Select RGB if the tracked
feature is a distinct color. Select Luminance if the tracked feature has a different brightness than the surrounding image (such as a burning candle
carried through a room). Select Saturation if the tracked feature has a high concentration of color, surrounded by variations of the same color (such
as a bright red scarf against a brick wall).

Process Before Match Temporarily blurs or sharpens an image to improve tracking. Blur reduces noise in the footage. Usually a value of 2 to 3
pixels is enough to produce better tracks in grainy or noisy footage. Enhance exaggerates or refines the edges of an image and makes them
easier to track.

Note: After Effects blurs or enhances the layer only for tracking. This blurring does not affect the motion source layer.

Track Fields Temporarily doubles the frame rate of the composition and interpolates each field to a full frame to track motion in both fields of
interlaced video.

Subpixel Positioning When selected, keyframes are generated to a precision of a fraction of a pixel. When deselected, the tracker rounds off
values to the nearest pixel for generated keyframes.

Adapt Feature On Every Frame Causes After Effects to adapt the tracked feature for each frame. The image data that is searched for within the
search region is the image data that was within the feature region in the previous frame, rather than the image data that was in the feature region
at the beginning of analysis.

If Confidence Is Below Specifies the action to perform when the Confidence property value is below the percentage value that you specify.

Note: To determine an acceptable confidence threshold, track the motion and then examine the Confidence values for the track point in the
Timeline panel for problematic frames. Specify a confidence value that is slightly larger than the largest confidence value for the problematic
frames.

« Select Continue Tracking to ignore the Confidence value. This behavior is the default behavior.
« Select Stop Tracking to stop the motion tracking.

« Select Extrapolate Motion to estimate the position of the feature region. Attach-point keyframes aren’t created for low-confidence frames, and
attach-point keyframes for the low-confidence frames from previous tracks are deleted.

» Select Adapt Feature to use the original tracked feature until the confidence level falls below the specified threshold. At that point, After
Effects adapts the tracked feature to be the contents of the feature region in the frame preceding the one that has low confidence and
continues tracking. This option isn’t available if Adapt Feature On Every Frame is selected in the Motion Tracker Options dialog box; enabling
feature adaptiveness causes After Effects to adapt the feature region with every frame regardless of the confidence level.

Options Opens the Tracker Plug-in Options dialog box, which includes options for the AE Original Built-in Tracker. This command is only
available if you choose to use the older After Effects tracker plug-in.

Note: To show or hide motion paths in the Layer panel, select or deselect the Display Motion Paths option in the panel menu of the Tracker
panel. (The panel menu is the menu that you access by clicking the icon in the upper-right corner of a panel.) You can also use commands in this
menu to add a new track point, reveal the current track in the Timeline panel, and toggle whether the feature region magnification is enabled.

Motion tracking properties in the Timeline panel

Each time you click Track Motion or Stabilize Motion in the Tracker panel (or choose Animation > Track Motion or Animation > Stabilize Motion), a
new tracker is created for the layer in the Timeline panel. Each tracker contains track points, which are property groups that store the tracking data
after tracking has been performed. Trackers are grouped in the Motion Trackers property group for each layer in the Timeline panel.

Q To show a tracker in the Timeline panel, select the tracker from the Current Track menu in the Tracker panel and press SS.

You can rename trackers and track points and modify and animate their property values in the Timeline panel just as you do for other layer
properties and property groups. You must click Apply in the Tracker panel to apply the property changes to the target.

Feature Center Position of the center of the feature region.

Feature Size Width and height of the feature region.
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Search Offset Position of the center of the search region relative to the center of the feature region.
Search Size Width and height of the search region.

Confidence Property through which After Effects reports the amount of certainty regarding the match made for each frame. In general,
Confidence is not a property that you modify.

Attach Point Position assigned to the target layer or effect control point.

Attach Point Offset Position of the attach point relative to the center of the feature region.

Adjust the track point To the top

When you set up motion tracking, it's often necessary to refine your track point by adjusting the feature region, search region, and attach point.
You can resize or move these items independently or in groups by dragging using the Selection tool. To help you define the area to be tracked,
the image area within the feature region is magnified to 400% while you move the region.

= - F.%' |
Track point components and Selection tool pointer icons

A. Search region B. Feature region C. Keyframe marker D. Attach point E. Moves search region F. Moves both regions G. Moves entire track
point H. Moves attach point |. Moves entire track point J. Resizes region

« To turn on or off feature region magnification, choose Magnify Feature When Dragging from the Tracker panel menu.

« To move the feature region, search region, and attach point together, drag inside the track point area (avoiding the region edges and the
attach point), or press the Up, Down, Left, or Right Arrow key. Hold Shift while pressing an arrow key to move by an increment 10 times as
large.

« To move only the feature and search regions together, drag the edge of the feature region, or Alt-drag (Windows) or Option-drag (Mac OS)
with the Selection tool inside the feature or search region. You can also hold Alt (Windows) or Option (Mac OS) while pressing the Up, Down,
Left, or Right Arrow key. Hold Alt+Shift (Windows) or Option+Shift (Mac OS) while pressing an arrow key to move by an increment 10 times
as large.

« To move only the search region, drag the edge of the search region.

Q Offset the search region center from the feature region center in the direction in which the tracked feature is traveling.

« To move only the attach point, drag the attach point.
« To resize the feature or search region, drag a corner handle.

« To make all of the sides of the region match the length of the longest side, and to resize the region relative to the original center point of the
region, Shift-drag a corner handle.

» To make all of the sides of the region match the length of the longest side, and to resize the region relative to a particular corner handle,
Ctrl+Shift-drag (Windows) or Command+Shift-drag (Mac OS) the opposite corner handle.

Q To restrict the movement of the track point to the x (horizontal) or y (vertical) axis during tracking, resize the height or width of the search region
to match the height or width of the feature region.

To the top
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Apply tracking data to a new target

After you've tracked a motion source layer, you can apply the tracking data stored on that layer to any number of other target layers and effect
control points. For example, you can apply the track to the position of a light bulb and to the effect control point of the Lens Flare effect.

1.

Correct a motion track

In the Tracker panel, choose the tracked layer from the Motion Source menu.

2. Choose the track that contains the tracking data you want from the Current Track menu.
3.
4. In the Tracker panel, click the Apply button.

Click Edit Target, and choose the target.

To the top

As an image moves in a shot, the lighting, surrounding objects, and angle of the object can all change, making the once distinct feature no longer
identifiable at the subpixel level. Also, if the search region is too small, the tracked feature may leave its bounds from one frame to the next.

Learning to choose a trackable feature takes time. Even with careful planning and practice, the feature region can drift away from the desired
feature. Re-adjusting the feature and search regions, changing the tracking settings, and trying again is a standard part of automatic tracking. It's
not necessary to get a single good track in one try. You may need to track the shot in sections, redefining the feature region in places where the
feature changes and the region drifts. You may even need to choose a different feature to track, one with movement that closely matches that of
the feature to track, and use the attach point offset to place the target.

After you've tracked motion, each track point has a motion path in the Layer panel that shows the position of the center of the feature region. You
can fine-tune the keyframes of the motion path in the Layer panel as you would any other motion path. Modifying the motion path is most useful
when you want to manually change the motion tracking data before applying it to a target. In some cases, it may be easier to manually modify the
motion path created by the motion tracker than to get a perfect track.

Motion source and its motion path
A. Moving the feature and search regions B. Keyframe marker

Correct drifting by adjusting the feature and search regions

1.
2.
3.

Move the current-time indicator to the last well-tracked frame.
Alt-drag (Windows) or Option-drag (Mac OS) the feature and search regions only (not the attach point) to the correct location.

If you are correcting the track for one frame, go to step 4. If you are correcting the track for several contiguous frames, adjust the feature
region and search region if necessary, and click Analyze. Watch the tracking to make sure that it is accurate. If the tracking is not accurate,
then click the button again to stop tracking, adjust the feature region, and begin again.

. When you are satisfied with the track, click Apply to apply the keyframes to the target layer or effect control point.

Correct drifting by modifying tracking settings

a b~ WO N P

. Move the current-time indicator to the last well-tracked frame.

. In the Tracker panel, click Options.

. Change settings in the Motion Tracker dialog box as appropriate. (See Motion tracking options.)

. In the Tracker panel, click the Analyze Forward or the Analyze Backward button.

. Watch the tracking to make sure that it is accurate. If the tracking is not accurate, then click the button again to stop tracking, adjust the

settings, and begin again.

. When you are satisfied with the track, click Apply to apply the keyframes to the target layer or effect control point.

To the top
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Stabilize motion with the Warp Stabilizer effect (CS5.5 and later)

You can stabilize motion with the Warp Stabilizer effect. It removes jitter caused by camera movement, making it possible to transform shaky,
handheld footage into steady, smooth shots. See Tracking and stabilizing motion for more information about using the point tracker for stabilizing
motion.

For video tutorials, details, and resources about the Warp Stabilizer effect, see this article on the Adobe website.

Stabilize with the Warp Stabilizer effect
To stabilize motion using the Warp Stabilizer effect, do the following:

1. Select the layer you want to stabilize.

2. Do one of the following:

« Choose Effect > Distort > Warp Stabilizer.
* Go to the Effects & Presets panel > Distort and apply the Warp Stabilizer to the layer.

In After Effects CS5.5:

» Choose Animation > Stabilize Motion.
« In the Tracker panel, click the Stabilize Motion button.
« In After Effects CS5.5, right-click the footage item in the Timeline panel and choose > Stabilize Motion.

In After Effects CS6:

« Choose Animation > Warp Stabilizer.
« In the Tracker panel, click the Warp Stabilizer button.
» Right-click the footage item in the Timeline panel and choose > Warp Stabilizer.

After the effect is added to the layer, analysis of the footage begins immediately in the background. As analysis begins, the first of two

banners displays in the Composition panel indicating that analysis is occurring. When analysis is complete, the second banner displays a
message that stabilization is occurring.

You are free to work with the footage or elsewhere in the project while these steps are occurring.

Stabilizing using the point tracker in After Effects CS6

Though the Warp Stabilizer will serve most of your needs for stabilization, there are times when you may want to use the legacy stabilizer. You
can access the stabilizer in the following way:

1. Select a layer.
2. In the Tracker panel, click Stabilize Motion.
3. Switch Track Type to Stabilize.

4. Stabilize footage as you would in After Effects CS5. (See Track or stabilize motion.)

Stabilizing using the point tracker in After Effects CS5.5
In After Effects CS5.5, access the legacy stabilizer in the following way:

1. Select a layer.
2. In the Tracker panel, click Track Motion.
3. Switch Track Type to Stabilize.

4. Stabilize footage as you would in After Effects CS5. (See Track or stabilize motion.)

Warp Stabilizer settings
Analyze

There is no need to press this button when you first apply Warp Stabilizer, it is pressed for you automatically. The Analyze button remains dimmed
until some change takes place. For example, if you adjust a layer’s In or Out points, or there is an upstream change to the layer source. Click the
button to reanalyze the footage.

Note: Analysis does not take into account any masks or effects that are applied directly to the same layer. Pre-compose and place them in the
upstream composition if you want them to be analyzed.
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Cancel
Cancels an analysis in progress. During analysis, status information appears next to the Cancel button.
Stabilization

Stabilization settings allow for adjusting the stabilization process.

Result Controls the intended result for the footage (Smooth or No Motion).

« Smooth motion (default): Retains the original camera movement but makes it smoother. When selected, Smoothness is enabled to control
how smooth the camera movement becomes.

« No Motion: Attempts to remove all camera motion from the shot. When selected, the Crop Less <-> Smooth More function is disabled in the
Advanced section. This setting is used for footage where at least a portion of the main subject remains within the frame for the entire range
being analyzed.

Smoothness Chooses how much the camera’s original motion is stabilized. Lower values are closer to the camera’s original motion while higher
values are smoother. Values above 100 require more cropping of the image. Enabled when the Result is set to Smooth Motion.

Method Specifies the most complex operation the Warp Stabilizer performs on the footage to stabilize it:
« Position Tracking is based on position data only and is the most basic way footage can be stabilized.

« Position, Scale And Rotation Stabilization is based upon position, scale, and rotation data. If there are not enough areas to track, Warp
Stabilizer chooses the previous type (Position).

« Perspective: Uses a type of stabilization in which the entire frame is effectively corner-pinned. If there are not enough areas to track, Warp
Stabilizer chooses the previous type (Position, Scale, Rotation).

» Subspace Warp (default): Attempts to warp various parts of the frame differently to stabilize the entire frame. If there are not enough areas
to track, Warp Stabilizer choose the previous type (Perspective).

The method in use on any given frame can change across the course of the clip based on the tracking accuracy.

note: In some cases, Subspace Warp can introduce unwanted warping, and Perspective can introduce unwanted keystoning. You can
prevent anomalies by choosing a simpler method.

Borders

Borders settings adjust how borders (the moving edges) are treated for footage that is stabilized.

Framing Controls how the edges appear in a stabilizing result. Framing can be set to one of the following:

« Stabilize Only: Displays the entire frame, including the moving edges. Stabilize Only shows how much work is being done to stabilize the
image. Using Stabilize Only allows you to crop the footage using other methods. When selected, the Auto-scale section and Crop Less <->
Smooth More property are disabled.

» Stabilize, Crop: Crops the moving edges without scaling. Stabilize, Crop is identical to using Stabilize, Crop, Auto-scale, and setting
Maximum Scale to 100%. With this option enabled, the Auto-scale section is disabled, but the Crop Less <-> Smooth More property is
enabled.

« Stabilize, Crop, Auto-scale (default): Crops the moving edges and scales up the image to refill the frame. The automatic scaling is
controlled by various properties in the Auto-scale section.

« Stabilize, Synthesize Edges: Fills in the blank space created by the moving edges with content from frames earlier and later in time
(controlled by Synthesizes Input Range in the Advanced section). With this option, the Auto-scale section and Crop Less <-> Smooth More
are disabled.

Note: Itis possible for artifacts to appear when there is movement at the edge of the frame not related to camera movement.

Auto-scale Displays the current auto-scale amount, and allows you to set limits on the amount of auto-scaling. Enable Auto-scale by setting
framing to Stabilize, Crop, Auto-scale.

e Maximum Scale: Limits the maximum amount a clip is scaled up for stabilization.

« Action-Safe Margin: When non-zero, specifies a border around the edge of the image that you don’t expect to be visible. Thus, auto-scale
does not try to fill it.

Additional Scale Scales up the clip with the same result as scaling using the Scale property under Transform, but avoids an extra resampling of
the image.

Advanced

Detailed Analysis When set to on, makes the next Analysis phase do extra work to find elements to track. The resulting data (stored in the
project as part of the effect) is much larger and slower with this option enabled.

Rolling Shutter Ripple The stabilizer automatically removes the rippling associated with stabilized rolling shutter footage. Automatic Reduction is
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the default. Use Enhanced Reduction if the footage contains larger ripples. To use either method, set the Method to Subspace Warp or
Perspective.

Crop Less <-> Smooth More When cropping, controls the trade-off between smoothness and scaling of the cropping rectangle as it moves over
the stabilized image. Lower values are smooth, however, more of the image is viewed. At 100%, the result is the same as the Stabilize Only
option with manual cropping.

Synthesis Input Range (seconds) Used by Stabilize, Synthesize Edges framing, controls how far backward and forward in time the synthesis
process goes to fill in any missing pixels.

Synthesis Edge Feather Selects the amount of feather for the synthesized pieces. It is enabled only when using the Stabilize, Synthesize Edges
framing. Use the feather control to smooth over edges where the synthesized pixels join up with the original frame.

Synthesis Edge Cropping Trims off the edges of each frame before it is used to combine with other frames when using the Stabilize, Synthesize
Edges framing option. Use the cropping controls to crop off bad edges that are common in analog video capture, or low quality optics. By default,
all edges are set to zero pixels.

Hide Warning Banner Use when you don’t want to reanalyze footage even though there is a warning banner indicating that it must be
reanalyzed.
Warp Stabilizer workflow tips

1. Apply the Warp Stabilizer.
2. While Warp Stabilizer is analyzing your footage, you can adjust settings or work on a different part of your project.

3. Choose Stabilization > Result > No Motion if you want to completely remove all camera motion. Choose Stabilization > Result > Smooth
Motion if you want to include some of the original camera movement in the shot.

4. If the result is good, you're done with stabilization. If not, do one or more of the following:

« If the footage is too warped, or distorted, switch the Method to Position, Scale, Rotation.

« If there are occasional rippled distortions, and footage was shot with a rolling shutter camera, set Advanced > Rolling Shutter Ripple to
Enhanced Reduction.

e Try checking Advanced > Detailed Analysis.

5. If the result is too cropped, reduce either Smoothness or Crop Less <-> Smooth More. Crop Less <-> Smooth More is much more
responsive, as it doesn’t require a restabilize phase.

6. If you want to get a feel for how much work the stabilizer is actually doing, set the Framing to Stabilize Only.

When Framing is set to one of the cropping options and the cropping gets extreme, a red banner appears saying, “To avoid extreme cropping set
Framing to Stabilize Only or adjust other parameters”. In this situation, you can either set Framing to Stabilize Only, or Stabilize, Synthesize Edges.
Other options include reducing the value of Crop Less <-> Smooth More, or reducing Smoothness. Or, if you are satisfied with the results, enable
the Hide Warning Banner option.

e Expression basics
e Scale orflip a layer
e Motion paths
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Tracking 3D Camera Movement (CS6)

3D camera tracker effect
Analyzing footage and extracting camera motion
Attaching content into a scene containing a solved camera
Moving the target to attach content to different location
Resizing a target
Selecting and deselecting track points
Deleting unwanted track points
Creating a "shadow catcher” layer
Effects controls for the 3D camera tracker
Exporting 3D Camera Tracker data to 3D applications

To thet
3D camera tracker effect ometop

The 3D camera tracker effect analyzes video sequences to extract camera motion and 3D scene data. The 3D camera motion allows you to
correctly composite 3D elements over your 2D footage.

Q Like the Warp Stabilizer, the 3D camera tracker effect performs analysis using a background process. Feel free to adjust settings or work on a
different part of your project while analysis is taking place.

For details about using the 3D camera tracker effect, see this video tutorial by Angie Taylor from Learn by Video.

Analyzing footage and extracting camera motion
1. With a footage layer selected, do one of the following:
a. Choose Animation > Track Camera, or choose Track Camera from the layer context menu.
b. Choose Effect > Perspective > 3D Camera Tracker.
c. In the Tracker panel, click the Track Camera button.

The 3D Camera Tracker effect is applied. The analysis and solving phases occur in the background, with status appearing as a banner
on the footage and next to the Cancel button.

2. Adjust the settings, as needed.
The 3D solved track points appears as small colored x's. You can use these track points to place content into the scene.

Q You can select more than one layer at a time for camera tracking using the 3D camera tracker effect.

Attaching content into a scene containing a solved camera
1. With the effect selected, select the track point or multiple track points (defining a best-fit plane) to use as the attach point.

a. Hover between three neighboring unselected track points that can define a plane, a semitransparent triangle appears between the
points. A red target appears, showing the orientation of the plane in 3D space.

b. Draw a marquee-selection box around multiple track points to select them.
2. Right-click above the selection or target, and then choose the type of content to create. The following types can be created:
o Text
« Solid
« Null layer for the center of the target
« Text, solid, or null layer for each selected point

« "Shadow catcher" layer (a solid that accepts shadows only) for the created content by using the Create Shadow Catcher command in the
context menu.

Note: A shadow catcher layer also creates a light if one does not exist.
Q If creating multiple layers, each one has a unique numbered name. If creating multiple text layers, In and Out points are trimmed to match the

point durations.
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Moving the target to attach content to different location

To move the target so that you can attach content to a different location, do the following:
1. When above the center of the target, the "move" cursor appears for repositioning the target.
2. Drag the center of the target to desired location.

Once at the intended location, you can attach content by using the commands in the context menu.

Q If the size of the targets is too small or too large to see you can resize them to help visualize the planes. The target size also controls the
default size of text and solid layers created using the context menu commands.

Resizing a target
To resize a target, do one of the following:
« Adjust the Target Size property.

» Press Alt-click (Windows) or Option-click (Mac OS) as you drag from the center of the target. When above the center of the target, a cursor
with horizontal arrows allows you to resize the target.

Selecting and deselecting track points
To select track points, do one of the following:

e Click a track point.

« Click between three adjacent track points.

« Draw a marquee-selection box around multiple points.

« Shift-click or draw a Shift-marquee selection box around the track points to add multiple track points to the current selection.
To deselect track points, do one of the following:

« Alt-click (Windows) or Option-click (Mac OS) selected track points.

e Click away from a track point.

Q Moving objects can confuse the 3D camera tracker effect. It can interpret points for stationary objects close to the camera as moving due to
parallax. To help solve the camera, delete bad, or unwanted points.

Deleting unwanted track points
To delete unwanted track points, do the following:

1. Select the track points.
2. Press Delete or choose Delete Selected Points from the context menu.

After deleting unwanted track points, the camera is re-solved. You can delete additional points while re-solving takes place in the background.
Deleting 3D points deletes the corresponding 2D points, as well.

Creating a "shadow catcher" layer

You can quickly create a "shadow catcher" layer, used to create realistic shadows for the effect. A shadow catcher layer is white solid the same
size as the footage, but set to accept shadows only.

To create a shadow catcher layer, use the Create Shadow Catcher, or Create Shadow Catcher and Camera commands in the context menu.

If necessary, adjust the position and scale of the shadow catcher layer so the cast shadow appears as desired. This command also creates a
shadow-casting light (a light that is switched on, and casts shadows) if one does not exist in the composition.

Effects controls for the 3D camera tracker
The effect has the following controls and settings:

Analyze/Cancel Starts or stops the background analysis of the footage. During analysis, status appears as a banner on the footage and next to
the Cancel button.

Shot Type Specifies whether the footage was captured with a fixed horizontal angle of view, variable zoom, or a specific horizontal angle of view.
Changing this setting requires a re-solve.

Horizontal Angle of View Specifies the horizontal angle of view the solver should use. Enabled only when Shot Type is set to Specify Angle of
View.
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Show Track Points Identifies detected features as 3D points with perspective hinting (3D Solved) or 2D points captured by the feature track (2D
Source).

Render Track Points Controls if the track points are rendered as part of the effect.

Note: When the effect is selected, track points are always shown, even if Render Track Points is not selected. When enabled, the points are
displayed into the image allowing them to be seen during RAM preview.

Track Point Size Changes the displayed size of the track points.

Create Camera Creates the 3D camera. A camera is automatically added when you create a text, solid, or null layer from the context menu.

Advanced controls Advanced controls for the 3D camera tracker effect:

Solve Method: Provides hints about the scene to help in solving the camera. Solve the camera by trying the following:
« Auto Detect: Automatically detects the scene type.
« Typical: Specifies the scene as that which are not purely rotational, or mostly flat.
« Mostly Flat Scene: Specifies the scene as mostly flat, or planar.
« Tripod Pan: Specifies the scene as purely rotational.

* Method Used: When Solve Method is set to Auto Detect, this displays the actual solve method used.

« Average Error: Displays the average distance (in pixels) between the original 2D source points and a reprojection of the 3D solved points
onto the 2D plane of the source footage. If a track/solve was perfect, this error would be 0 and there would be no visible difference if you
toggled between 2D Source and 3D Solved track points. You can use this value to tell if deleting points, changing the solve method, or
making other changes is lowering this value, and thus improving the track.

« Detailed Analysis: When checked, makes the next analysis phase do extra work to find elements to track. The resulting data (stored in the
project as part of the effect) is much larger and slower with this option enabled.

« Hide Warning Banner: Use when you don't want to reanalyze footage even though there is a warning banner indicating that it needs to be
reanalyzed.

Exporting 3D Camera Tracker data to 3D applications
You can export 3D Camera Tracker data to 3D applications like Maxon Cinema 4D.

Do the following:

1. Download plug-ins for exporting camera tracking data. For example, from Maxon.net

2. Install the plug-ins to the plug-ins folder.

3. Choose File > Export > (plug-in manufacturer]. For Cinema4D, choose Cinema 4D Exporter.
4. Name the file and click Save.

5. Open the file in the 3D application.

For more information about exporting camera tracker data, and how to import rendered objects back in to After Effects, see this video tutorial by
Chris and Trish Meyer.
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Animating with Puppet tools

Puppet tools overview and resources

Manually animate an image with the Puppet tools

Record animation by sketching motion with the Puppet Pin tool
How the Puppet effect creates outlines

Work with Puppet pins and the distortion mesh

Puppet Overlap controls

Puppet Starch controls

. To the to
Puppet tools overview and resources .

Use the Puppet tools to quickly add natural motion to raster images and vector graphics, including still images, shapes, and text characters.

Note: Though the Puppet tools work within an effect (the Puppet effect), you don’t apply the effect using the Effect menu or the Effects & Presets
panel. Use the Puppet tools in the Tools panel to directly apply and work with the effect in the Layer panel or Composition panel.

The Puppet effect works by deforming part of an image according to the positions of pins that you place and move. These pins define what parts
of the image should move, what parts should remain rigid, and what parts should be in front when parts overlap.

Each Puppet tool is used to place and modify a specific type of pin:

Puppet Pin tool # Use this tool to place and move Deform pins.

Puppet Overlap tool kA Use this tool to place Overlap pins, which indicate which parts of an image should appear in front of others when
distortion causes parts of the image to overlap one another.

Puppet Starch tool ;&ﬁ Use this tool to place Starch pins, which stiffen parts of the image so that they are distorted less.

- -

Mesh éreated by placing Deform pins (left), ahd result of dragging a Deform pin

When you place the first pin, the area within an outline is automatically divided into a mesh of triangles. An outline is only visible when the Puppet
effect has been applied and a Puppet tool pointer is over the area that the outline defines. (See How the Puppet effect creates outlines.) Each part
of the mesh is also associated with the pixels of the image, so the pixels move with the mesh.

Note: To show the mesh, select Show in the Tools panel.

When you move one or more Deform pins, the mesh changes shape to accommodate this movement, while keeping the overall mesh as rigid as
possible. The result is that a movement in one part of the image causes natural, life-like movement in other parts of the image.

For example, if you place Deform pins in a person’s feet and hands and then move one of the hands to make it wave, the motion in the attached
arm is large, but the motion in the waist is small, just as in the real world.

If a single animated Deform pin is selected, its Position keyframes are visible in the Composition panel and Layer panel as a motion path. You can
work with these motion paths as you work with other motion paths, including setting keyframes to rove across time. (See Smooth motion with
roving keyframes.)

You can have multiple meshes on one layer. Having multiple meshes on one layer is useful for deforming several parts of an image individually—
such as text characters—as well as for deforming multiple instances of the same part of an image, each with a different deformation.

The original, undistorted mesh is calculated at the current frame at the time at which you apply the effect. The mesh does not change to
accommodate motion in a layer based on motion footage, nor does the mesh update if you replace a layer’s source footage item.

Note: Don't animate the position or scale of a continuously rasterized layer with layer transformations if you are also animating the layer with the
Puppet tools. The render order for continuously rasterized layers—such as shape layers and text layers—is different from the render order for
raster layers. You can precompose the shape layer and use the Puppet tools on the precomposition layer, or you can use the Puppet tools to
transform the shapes within the layer. (See Render order and collapsing transformations and Continuously rasterize a layer containing vector
graphics.)

The motion created by the Puppet tools is sampled by motion blur if motion blur is enabled for the layer and the composition, though the number
of samples used is half of the value specified by the Samples Per Frame value. (See Motion blur.)
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Q You can use expressions to link the positions of Deform pins to motion tracking data, audio amplitude keyframes, or any other properties.

Online resources for the Puppet tools
For a video tutorial on using the Puppet tools, go to the Adobe website.

Trish and Chris Meyer give tips for using the Puppet tools on the ProVideo Coalition website.

Aharon Rabinowitz provides a tutorial on the Creative COW website that shows a creative way to use the Puppet tools with a particle generator to
simulate airflow over a car.

Eran Stern provides a video tutorial on the Creative COW website that shows how to duplicate an object using the Puppet Pin tool.

Richard Harrington provides a pair of video tutorials that show how to prepare an image in Photoshop for animation in After Effects with the Puppet
tools:

e Partl
e Part 2

Robert Powers provides a video tutorial on the Slippery Rock NYC website that demonstrates the use of parenting and the Puppet tools to animate
a character.

Dave Scotland provides a video tutorial on the CG Swot website that demonstrates how to create a looping character animation using the Puppet
tools.

Kert Gartner provides a video tutorial on the VFX Haiku website that shows how to add organic motion to images using the wiggle expression
method on Puppet pins.

Daniel Gies provides a detailed series of video tutorials in which he demonstrates the use of inverse kinematics and the Puppet tools to rig and
animate a character.

Manually animate an image with the Puppet tools fothetop

The stopwatch switch © is automatically set for the Position property of a Deform pin as soon as the pin is created. Therefore, a keyframe is set or
modified each time that you change the position of a Deform pin. This auto-keyframing is unlike most properties in After Effects, for which you
must explicitly set the stopwatch switch by adding a keyframe or an expression to animate each property. The auto-animation of Deform pins
makes it convenient to add them and animate them in the Composition panel or Layer panel, without manipulating the properties in the Timeline
panel.

1. Select the layer that contains the image to animate.
2. Using the Puppet Pin tool }?, do one of the following in the Composition panel or the Layer panel:

« Click any nontransparent pixel of a raster layer to apply the Puppet effect and create a mesh for the outline created by auto-tracing the
alpha channel of a layer.

« Click within a closed path on a vector layer to apply the Puppet effect and create a mesh for the outline defined by that path.
« Click within a closed, unlocked mask to apply the Puppet effect and create a mesh for the outline defined by the mask path.

« Click outside all closed paths on a vector layer to apply the Puppet effect without creating a mesh. Outlines are created for paths on the
layer, though an outline is only visible when a Puppet tool pointer is over the area that the outline defines. Place the pointer over the
area enclosed by a path to see the outline in which a mesh will be created if you click that point. (See How the Puppet effect creates
outlines.) Click within an outline to create a mesh.

A Deform pin is placed where you clicked to create the mesh.

Note: If an image is too complex for the Puppet effect to generate a mesh with the current Triangle value, a “Mesh Generation Failed”
message appears in the Info panel. Increase the Triangle value in the Tools panel and try again.

3. Click in one or more places within the outline to add more Deform pins.

Use as few pins as possible to achieve your desired result. The natural deformation provided by the Puppet effect can be lost if you over-
constrain the image. Just add pins to the parts of the figure that you know that you want to control. For example, when animating a person
waving, add a pin to each foot to hold them to the ground, and add a pin to the waving hand.

4. Go to another time in the composition, and move the position of one or more of the Deform pins by dragging them in the Composition or
Layer panel with the Puppet Pin tool. Repeat this step until you have completed your animation.

You can modify the motion paths of the Deform pins using the same techniques that you use to modify any other motion paths.

Note: After Effects CS6 no longer draws the tinted fill for the original layer region when hovering using the Puppet Pin tool.

Record animation by sketching motion with the Puppet Pin tool fothetop

You can sketch the motion path of one or more Deform pins in real time—or at a speed that you specify—much as you can sketch the motion path
of a layer using Motion Sketch.
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If your composition contains audio, you can sketch motion in time with the audio.

Before you begin recording motion, you may want to configure settings for recording. To open the Puppet Record Options dialog box, click Record
Options in the Tools panel.

Speed The ratio of the speed of the recorded motion to speed of playback. If Speed is 100%, the motion is played back at the speed at which it
was recorded. If Speed is greater than 100%, the motion plays back slower than it was recorded.
Smoothing Set this value higher to remove more extraneous keyframes from the motion path as it's drawn. Creating fewer keyframes makes
motion smoother.
Use Draft Deformation The distorted outline that is shown during recording does not take Starch pins into account. This option can improve
performance for a complex mesh.
Note: This procedure assumes that you have already placed Deform pins in the object to animate. For information on placing Deform pins, see
Manually animate an image with the Puppet tools.

1. Select one or more Deform pins.

2. Go to the time at which to begin recording motion.

3. In the Composition panel or Layer panel, hold the Ctrl (Windows) or Command (Mac OS) key to activate the Puppet Sketch tool. Ctrl-drag
(Windows) or Command-drag (Mac OS) the pins to animate.

Recording of motion begins when you click to begin the drag. Recording ends when you release the mouse button.

The color of the outline for the mesh for which motion is being sketched is the same as the color of the pin (yellow). Reference outlines, for
other meshes on the same layer, match the label color of the layer.

The current-time indicator returns to the time at which recording began, so that you can repeat the recording operation with more Deform
pins or redo the recording operation with the same pins.

You can modify the motion paths of the Deform pins using the same techniques that you use to modify any other motion paths. The motion path
for a pin is shown only if it is the only pin selected.

Q Try creating several duplicate meshes and sketching motion for each mesh. When you have multiple meshes in the same instance of the
Puppet effect, you can sketch motion for one mesh while seeing the reference outlines of the others, allowing you to follow their movements,
either roughly or precisely.

How the Puppet effect creates outlines fotnetop

When a Puppet mesh is created, its boundaries are determined by an outline, which can be defined by any of the following types of closed paths:
* An unlocked mask path
« A shape path on a shape layer
« A text character’s outline

If a layer has no unlocked masks, shapes, or text characters on it when you apply the Puppet effect, it uses Auto-trace to create paths from the
alpha channel. These paths are only used by the Puppet effect in the determination of outlines and do not appear as masks on the layer. If the
layer is a raster layer with no alpha channel, the result is a single rectangular path around the bounds of the layer. For a complex image, or to

configure Auto-trace settings, use Auto-trace before using the Puppet tools. (See Create a mask from channel values with Auto-trace.)

A text character that consists of multiple disjoint closed paths (such as the letter i) is treated as multiple separate paths.

The stroke of a shape or text character is not used in the determination of outlines; only the path is used. To encompass a stroke within a mesh
created from such items, increase the Expansion value. The default value of 3 pixels for Expansion encompasses a stroke that extends 3 pixels or
less from its path.

Q Apply paint strokes to a layer using the Brush tool with the Paint On Transparent option. Painting with this option selected creates a raster layer
with only the paint strokes, defined by an alpha channel. You can then use the Puppet tools to animate the paint strokes. Do not use a mask on
the layer.

If multiple masks, shapes, or characters overlap on the same layer, an outline is created from the union of the overlapping shapes, overlapping
characters, or overlapping masks. If a mask overlaps a text character or shape, outlines are created for the entire character or shape, for the
portion of the character or shape that is inside the mask, and for the mask itself.

Q To distort multiple disjoint characters or shapes as one object, surround the individual objects with a mask (with mask mode set to None), and
use the mask path as the outline with which to create the mesh. You can delete the mask after you have created the mesh.

If the Puppet effect has already been applied to a layer, outlines appear with a yellow highlight as you move a Puppet tool pointer over them. You
can choose the outline in which to place an initial pin to create a mesh. A mesh is created each time that you click within an outline with a Puppet
tool.

If the Puppet effect has not already been applied to a layer, outlines for that layer have not yet been calculated. When you click, the Puppet effect
calculates outlines and determines whether you have clicked within an outline. If so, it creates a mesh defined by the outline in which you clicked.
Otherwise, you can move the pointer around in the layer to select the outline in which to place a pin and create a mesh. Moving the pointer around
in the layer is useful for seeing the outlines of various objects and choosing which outlines to use to create a mesh.
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Outline for union of two shape paths, indicated by yellow highlight, visible because Puppet tool pointer is within area defined by outline

To the top

Work with Puppet pins and the distortion mesh

» To show the mesh for the Puppet effect, select Show in the options section of the Tools panel.

« To select or move a pin, click or drag it with the Move tool P& To activate the Move tool, place the pointer on a pin while either the Selection
tool X or the corresponding Puppet tool is active.

» To select multiple pins, Shift-click them, or use the marquee-selection tool M to drag a marquee-selection box around them. To activate the
marquee-selection tool, place the pointer for a Puppet tool outside all meshes and outlines or hold the Alt (Windows) or Option (Mac OS)
key.

« To select all pins of one kind (Deform, Starch, or Overlap), select one pin of that kind and press Ctrl+A (Windows) or Command+A (Mac
0S).

» To delete selected pins, press the Delete key. If the pin has multiple keyframes, and only the keyframe at the current time is selected,
pressing Delete deletes only that keyframe; pressing Delete again deletes the pin.

» To reset Deform pins to their original locations at the current time, click Reset for the Puppet effect in the Timeline panel or Effect Controls
panel. To remove all pins and meshes from an instance of the Puppet effect, click Reset again.
Q Sometimes, you want to animate an image from an initial position, through an intermediate position, and back to the initial position. Rather
than manually dragging the pins back to their initial positions at the end of the animation, place the current-time indicator at the end time
and click Reset. Only the keyframes at the current time are reset.

» To increase or decrease the number of triangles used in a mesh, modify the Triangle value in the options section of the Tools panel or in the
Timeline panel. Modifying the Triangle value sets the value for a selected mesh or, if no mesh is selected, sets the value for meshes created
later.

A higher number of triangles gives smoother results but takes longer to render. Small objects, like text characters, usually distort well with
only 50 triangles, whereas a large figure may require 500. The number of triangles used may not match the Triangle value exactly; this value
is a target only.

« To expand the mesh beyond the original outline, increase the Expansion property in the options section of the Tools panel or in the Timeline
panel. Modifying the Expansion property sets the value for a selected mesh or, if no mesh is selected, sets the value for meshes created
later. Expanding the mesh is useful for encompassing a stroke.

« To duplicate an object using Puppet Pin tool, click within the original outline. Clicking within the original outline creates a new mesh, with its
own copy of the pixels from within the original outline. You can also duplicate a Mesh group in the Timeline panel to achieve the same result,
which is sometimes easier than clicking within the original outline without clicking the mesh to create a pin.

Puppet Overlap controls To the top

When you are distorting one part of an image, you may want to control which parts of the image appear in front of other parts. For example, you
may want to keep an arm in front of the face as you make the arm wave. Use the Puppet Overlap tool to apply Overlap pins to the parts of an
object for which you want to control apparent depth.

You apply Puppet Overlap pins to the original outline, not to the deformed image.
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Overlap pin wth negative In Front value (tob), and Overlap pin with positive In Front value (bottom)

Each Overlap pin has the following properties:

In Front The apparent proximity to the viewer. The influence of Overlap pins is cumulative, meaning that the In Front values are added together
for places on the mesh where extents overlap. You can use negative In Front values to cancel out the influence of another Overlap pin at a
specific location.

An area of the mesh that is not influenced by Overlap pins has an implicit In Front value of 0. The default value for a new Overlap pin is 50.

Q When animating the In Front value, you should usually use Hold keyframes. You do not usually want to interpolate gradually from an element
being in front to an element being in back.

Extent How far from the Overlap pin its influence extends. The influence ends abruptly; it does not decrease gradually with distance from the pin.
Extent is indicated visually by a fill in the affected parts of the mesh. The fill is dark if In Front is negative; the fill is light if In Front is positive.

To the top

Puppet Starch controls

When you are distorting one part of an image, you may want to prevent other parts from being distorted. For example, you may want to preserve
the rigidity of an arm as you move a hand to make it wave. Use the Puppet Starch tool to apply Starch pins to the part of an object that you want
to keep rigid.

You apply Puppet Starch pins to the original outline, not to the deformed image.

& —i S
Unwanted distortion in figure (upper left) is prevented with Starch pin (upper right and lower left)

Each Starch pin has the following properties:

Amount The strength of the stiffening agent. The influence of Starch pins is cumulative, meaning that the Amount values are added together for
places on the mesh where extents overlap. You can use negative Amount values to cancel out the influence of another Starch pin at a specific
location.

—
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Q If you notice image tearing near a Deform pin, use a Starch pin with a very small Amount value (less than 0.1) near the Deform pin. Small
Amount values are good for maintaining image integrity without introducing much rigidity.

Extent How far from the Starch pin its influence extends. The influence ends abruptly; it does not decrease gradually with distance from the pin.
Extent is indicated visually by a pale fill in the affected parts of the mesh.

In addition to animating still images, you can use the Puppet effect on a layer with motion footage as its source. For example, you could distort the
contents of the entire composition frame to match the motion of an object within the frame. In this case, consider creating a mesh for the entire
layer, using the layer boundaries as the outline, and using the Puppet Starch tool around the edges to prevent the edges of the layer from
distorting.

More Help topics
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Time-stretching and time-remapping

Time-stretch a layer

Reverse the playback direction of a layer

Reverse keyframes without reversing layer playback

Time-remapping

Frame blending

Time-stretching, time-remapping, and the Timewarp effect are all useful for creating slow motion, fast motion, freeze frame, or other retiming
results.

For information on the Timewarp effect, see Timewarp effect.

Andrew Kramer provides a video tutorial on his Video Copilot website that demonstrates time-stretching, time-remapping, and frame blending.

. To the to
Time-stretch a layer ’
Speeding up or slowing down an entire layer by the same factor throughout is known as time-stretching. When you time-stretch a layer, the audio
and the original frames in the footage (and all keyframes that belong to the layer) are redistributed along the new duration. Use this command only
when you want the layer and all layer keyframes to change to the new duration.

Lo N ¢

Time-stretching a layer redistributes keyframes along the new duration.

If you time-stretch a layer so that the resulting frame rate is very different from the original frame rate, the quality of motion within the layer may
suffer. For best results when time-remapping a layer, use the Timewarp effect.

Time-stretch a layer from a specific time
1. In the Timeline or Composition panel, select the layer.
2. Choose Layer > Time > Time Stretch.
3. Type a new duration for the layer, or type a Stretch Factor.
4. To specify the point in time from which the layer will be time-stretched, click one of the Hold In Place options, and then click OK.
Layer In-point Holds the starting time of the layer at its current value and time-stretches the layer by moving its Out point.

Current Frame Holds the layer at the position of the current-time indicator (also the frame displayed in the Composition panel), and time-
stretches the layer by moving the In and Out points.

Layer Out-point Holds the ending time of the layer at its current value and time-stretches the layer by moving its In point.

Time-stretch alayer to a specific time
1. In the Timeline panel, move the current-time indicator to the frame where you want the layer to begin or end.
2. Display the In and Out columns by choosing Columns > In and Columns > Out from the Timeline panel menu.
3. Do one of the following:

« To stretch the In point to the current time, press Ctrl (Windows) or Command (Mac OS) as you click the In time for the layer in the In

233


http://www.videocopilot.net/tutorials/speed_variation/

column.

« To stretch the Out point to the current time, press Ctrl (Windows) or Command (Mac OS) as you click the Out time for the layer in the
Out column.

Time-stretch alayer but not its keyframes
When you time-stretch a layer, the positions of its keyframes stretch with it by default. You can circumvent this behavior by cutting and pasting
keyframes.
1. Make a note of the time at which the first keyframe appears. (Placing a composition marker is a good way to mark the time.)
In the Timeline panel, click the name of one or more layer properties containing the keyframes you want to keep at the same times.
Choose Edit > Cut.
Move or stretch the layer to its new In and Out points.
Move the current-time indicator to the time at which the first keyframe appeared before you cut the keyframes.
Choose Edit > Paste.

o gk wN

Reverse the playback direction of a layer fothetop

When you reverse the direction at which a layer plays back, all keyframes for all properties on the selected layer also reverse order. The layer
itself maintains its original In and Out points relative to the composition.

Note: For best results, precompose the layer and then reverse the layer inside the precomposition. For more information on this process, see
About precomposing and nesting.
1. In a Timeline panel, select the layer you want to reverse.

2. Choose Layer > Time > Time-Reverse Layer, or press Ctrl+Alt+R (Windows) or Command+Option+R (Mac OS).

. . To the to
Reverse keyframes without reversing layer playback ’
You can select and reverse keyframes across multiple layers and properties, but each set of keyframes for a property is reversed only within its
original time range and not that of any other selected property. Markers in the Timeline panel are not reversed, so you may need to move markers
after reversing keyframes.

1. In the Timeline panel, select a range of keyframes you want to reverse.
2. Choose Animation > Keyframe Assistant > Time-Reverse Keyframes.

. . To the top
Time-remapping

Time-remapping overview

You can expand, compress, play backward, or freeze a portion of the duration of a layer using a process known as time-remapping. For example, if
you are using footage of a person walking, you can play footage of the person moving forward, and then play a few frames backward to make the
person retreat, and then play forward again to have the person resume walking. Time-remapping is good for combinations of slow motion, fast
motion, and reverse motion.

The Timewarp effect provides similar features with more control over some aspects of frame blending, but with additional limitations as a result of
being applied as an effect.

m

Frames from non-time-remapped footage are displayed at a constant speed in one direction.
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Time-remapping distorts time for a range of frames within a layer.

When you apply time-remapping to a layer containing audio and video, the audio and video remain synchronized. You can remap audio files to
gradually decrease or increase the pitch, play audio backward, or create a warbled or scratchy sound. Still-image layers cannot be time-remapped.

You can remap time in either the Layer panel or the Graph Editor. Remapping video in one panel displays the results in both. Each provides a
different view of the layer duration:

« The Layer panel provides a visual reference of the frames you change, as well as the frame number. The panel displays the current-time
indicator and a remap-time marker, which you move to select the frame you want to play at the current time.

o0

Layer panel for time remapping
A. Current-time indicator B. Time-remap value C. Remap-time marker D. Navigator bar

« The Graph Editor provides a view of the changes you specify over time by marking your changes with keyframes and a graph like the one
displayed for other layer properties.

A B C D

2.0

1.0

n.n

Time-remapping graph
A. No change B. Fast motion C. Freeze frame D. Backward motion

When remapping time in the Graph Editor, use the values represented in the Time Remap graph to determine and control which frame of the
movie plays at which point in time. Each Time Remap keyframe has a time value associated with it that corresponds to a specific frame in the
layer; this value is represented vertically on the Time Remap value graph. When you enable time remapping for a layer, After Effects adds a Time
Remap keyframe at the start and end points of the layer. These initial Time Remap keyframes have vertical time values equal to their horizontal
position on the timeline.
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By setting additional Time Remap keyframes, you can create complex motion results. Each time you add a Time Remap keyframe, you create
another point at which you can change the speed or direction of playback. As you move the keyframe up or down in the value graph, you adjust
which frame of the video is set to play at the current time. After Effects then interpolates intermediate frames and plays the footage forward or
backward from that point to the next Time Remap keyframe. In the value graph, reading from left to right, an upward angle indicates forward
playback, while a downward angle indicates reverse playback. The amount of the upward or downward angle corresponds to the speed of
playback.

Similarly, the value that appears next to the Time Remap property name indicates which frame plays at the current time. As you drag a value
graph marker up or down, this value changes accordingly and a Time Remap keyframe is set, if necessary. You can click this value and type a
new one, or drag the value to adjust it.

The original duration of the source footage may no longer be valid when remapping time, because parts of the layer no longer play at the original
rate. If necessary, set a new duration for the layer before you remap time.

As with other layer properties, you can view the values of the Time Remap graph as either a value graph or a speed graph.

If you remap time and the resulting frame rate is very different from the original, the quality of motion within the layer may suffer. Apply frame
blending to improve time remapping for slow motion or fast motion.

Note: Use the information shown in the Info panel to guide you as you work with time-remapping. The ratio given in the units of seconds/sec
indicates the current speed of playback—the number of seconds of the original layer being played for each second after time-remapping.

Time-remap a layer
You can time-remap all or part of a layer to create many different results, such as freeze-frame or slow-motion results. (See Time-remapping.)

Freeze the current frame for the duration of the layer
1. In a Composition or Timeline panel, select the layer.
2. Place the current-time indicator on the frame that you want to freeze.
3. Choose Layer > Time > Freeze Frame.

Time-remapping is enabled, and a Hold keyframe is placed at the position of the current-time indicator to freeze the frame.If you previously
enabled time-remapping on the layer, any keyframes you created are deleted when you apply the Freeze Frame command.

Freeze the first frame without changing the speed
1. In a Composition or Timeline panel, select the layer that you want to remap.
2. Choose Layer > Time > Enable Time Remapping.

This command adds two Time Remap keyframes by default, one at the beginning of the layer and one at the end.

3. Move the current-time indicator to where you want the movie to begin.
4. Click the Time Remap property name to select the start and end keyframes.

5. Drag the first keyframe to the current-time indicator, which moves the start and end keyframes. (If you are working in the Graph Editor, drag
the bounding box—not the keyframe or a handle—so that both keyframes move.)

Freeze a frame in the middle of the duration of a layer

1. In a Composition or Timeline panel, select the layer that you want to remap.

2. Choose Layer > Time > Enable Time Remapping.

This command adds two Time Remap keyframes by default, one at the beginning of the layer and one at the end.

3. Move the current-time indicator to the frame that you want to freeze, and set a Time Remap keyframe at the current time by clicking the
keyframe navigator diamond for the Time Remap property.
Select the last two Time Remap keyframes (the second and third keyframes) and drag them to the right.
Press F2 to deselect the keyframes, and then click the second (middle) keyframe to select it.
Press Ctrl+C (Windows) or Command+C (Mac OS) to copy the keyframe.
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Press Ctrl+V (Windows) or Command+V (Mac OS) to paste the keyframe at the current time. You should not have moved the current-time
indicator since step 3.

8. (Optional) To extend the layer so that its duration is increased to accommodate the time added by the freeze-frame operation, press the K
key twice to move the current-time indicator to the last Time Remap keyframe, and press Alt+] (Windows) or Option+] (Mac OS).

The portion of the layer between the first and second keyframes plays at an unaltered rate (the same as for the non-time-remapped layer), as
does the portion of the layer between the third and fourth keyframes. The second and third keyframes are identical, so a single frozen frame plays
during the time between those two keyframes.

Remap time using the Graph Editor

Q To switch between Graph Editor mode and layer bar mode, press Shift+F3.

1. In a Composition or Timeline panel, select the layer you want to remap.
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2. Choose Layer > Time > Enable Time Remapping.
3. In the Timeline panel, click the name of the Time Remap property to select it.

4. Move the current-time indicator to the time at which to add a keyframe, and click the keyframe button < in the keyframe navigator to add a
keyframe.

5. In the Graph Editor, drag the keyframe marker up or down, watching the Time Remap value as you drag. To snap to other keyframes, Shift-
drag.

2.0

1.0

2.0

D

0.0 | S

Dragging the keyframe down slows down the layer.

« To slow the layer down, drag the keyframe down. (If the layer is playing in reverse, drag up.)
« To speed the layer up, drag the keyframe up. (If the layer is playing in reverse, drag down.)
« To play frames backward, drag the keyframe down to a value below the previous keyframe value.

« To play frames forward, drag the keyframe up to a value above the previous keyframe value.

To freeze the previous keyframe, drag the current keyframe marker to a value equal to the previous keyframe value so that the graph
line is flat. Another method is to select the keyframe and choose Animation > Toggle Hold Keyframe, and then add another keyframe
where you want the motion to start again.

Q Before you move a time-remap keyframe, it's a good idea to select all subsequent time-remap keyframes in the layer first. This selection will
preserve the timing of the rest of the layer when you remap time for the current keyframe.

Remap time in a Layer panel
1. Open the Layer panel for the layer you want to remap.

2. Choose Layer > Time > Enable Time Remapping. A second time ruler appears in the Layer panel above the default time ruler and the
navigator bar.

3. On the lower time ruler, move the current-time indicator to the first frame where you want the change to occur.

4. On the upper time ruler, the remap-time marker indicates the frame currently mapped to the time indicated on the lower time ruler. To
display a different frame at the time indicated on the lower time ruler, move the remap-time marker accordingly.

5. Move the current-time indicator on the lower time ruler to the last frame where you want change to occur.
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6. Move the remap-time marker on the upper time ruler to the frame you want to display at the time indicated on the lower time ruler:
« To move the preceding portion of the layer forward, set the remap-time marker to a later time than the current-time indicator.
« To move the preceding portion of the layer backward, set the remap-time marker to an earlier time than the current-time indicator.

« To freeze a frame, set the remap-time marker to the frame you want frozen. Then, move the current-time indicator (lower ruler) to the
last point in time where the frame will appear frozen and move the remap-time marker again to the frame you want frozen.

Time-remap audio pitch

The speed graph of the Time Remap property directly relates to the pitch of an audio file. By making subtle changes to the speed graph, you can
create a variety of interesting effects. To avoid screeching audio, you may want to keep the Speed value below 200%. When the speed is too
high, use the Levels controls, located under the Audio property, to control the volume.

You may hear clicks at the beginning and end of an audio (or an audio and video) layer after setting new In and Out points in the Time Remap
graph. Use the Levels controls to remove these clicks.

Change the pitch of an audio layer
1. In a Composition or Timeline panel, select the layer you want to remap.
Choose Layer > Time > Enable Time Remapping.
Click the Graph Editor button in the Timeline panel to display the Graph Editor, if necessary.
Click the Choose Graph Type And Options button at the bottom of the Graph Editor and choose Edit Speed Graph.
Move the current-time indicator to the frame where you want change to begin, and then click the Add A Keyframe button.

o g~ wN

On the speed graph below the keyframe, drag a marker, watching the Speed value as you drag.
« To lower the pitch, drag the speed graph marker down.

« To increase the pitch, drag the speed graph marker up.

Remove clicks from new In and Out points
1. If necessary, choose panel > Audio.
In the Timeline panel, select the audio (or audio and video) layer to which you applied time-remapping.
Expand the layer outline to display the Audio property and then the Audio Levels property.
Move the current-time indicator to the new In point and choose Animation > Add Audio Levels Keyframe.
In the Audio panel, change the decibel value to 0.0.
Press the Page Up key on your keyboard to move the current-time indicator to the previous frame.
In the Audio panel, change the decibel level to -96.0.
Move the current time to the new Out point and set the decibel level to 0.
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Press the Page Down key to move the current-time indicator to the next frame.
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In the Audio panel, change the decibel level to -96.0.
Q You can change the decibel Slider Minimum value in the Audio Options dialog box, which is available from the Audio panel menu.

Online resources for time-remapping
Aharon Rabinowitz provides a tutorial on the Creative COW website that shows how to use time-remapping to do lip-synching. This same basic
concept can be used for many kinds of character animation.

Robert Powers provides a video tutorial on the Slippery Rock NYC website that demonstrates how to use time-remapping to animate a character
to synchronize mouth movement with audio (lip synch).

Charles Bordenave (nab) provides a script on the After Effects Scripts website that automatically modulates time-remapping on a layer according
to audio amplitude.

Sam Morris provides a tutorial that introduces time-remapping on his website.

Andrew Kramer provides a video tutorial on his Video Copilot website that demonstrates time-stretching, time-remapping, and frame blending.

Frame blending fothetop
When you time-stretch or time-remap a layer to a slower frame rate or to a rate lower than the frame rate of its composition, movement can
appear jerky. This jerky appearance results because the layer now has fewer frames per second than the composition. Likewise, the same jerky
appearance can occur when you time-stretch or time-remap a layer to a frame rate that is faster than the frame rate of its composition. To create
smoother motion when you slow down or speed up a layer, use frame blending. Don’t apply frame blending unless the video of a layer has been
re-timed—that is, the video is playing at a different frame rate than the frame rate of the source video.

After Effects provides two types of frame blending: Frame Mix and Pixel Motion. Frame Mix takes less time to render, but Pixel Motion provides
much better results, especially for footage that has been drastically slowed down.
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The Quality setting you select also affects frame blending. When the layer is set to Best quality, frame blending results in smoother motion but
may take longer to render than when set to Draft quality.

Note: When working with a frame-blended layer in Draft mode, After Effects always uses Frame Mix interpolation to increase rendering speed.
You can also enable frame blending for all compositions when you render a movie.

Use frame blending to enhance the quality of time-altered motion in a layer that contains live-action footage—video, for example. You can apply
frame blending to a sequence of still images, but not to a single still image. If you are animating a layer—for example, moving a text layer across
the screen—use motion blur.

Note: You can't apply frame blending to a precomposition layer (a layer that uses a nested composition as its source footage item). You can,
however, apply frame blending to the layers within the nested composition if those layers themselves are based on motion footage items, such as
video or image sequences.

1. Select the layer in the Timeline panel.
2. Do one of the following:

« Choose Layer > Frame Blending > Frame Mix.
* Choose Layer > Frame Blending > Pixel Motion.

A check mark by the appropriate Frame Blending command (Frame Mix or Pixel Motion) indicates that it is applied to the selected layer. Also, the
Frame Blending switch ## appears in the Switches column for the layer in the Timeline panel. Remove frame blending either by clicking the Frame
Blending switch or by choosing the appropriate Frame Blending command again.

Regardless of the state of the layer switches, if frame blending is off for the composition, it is off for all layers in the composition. You set frame

blending for the composition by choosing Enable Frame Blending from the Timeline panel menu, or clicking the Enable Frame Blending button E@
at the top of the Timeline panel.

& Motion blur can make it harder for Pixel Motion to find discrete objects in each frame, which makes the calculation of motion vectors less
reliable. For better results when using Pixel Motion to create slow motion, use footage with less motion blur.

More Help topics
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